# Contents

**Introducing ABBYY FineReader** ................................................................. 9  
  About ABBYY FineReader ........................................................................... 10  
  What's New in ABBYY FineReader PDF 16 .............................................. 12  

**The New Task window** ............................................................................ 13  
  Viewing and editing PDFs .......................................................................... 15  
  Quick conversion ........................................................................................ 18  
    Creating PDF documents ........................................................................ 21  
    Creating Microsoft Word documents .................................................... 23  
    Creating Microsoft Excel spreadsheets .................................................. 25  
    Other formats .......................................................................................... 27  
  Advanced conversion .................................................................................. 28  
  Comparing documents ............................................................................... 32  
  Mobile application documents ................................................................... 35  
  Scanning and saving documents ............................................................... 36  
    Scanning to the OCR Editor .................................................................. 39  
    Scanning to PDF ..................................................................................... 41  
    Scanning to Microsoft Word .................................................................. 43  
    Scanning to Microsoft Excel .................................................................. 45  
    Scanning to image files .......................................................................... 47  
    Scanning to other formats ..................................................................... 49  

**PDF Editor** ............................................................................................... 50  
  Viewing PDF documents ............................................................................ 51  
  Viewing modes ........................................................................................... 53  
  Navigating PDF documents ....................................................................... 56  
  Background recognition ............................................................................ 58  
  PDF security features ............................................................................... 59  
  Searching PDF documents ........................................................................ 60  
    Keyword search ........................................................................................ 61  
    Search and replace ................................................................................... 63  
    Search and redact ..................................................................................... 65  
  Copying data from PDF documents .......................................................... 67  
    Copying an area as an image .................................................................. 68  
    Copying an area as text .......................................................................... 69  
    Copying an area as a table ..................................................................... 71  
  Reviewing PDF documents ........................................................................ 73  
    Comments ............................................................................................... 74  
    Marking up text ....................................................................................... 75  
    Drawing shapes ....................................................................................... 77  
    Adding a Text block annotation to a PDF document ............................. 79
Contents

Collaborating on PDF documents .............................................................. 80
Adding stamps ......................................................................................... 85

Working with PDF content ........................................................................ 88
Inserting and editing text ........................................................................ 88
Inserting and editing pictures ................................................................. 96
Inserting and editing hyperlinks ............................................................... 97
Recognizing text .................................................................................... 99
Organizing pages in a PDF document ..................................................... 100
Adding bookmarks ................................................................................ 114
Adding headers and footers .................................................................... 116
Adding watermarks ................................................................................ 119
Adding file attachments ......................................................................... 120
Viewing metadata .................................................................................. 121
Enhancing page images ......................................................................... 122

Working with interactive PDF forms ...................................................... 123
Filling out forms .................................................................................... 124
Creating forms ...................................................................................... 126
Editing forms ......................................................................................... 128
  Text field .............................................................................................. 134
  Drop-down list .................................................................................... 139
  Check box ........................................................................................... 144
  Radio button ....................................................................................... 147
  Button ................................................................................................ 150
  Signature field .................................................................................... 160
  List box .............................................................................................. 163

Signing PDF documents .......................................................................... 167
  Digital signature ................................................................................ 168
  Time Stamp Server Settings .............................................................. 169
  Text signature .................................................................................... 170
  Picture signature ................................................................................ 171

Protecting PDF documents with passwords ......................................... 171
  Passwords and permissions .............................................................. 172
  Deleting confidential information from PDF documents .................. 173
Creating PDF documents ........................................................................ 174
  Creating PDF documents from selected pages ............................... 174

Saving and exporting PDF documents .................................................... 174
  Saving PDF documents .................................................................... 175
  Saving in PDF/A ................................................................................. 176
  Saving in other formats .................................................................... 178
  Reducing the size of your PDF documents ........................................ 179
Contents

Sending PDF documents to the OCR Editor ................................................................. 180  
E-mailing PDF documents ....................................................................................... 181  
Printing PDF documents ....................................................................................... 181  
Splitting PDF documents ....................................................................................... 182  
  Splitting by file size .............................................................................................. 183  
  Splitting by page count ....................................................................................... 184  
  Splitting by bookmarks ...................................................................................... 185  

OCR Editor .............................................................................................................. 186

  Launching the OCR Editor ................................................................................... 186  
  OCR Editor interface ............................................................................................ 187  
  Obtaining documents ........................................................................................... 190  
    Opening images and PDFs .............................................................................. 191  
    Scanning paper documents .......................................................................... 192  
  Recognizing documents ....................................................................................... 193  
    OCR projects .................................................................................................. 194  
    Group work with OCR projects .................................................................. 199  
  Improving OCR results ....................................................................................... 200  
    If your document image has defects and OCR accuracy is low .................. 201  
    If areas are detected incorrectly ..................................................................... 204  
      Editing area properties ............................................................................... 208  
    If the complex structure of a paper document is not reproduced ............ 209  
    If you are processing a large number of documents with identical layouts .... 210  
    If tables and pictures are not detected ............................................................. 211  
    If a barcode is not detected ............................................................................. 214  
    If an incorrect font is used or some characters are replaced with “?” or “□” ..... 215  
    If your printed document contains non-standard fonts ............................... 216  
    If your document contains many specialized terms ..................................... 219  
    If the program fails to recognize certain characters ..................................... 220  
    If vertical or inverted text was not recognized ............................................. 222  
  Checking and editing texts ................................................................................... 223  
    Checking recognized text .............................................................................. 224  
    Using styles ..................................................................................................... 227  
    Editing hyperlinks ............................................................................................ 228  
    Editing tables .................................................................................................. 229  
      Removing confidential information ............................................................. 229  
  Copying content from documents .................................................................... 230  
  Saving OCR results ............................................................................................. 231  
    Saving in PDF .................................................................................................. 233  
    Saving editable documents ............................................................................ 234  
    Saving tables ................................................................................................... 236  

  Splitting by bookmarks ....................................................................................... 185  
  Splitting by page count ....................................................................................... 184  
  Removing confidential information .................................................................... 229  
  Using styles ..................................................................................................... 227  
  Editing hyperlinks ............................................................................................ 228  
  Editing tables .................................................................................................. 229  
  Removing confidential information .................................................................... 229  
  Copying content from documents .................................................................... 230  
  Saving OCR results ............................................................................................. 231  
    Saving in PDF .................................................................................................. 233  
    Saving editable documents ............................................................................ 234  
    Saving tables ................................................................................................... 236
## Contents

- Saving e-books .......................................................................................................................... 237
- Saving in HTML .......................................................................................................................... 238
- Saving images ............................................................................................................................. 239
- Sending OCR results to the PDF Editor .................................................................................. 240
- E-mailing OCR results .............................................................................................................. 241
- Sending OCR results to Kindle ................................................................................................. 242

### Integration with other applications .................................................................................. 243

- Integration with Windows Explorer ......................................................................................... 244
- Integration with Microsoft Office .............................................................................................. 247
  - Integration with Microsoft Word ............................................................................................. 248
    - Creating a PDF document using a Word document ............................................................ 249
    - Creating a Word document using image files .................................................................. 251
    - Comparing Word documents ............................................................................................. 251
  - Integration with Microsoft Excel ......................................................................................... 252
  - Integration with Microsoft PowerPoint ................................................................................. 254
  - Integration with Microsoft Outlook ....................................................................................... 256
  - Integration with Microsoft SharePoint .................................................................................. 258
  - Integration with the mobile application ................................................................................ 258
- Cloud storage ............................................................................................................................. 263

### Automating and scheduling OCR ...................................................................................... 264

- Automating document processing with ABBYY FineReader ................................................ 265
- ABBYY Hot Folder .................................................................................................................... 268

### ABBYY Compare Documents ............................................................................................. 273

- Launching ABBYY Compare Documents .............................................................................. 274
- Comparing documents ............................................................................................................ 275
- The main window ..................................................................................................................... 277
- Improving comparison results ................................................................................................. 278
- Viewing comparison results ..................................................................................................... 280
- Saving comparison results ...................................................................................................... 282

### ABBYY Screenshot Reader .................................................................................................. 283

### Reference .............................................................................................................................. 287

- How to set ABBYY FineReader PDF 16 as your default PDF viewer ..................................... 288
- Types of PDF documents .......................................................................................................... 290
- Scanning tips .............................................................................................................................. 293
- Taking photos of documents .................................................................................................... 296
- Options dialog box .................................................................................................................. 299
- Format settings ......................................................................................................................... 302
Introducing ABBYY FineReader
This chapter provides an overview of ABBYY FineReader and its features.

Chapter contents

- About ABBYY FineReader
- What's New in ABBYY FineReader PDF
About ABBYY FineReader

ABBYY FineReader PDF is a universal PDF tool for managing documents in the digital workplace. Powered by ABBYY’s AI-based OCR and document-conversion technologies, FineReader unlocks the information contained within a document to increase business productivity. FineReader makes it easy and efficient to digitize, retrieve, edit, convert, protect, share, and collaborate on all kinds of PDF and paper documents in the modern working world.

What you can do with ABBYY FineReader PDF:

- Work with any type of PDF, including scanned documents
  - **Edit text** (even whole paragraphs, also within table cells), **hyperlinks**, and **pictures** throughout a document.
  - **Search by keywords** in the text, comments, bookmarks, and metadata within a document.
  - **Rearrange, add, delete** and enhance (rotate, crop, deskew) pages in PDFs.
  - **Copy text, tables, and pictures** from PDFs, scans, or photos in a few clicks.
  - **Export PDFs into Microsoft Word, Excel, or another editable format**.
  - **Add comments and annotations** to documents.
  - **Add watermarks**, headers and footers, bates numbering, and stamps to PDFs.
  - **Apply and verify digital signatures**.
  - **Protect PDFs** with passwords and encryption.
  - **Remove sensitive information** from documents through redaction.
  - **Create / combine PDF documents** including industry standards PDF/A for long-term archiving and PDF/UA for accessibility.
  - **Fill out PDF forms**
  - **View** and **print** PDFs.
  - **Identify differences** in the text from two versions of the same document, whether the versions be PDFs, scans, images, Microsoft Word documents, or any combination of supported digital files.
  - **Save and share** these differences as a Microsoft Word document in Track Changes mode.

- **Scan and convert documents**
Scan and convert PDF and paper documents into editable and searchable formats (including Microsoft Word, Microsoft Excel, searchable PDF, PDF/A, PDF/UA, and many more) to further edit, reuse, or store them.

Convert paper documents, document images, and PDFs quickly and accurately - while retaining their original layout, formatting, and structure - with the advanced OCR Editor.

Improve quality and correct distortions in the digital images of documents (scans/photographs) before converting them, either automatically or manually.

Quickly check how recognized text matches up with the original document and make any necessary changes with a built-in text editor and verification tools before saving.

Improve the accuracy of converting documents with advanced tools: adjust or specify document areas, train the program to recognize unusual or decorative fonts, and create user dictionaries and languages for specific terminology, abbreviations, codes, etc.

- **Compare texts to identify differences** between two versions of the same document*

ABBYY FineReader PDF can compare two versions of the same document even if they are in two different formats. For example, you can compare a scanned document and the same document in Microsoft Word (in either DOC and DOCX formats).

Save and share the differences as a simple list of changes, as an entire Microsoft Word document in Track Changes mode, or as an entire PDF with highlighted text mark-ups and comments.

- **Automate your personal document conversion routines with ABBYY Hot Folder**

ABBYY Hot Folder is a conversion scheduling tool included with ABBYY FineReader PDF that watches for documents in user-defined folders and converts them on a schedule with pre-set parameters.

- **Take a snapshot of any part of the screen with ABBYY Screenshot Reader**

If a screenshot contains text or tables, it can also be extracted and saved as an editable format.**

---

* This feature is not available with all versions of ABBYY FineReader. Please visit [our home page](#) for more information.

** In order to use ABBYY Screenshot Reader, you must first register your copy of ABBYY FineReader.
What's New in ABBYY FineReader PDF 16

Redesigned user interface

- New ribbon-style interface for easier navigation and updated graphics bring a fresh look and improved experience when working with this ultimate PDF tool.

“Organize Pages” tool

- New “Organize Pages” tool, in addition to the redesigned and improved existing page tools, perfects your productivity when managing PDF pages and rearranging PDF documents.

x64 nature

- FineReader PDF 16 is a 64-bit application for increased performance on x64 Windows platforms.

ABBYY’s renowned OCR improved

- To maintain the status of best-in-class software for PDF and scanned document conversion scenarios, the latest OCR improvements provide more precise document layout detection and reconstruction.

Simplified license management and deployment for organizations

- Support of deployment in Microsoft Azure
- Simplified license update process
- New WIX-based installer
- Free PDF Viewer now compatible with Concurrent licenses

SVG-to-PDF

- Create searchable PDFs from documents in vector SVG format, such as drawings, charts, and diagrams.

We would like to extend our sincere appreciation for all the users who have contributed feedback and helped us broaden FineReader’s capabilities to make it more useful in daily work.
The New Task window

When you launch ABBYY FineReader, a New Task window opens, where you can easily open, scan, create, or compare documents. If the New Task window has been closed or if ABBYY FineReader was launched by right-clicking a file in Windows Explorer, you can return to the main screen of the program by clicking the button on either the toolbar of the Document tab on the PDF Editor screen or on the main toolbar of the OCR Editor screen.

To start processing a document, select a task:

1. In the left-hand pane:
   - Click **Open** if you already have documents that you need to process.
   - Click **Scan** if you need to scan paper documents first.
   - Click **Compare** if you want to compare two versions of the same document.
   - Click **Recent** to resume work on a previously saved PDF document or OCR project.
   - Click **Mobile application** to create documents on your smartphone using FineReader PDF for iOS or Android and continue working with them on your computer.
2. In the right-hand pane, select the appropriate task.

All ABBYY FineReader tasks are carried out using settings specified in the **Options** dialog box. To open this dialog box, select **Tools > Options**.

**Chapter contents**

- Viewing and editing PDF documents
- Quick conversion
- Advanced conversion
- Comparing documents
- Mobile application documents
- Scanning and saving documents
Viewing and editing PDFs

With ABBYY FineReader, you can easily view, edit, comment, and search inside any type of PDF documents, even those that were obtained by simply scanning a paper document and so do not contain any searchable or editable text.

Viewing PDF documents and adding your comments

On the home screen, navigate to the Open tab and click the PDF Document button:

![PDF Document](image)

The selected document will be opened in the PDF Editor for viewing and commenting.

Use the Pages, Bookmarks, Search, and Comments buttons in the Document tab to navigate around the document.
ABBYY FineReader offers the following commenting tools:

- **Add Note**
- **Highlight**, Underline, Strikethrough, and Insert Text
- **Draw** Shape, Line, or Arrow

### Editing PDF documents

You can use ABBYY FineReader to edit text and images, create headers and footers, as well as add your own images. To switch to the editing mode, navigate to the **Edit Content** tab.

**See also:** [Editing text](#), [Inserting and editing pictures](#)

### Protecting PDF documents
You can also use ABBYY FineReader to add digital and text signatures, encrypt a document using either a password or a watermark, and redact confidential information. You can do this by navigating to the Security tab.

See also: Digital signatures[168], Removing confidential information from PDF documents[173], Passwords and permissions[123].

Working with interactive forms

ABBYY FineReader PDF allows you to create, edit, fill out, save, and print interactive PDF forms. See also: Working with interactive PDF forms[123]

When you open a PDF that contains an interactive form, the form fields are highlighted, inviting you to select a value from the drop-down list or type in some information.

✓ If you encounter a form that cannot be filled out by simply typing text in the empty fields, use the Export tool to type the necessary information over the form. See also: Filling out forms[124].

✓ For more information on working with PDF documents, see Working with PDF documents[80].
Quick conversion

You can use the built-in tasks on the Open tab of the New Task screen to convert PDF documents or images or create a new PDF from files in various formats.

Converting one or more files

1. Click the Open tab and then click a desired task:

- **Convert to PDF** creates PDF documents from *.docx, *.html, *.jpeg, and other files. You can also use this task to combine multiple files into one PDF document.

- **Convert to Microsoft Word** creates Word documents from PDF and image files. You can also use this task to combine multiple files into one Microsoft Word document.

- **Convert to Microsoft Excel** creates Excel spreadsheets from PDF and image files. You can also use this task to combine multiple files into one Excel document.

- **Convert to Other Formats** converts PDF and image files into popular formats, including *.odt, *.pptx, *.epub, *.html, and many more.
2. In the dialog box that opens, select one or more files to convert.

3. Specify conversion settings. These settings determine the appearance and properties of the output document.

4. Add or remove files if necessary.

5. Click the **Convert to <format>** button.

6. Specify a destination folder for the output file. When the task is completed, the resulting file will be placed into the folder that you specified.

**Combining files**

1. Click the **Open** tab and then click a desired task.

2. In the dialog box that opens, select the files that you want to convert.

4. Add or remove files if necessary.

5. Arrange the files in the desired order and select the **Combine all files into one document** option.

6. Click the **Convert to <format>** button.

7. Specify a name and a destination folder for the output file.

When the task is completed, the resulting file will be placed into the folder that you specified.

💡 Use **advanced conversion** for large documents with complicated layouts.

☐ **See also:**

- [Creating PDF documents](#)
- [Creating Microsoft Word documents](#)
- [Creating Microsoft Excel spreadsheets](#)
- [Other formats](#)
Creating PDF documents

Video: How to Create and Merge PDF

In the **New Task** window, you can:

- Create PDF documents from files in various formats.
- Convert multiple files to PDF.
- Combine multiple files into one PDF.
- Create searchable PDF documents.
- Create PDF/A-compliant documents.

**Converting one or more files**

1. Click the **Open** tab and then click **Convert to PDF**.

2. In the dialog box that opens, select one or more files to convert.

3. Specify conversion settings. These settings determine the appearance and properties of the output document.

   3.1. **Image quality** The quality of the pictures and the size of the resulting file can be tweaked using the options in the **Image quality** drop-down menu:

      - **Best quality**
        Select this option to retain the quality of the pictures and the page image. The original resolution will be preserved.

      - **Balanced**
        Select this option to reduce the size of the output PDF file without too much loss in picture quality.

      - **Compact size**
        Select this option to obtain a small-sized PDF file at the expense of picture quality.

      - **Custom...**
        Select this option to customize picture saving. In the **Custom Settings** dialog box, specify desired values and click **OK**.

   3.2. **Full-text search** Use this drop-down menu to enable or disable full-text searches in the output document:

      - **As in original document** The text on the images will not be recognized. Users will be able to search inside the output document only if the original document has a text layer.
- **Search inside text and images** The text on the images will be recognized. Users will be able to search inside the output document.

- **Disable full-text search** The document will be converted to image-only PDF. Users will not be able to search inside the output document.

3.3. **Create PDF/A documents** Select this option to create a PDF/A-compliant document. A PDF/A-2b document will be created by default. Click **More options...** to select another version of PDF/A.

3.4. **Use MRC compression** Select this option to apply Mixed Raster Content (MRC) compression to reduce file size without noticeable loss in image quality.

3.5. **OCR languages** Select the language(s) of your document. See also: [OCR languages](#).

3.6. **Image preprocessing settings...** Here you can specify some additional manipulations to be performed on your scans and image files to improve their appearance and the quality of conversion. See also: [Image processing options](#).

3.7. **More options...** Open the PDF tab of the **Format Settings** dialog box.

4. Add or remove files if necessary.

5. Click the **Convert to PDF** button.

   When the task is completed, the resulting PDF document will be placed into the folder that you specified.

### Combining files

1. Click the **Open** tab and then click **Convert to PDF**.

2. In the dialog box that opens, select the files that you want to convert.

3. Specify **conversion settings**.

4. Add or remove files if necessary.

5. Arrange the files in the desired order and select the **Combine all files into one document** option.

6. Click the **Convert to PDF** button.

7. Specify a name and a destination folder for the output file.
   When the task is completed, the resulting PDF document will be placed into the folder that you specified.
Creating Microsoft Word documents

Video: [How to Convert PDF to Microsoft Word](#)

In the **New Task** window, you can create Microsoft Word documents from PDF documents and images and from files in any of the [supported formats](#). You can also convert and combine multiple files into one Microsoft Word document.

Converting one or more files

1. Click the **Open** tab and then click **Convert to Microsoft Word**.
2. In the dialog box that opens, select one or more files to convert.
3. Specify conversion settings. These settings determine the appearance and properties of the output document.

   3.1. **Keep formatting.**
      Select the appropriate setting depending on how you plan to use the output document:
      
      - **Exact copy**
        The output document will look almost exactly like the original, but will offer limited editing options.
      
      - **Editable copy**
        The appearance of the output document may slightly differ from the original, but the document can be easily edited.
      
      - **Formatted text**
        The font types, font sizes, and paragraph formatting will be retained. The output text will be placed in one column.
      
      - **Plain text**
        Only the paragraph formatting will be retained. The output text will be placed in one column and a single font will be used throughout.

   3.2. **OCR languages** Select the language(s) of your document. See also: [OCR languages](#).

   3.3. **Keep pictures** Select this option if you want to preserve the pictures in the output document.

   3.4. **Keep headers, footers, and page numbers** Select this option to preserve the headers, footers, and page numbers.

   3.5. **More options...** Opens the **DOC(X)/RTF/ODT** tab of the [Format Settings](#) dialog box.

4. Add or remove files if necessary.
5. Click the **Convert to Word** button.

   When the task is completed, the resulting Microsoft Word document will be placed into the folder that you specified.

**Combining files**

1. Click the **Open** tab and then click **Convert to Microsoft Word**.

2. In the dialog box that opens, select the files that you want to convert.

3. Specify **conversion settings**.

4. Add or remove files if necessary.

5. Arrange the files in the desired order and select the **Combine all files into one document** option.

6. Click the **Convert to Word** button.

7. Specify a name and a destination folder for the output file.  
   When the task is completed, the resulting Microsoft Word document will be placed into the folder that you specified.
Creating Microsoft Excel spreadsheets

In the New Task window, you can create Microsoft Excel documents from PDF documents and images and from files in any of the supported formats. You can also convert and combine multiple files into one Excel document.

Converting one or more files

1. Click the Open tab and then click Convert to Microsoft Excel.
2. In the dialog box that opens, select one or more files to convert.
3. Specify conversion settings. These settings determine the appearance and properties of the output document.
   3.1. **Keep formatting.**
       Select the appropriate setting depending on how you plan to use the output document.
       - Formatted text
         The font types, font sizes, and paragraph formatting will be retained.
       - Plain text
         Only the paragraphs will be retained. A single font will be used throughout.
   3.2. **OCR languages** Select the language(s) of your document. See also: OCR languages.
   3.3. **Keep pictures (XLSX only)** Select this option if you want to preserve the pictures in the output document.
   3.4. **Create a separate sheet for each page (XLSX only)** Select this option if you want to create a separate Microsoft Excel spreadsheet from each page of the original document(s).
   3.5. **More options...** Opens the XLS(X) tab of the Format Settings dialog box.
4. Add or remove files if necessary.
5. Click the Convert to Excel button.
   When the task is completed, the resulting Microsoft Excel file will be placed into the folder that you specified.

Combining files

1. Click the Open and then click Convert to Microsoft Excel.
2. In the dialog box that opens, select the files that you want to convert.
4. Add or remove files if necessary.

5. Arrange the files in the desired order and select the **Combine all files into one document** option.

6. Click the **Convert to Excel** button.

7. Specify a name and a destination folder for the output file.
   When the task is completed, the resulting Microsoft Excel document will be placed into the folder that you specified.
Other formats

In the **New Task** window, you can convert PDF documents and images into popular formats (*.pptx, *.odt, *.html, *.epub, *.fb2, *.rtf, *.txt, *.csv, *.djvu) and combine multiple files into one document.

Converting one or more files

1. Click the **Open** tab and then click **Convert to other formats**.
2. In the dialog box that opens, select one or more files to convert.
3. Specify conversion settings. These settings determine the appearance and properties of the output document.
   - **Select output format** Select a format into which to convert your file.
   - **OCR languages** Select the language(s) of your document. See also: [OCR languages](#).
   - **More options...** Opens the corresponding tab of the [Format Settings](#) dialog box.
4. Add or remove files if necessary.
5. Click the **Convert to <format>** button.
   When the task is completed, the resulting file will be placed into the folder that you specified.

Combining files

1. Click the **Open** tab and then click **Convert to other formats**.
2. In the dialog box that opens, select the files that you want to convert.
3. Specify [conversion settings](#).
4. Add or remove files if necessary.
5. Arrange the files in the desired order and select the **Combine all files into one document** option.
6. Click the **Convert to <format>** button.
7. Specify a name and a destination folder for the output file.
   When the task is completed, the resulting document will be placed into the folder that you specified.
**Advanced conversion**

ABYY FineReader includes an OCR Editor, which provides advanced OCR and conversion features.

The OCR Editor allows you to check recognition areas and verify recognized text, preprocess images in order to improve OCR accuracy, and much more.
The OCR Editor also offer powerful features for fine-tuning OCR and conversion to get the best possible results. For example, you can edit recognition areas, check recognized text, and train ABBYY FineReader to recognize non-standard characters and fonts.

1. There are several ways to open the OCR Editor:

   - Click New Task > Open tab, and then click the OCR Editor button:

   - or New Task > Tools > OCR Editor

   - or New Task > File > Open in OCR Editor...
2. In the **Open Image** dialog box, select the files you want to open. If you are using the default settings, ABBYY FineReader will automatically analyze and recognize the files you opened. You can change these settings on the **Image Processing** tab of the **Options** dialog box (click **Tools** > **Options...** to open this dialog box).

3. After you open a document, its image will be displayed in the **Image** pane, and text, picture, table and barcode areas will be marked on the image. Check that the areas have been detected correctly and edit them if necessary.

**Editing areas quickly**
ABYY FineReader analyzes documents to detect areas that contain text, pictures, tables, and barcodes.

Sometimes, areas in complex documents may be detected incorrectly. In most cases it is easier to correct automatically detected areas than to draw all areas manually.

You can find tools for drawing and editing areas on the toolbar above the image pane and on the toolbars that appear above text, picture, background picture, and table areas when you select them.

You can use these tools to:

- Add and delete areas
- Change the type of an area
- Adjust area borders and move entire areas
- Add rectangular parts to areas or delete them
- Change the order of areas

4. If you made any changes to areas, click the Recognize button on the main toolbar to recognize the document again.

5. Check the recognized text in the Text pane and correct it if necessary.

6. **Save the recognized document**. You can select the format in which to save your document from the drop-down list of the Save/Send button on the main toolbar (click the arrow next to the button to open the drop-down list).

For more information about the OCR Editor and its features, see *Working with the OCR Editor*.
Comparing documents

(This functionality is not available in some versions of ABBYY FineReader. See also: http://www.ABBYY.com/FineReader.)

ABBYY FineReader includes ABBYY Compare Documents, an application that lets you compare two versions of a document, even if these versions are in different formats. ABBYY FineReader's document comparison tool lets you detect significant inconsistencies in a text and, for example, prevent the approval or publication of the wrong version of a document.

There are several ways to start ABBYY Compare Documents:

- Click New Task and navigate to the Compare tab, then click the Compare button:
Click the Start button in Windows and click ABBYY FineReader PDF > ABBYY Compare Documents (in Windows 10, click the Start button, click the All Programs item on the start menu, and then click ABBYY FineReader PDF > ABBYY Compare Documents)

or New Task > Tools > Compare Documents

or PDF Editor > File > Compare Documents

or OCR Editor > Tools > Compare Documents

Right-click a file in Windows Explorer and click Compare documents... on the shortcut menu.

Follow the instructions below to compare two documents.

1. Open ABBYY Compare Documents, open one of the versions that you want to compare in the left-hand pane and the other one in the right-hand pane.

2. In the COMPARE pane, select the languages of the document from the drop-down list.
3. Click the Compare button to compare the documents.

4. Review the differences detected by ABBYY Compare Documents. The differences between the two versions will be highlighted in each version and listed in the right-hand pane, providing you with a clear picture of the changes made to the document. This makes it easy to see which text was added, removed or edited in each version. Both pages are scrolled simultaneously and the identical fragments are always displayed side by side. Differences can be removed from the list or copied to the Clipboard.

Differences that were removed from the list will not be saved to the difference report.

You can save the comparison results:

- As a Microsoft Word files where the differences will be shown using the Track Changes feature.
- As a PDF document with comments.
- As a Microsoft Word table containing the differences.

For more information on comparing two versions of the same document, see ABBYY Compare Documents.
Mobile application documents

You can create documents in the FineReader PDF mobile application and continue working with them in FineReader PDF on your PC.

To send a document from your smartphone to your PC, do the following:

1. Install the FineReader PDF mobile application on your iOS/Android device (available in App Store and Google Play).

2. Create a document on your iOS/Android device using your FineReader PDF mobile application.

3. Send that document to your PC using export to Google Drive (FineReader).

Next, to get quick access to documents created using the mobile application:

1. Install a Google Drive cloud storage client on your PC.
   - Download Google Drive for Windows from the Google website.

2. On the home screen, specify the FineReader folder in your local Google Drive storage by clicking Select folder in the Mobile application tab.

3. From the list of mobile application documents and folders that will appear, select the appropriate document or folder.

4. Make your changes and save the document.

For more information about working with documents created using the mobile application, see Integration with the mobile application.
Scanning and saving documents

You can use the tasks on the Scan tab of the New Task window to create digital documents in various formats. You will need a scanner or a digital camera to obtain document images.

1. Click the Scan tab and then click a task:

   - **OCR Editor** opens scans in the OCR Editor.
   - **PDF Document** creates PDF documents from images obtained from a scanner or digital camera.
   - **Microsoft Word** creates Microsoft Word documents from images obtained from a scanner or digital camera.
   - **Microsoft Excel** creates Microsoft Excel documents from images obtained from a scanner or digital camera.
   - **Image Files** creates image-only documents from images obtained from a scanner or digital camera.
• **Other Formats** creates documents in popular formats, such as *.odt, *.pptx, *.epub, and *.html, from images obtained from a scanner or digital camera.

2. Select a device and specify **scanning settings**.

3. Click the **Preview** button or click anywhere inside the image.

4. Review the image. If you are not satisfied with the quality of the image, change the scanning settings and click the **Preview** button again.

5. Specify the settings specific to the selected format. These settings determine the appearance and properties of the output document.

6. Click the **Scan to <format>** button.

7. When scanning starts, a dialog box with a progress bar and tips will be displayed.

8. After a page has been scanned, a dialog box prompting you to decide what to do next will be displayed. Click **Scan Again** to scan more pages using the current settings or click **Finish Scanning** to close the dialog box.

9. Depending on the task you selected in step 1, the scanned images will be:
   - Processed and added to an OCR project in the **OCR Editor**.
   - Processed and converted to PDF. Specify the folder where you want to save the resulting document. The document will remain open in the OCR Editor.
   - Processed and converted to the selected format. Specify the folder where you want to save the resulting document. The document will remain open in the OCR Editor.
See also:

- Scanning to the OCR Editor
- Scanning to PDF
- Scanning to Microsoft Word
- Scanning to Microsoft Excel
- Scanning to image files
- Scanning to other formats
Scanning to the OCR Editor
You can open images from a scanner or camera in the OCR Editor, where you will be able to:

- Draw and edit recognition areas manually
- Check recognized text
- Train ABBYY FineReader to recognize non-standard characters and fonts
- Use other advanced tools to ensure the best possible OCR result.

1. Open the **New Task** window, click the **Scan** tab, and then click the **OCR Editor** task.
2. Select a device and specify scanning settings.
3. Click the **Preview** button or click anywhere inside the image.
4. Review the image. If you are not satisfied with the quality of the image, change the scanning settings and click the **Preview** button again.
5. Specify preprocessing and automation settings.
   5.1. **Automatically process page images as they are added**
   This option enables or disables automatic processing of newly added pages. If automatic processing is enabled, you can select general document processing options and image preprocessing settings to be used when scanning and opening images:

   - **Recognize page images**
     Enable this option if you want FineReader to automatically preprocess newly added images using the settings specified in the **Preprocessing Settings** dialog box (click the **Image preprocessing settings (apply to conversion and OCR)** link below to open this dialog box). Analysis and OCR will also be performed automatically.

   - **Analyze page images**
     Performs image preprocessing and document analysis automatically, but OCR has to be started manually.

   - **Preprocess page images**
     Preprocesses images automatically. Analysis and OCR have to be started manually.

5.2. **OCR languages**
Use this option to specify the languages of the document. **See also: OCR languages**
5.3. **Image preprocessing settings...**

Opens the **Preprocessing Settings** dialog box where you can specify image preprocessing settings such as detection of page orientation and automatic preprocessing settings. These settings can significantly improve source images, resulting in greater OCR accuracy. **See also:** *Image processing options*.

5.4. **More options...**

Opens the **Image Processing** tab of the **Options** dialog box. You can also open this dialog box by clicking **Options...** on the **Tools** menu.

6. Click **Scan**.

7. A progress dialog box will be displayed, showing a progress bar and tips.

8. After the page has been scanned, a dialog box prompting you to decide what to do next will appear.

   Click **Scan Again** to scan subsequent pages using the current settings or **Finish Scanning** to close the dialog box.

9. After the scanning process is completed, the scanned images will be added to an OCR project in the OCR Editor and processed using the preprocessing and automation settings you specified earlier.

   ✗ For more information about the OCR Editor and its features, see *Working with the OCR Editor*. 
Scanning to PDF

The PDF Document task in the New Task window lets you create PDF documents from images obtained from a scanner or a digital camera.

1. Open the New Task window, click the Scan tab, and then click PDF Document.

2. Select a device and specify scanning settings.

3. Click the Preview button or click anywhere inside the image.

4. Review the image. If you are not satisfied with the quality of the image, change the scanning settings and click the Preview button again.

5. Specify conversion settings. These settings determine the appearance and properties of the output document.

5.1. Image quality This option determines the quality of images and pictures, which affects the size of the resulting output file. The following quality settings are available:

   • Best quality
     Select this option to retain the quality of the pictures and the page image. The original resolution will be preserved.

   • Balanced
     Select this option to reduce the size of the output PDF file without too much loss in picture quality.

   • Compact size
     Select this option to obtain a small-sized PDF file at the expense of picture quality.

   • Custom...
     Select this option to customize picture saving. In the Custom Settings dialog box, specify the desired values and click OK.

5.2. Create PDF/A documents
   Select this option to create a PDF/A-compliant document.

5.3. Use MRC compression
   Select this option to apply Mixed Raster Content (MRC) compression to reduce file size without noticeable loss in image quality.

5.4. Recognize text on images
   Select this option if you want OCR to start automatically.

5.5. OCR languages
   Use this option to specify the languages of the document. See also: OCR languages.
5.6. **Image preprocessing settings...**

Use this option to specify image preprocessing settings, such as detection of page orientation and automatic preprocessing settings. These settings can significantly improve source images, resulting in greater OCR accuracy. See also: [Image processing options](#).

5.7. **More options...**

Opens the PDF section of the Format Settings of the Options dialog box, where you can specify additional settings (you can also open this dialog box by clicking Options... on the Tools menu).

6. Click **Scan to PDF**.

7. A dialog box will be displayed, showing a progress bar and tips.

8. After the page has been scanned, a dialog box prompting you to decide what to do next will appear.

   Click **Scan Again** to scan more pages using the current settings or click **Finish Scanning** to close the dialog box.

9. After the scanning is completed, the scanned images will be processed using the settings you specified, converted to PDF, and opened in the OCR Editor.

10. Specify the folder where you want to save the resulting PDF.
Scanning to Microsoft Word

The **Microsoft Word** task in the **New Task** window lets you create Microsoft Word documents from images obtained from a scanner or a digital camera.

1. Open the **New Task** window, click the **Scan** tab, and then click the **Microsoft Word** task.

2. Select a device and specify scanning settings.

3. Click the **Preview** button or click anywhere inside the image.

4. Review the image. If you are not satisfied with the quality of the image, change the scanning settings and click the **Preview** button again.

5. Specify conversion settings. These settings determine the appearance and properties of the output document.

   5.1. **Preserve formatting**
       Select the appropriate setting depending on how you plan to use the output document.

       - **Exact copy**
         The output document will look almost exactly like the original, but will offer limited editing options.

       - **Editable copy**
         The appearance of the output document may slightly differ from the original, but the document can be easily edited.

       - **Formatted text**
         The font types, font sizes, and paragraph formatting will be retained. The output text will be placed in one column.

       - **Plain text**
         Only the paragraph formatting will be retained. The output text will be placed in one column and a single font will be used throughout.

   5.2. **OCR languages**
       Select the language(s) of your document. See also: [OCR languages](#).

   5.3. **Keep pictures**
       Select this option if you want to preserve the pictures in the output document.

   5.4. **Keep headers, footers, and page numbers**
       Select this option to preserve the headers, footers, and page numbers.
5.5. **Image preprocessing settings...**

Specify image preprocessing settings, such as detection of page orientation and automatic preprocessing settings. These settings can significantly improve source images, resulting in greater OCR accuracy. **See also:** *Image processing options*.

5.6. **More options...**

Opens the **DOC(X)/RTF/ODT** section of the **Format Settings** tab of the **Options** dialog box, where you can specify additional settings (you can also open this dialog box by clicking **Options...** on the **Tools** menu).

6. Click **Scan to Word**.

7. A dialog box will be displayed, showing a progress bar and tips.

8. After the page has been scanned, a dialog box prompting you to decide what to do next will appear.
   
   Click **Scan Again** to scan more pages using the current settings or click **Finish Scanning** to close the dialog box.

9. Specify the folder where you want to save your Microsoft Word document.

When the task is completed, a Microsoft Word document will be created in the folder that you specified. All of the document's pages will also be opened in the OCR Editor.
Scanning to Microsoft Excel

The **Microsoft Excel** task in the **New Task** window lets you create Microsoft Excel documents from images obtained from a scanner or a digital camera.

1. Open the **New Task** window, click the **Scan** tab, and then click the **Microsoft Excel** task.

2. Select a device and specify **scanning settings**.

3. Click the **Preview** button or click anywhere inside the image.

4. Review the image. If you are not satisfied with the quality of the image, change the scanning settings and click the **Preview** button again.

5. Specify conversion settings. These settings determine the appearance and properties of the output document.

   5.1. **Preserve formatting.**
       Select the appropriate setting depending on how you plan to use the output document.

       - **Formatted text**
         The font types, font sizes, and paragraph formatting will be retained.

       - **Plain text**
         Only the paragraphs will be retained. A single font will be used throughout.

   5.2. **OCR languages**
       Select the language(s) of your document. **See also:** [OCR languages](#).

   5.3. **XLSX settings:**

       - **Keep pictures**
         Select this option if you want to preserve the pictures in the output document.

       - **Create a separate sheet for each page**
         Select this option if you want to create a separate Microsoft Excel spreadsheet from each page of the original document(s).

   5.4. **Image preprocessing settings...**
       Use this option to specify image preprocessing settings, such as detection of page orientation and automatic preprocessing settings. These settings can significantly improve source images, resulting in greater OCR accuracy. **See also:** [Image processing options](#).

   5.5. **More options...**
       Opens the **XLS(X)** section of the **Format Settings** tab of the **Options** dialog box, where you can specify additional settings (you can also open this dialog box by clicking **Options...** on the **Tools** menu).
6. Click **Scan to Excel**.

7. A dialog box will be displayed, showing a progress bar and tips.

8. After the page has been scanned, a dialog box prompting you to decide what to do next will appear.
   Click **Scan Again** to scan more pages using the current settings or click **Finish Scanning** to close the dialog box.

9. Specify the folder where you want to save your Microsoft Excel document.

   When the task is completed, a Microsoft Excel document will be created in the folder that you specified. All of the document's pages will also be opened in the OCR Editor.
Scanning to image files

The **Image Files** task in the **New Task** window lets you create image-only documents from images obtained from a scanner or a digital camera.

1. Click the **Scan** tab and then click the **Image Files** task.

2. Select a device and specify [scanning settings](#).

3. Click the **Preview** button or click anywhere inside the image.

4. Review the image. If you are not satisfied with the quality of the image, change the scanning settings and click the **Preview** button again.

5. Specify conversion settings. These settings determine the appearance and properties of the output document.

   5.1. **Select image format**

       Use this setting to select the desired image file format.

   5.2. **Compression**

       If you selected the TIFF format, you will be able to compress scanned images. Image compression reduces file size.

       Using different compression methods results in different data compression rates and may result in data loss (loss of image quality). There are two factors you should consider when choosing a compression method: the quality of images in the output file and its size.

       ABBYY FineReader lets you use the following compression methods:

       - **PACKBITS**
         
         Does not cause data loss and is well suited for compressing black-and-white scans.

       - **JPEG (JFIF format)**

         This method is used to compress grayscale and color images such as photographs. It compresses images significantly, but at the cost of some data loss. This leads to reduced image quality (blurriness and loss of color saturation).

       - **ZIP**

         Does not cause data loss and works best on images that contain large single-color areas such as screenshots and black-and-white images.

       - **LZW**

         Does not cause data loss and works best on images with vector graphics and grayscale images.
5.3. **Image preprocessing settings...**

Specify image preprocessing settings, such as detection of page orientation and automatic preprocessing settings. These settings can significantly improve source images, resulting in greater OCR accuracy. **See also:** *Image processing options*.

6. Click **Scan to <format>**.

7. A dialog box will be displayed, showing a progress bar and tips.

8. After the page has been scanned, a dialog box prompting you to decide what to do next will appear.

   Click **Scan Again** to scan more pages using the current settings or click **Finish Scanning** to close the dialog box.

9. Specify the folder where you want to save your output file.

When the task is completed, output files in the specified format will be created in the folder that you specified. All of the document's pages will also be opened in the OCR Editor.
Scanning to other formats


1. Open the New Task window, click the Scan tab, and then click the Other Formats task.
2. Select a device and specify scanning settings.
3. Click the Preview button or click anywhere inside the image.
4. Review the image. If you are not satisfied with the quality of the image, change the scanning settings and click the Preview button again.
5. Specify conversion settings. These settings determine the appearance and properties of the output document.
   5.1. Select output format
       Use this option to select the desired format for the output file.
   5.2. OCR languages
       Select the language(s) of your document. See also: OCR languages.
   5.3. Image preprocessing settings...
       Specify image preprocessing settings, such as detection of page orientation and automatic preprocessing settings. These settings can significantly improve source images, resulting in greater OCR accuracy. See also: Image processing options.
   5.4. More options...
       Opens the section with the settings of the selected format on the Format Settings tab of the Options dialog box, where you can specify additional settings (you can also open this dialog box by clicking Options... on the Tools menu).
6. Click Scan to <format>.
7. A dialog box will be displayed, showing a progress bar and tips.
8. After the page has been scanned, a dialog box prompting you to decide what to do next will appear.
   Click Scan Again to scan more pages using the current settings or click Finish Scanning to close the dialog box.
9. Specify the folder where you want to save your output file.

When the task is completed, output files in the specified format will be created in the folder that you specified. All of the document’s images will also be opened in the OCR Editor.
PDF Editor

The PDF Editor in ABBYY FineReader is an easy-to-use tool for working with PDF documents. Using the PDF Editor you can view PDF documents, carry out text searches, delete, rotate, crop, move, replace, and recognize selected pages inside a document, as well as add missing or empty pages, edit document text, copy pictures or text fragments from PDF documents and paste them into other applications, add your comments to PDF documents, and create, fill out, and edit interactive PDF forms. You don't need to convert your PDF to an editable format, even if it only contains scans without a text layer.

Chapter contents

- Viewing PDF documents 51
- Searching PDF documents 60
- Copying data from PDF documents 67
- Reviewing PDF documents 73
- Working with PDF content 80
- Working with interactive PDF forms 123
- Signing PDF documents with a digital signature 167
- Protecting PDF documents with passwords 171
- Creating PDF documents 174
- Saving and exporting PDF documents 174
- Splitting PDF documents 182
Viewing PDF documents

The PDF Editor allows you to view and search PDF documents and copy text, pictures, and tables inside them.

To open a PDF document in the PDF Editor:

- Select **New Task**, navigate to the **Open** tab, and click the PDF Document button:

- Alternatively, select **New Task** > **File** > **New PDF Document** or **Open PDF Document**.

The document will be displayed in the PDF Editor.

To customize the way the document is displayed, use the following settings.
• The viewing modes change the way pages are displayed and scrolled.

See also: Viewing modes

• The zoom feature lets you zoom in to and out of the document.

  - **Fit to Width** changes the scale at which the document is displayed so that the width of the document fits to the width of the screen.
  
  - **Best Fit** changes the scale at which the document is displayed so that the height of the document fits to the height of the screen.
  
  - **Zoom Out/Zoom In** lets you adjust the scale manually.

Chapter contents

• Viewing modes

• Navigating PDF documents

• Background recognition

• PDF security features
Viewing modes

The PDF Editor has four viewing modes that determine how document pages are displayed and scrolled:

**One-Page View** displays one page and hides all the other pages.

**One-Page Scrolling** displays pages one after the other, so that when you get to the bottom of one page, the top of the next page is visible.

**Two-Page View** displays pages side-by-side, with odd-numbered pages on the left and even-numbered pages on the right.

**Two-Page Scrolling** displays two pages side-by-side with subsequent pages appearing as you scroll down.
If you want to display even pages on the left and odd pages on the right in one of the two-page viewing modes, in the main menu, click **View** > **View mode** > **Odd Pages on the Right**.

There are several ways to change the viewing mode:

- Click one of the buttons in the drop-down list on the lower pane of the PDF Editor screen:

  ![View Modes](image)

- In the main menu, select **View** > **View mode** and select one of the viewing modes.

- Use the following keyboard shortcuts: Ctrl+5, Ctrl+6, Ctrl+7, Ctrl+8.

**Full-screen mode**

The PDF Editor has a full-screen viewing mode, in which the document takes up the entire screen space and no panels or toolbars are visible.

To enter full-screen mode, do one of the following:

- Click the button on the toolbar at the bottom of the screen.

- In the main menu, select **View** > **Full Screen**.

- Press F11.

In the full-screen mode, you can:

- Scroll the document.

- View comments (place the mouse pointer over a commented area to display the comment).

- Change viewing modes and scaling.
  - To display the bottom toolbar with viewing options, move the mouse pointer to the bottom edge of the screen.

- Go to specific pages in the document.

  See also: **Navigating PDF documents**

You can also right-click the document in full-screen view and use the commands on the shortcut menu to:

- **Add comments** and text insertion points
• Create bookmarks
• Edit text and pictures

To exit the full-screen mode, press F11 or Esc.

Hiding toolbars and panes when reading PDF documents

When reading a document in the PDF Editor, you may want to hide some or all of the toolbars and panes in order to leave as much screen space for the document as possible. The menu bar, the main toolbar, and the toolbar at the bottom of the screen can't be hidden separately, but you can use the full-screen mode if you want to hide all toolbars and panes.

You can hide the following toolbars and panes:

• To hide the navigation pane, press F5 or click View in the main menu and disable the Show Navigation Pane option.

• To hide the Comments pane, press F7 or click View in the main menu and disable the Show Comments Pane option.

The PDF Editor with the navigation pane, PDF toolbar, and comment pane hidden:
Navigating PDF documents

The PDF Editor offers a number of tools for navigating PDF documents.

- The **Pages** pane lets you navigate pages quickly, change the order of pages, add pages to the document, or delete them.
- The **Bookmarks** pane contains tools for creating, editing, and navigating bookmarks.
- The **Search** pane lets you search and highlight text.
- The **Comments** pane lets you view and navigate comments.
- The **Attachments** pane lets you view and edit attachments.
- The **Digital Signatures** pane lets you view and delete digital signatures.

The keyboard shortcuts for showing and hiding these panes are listed in *Keyboard shortcuts*.

Viewing a specific page

The PDF Editor provides several tools that make it easier to navigate long documents.

To navigate between pages:
• Use the buttons on the lower pane of the PDF Editor screen.

• In the main menu, select **View** > **Go to Page** and then click **Next Page**, **Previous Page**, **First Page** or **Last Page**.

To quickly open a specific page:

• Type the number of the desired page in the box on the lower pane of the PDF Editor screen and press **Enter**.

• In the main menu, select **View** > **Go to Page** > **Page Number**..., type the number of the desired page, and click **OK**.

**Navigating pages in the full-screen view**

To open a specific page in full-screen view, do the following:

1. Move the mouse pointer to the bottom edge of the screen to bring up the toolbar.

2. Type the number of the desired page in the box on the toolbar at the bottom of the screen.

3. Press Enter.
Background recognition

The PDF Editor allows you to search and copy text and pictures in PDF documents without a text layer, such as scanned documents and documents created from image files. This is possible thanks to an OCR process that runs in the background.

Background recognition is enabled by default and starts automatically when you open a PDF document.

The background recognition process does not change the contents of the PDF file. Instead, it adds a temporary text layer that will not be available when you open the document in other applications.

💡 If you want to make the document searchable in other applications, you will need to save the text layer created by the background recognition process. To do this, click the button on the toolbar in the Document tab and select Recognize Document... from the drop-down list. See also: Recognizing text.

⚠️ Important! If the search or copy functions don't work properly, check that the right OCR languages are selected for the document. See also: Document features to consider prior to OCR.
To disable background recognition, clear the **Enable background recognition in the PDF Editor** option in the **Options** dialog box.

The background recognition process cannot run on computers with a single-core processor.

**PDF security features**

Some PDF documents can harm your computer.

ABBYY FineReader has a number of features that make working with PDF documents safer. The program will ask for your confirmation when you perform the following potentially dangerous actions:

- Opening attachments
- Opening links
- Submitting form data.

If you trust the creator of the document, click **Allow**; otherwise, click **Cancel**.

You can also protect your computer from malicious JavaScript code by disabling JavaScript in PDF documents. To disable JavaScript, open the **Options** dialog box, click the **Other** tab, and clear the **Enable JavaScript in PDF documents** option. No when you open a PDF document with JavaScript the following notification will appear at the top of the window:

This document has features that require JavaScript. You can enable JavaScript to access these features, but this may result in security issues. Only enable JavaScript if you trust the author of this document. **JavaScript Settings**

If you trust the person or entity who sent you the PDF document, you can enable JavaScript by selecting one of the following options from the **JavaScript Settings** drop-down list:

- **Enable JavaScript for This Document Only** to enable JavaScript while the current document is open.
- **Enable JavaScript for All Documents** to open the **Options** dialog box, where you can enable JavaScript for all documents.
Searching PDF documents

The PDF Editor allows you to search for, highlight, replace, and redact information. The search will be carried out not only in the main document text, but also in the comments, the headers and footers, as well as the metadata. Thanks to background recognition, you will be able to carry out searches in any PDF documents, including scanned ones. To simplify navigating the search results, they will be displayed in a separate panel. Words or phrases that have been found in the main text body will be highlighted. This will make it easier for you to select, replace, or redact all word or phrase search hits.

Chapter contents:

- Keyword search
- Search and replace
- Search and redact
Keyword search

Video: How to Search in Scanned PDF Documents

To carry out a keyword search, do the following:

1. Click the search icon in the pane on the left or click View > Search in the main menu to open the Search pane.

2. In the Find what text field, type the word or phrase you want to find. Words or phrases that match your query will be highlighted in the document. The search results will be arranged into groups (by source: text, comments, or bookmarks) and you will be able to highlight the entire text group.

3. If required, click the arrow next to the icon and select any of the following:

   - **Exact Match** will find only words that are an exact match of the words you typed in the search box.
     E.g. searching for the word "correct" will not find words like "incorrectly" or "correction".

   - **Match Case** will find only words that match the capitalization in your query.
     E.g. searching for the word "Editor" will not find words like "editor" or "EDITOR".

You can **highlight, cross out, and underline** search hits in the text. To do this, select the appropriate words in the search results and click the respective tool (highlight, cross out, or underline).

This will create comments in the PDF document and will also mark any changes that will need to be made to the source document. This will not affect your PDF document's text itself.

To change the color used for text markup, click the arrow next to the respective tool and select the desired color on the color palette that appears.
To navigate to the next/previous search hit, use the buttons. You can also select the next search result by pressing F3.
The PDF Editor allows you to search for and replace words and phrases. To do so, follow these steps:

1. Click the ![search](search_icon.png) tab in the pane on the left or click **View > Search** in the main menu to open the **Search** pane.

2. Navigate to the **Replace** tab.

3. In the **Find what** text field, type the word or phrase you want to find. Words or phrases that match your query will be highlighted in the document. The search results will be arranged into groups (by source: text, comments, or bookmarks) and you will be able to highlight entire groups.

4. If required, click the arrow next to the ![options](options_icon.png) icon and select any of the following:
   - **Exact Match** will find only words that are an exact match of the words you typed in the search box.
     E.g. searching for the word "correct" will not find words like "incorrectly" or "correction".
   - **Match Case** will find only words that match the capitalization in your query.
     E.g. searching for the word "Editor" will not find words like "editor" or "EDITOR".

5. In the **Replace with** field, enter the text that will replace the original text.

6. In the search results, mark a word or phrase to be replaced.
   - ![check](check_icon.png) To replace several words or phrases at once, select the appropriate value in the Search panel.
7. Click **Replace**.
   This will replace your selected word or phrase with the one you specified, and the corresponding entry will be removed from the search results.

   - To navigate to the next/previous search hit, use the buttons. You can also select the next search result by pressing **F3**.

8. Save your changes.
Search and redact

Video: How to Redact confidential information in a PDF by keyword list

The PDF Editor allows you to use word, word combination, and keyword list search to remove confidential information from PDF documents before publishing them. To do so, follow these steps:

1. Click the tab in the pane on the left or click View > Search in the main menu to open the Search pane.

2. Navigate to the Redact tab.

3. In the Find what text field:
   - type the word or phrase you want to find
   - or click the icon and select Find Using Keyword List from the drop-down list to search for text using a custom list.

4. Words or phrases that match your query will be highlighted in the document. The search results will be arranged into groups (by source: text, comments, or bookmarks) and you will be able to highlight entire groups.

5. If required, click the arrow next to the icon and select any of the following:
   - **Exact Match** will find only words that are an exact match of the words you typed in the search box.
     E.g. searching for the word "correct" will not find words like "incorrectly" or "correction".
   - **Match Case** will find only words that match the capitalization in your query.
     E.g. searching for the word "Editor" will not find words like "editor" or "EDITOR".
6. In the search results, mark a word or phrase to be redacted.
   To redact several words or phrases at once, hold the Ctrl key and select the appropriate
   value in the Search panel.

7. Click Redact.
   This will remove the selected words or phrases and paint over their respective occurrences.

   In the Open Image dialog box, select the files you want to open.
   If you are using the default settings, will analyze

8. Save your changes.

**Searching and redacting using keyword lists**

If you need to search for and redact repeating words or word combinations from a document (e.g. confidential information about your organization, etc.), create a keyword list for these words and use it to search for and redact the appropriate text. To do so, click the icon in the Find what text field and select one of the following from the drop-down list:
• **Add Keyword to List** to add a word or word combination currently in the text field to a keyword list;

• **Find Using Keyword List** to search the text using a custom keyword list;

• **Edit Keyword List...** to add, modify, delete, and save keywords for a list.

To save the changes that you have made to a list and carry out a search using the modified keyword list, click **Save and Find**.

To view all keywords in a particular list, hover the cursor over the list's name.

To close a keyword list, click the icon next to its name or uncheck **Find Using Keyword List**.

### Copying data from PDF documents

The PDF Editor allows you to copy any area of a PDF document without recognizing the whole document or converting it into an editable format.

You can **copy** any area as:

- **an image**
- **text**
- **a table**
Copying an area as an image

To copy an area of a PDF document as an image:

1. Use the mouse to draw a rectangle around the area that you want to copy.
   - The area that you mark up has to be confined to a single page.

2. Click the icon on the toolbar that appears next to the marked up area.

   ![Copy as Image Icon](image)

   Alternatively, you can right-click the marked up area and then click Copy as Image on the shortcut menu or press Ctrl+C on the keyboard.

   ![Shortcut Menu](image)

   - Text from the marked up area will be copied to the clipboard as an image.

3. Paste the copied image into the desired application.
Copying an area as text

Video: How to Extract Text from Scanned PDFs

To copy an area of a PDF document as text, use one of two methods:

**Method 1:**

1. Use the mouse to draw a rectangle around the area that you want to copy.
   - The area you mark up has to be confined to a single page.
2. Click the icon on the toolbar that appears next to the marked up area.

Alternatively, you can right-click the marked up area and then click **Copy as Text** on the shortcut menu or press Ctrl+Shift+C on the keyboard.
3. Paste the copied text into the desired application.

**Method 2:**

1. Use the mouse to mark up the text strings that you want to copy.
   - You can mark up text strings on several pages at once.

2. Right-click the marked up text.

3. Click **Copy Text** on the shortcut menu that appears or press Ctrl+C on the keyboard.

4. Paste the copied text into the desired application.

You can use Method 2 only for PDF documents with a text layer. If there is no text layer in a PDF document, ABBYY FineReader PDF creates a text layer as a result of the **background recognition** process.

- If you are unable to mark up text strings with the mouse cursor, make sure that the **Enable background recognition in the PDF Editor** option in the **Options** dialog box is selected.

- If there are visual differences and recognition errors in the copied text, make sure that the right OCR languages are selected for the document.

**See also:** [Document features to consider prior to OCR](#)

- To save the text layer created by the background recognition process, click the arrow next to the button on the toolbar in the **Document** tab and select **Recognize Document**.

**See also:** [Recognizing text](#)
Copying an area as a table

Video: How to Extract Tables from PDF

To copy an area of a PDF document as a table:

1. Use the mouse to draw a rectangle around the area that you want to copy.
   - You can mark up a table or any part of one, as well as plain text, even on the images.
   - The area that you mark up has to be confined to a single page.

2. Click the icon on the toolbar that appears next to the marked up area.

   Alternatively, you can right-click the marked up area and then click Copy as Table on the shortcut menu or press Ctrl+Alt+C on the keyboard.

3. Paste the copied table into the desired application.

   PDF Editor allows you to change the table structure before copying it. You can:
   - add vertical / horizontal separators;
   - delete separators;
   - split / merge table cells.
After the text from the marked up area has been recognized, a toolbar with table editing tools will be displayed next to the area.

Use these tools to change the table structure and click the icon on the table editing toolbar again. The edited table will be copied to the clipboard.

No changes will be made to the table in the original file.

You can edit the table in the original file in the OCR Editor.

If the table data that has been copied differs significantly from the original document data:

- If the document does not have a text layer, make sure that the right OCR languages are selected.
- If the page containing the data you want to copy has a text layer of a poor quality, replace the text layer with a new one.

Now, try copying the data again.
Reviewing PDF documents

Video: How to Comment and Annotate in PDF

The PDF Editor includes a number of features for reviewing PDF documents. While reading a document, you can add comments, highlight important fragments, make notes, draw shapes to highlight specific areas, and place stamps on pages.

Chapter contents

- Adding comments
- Marking up text
- Drawing shapes
- Adding text to PDF documents
- Adding stamps
- Collaborating on PDF documents
Comments

The PDF Editor offers tools for adding notes to any part of a PDF document, making discussing and reviewing PDF documents much simpler.

1. Click the tool on the toolbar in the Document tab.

2. If you don't like the default note color, select another one on the toolbar that appears above the document.

3. Click where you want the note to appear on the page and type the note.

You can change the color of an existing note using its shortcut menu.

To find out how to open notes, reply to notes or delete them, see Collaborating on PDF documents.

Six things about FineReader you may especially like

- Flexible pricing plans: Benefit from one-year or three-year subscription plans.
- On premise:

ABBYY FineReader PDF is a great choice for a PDF solution when you are looking for an alternative to Adobe Acrobat. FineReader PDF is powered by ABBYY’s established OCR, which will drive your digital transformation process even further.

OCR:

It's necessary to give an explanation:
OCR - Optical Character Recognition.
Marking up text

The PDF Editor allows you to indicate what changes should be made to a document. Any editing marks that you add will not alter the text itself but merely indicate what changes must be made and where.

 Annotations related to editing text are only available in documents with a text layer or documents that have been recognized by the background recognition process.

ABBYY FineReader includes the following markup tools:

- Highlight
- Underline
- Strikethrough
- Add Note to Insert Text

You can add a comment to any type of annotation by double-clicking the annotation. For more on comments, see Collaborating on PDF documents.

To highlight, underline, or cross out a text fragment:

- Select a markup tool on the toolbar in the Document tab and then select the desired text fragment, or
- Select the desired text fragment and then select a markup tool on the toolbar in the Document tab.

To indicate an insertion point:

- Click the tool on the toolbar in the Document tab and click the place where you think text needs to be inserted.

To change the color of an annotation:
Right-click the annotation and select the desired color on the shortcut menu or

Click a markup tool on the toolbar in the Document tab and then click one of the color boxes on the toolbar that appears above the document.

You can use the search feature to mark up specific text fragments without reading through the entire document to find them.

1. Open the Search pane.

2. Type the word or phrase you want to find.

3. In the SEARCH pane, select the search hits you want to mark up and click the desired markup tool. If you want to choose a different color, click the arrow next to the markup tool instead of clicking the tool itself and then click the desired color on the color palette that appears.

By default, the markup tools in the Search pane use the same colors as the markup tools on the PDF Tools toolbar.
Drawing shapes

The PDF Editor allows you to draw various markings on the page of a PDF document. You can also add comments to the various shapes that you have drawn.

1. On toolbar in the **Document** tab, click 💞 **Draw** 🔗.

2. Select the appropriate drawing tool from the drop-down menu.

   - **Ink**
     
     Draws a line when you hold down the left mouse button, letting you draw any shape.
• **Line**
  Draws a straight line. If you want to draw a vertical, horizontal or diagonal (sloped at an angle of 45°) line, hold down the **Shift** key.

• **Arrow**
  Draws an arrow. If you want to draw a vertical, horizontal or diagonal (sloped at an angle of 45°) line, hold down the **Shift** key.

• **Rectangle**
  Draws a rectangle. If you want to draw a square, hold down the **Shift** key.

• **Oval**
  Draws an oval. If you want to draw a circle, hold down the **Shift** key.

• **Polygon**
  Draws a polygon. Click where you want to place the initial vertex of the polygon. To complete the polygon, click the initial vertex.

• **Cloud**
  Draws a cloud. Click where you want to place the initial vertex of the cloud. To complete the cloud, click the initial vertex.

• **Polyline**
  Draws a jagged line. Click the page to start drawing, click again when you want to draw the next segment, and double-click where you want the jagged line to end.

• **Text Box**
  Draws a rectangle with a nested text annotation. For more details, see Adding a Text block annotation to a PDF document.

3. Once you have finished drawing the shape, double-click it if you want to type a comment. If you are using the **Ink** tool, you will need to disable the drawing tools before you can type a comment.

To draw a set of shapes using the **Ink** tool and add a comment to the entire set:

• Hold down the **Shift** key and draw the figure. You can release the mouse button, but only release the **Shift** key when you are finished drawing.

• Disable the drawing tools, double-click one of the shapes in the set, and type your comment.

4. Drawing tools have several settings you can change.

To change these options:
• Right-click a shape you drew on the page and use the commands on its shortcut menu.
• Selecting the desired settings on the PDF Tools toolbar before drawing a shape.

For more on using and editing comments, see Collaborating on PDF documents.

Adding a Text block annotation to a PDF document

The PDF Editor allows you to add blocks of text to any type of PDF.

A text block is an annotation. Text in a text block is not the body text of a PDF document. For more information about adding body text to a PDF document, see Inserting and editing text.

To add a text block to a PDF document, do the following:

1. Click the icon on the toolbar in the Document tab and select from the drop-down list.
   A toolbar with text editing tools will appear beneath the PDF Tools toolbar.
2. Click where you want to add text. To change the size of the text block, drag one of the sizing handles in the desired direction.
3. Type your text. You can choose a font type, font size, and font color.
4. Change the size of the text block if necessary.
5. To draw a border around the text block, select the color and thickness of the border.
6. You can also change the background color of the text block or use the Detect background color option to use the background color of the page.
   By default, a transparent background is used.

You can use the PDF Editor to fill out forms that do not have interactive fields. To do this, simply type text over the form using the Export tool.

When you add a text block, a new comment containing text from the block will appear in the Comments pane. You can change the status of the comment in the same way you change the status of an annotation. See also: Collaborating on PDF documents.
Collaborating on PDF documents

The PDF Editor allows you to see and reply to comments made by other reviewers, even if they were created in applications other than ABBYY FineReader. You can also change the status of a comment to inform a reviewer that you have accepted or rejected his/her suggestion.

To view a list of all comments in the document, open the Comments pane by clicking the button on the toolbar in the tab.

There are other ways to open the Comments pane:

- Right-click an annotation, stamp or comment and click Show Comments Pane on the shortcut menu.

- Select View in the main menu and click Show Comments Pane.

- Press F7.

Adding a comment to an annotation
• Double-click the annotation to which you want to add a comment, or

• Right-click the annotation and select the Add Comment command on the shortcut menu.

If the Comments pane is hidden, a comment box where you can type the comment will appear. If the Comments pane is visible, the comment box associated with the annotation will be highlighted.

Opening a comment

• Select the annotation that contains the comment you want to see.

If the Comments pane is hidden, a comment box where you can type the comment will appear. If the Comments pane is visible, the comment box associated with the annotation will be highlighted.

☑ If you want a comment to always be visible, double-click its annotation. To hide a comment, click the button in the upper-right corner of the comment box.

Replying to a comment

1. Select the annotation that contains the comment to which you want to reply.

2. Click Reply in the comment box or press Ctrl+Enter and type your reply.

Deleting an annotation or its associated comment or reply
To delete an annotation:

- Select the annotation you want to delete and press Delete on the keyboard or right-click the annotation and click **Delete** on the shortcut menu.
  The comment associated with the annotation will also be deleted.

- Select a comment box in the **Comments** pane and press Delete on the keyboard or right-click the comment box and click **Delete**.
  The annotation associated with the comment will also be deleted.

To delete a comment in the **Comments** pane:

- Right-click anywhere inside the comment box and select **Delete** on the shortcut menu.
  All replies associated with the comment will also be deleted.

To delete all comments and annotations:

- Select **Document** in the main menu and click **Delete Comments and Markup**...

To delete a reply:

- Right-click the reply and select **Delete Reply** on the shortcut menu.
  In the same manner, you can delete a reply on the **Comments** pane.

**Flagging a comment or changing its status**

You can assign statuses to comments you have read or flag those comments which you want to revisit later.

To flag a comment:

- Click the ☑ box next to the comment in the **Comments** pane or right-click the comment and click **Add Checkmark** on the shortcut menu.

To change the status of a comment:

- Right-click a comment or its annotation, click **Status** on its shortcut menu, and select the desired status.

- Click the *** button in the comments box and select the desired status.

**Properties of annotations and comments**
In the **Properties**... dialog box of an annotation or comment, you can change the author or the subject and see how the status of the annotation or comment changed over time. If you have changed the name of the author, you can click the **Set Default** button to use the new name for any annotations and comments you make in the future.

To open the **Properties** dialog box of an annotation or comment:

- Right-click the annotation, stamp or comment and click **Properties**... on the shortcut menu.

**The Comments pane**
The **Comments** pane displays all annotations added to the document, with or without comments, and all text blocks, stamps, and editorial marks.

- To navigate the comments, use the buttons.
- You can search for a specific comment, reply or author using the search box at the top of the **Comments** pane.

To sort the comments:

- On the **Comments** pane, click and then select the desired sorting option from the menu.

You can filter the comments by type, author, flag status, or comment status.

To filter the comments:

- On the **Comments** pane, click to open the filter menu and then click **Show All Comments, Hide Current Comments**, or select the criteria you want to use to filter the comments.

You can filter the comments by:

1. Type
2. Author
3. Page
4. Date
5. Flag Status
6. Status

To reset the filter, click **Reset**.

If you just want to see the authors and dates of the comments, click to hide the text of the comments. To display the text again, click .
Adding stamps

The PDF Editor allows you to stamp PDF documents in the same manner as you stamp paper documents. You can select a stamp from the list of available stamps or create your own, adding any desired text, the date and time of stamping, or an image.

To stamp a page:

1. On the toolbar in the Document tab, click and select the desired stamp.
   🌟 If the stamp you want to use is not available in the menu, click Other stamp.
2. Stamp the page.
3. Move the stamp to the desired location if necessary.

You can add comments to stamps and change their statuses in the same manner as you add comments to annotations. See also: Collaborating on PDF documents.

How to create a stamp
The PDF Editor allows you to create textual stamps and stamps from images.

To create a stamp from an image:

1. On the toolbar in the Document tab, click \(\text{Create Stamp from Image...}\).
2. In the dialog box that opens, type a name for your stamp in the Name field.
3. Click Open to open an image from your hard disk or click Paste from Clipboard if you have previously copied an image to the Clipboard.
4. Use the Stamp size slider if you need to adjust the size of the image.
5. Click Save.

To create a text stamp:

1. On the toolbar in the Document tab, click \(\text{Create Text Stamp...}\).
2. In the dialog box that opens, type a name for your stamp in the Name field.
3. In the Stamp text field, type the text that you want to appear on the stamp.
4. From the Add Date/Time drop-down list, select the date and time format that you want to use.
   - When you stamp a page, the stamp will contain the date and time of the stamping in the format you specified.
   - All text elements will be added to the stamp at the position of the cursor in the Stamp text field. You can change the order of the stamp elements in this field, add explanatory text, and set up the date and time formats. For more on dates and times, see Current date and time on stamps and in Bates numbers.
5. In the Font and border group of options, select a font type, font size, and font effects for the text in the stamp and a color for the stamp.
6. Enable the Add border option if you want the stamp to have a border.
7. The View box contains a preview of the stamp, so you can see the effects of the changes you make.
8. Click Save.

How to edit stamps
1. On the toolbar in the Document tab, click > Manage Stamps.

2. In the dialog box that opens, select a stamp and click Edit.

3. Specify the desired settings and click Use.

How to delete a stamp

To remove a stamp from your document, do one of the following:

- Select the stamp in the document and press Delete.
- Right-click the stamp in the document and select Delete... on the shortcut menu.
- Select the comment for the stamp in the Comments pane and press Delete.

To remove a stamp from the list:

1. On the toolbar in the Document tab, click > Manage Stamps.

2. In the dialog box that opens, select the stamp and click Delete.
Working with PDF content

The PDF Editor allows you to modify the contents of PDF documents without the need to convert PDF documents to editable formats.

Chapter contents

- Inserting and editing text
- Inserting and editing pictures
- Inserting and editing hyperlinks
- Recognizing text
- Organizing pages in a PDF document
- Adding bookmarks
- Adding headers and footers
- Adding watermarks
- Adding file attachments
- Viewing metadata
- Enhancing page images

Inserting and editing text

Video: How to Edit Any PDF

The PDF Editor in ABBYY FineReader PDF allows you to insert and edit text in any PDF document:
PDF documents created using other applications
scanned documents
searchable PDF documents

The following features are available:

• adding new text
• deleting text
• copying and pasting text from the clipboard
• editing the formatting of text inside existing text blocks
• changing the text block size
• moving text blocks on a page
• correcting page orientation, skewing, distorted text, and other defects found in scanned documents

* except PDF documents containing vector graphics text

Inserting new text

New text can be added to a page in the following ways:

• Add a new text block using the Add Text tool
  This is the most convenient way to insert:
  o a large volume of text
  o an isolated text block

• Edit an existing text block
  This is the most convenient way to insert text if you need to add a relatively small volume of text to an already existing text block.

• Add text using the Header and Footer tool
  This is the most convenient way to insert text if you need to add identical text to several pages at once.

Adding new text using the Add Text tool

To add a new text block to a PDF document:
1. Switch to the editing mode.
You can do so by navigating to the Edit Content tab or by using the Ctrl+E hotkey.

**Note:** you might have to wait some time for the program to prepare the document for editing. During this time, a page preparation indicator will be displayed under the toolbar.

Doing so will make text and images on the page be marked as separate blocks:

**Note:** when working with scanned documents and searchable PDF documents, it is important to specify the correct languages, especially when background recognition is disabled. For more details, see Document features to consider prior to OCR.

**Tip:** before starting your work with scanned documents and searchable PDF documents, it is sometimes best to correct the page orientation, skew, distorted text, and other defects.

2. Click the **Add Text** button on the toolbar or press Ctrl + T on the keyboard. This will enable the editing tools in the toolbar.

3. Place the cursor in the particular spot where you want a new text block to be added and mark out a rectangular shape of the appropriate size for your new text block or left-click once for a text block of a default shape.

**Note:** the size of the new text block cannot be larger than the page itself.

**Note:** you can create new text blocks over other objects.
4. Enter your text into the text block that you have just created.

   **Note:** When adding a large volume of text, take care to not go over the edges of the page itself.

5. Finish adding the text. To do this, left-click the area outside of the text block or press the Esc key.

6. Save the changes you have made to the document by clicking the button on the toolbar in the Document tab or by selecting **File > Save** in the main menu. Alternatively, you can use the **Ctrl+S** hotkey.

7. To exit the text editing mode, switch to any other tab.

**Editing existing text**

To edit text in a PDF document:
1. Switch to editing mode.
   You can do so by navigating to the Edit Content tab or by using the Ctrl+E hotkey.

   **Note:** you might have to wait some time for the program to prepare the text for editing. During this time, a page preparation indicator will be displayed under the toolbar.

   ![Preparing the page indicator](image)

   This will make text and images on the page be marked as separate blocks:

   ![Text and images marked as separate blocks](image)

   **Note:** when working with scanned documents and searchable PDF documents, it is important to specify the correct languages, especially when background recognition is disabled. For more details, see Document features to consider prior to OCR.

   **Tip:** before starting your work with scanned documents and searchable PDF documents, it is sometimes best to correct the page orientation, skew, distorted text, and other defects.

2. Edit the text in the PDF document.
   You can:

   - **Add new text to an existing text block**
     To do this, place the cursor into the text block and type the appropriate text or paste the text from the clipboard.
     The program will pick a suitable font automatically.
     **Note:** the name of the current font is displayed in the list on the toolbar. A pair of square brackets around a font name means that the font is built into the edited PDF document, but has not been installed on your system. To use this font when typing new text, install it on your system first. Otherwise, the program will pick the default font.

   - **Delete text from an existing text block**
     To do this, select the text you want to delete and delete it.
• **Delete a text block entirely**
  To do this:
  
  o  Hold down the Ctrl key and left-click the text block.
  Alternatively, you can select a text block by left-clicking inside it, place the cursor on one of the block's edges, and select it by left-clicking it when the cursor's appearance changes to 🖋.

  o  Delete the text block by pressing Delete.

• **Change the formatting of text**
  To do this, select the appropriate text inside a text block and edit it using the appropriate toolbar buttons:

• **Change the size of a text block**
  To do this, first select the appropriate text block by left-clicking inside it. The text block edges will now have little square icons on them.

  Place the cursor on top of one of the square icons. When the cursor's appearance changes to 🕹️, hold down the left mouse button and drag the cursor so that the text block's size changes to the size that you want.

  **Note:** when changing a text block's size, take care to not go over the edges of the page.

• **Move text blocks around on a page**
  To do this, hold down the Ctrl key and place the mouse cursor on a text block. While still holding down the Ctrl key, drag the block to the desired location.
  Alternatively, you can select a text block by left-clicking inside it, place the cursor on one of its edges, and move it by holding down the left mouse button when the cursor's
appearance changes to ✉️.

**Note:** when moving a text block, take care to not go over the visible edges of the page.

3. Finish editing the text. To do this, left-click outside the text block or press the Esc key.

4. Exit the text editing mode. To do this, switch to any other tab.

5. Save the changes you have made to the document by clicking ✉️ button on the toolbar of the Document tab or by selecting **File > Save** in the main menu. Alternatively, you can use the Ctrl+S hotkey.

Video: [How to Update Tables in a PDF File](#)

**Improving text editing in scanned documents**

Before starting to edit scanned documents and searchable PDF documents, you can do the following to improve the editing of text:
• **Correct the page orientation, skew, distorted text, and other defects**
  To make cosmetic changes to the appearance of a scanned document, click the **Correct Skew and Page Orientation** button on the toolbar in the **Edit Content** tab and choose **Correct Skew and Orientation for Current Page** (for a particular page or for the whole document).

  ![Correct Skew and Page Orientation button](image)

  **Note:** the **Correct Skew and Page Orientation** button appears on the toolbar in the **Edit Content** tab only for those pages, where the program has detected text skewing.

• **Re-recognize a page / document**
  If a page contains a text layer, it will be used when editing the text. To recognize a page from scratch, click the **Text Layer** button in the toolbar and select **Recognize Page and Replace Existing Text Layer**... (for a particular page or for the whole document).

  ![Text Layer button](image)

  This will open the **Recognize Document** dialog box.
  Select the appropriate languages from the drop-down list in its upper half.
  Mark the checkboxes next to **Correct page orientation** and **Deskew images and correct image resolution** in the lower part of the window.

  ![Recognize Document dialog box](image)

  Click **Recognize**.
Inserting and editing pictures

The PDF Editor allows you to insert pictures into PDF documents of any type.

1. On the toolbar in the Edit Content tab, click the Picture button or select Edit Content > Add Picture... in the main menu.

2. In the dialog box that opens, select a picture and click Open.

3. Move the picture to the desired location on the page.

You can move, rotate, delete, and resize pictures. When you move a picture, it may overlap with other objects on the page. To bring an overlapping picture to the foreground, right-click it and select Bring Picture to Front.

To delete a picture:

- To delete a picture in a PDF document created in another application, right-click the picture and click Delete on the shortcut menu.

- You can delete a part of the document image and anything that it may contain, including pictures. To do this, click the Erase tool on the toolbar in the Security tab and select the area you want to erase.

The Erase tool deletes pictures and text, automatically selecting the appropriate background color to fill the empty space.
Inserting and editing hyperlinks

ABYY FineReader allows you to insert hyperlinks into PDF documents of any type and edit existing hyperlinks.

When you point the mouse cursor to a hyperlink, its address is shown in a pop-up box. To follow the link, simply click it.

**To insert a hyperlink into a PDF document:**

1. Type the text to be used as a hyperlink.

2. Either select **Edit > Add Link...** in the main menu or select the text, right-click it, and then click **Add Link...** on the shortcut menu.

**Linking to a specific text fragment in the current document**

In the Link Editor:

- Select **Page in this document** and enter the number of the page that the link should open, or
- Click **Select specific destination...** and place the mouse cursor where you want to direct users who click the link.

**Linking to a web page**

In the Link Editor:

- Select **Web address, e-mail address, file or other resource** and type the URL of the page you want to link to (e.g. [http://www.abbyy.com](http://www.abbyy.com)).

**Linking to an e-mail address**

In the Link Editor:

- Select **Web address, e-mail address, file or other resource** and type the recipient's e-mail address preceded by "mailto:" (e.g. mailto:office@abbyy.com).

**Linking to a file**

In the Link Editor:

- Select **Web address, e-mail address, file or other resource** and enter the path to the file that the link should open preceded by “file://” (e.g. file://D:/MyDocuments/ABBYYFineReader.pdf).

**To edit a hyperlink:**
1. Select the hyperlink you want to edit.

2. Right-click the selected link and click **Edit Link...** on the shortcut menu.

3. In the Link Editor, do one of the following:
   
   - Change the number of the page that the link should open
   
   - Click **Select specific destination...** and place the mouse cursor where you want to direct users who click the link
   
   - Change the URL, e-mail address, or path to a file or other resource.

💡 You can copy the URL, e-mail address or the path to a file or other resource into the Clipboard. To do this, right click the link, select **Copy Link**, and copy the URL, e-mail address, or path.

**To delete a hyperlink from a PDF document:**

1. Select the hyperlink you want to delete.

2. Right-click the selected link and click **Remove Link** on the shortcut menu.
Recognizing text

Background recognition is a process that adds a temporary text layer to a document, enabling you to mark up, copy, and search its text. You can make these capabilities available to other users by adding a permanent text layer to PDF documents. Documents with text layers are practically indistinguishable from their originals. You can also replace an existing text layer in a searchable PDF document.

1. On the toolbar in the Document tab, click the button and select Recognize Document... from the drop-down list. Alternatively, select Document > Recognize Document > Recognize Document... in the main menu or use the CTRL+SHIFT+R hotkey.

2. In the dialog box that opens, specify the appropriate OCR languages. See also: Document features to consider prior to OCR.

3. To improve the quality of OCR, enable image processing. Image processing may change the appearance of your document.
   - Correct page orientation - The program will detect text orientation and correct if necessary.
   - Deskew images and correct image resolution - The program will detect and correct any skew, select the appropriate image resolution, and make some other changes to improve the images.

4. Click the Recognize button.

5. As a result, the output document will contain a searchable text layer.

You can also add a text layer when adding pages to a PDF document from a file or when scanning paper documents. To do this, select the Recognize text on images option in the Image Processing Settings dialog box (navigate to the Organize Pages tab, click the button on the toolbar and select Image Processing Settings) and specify the languages of the document. See also: Working with pages.

If you want to check recognized text, train the program to recognize non-standard fonts and characters, or use some other advanced features of ABBYY FineReader, on the toolbar in the Document tab, click the button and select Recognize and Verify in OCR Editor from the drop-down list. Alternatively, select Document in the main menu and click Recognize Document > Recognize and Verify in OCR Editor. See also: Sending PDF documents to the OCR Editor.
Organizing pages in a PDF document

Video: How to Organize Pages in a PDF

The PDF Editor allows you to delete, rotate, crop, move, replace, and recognize selected pages, as well as add missing or empty pages, correct page images, and create new PDF files using selected pages. Any of this can be done by quickly switching between the different pages of your PDF document or by selecting an appropriate range of pages.

To switch the Organize Pages mode, select the Organize Pages tab.

To select the appropriate pages, in the Page Range box, specify either a page number, a page range (e.g., 2,3,5-7), or select one of the following from the drop-down list: Even Pages, Odd Pages, All Pages.

Deleting a page from a PDF document...
To delete an unwanted page from a PDF document, select one or several pages and do one of the following:

- click the *button that appears when hovering the mouse cursor over a page thumbnail*
- click the *button on the toolbar*
- select *Organize Pages > Delete Pages* on the main menu
- select *Delete Pages...* from the drop-down menu for the appropriate page
- press *Del* or use the *Ctrl+Backspace* hotkey

**Rotating a page...**
To pages that have an incorrect orientation, select one or several pages and then use one of the following to rotate it:

- use the page rotation icons that appear when hovering the mouse cursor over a page thumbnail

- use the buttons on the toolbar

- select Organize Pages > Rotate Pages > Rotate Right/Rotate Left on the main menu

- select Rotate Pages > Rotate Right/Rotate Left from the page context menu

- use the Ctrl+Shift+> and Ctrl+Shift+< hotkeys

To automatically correct the orientation of selected pages, click the button on the toolbar or select Rotate Pages > Correct Page Orientation from the drop-down menu.

Cropping a page...
To crop the borders of a page, follow the steps below:

1. Select one or several pages.

2. Click the Crop button on the toolbar or select **Organize Pages > Crop Pages** on the main menu. Alternatively, select **Crop Pages...** from the page context menu. Doing so will switch to the crop mode: page thumbnails will be displayed on the left of the screen, while the image of the selected page will be displayed on the right.

3. On the Crop toolbar, select a crop frame:
   - **Separate frame for each page** if you need to specify a different size for each selected page.
   - **Single frame for all pages** if you need to specify the same size for all selected document pages.

4. Move the edges of the frame to manually specify the crop frame on the page. Alternatively, select a frame of the appropriate size from either the toolbar drop-down menu or the page context menu.
5. Click **Apply Crop** on the Crop toolbar or select it from the page context menu. Alternatively, press **Enter**.

- To exit the Crop mode, click **Exit Crop** on the Crop toolbar or select it from the page context menu. Alternatively, press **Esc**.

**Adding an empty page to a PDF document...**

To add an empty page to a PDF document, do the following:

1. Place the mouse cursor over the part of the document where you want to insert the empty page, and click the button that will appear.

2. In the menu that will appear, select **Add Blank Page**.

3. Select the appropriate page size in the dialog box that will appear.

4. Click **Add**.

- To add an empty page, you can also use the button in the **Organize Pages** toolbar or select **Organize Pages > Add Pages > Add Blank Page** on the main menu.

This will add an empty page at the selected location in the PDF document.

**Adding pages from a PDF document...**
To add pages from another PDF document to the current document, do the following:

1. Place the mouse cursor over the part of the document where the pages need to be inserted and click the button that will appear.

2. In the menu that will appear, select **Add Pages from PDF...**

3. In the dialog box that will open, select the PDF file that will be used as the source file for the pages to be added to the current document. If required, specify the page numbers.

4. Click **Open**.

   - When selecting several PDF files, you can modify the order in which they will be added by using the controls. You can also delete unwanted PDF files by clicking the button.

   - Pages from other PDF files can also be added by clicking the button on the **Organize Pages** toolbar or by selecting **Organize Pages > Add Pages > Add from PDF...** on the main menu.

This will add the selected PDF files to the document that is currently open in ABBYY FineReader without processing them.

*Adding pages from a file...*
To add pages from a different file to the current document, do the following:

1. Click the button on the toolbar.

2. From the drop-down menu, select Add from File...

3. In the dialog that will open, select the file or several files (of supported format or formats) that you want to add to the PDF document that is currently open, and specify the relevant pages if required.

4. Click Open.

5. In the dialog box that will appear, specify the page in front of or after which the new pages should be added: before first, after last, or after the selected page.

6. If required, uncheck the Split facing pages option and modify the image processing properties for pages added to the document by clicking Image Processing Settings.

7. Click Add.

When selecting several files, you can modify the order in which they will be added by using the controls. You can also delete unwanted files by clicking the button.

Pages from other files can also be added by selecting Organize Pages > Add Pages > Add from File... on the main menu or by clicking the button that appears when placing the mouse cursor over the area between pages.

This will add the PDF document created using the selected files to the document that is currently open in ABBYY FineReader.
💡 File processing speed will be significantly lower than when using the **Add from PDF...** command due to the applied image processing settings for pages added to the document.

**Scanning pages and adding them to a PDF document...**
To scan pages and add them to the current PDF document, do the following:

1. Click the button on the toolbar.

2. Select Add from Scanner... from the drop-down menu.

3. Select a device and specify the scanning parameters.

4. Specify the page in front of or after which the new pages should be added: before first, after last, or after the selected page.

5. Click Preview or click left-click anywhere on the scanned area to view the output image.

6. If required, modify the image processing settings for pages added to the document by clicking Settings....

7. Click Scan.

8. Once scanning has finished, click one of the following:
   - Scan to begin the scanning process using the current settings again.
   - Preview to view the output image.
   - to close the dialog box.

To add pages from your scanner, you can also select Organize Pages > Add Pages > Add from Scanner... on the main menu or click the button that appears when placing the mouse cursor over the area between pages.

This will add the scanned pages to the current PDF document.
Modifying page order in a document...

To modify the page order in a document, select one or several pages and do one of the following:

- Drag the appropriate pages to their required place in the document. While dragging a page or pages, a bar that demonstrates where the pages will be moved will appear. The bar will also have a number denoting the number of pages being moved.

- Click the \[\text{Move}\] button on the toolbar or select \text{Organize Pages} > \text{Move Pages} on the main menu. Alternatively, select \text{Move Pages} from the context menu. Then, specify where the selected pages should be moved using the dialog box that will appear: before first, after last, or after the specified page. Click \text{Move}.

This will move the selected pages of the current PDF document to the specified location.

Replacing document pages...
To replace pages in the current document with pages from a different PDF document, do the following:

1. Select one or several pages that you want to replace.

2. Click the Replace button on the toolbar or select Organize Pages > Replace Pages on the main menu. Alternatively, select Replace Pages... from the context menu.

3. In the dialog box that will open, select the PDF document containing the pages you want to replace pages from the current document with, and click Open.

4. In the Replace Pages dialog, specify the page range that needs to be replaced in the current document, as well as the source page range for pages from the other document.

5. Click Replace.

This will replace the selected pages of the current PDF document with pages from the other PDF document.

Deleting blank pages from a document...

To delete all blank pages from a PDF document, do the following:

1. In the main menu, select Organize Pages > Delete Blank Pages.

2. In the dialog box that will open, select the pages that you want to delete.

   By default, all pages identified by ABBYY FineReader as blank are selected. You can use the + and – hotkeys to view the pages.

   ❗️ Before you delete the selected pages, make sure that they do not contain any handwritten notes, pictures, or other data that may be important.

3. Click Delete selected pages.

Doing so will remove all specified blank pages from the PDF document.

Splitting a PDF document...

To split a single PDF document into multiple smaller ones, do the following:

1. Click the Split button on the toolbar or select Organize Pages > Split Document... on the main menu.

2. In the dialog box that will open, specify how the document should be split: by file size, by page count, or by bookmarks. For more information, see Splitting PDF Documents.

Recognizing selected pages...
To add a text layer to the selected pages, do the following:

1. Select one or several pages that you want to recognize.

2. On the toolbar, click the arrow next to the Recognize button and then select Recognize Selected Pages from the drop-down list. Alternatively, select Recognize > Recognize Selected Pages from the context menu.

3. In the dialog box that will appear, specify the recognition languages. For more information, see Document features to consider prior to OCR.

4. To improve the recognition quality, enable image processing. Enabling image processing may change the visual appearance of the document.
   - Correct page orientation - automatically detects page orientation and corrects it if required.
   - Deskew images and correct image resolution - automatically detects and corrects any skewing, selects the appropriate image resolution, and makes some other changes to improve the images.

5. Click Recognize.

This will add a text layer to the selected pages.

To send a PDF document from the PDF Editor to the OCR Editor, select the appropriate pages, click the arrow next to the Recognize button on the toolbar, and select Send Selected Pages to OCR Editor from the drop-down list. This will open the selected pages in the window of the OCR Editor, where you can mark out recognition areas, verify recognized text, "teach" the program to recognize non-standard characters and fonts, as well as use other advanced ABBYY FineReader features to maximize the quality of the recognition results.

Enhancing page images...
The PDF Editor lets you enhance the quality of PDF documents created using image files. Depending on the type of the source images, the program will automatically determine and apply the features required to correct them. Aside from automatic image processing, ABBYY FineReader can also correct page orientation, deskew images, distorted text, and other defects, as well as use ABBYY PreciseScan.

1. Select one or several page images that you want to enhance.

2. Click the button on the toolbar or select Organize Pages > Enhance Images... on the main menu. Alternatively, select Enhance Images from the context menu.

3. Specify the required parameters in the Image Enhancement dialog box that will appear. For more information, see Enhancing page images.

Creating a PDF document from the selected pages...

To create a new PDF document that contains only specific selected pages, do the following:

1. Select the required pages.

2. From the context menu, select Create PDF from Selected Pages.

The output PDF document will be opened in a new ABBYY FineReader window.

Image processing parameters for added pages...
The PDF Editor offers various image processing options that can enhance the source image and let you improve the quality of recognition results.

You can set image processing options when scanning paper documents, creating a PDF document using image files, as well as by using the button. To do so, click the arrow icon next to the button and select Image Processing Settings... from the drop-down list.

- **Image quality** — the image quality and size of the output file will depend on the value specified in the drop-down list of the Image quality group:
  - **Best quality**
    Select this option if you need to preserve the original image quality of pages and images. Their original image resolutions will be preserved as well.
  - **Balanced**
    Select this option if you want to reduce the size of the document but still maintain a high enough quality of pages and images.
  - **Compact size**
    Select this option if you want the output file to be a PDF document of a compact size. This will reduce the quality of the pages and images.
  - **Custom...**
    Select this option to specify your own custom options for saving pages and images. In the Custom Settings dialog box that will open, select the required values and click OK.

- **Recognize text on images** — mark this option to add a text layer. This will create a text-searchable PDF document, the appearance of which will be almost identical to the original document.

- **Use MRC compression (specify OCR languages below)** — mark this option to apply a compression algorithm that uses Mixed Raster Content (MRC) to the recognized pages. This will allow the file size to be reduced without a loss in image quality.

- **Apply ABBYY PreciseScan to smooth characters on image** — mark this option to use ABBYY’s PreciseScan feature. ABBYY PreciseScan makes document characters less pixelated when page scaling is increased.

- **OCR languages** — to get the best possible recognition quality, it is important to specify the correct recognition languages. See also: Document features to consider prior to OCR.
Adding bookmarks

Video: How to Bookmark PDFs

The PDF Editor allows you to add bookmarks to PDF documents of any type.

You can create a bookmark in the Bookmarks pane or using a shortcut menu.

1. To create a bookmark in the Bookmarks pane:
   a. Click the button on the vertical bar to the left. Alternatively, select View > Bookmarks in the main menu. This will open the Bookmarks pane.
   b. Click and type a name for your bookmark.
   c. By default, the newly created bookmark will point to the start of the current page.

2. To create a bookmark using a shortcut menu:
   a. Select a text fragment, a picture, or any other place in the document that you want to bookmark.
   b. Right-click the selection and click Add Bookmark... on the shortcut menu.
   c. Type a name for your bookmark in the Bookmarks pane.
      ☑ If you bookmark a text fragment, the selected text will be used as the name of the bookmark.
   d. The newly created bookmark will point to the text fragment, picture or other place in the document that you selected.

To select a different destination for your bookmark, click Set Destination on the shortcut menu of the bookmark and then click where you want the bookmark to be inserted in your document.

☑ Bookmarks can be nested. A new bookmark will have the same nesting level as the previously selected bookmark. If a new bookmark is the first bookmark in the document, it is placed at the root level.

☑ Alternatively, you can create a bookmark by clicking Document > Add Bookmark....

Rearranging bookmarks...
1. Select a bookmark in the **Bookmarks** pane.

2. Hold down the left mouse button and drag the bookmark to a desired location.

To create a nested bookmark, drag it onto an existing parent bookmark, wait for the icon of the parent bookmark to change, and release the left mouse button. Alternatively, right-click a bookmark and use the **Move one level left** and **Move one level right** commands on the shortcut menu.

💡 Rearranging bookmarks or changing their nesting levels will not affect the appearance of the document.

**Renaming bookmarks...**

1. Select a bookmark in the **Bookmarks** pane.

2. Click the button or click **Rename** on the shortcut menu of the bookmark.

3. Type in a new name.

**Deleting bookmarks...**

1. Select a bookmark in the **Bookmarks** pane.

2. Click the button or click **Delete** on the shortcut menu of the bookmark.

✔ You can delete several bookmarks at a time if they are positioned at the same nesting level. While holding down the Ctrl key, select the bookmarks you want to delete and click **Delete**.

💡 When you delete a parent bookmark, all of its child bookmarks are also deleted.
Adding headers and footers

The PDF Editor allows you to add headers and footers to pages in PDF documents. Headers and footers are recurrent text at the top or bottom of the pages where you can put page numbers, the name of the author, the date or time of creation, or Bates numbers to be used for document indexing.

To add a header or footer to your document:

1. Click the **Header and Footer** button on the toolbar in the **Edit Content** tab.
2. Select the desired type of header or footer from the drop-down menu.

Creating headers/footers...
1. Click the **Create Header and Footer...** button on the toolbar in the **Edit Content** tab and then click **Create Header and Footer...**

2. In the dialog box that opens, choose one of the six possible locations on the page. For greater precision, enter the exact distance between the header or footer and the corresponding edge of the page.
   🌟 You can select the units used for measuring the distance between the header/footer and the edge of the page from the **Measurement units** drop-down list below the preview pane.

3. In the **Text** field, type the text you want to be placed at the top or bottom of all of the pages of your document.

4. To add page numbers, date, time, or Bates numbers:
   - Click the **Page Number** button and select the desired page numbering format from the drop-down list that opens.
     The number of each page in the selected format will appear at the top or bottom of the respective page.
   - Click the **Bates Number** button.
     By default, numbering starts at 1 and all document pages are numbered. To change the default setting, click **Continue from %0...**
     Numbering will start at the number you specify in the **Start at** field and will increment either for each page or for each document, depending on your settings. Click **Save** to apply the changes.
   - Click the **Date/Time** button and select the desired date or time format.
     🌟 Each time you click the **Bates Number** button or an item in the **Page Number** of **Date/Time** drop-down list, the corresponding item will be added into the **Text** field after the mouse cursor. You can change the order of the items in this field, add your own explanatory text, or customize the date or time format. For more information about date and time formats, see "[Current date and time on stamps and in headers and footers](#)".
5. In the **Font** section, select the desired font, font size, **font effects**, and font color.

6. In the **Pages** section, specify whether your header/footer should appear on all of the pages or only on some of them.

   - Select **All** if you want your header/footer to appear on all of the pages, or select **Page range** and specify a specific range of pages.

   - You can put headers/footers only on odd or even pages. To do this, create a header/footer and select **Odd Pages** or **Even Pages** from the **Apply to** drop-down list.

7. Click **Save and Add** to save your changes and add the newly created header/footer to your document.

💡 You can create a new header/footer from an existing one. To do this, click the **Header and Footer** button and select **Manage Headers and Footers**... In the **Manage Headers and Footers** dialog box, select an existing header/footer and click **Copy**....

**Editing headers/footers**...

1. Click the **Header and Footer** button on the toolbar in the **Edit Content** tab and select **Manage Headers and Footers**...

2. In the **Manage Headers and Footers** dialog box, select the header/footer you want to modify and click **Edit**....

3. Make the necessary changes and click **Save**.

**Deleting a header/footer from the list**...

1. Click the **Header and Footer** button on the toolbar in the **Edit Content** tab and select **Manage Headers and Footers**...

2. In the **Manage Headers and Footers** dialog box, select a header/footer you want to delete and click **Delete**.
Adding watermarks

The PDF Editor allows you to add watermarks into PDF documents. A watermark is some text placed above or beneath the page content. You can use watermarks, for example, to indicate the author of a text or to identify pages containing confidential information.

To add a watermark:

1. Click on the toolbar in the Security tab and then click the Add Watermark... item.

2. In the dialog box that opens, select one of the nine possible locations on the page. You can further adjust the positioning of the watermark by changing the vertical and horizontal offset values.

3. In the Text field, enter the text you want to appear on the pages. You can select the font, font size, and font effects for your watermark text in the settings in the Font section.

4. Adjust the orientation and transparency of the watermark:
   a. In the Rotate field, specify a rotation angle (you can also use the slider to the right of the field).
   b. In the Transparency field, enter a transparency value (you can also use the slider to the right of the field).

5. Choose where you want to place your watermark — Above page content or In the background beneath page content.

6. Specify if the watermark should appear on all of the pages or only on selected pages in the document:
   a. Select All if the watermark should be placed on all the pages.
   b. Select Selected if the watermark should be placed only on the currently selected page.
   c. Select Page range if the watermark should be placed on a range of pages. If you select this option, you must specify a page range in the field below.

7. Review the watermark in the preview pane of the Add Watermark dialog box and, if you are satisfied with the result, click Save and Add.

💡 You can add multiple different watermarks into the same document.
To delete watermarks from a document, click on the toolbar in the **Security** tab and then click the **Delete Watermarks** item.

This command deletes all of the watermarks from the document.

**Adding file attachments**

Files of any format can be attached to a PDF document.

To view attached files:

- Click the button in the pane to the left, or select **View > Attachments** in the main menu.

You can open, save, rename or delete attached files.

In the **Attachments** pane:

- Select a file.

- On the toolbar, click the tool that corresponds to the action you want to perform. Alternatively, click the corresponding command on the shortcut menu.
Viewing metadata

The PDF Editor allows you to view the title and author of a PDF document and some other information. This information is called metadata. Some of the metadata are specified by the author and some are generated automatically. You can also search documents by metadata.

To view metadata, in the main menu, select File and click Document Properties... to open the Document Properties dialog box.

You can change or save any metadata created by the author, provided that the PDF document is not password-protected:

- **Title** contains the title of the document.
- **Author** contains the author of the document.
- **Subject** contains the subject of the document.
- **Keywords** contains keywords that you can use when searching documents.

The original metadata are preserved when you convert files in various formats to PDF, provided that you have not chosen to delete the metadata and have not specified new export options that will override the existing options.

The metadata of a document also contain the following information about the document and the file:

- **File name** contains the name of the file.
- **Location** contains the path to the folder where the document is stored.
- **File size** contains the size of the file.
- **Page size** contains the size of the current page.
- **Pages** contains the number of pages in the document.
- **PDF producer** contains the name of the application where the document was created.
- **Application** contains the name of the application where the document content was created.
- **PDF version** contains the version of PDF.
  - If the metadata of a document contain information about the compliance with the PDF/A or PDF/UA standard, this will be displayed in the Document Properties window.
- **Tagged PDF** contains information about document tags.
- **Fast Web View** specifies if the document supports Fast Web View technology, which speeds up loading documents online.
- **Created** contains the date and time when the document was created.
- **Modified** contains the date and time when the document was last changed.

**ABBYY FineReader allows you to view, edit, find, and delete metadata.**

### Enhancing page images

The PDF Editor can enhance the quality of PDF documents created from image files. Depending on the type of an input image, the program will select the appropriate image enhancement algorithms. Besides automatic image enhancement, the PDF Editor can correct page orientation, skew, distorted text lines and other defects, and make characters look smoother with ABBYY PreciseScan technology.

You can specify enhancement options in the **Image Enhancement** dialog box (select **Organize Pages > Enhance Images...** in the main menu to open this dialog box).

- **Correct page orientation** Select this option if you want the program to detect and correct page orientation automatically.
  
  For best recognition results, a page should have the standard orientation, i.e. with horizontal text lines and top-to-bottom reading order. Otherwise, the document may be recognized incorrectly.

- **Deskew images and correct image resolution** Select this option if you want the program to run a number of image processing routines on your images.
  
  Depending on the type of an input image, the program will select the image corrections to apply, such as skew correction, correction of trapezoid distortions, or adjustment of image resolution.
  
  This operation may take some time to complete.

- **Apply ABBYY PreciseScan to smooth characters on images** Select this option if you want to apply ABBYY PreciseScan technology, making the characters less pixelated when you zoom in.

Be sure to select the right OCR languages. See also: [Document features to consider prior to OCR](#)
Working with interactive PDF forms

Interactive PDF forms are a useful tool for gathering information. They can be filled out faster than printed forms and users are less likely to make errors when completing them.

Interactive PDF forms may contain the following types of fields: text fields, drop-down lists, check boxes, radio buttons, buttons, signature fields, and list boxes.

ABYY FineReader PDF includes a PDF editor which allows you to fill out, create, and edit interactive PDF forms.

With ABBYY FineReader PDF, you can easily print out completed or blank forms, save forms in various formats, or e-mail them.

Chapter contents

- Filling out forms
- Creating forms
- Editing forms
Filling out forms

ABBYY FineReader allows you to view, fill out, save, and print interactive forms.

1. If a document contains a form, the following message is displayed:

   This document contains interactive form fields. [ ] Highlight fields

   You can disable the highlighting of interactive form fields by unchecking Highlight fields either in this message or in the main menu: Form Editor > Highlight Fields.

2. To fill out a form, select values from drop-down lists or type in text from the keyboard.

With ABBYY FineReader you can also:

- Load data into a form
  Click Form Editor > Form Data > Load Form Data from File..., browse to a file with form data, and click Open. The form will be populated with data from the file you selected.
  Form data can be loaded from FDF or XFDF files.

- Save form data
  Click Form Editor > Form Data > Save Form Data to File..., specify a name for your file, select an output format, and click Save. The form data will be saved to file.
  Form data can be saved in FDF, XFDF, or HTML formats.

- Clear form fields
  Click Form Editor > Form Data > Reset Form. All of the form fields will be cleared.

If JavaScript is disabled in the program settings, some of the elements in PDF forms may be unavailable. For example, data format checks may not be available. You can enable JavaScript by clicking Options > Other > Enable JavaScript in PDF documents.

See also: PDF security features
💡 If no interactive fields are highlighted in your current form, make sure that the **Highlight fields** option is selected either in the upper part of the screen or in the main menu: **Form Editor > Highlight Fields**. If the option or menu item is selected but you still don't see any highlighted fields, use the **Export** tool to fill out your form.

**See also:** [Adding a text block annotation to a PDF document](#)
Creating forms

Video: How to Create Fillable PDF Forms

To create a form:

1. In the PDF Editor, create a new document or open an existing one. See also: Viewing PDF documents

2. Switch to form editing mode.
   To do so, navigate to the Form Editor tab. The toolbar on this tab will display the various field types that can be added to the PDF document.
   - If your form already contains interactive fields, their names will be displayed on the form. If you do not want to see the field names, right-click anywhere on the form and clear the check box next to the Show Field Names item on the shortcut menu. Alternatively, click Form Editor > Show Field Names.

   ![Form Editor in PDF Editor](image)

   - In form editing mode, the main PDF tools become unavailable.

3. Add and edit form fields as required and adjust their position on the page.
   - Fields can only be repositioned within the current page.
   - To see your form fields as they will be displayed to the user, exit form editing mode.

You can add fields of the following types:

- text field
- drop-down list
- check box
- radio buttons
- button
- signature field
- list box

4. **Save** your form.

Saving your form as a PDF document (File > Save As > PDF Document...) will preserve the interactive fields so that you or other users will be able to fill out the form when they open the PDF file. Saving your form in other formats (e.g. Microsoft Word) will render it non-editable.

💡 To fill out your PDF form, [exit form editing mode](#)
Editing forms

Video: How to Create Fillable PDF Forms

In the PDF Editor, you can perform various operations on interactive form fields in PDF documents. You can:

- **Add** fields.
- **Change** the size of a field and other field properties.
- **Copy** a field or create a linked copy of a field.
- **Move** a field to a different position within the current page.
- **Align** fields relative to one another or to the margins.
- **Delete** fields.
- **Clear** data from all fields.

### Adding fields

1. Navigate to the **Form Editor** tab.
2. On the form toolbar, click the type of field that you want to add.
3. Click where you want to add the field. A default-sized field will be added.

   - To draw a field of any size, do not release the left mouse button and drag the mouse pointer in the desired direction.
   - When you select the **Radio Button** tool, a radio button is added to the form each time you click your mouse inside the form. Once you have added the required number of radio buttons, press Esc to turn off the tool. See also: **Radio buttons**.
4. **Edit** the field if required.

### Editing fields

1. Navigate to the **Form Editor** tab.
2. Double-click the field that you want to edit (or right-click and select **Properties...** on the shortcut menu).

3. In the **Properties** dialog box, change the properties of the field.
   - The set of properties you see in this dialog box depends on the type of the selected field. Follow the links below to read more about the properties of each type of field:
     - text field
     - drop-down list
     - check box
     - radio buttons
     - button
     - signature field
     - list box

4. Click **OK** to save your changes.
   - Clicking **Cancel** discards all changes.

**Copying fields**
1. Navigate to the **Form Editor** tab and right-click the field that you want to copy and select **Copy** on the shortcut menu. Alternatively, select the field with a mouse click and press Ctrl+C on the keyboard.

2. Right-click where you want to copy the field and select **Paste** on the shortcut menu or press Ctrl+V on the keyboard.

- Copies will have the same properties as the original field with the exception of **Field Name**.
- Only empty **signature fields** can be copied.

**Creating a linked copy of a field**

Navigate to the **Form Editor** tab and right-click the field for which you want to create a linked copy and select **Create Linked Copy** on the shortcut menu. A linked copy will appear next to the original field.

- When a user enters data into a field that has linked copies, all of the copies will be automatically populated with the same data. This is useful when the same data has to be entered several times within the same document.

- Linked copies will have the same properties as the original field. You can change any property of a linked field. Changing the **Field Name** property will turn a linked copy into a simple copy, i.e. it will no longer be automatically populated with data from the original field.

**Moving fields around the page**

Navigate to the **Form Editor** tab and click the field that you want to move and drag it to the desired location.

- To move multiple fields, select them while holding down the Ctrl key. Next, click any of the selected fields and drag them to the desired location.

- Fields can only be moved within the current page.

**Aligning fields relative to one another or the page margins**
Navigate to the **Form Editor** tab and start moving a field around the page. Purple-colored guides will appear to help you align the fields relative to one another or the page margins.

If you do not want to see the guides, press and hold down the Ctrl key while moving fields around the page.

To specify coordinates for multiple fields:

1. Navigate to the **Form Editor** tab and right-click one of the fields whose coordinates you want to change and select **Properties...** on the shortcut menu. The **Properties** dialog box will open.

2. On the **General** tab, change the values in **X** and/or **Y** boxes.

3. Click **OK** to save your changes.
4. Repeat steps 1 through 3 for all the remaining fields that you want to align. Alternatively, align the remaining field using the purple-colored guides as described above.

- To align fields vertically, specify the same value for all the fields in the X box.
- To align fields horizontally, specify the same value for all the fields in the Y box.

Deleting fields

Navigate to the Form Editor tab and click the field that you want to delete and press the Delete key. Alternatively, right-click the field and select Delete on the shortcut menu.

- To delete multiple fields, select them while holding down the Ctrl key and then press the Delete key (or right-click the selection and select Delete on the shortcut menu).

Clearing data from all fields

Navigate to the Form Editor tab and right-click anywhere in your PDF document and select Reset Form on the shortcut menu.

Resizing fields

1. Navigate to the Form Editor tab and right-click the field that you want to resize and select Properties... on the shortcut menu. The Properties dialog box will open.

2. On the General tab, change the values in the Width and Height boxes.

3. Click OK to save your changes.

- You can also resize an interactive field by clicking it, resting your mouse on one of the sizing handles until the mouse pointer changes to , and dragging the handle in the desired direction.

Adding pop-up tips to fields

1. Navigate to the Form Editor tab and right-click the field for which you want to provide a tip and select Properties... on the shortcut menu. The Properties dialog box will open.

2. On the General tab, type the text of the tip in the Tooltip box. In the case of radio buttons, type a single tip for entire group in the Radio Group Tooltip box.

3. Click OK to save your changes.

Making fields required
1. Navigate to the **Form Editor** tab and right-click the field that you want to make required and select **Properties...** on the shortcut menu. The **Properties** dialog box will open.

- Any fields can be made required with the exception of buttons.

2. On the **General** tab, select the **Required** option.

3. Click **OK** to save your changes.

- In form editing mode, the **names** of required fields are highlighted in red.

- When you exit form editing mode, required fields will have a red-colored frame if the **Highlight fields** option is selected in the yellow pane above the form (or if the **Highlight Fields** item is selected in **Form Editor** in the main menu).

- The **Required** option merely informs the user that a particular field must always be completed. It does not limit the user's ability to save, e-mail or print a PDF form with required fields left empty.
Text field

Text Field is intended for textual data.

To add a text field onto your form, switch to form editing mode and click the tool.

See also: Adding interactive fields

To edit a text field, right-click the field and select Properties... on the shortcut menu.

See also: Editing interactive fields

Text field properties

General tab
On the General tab, you can specify the general properties of the text field (field name, pop-up tip, size, etc.).

**Field Name** - This is a required property. It will be displayed above the field in form editing mode. Each field must have a unique name. Field names must not start or end with a full stop or contain two or more consecutive full stops.

**Tooltip** - The text of the tip that appears when you point to the field in fill-out mode.

**Max Number of Symbols** - The maximum number of characters that can be entered into the field. If no value is specified, text of any length can be entered.

**Required** - If this option is selected, the field will be marked as required.

**Read-Only** - If this option is selected, the user will not be able to edit the field.

**Width** and **Height** - These boxes specify the size of the field in units selected in the Units box. The size of a field cannot be 0.

- The width and height of the field are independent of each other.

- The width and height of the field can only be changed in proportion to each other.

**X** and **Y** - These boxes contain the horizontal and vertical coordinates of the field. The coordinates start from the top left corner of the page.

**Units** - The measurement units for the field dimensions specified in the Width and Height boxes. The width and height of a field can be specified in centimeters, inches, or points.
Appearance tab

On the **Appearance** tab, you can specify frame thickness and color, fill color, and font size and color.

- **Fill Color** - The fill color.
- **Stroke Color** - The color of the frame enclosing the field.
- **Thickness** - The thickness of the frame enclosing the field.
- **Font Color** - The color of text typed into the field.
- **Font Name** - The font to be used for text typed into the field.
- **Font Size** - The size of text typed into the field.
- **Set as Default Style** - The current settings will be used for any new text fields that you create.

Format tab
On the Format tab, you can specify what type of data can be entered into the field by selecting the desired data type from the Format drop-down list. Two data types are available:

- **Text**
- **Date**

Text

Select **Text** from the Format drop-down list to allow users to enter any text in this field. This format is suitable for entering text, numbers, passwords, e-mail addresses, and other textual data.

Field Type - Indicates how many lines of text the field may contain.

- **Single Line** - The field may contain only one line of text.
- **Multiline** - The field may contain any number of lines.

Date

Select **Date** from the Format drop-down list to allow users to enter a date into this field.

In fill-out mode, clicking this field will display a calendar, where the user can quickly select a date.
View - The format to be used for the date.

Users will be able to enter a date in any format. However, when a user finishes entering the date, it will be reduced to the format specified in the View box.
**Drop-down list**

**Drop-down List** allows the user to select a value from the list or to enter a custom value.

To add a drop-down list onto your form, switch to form editing mode and click the tool.

**See also:** [Adding interactive fields](#)

To edit a drop-down list, right-click the drop-down list and select **Properties...** on the shortcut menu.

**See also:** [Editing interactive fields](#)

**Drop-down list properties**

**General tab**
On the **General** tab, you can specify the general properties of the drop-down list (field name, pop-up tip, size, etc.).

- **Field Name** - This is a required property. It will be displayed above the field in form editing mode. Each field must have a unique name. Field names must not start or end with a full stop or contain two or more consecutive full stops.

- **Tooltip** - The text of the tip that appears when you point to the field in fill-out mode.

- **Required** - If this option is selected, the field will be marked as required.

- **Read-Only** - If this option is selected, the user will not be able to edit the field.

- **Width** and **Height** - These boxes specify the size of the field in units selected in the **Units** box. The size of a field cannot be 0.

  - The width and height of the field are independent of each other.

  - The width and height of the field can only be changed in proportion to each other.

- **X** and **Y** - These boxes contain the horizontal and vertical coordinates of the field. The coordinates start from the top left corner of the page.

- **Units** - The measurement units for the field dimensions specified in the **Width** and **Height** boxes. The width and height of a field can be specified in centimeters, inches, or points.

**Appearance tab**
On the **Appearance** tab, you can specify frame thickness and color, fill color, and font size and color.

**Fill Color** - The fill color.

**Stroke Color** - The color of the frame enclosing the field.

**Thickness** - The thickness of the frame enclosing the field.

**Font Color** - The color of text items selected from the drop-down list.

**Font Name** - The font to be used for text items selected from the drop-down list.

**Font Size** - The size of text items selected from the drop-down list.

**Set as Default Style** - The current settings will be used for any new drop-down lists that you create.

**List Items tab**
On the **List Items** tab, you can edit the list of items by adding, deleting or modifying items. You can also move an item up or down, make an item the default choice, or allow the user to enter a custom value not included on the list.

**List Items** - Displays all the items that will appear on the drop-down list.

**Add** - Adds a new item at the end of the list.

**Edit** - Modifies the selected item.

**Delete** - Deletes the selected item from the list.

- To delete multiple items, click them one by one while holding down the Ctrl key and then click **Delete**.

**Set as Default** - Make the selected item the default choice. This choice will be suggested to the user by default, but the user will be free to choose any other item from the list. If the user clears data from **all the fields** the default choice will be restored.

- To specify a different item as the default choice, click that item and then click **Set as Default**.

**Unset as Default** - Removes the default status from the item that was previously made the default choice.

- Use this button if you no longer need to suggest a default choice.

**Up** - Moves the selected item up in the list.

**Down** - Moves the selected item down in the list.
Allow non-list items - Allows the user to enter a custom value not included on the drop-down list.
Check box

Check Box allows the user to select an option or leave it unselected (i.e. select between Yes or No).

To add a check box onto your form, switch to form editing mode and click the tool.

See also: Adding interactive fields

To edit a check box, right-click the check box and select Properties... on the shortcut menu.

See also: Editing interactive fields

Check box properties

General tab
On the **General** tab, you can specify the general properties of the check box (field name, pop-up tip, size, etc.).

**Field Name** - This is a required property. It will be displayed above the field in form editing mode. Each field must have a unique name. Field names must not start or end with a full stop or contain two or more consecutive full stops.

**Tooltip** - The text of the tip that appears when you point to the field in **fill-out** mode.

**Enabled by Default** - If this option is selected, this check box will be selected by default.

**Required** - If this option is selected, the field will be marked as **required**.

**Read-Only** - If this option is selected, the user will not be able to edit the field.

**Width** and **Height** - These boxes specify the size of the field in units selected in the **Units** box. The size of a field cannot be 0.

- The width and height of the field are independent of each other.

- The width and height of the field can only be changed in proportion to each other.

**X** and **Y** - These boxes contain the horizontal and vertical coordinates of the field. The coordinates start from the top left corner of the page.

**Units** - The measurement units for the field dimensions specified in the **Width** and **Height** boxes. The width and height of a field can be specified in centimeters, inches, or points.

**Appearance tab**
On the **Appearance** tab, you can specify frame thickness and color, fill color, and the color of the check.

![Check Box Properties](image)

**Checkmark Color** - The color of the check inside the box.

**Fill Color** - The fill color.

**Stroke Color** - The color of the frame enclosing the field.

**Thickness** - The thickness of the frame enclosing the field.

**Set as Default Style** - The current settings will be used for any new check boxes that you create.
Radio button

Radio Button allows the user to select only one option from a group of available options.

To add radio buttons onto your form:

1. Switch to form editing mode.

2. Click the Radio Button tool.

3. Click where you want to add a radio button. A default-sized radio button will be added. Continue clicking on the form to add the required number of radio buttons.

   You must add at least two radio buttons, because, by their very nature, radio buttons give the user a choice between two or among multiple options.

4. Click the tool again or press the Esc key to stop adding radio buttons.

   All the radio buttons you add before turning off this tool, will form a single group. If you need to add another group of radio buttons, repeat steps 2 through 4.

To edit a radio button, right click that button and select Properties... on the shortcut menu.

See also: Editing interactive fields

Radio button properties

General tab
On the **General** tab, you can specify the general properties of the group of radio buttons (group name, pop-up tip, size, etc.).

**Radio Group Name** - The name of the group that contains this radio button. This name will be displayed above all the radio buttons in this group when you switch to form editing mode. This is a required field. You can create a group of radio buttons by entering a new name in this field, or you can select an existing group from the drop-down list of groups.

**Radio Group Tooltip** - The text of the tip that appears when you point to the field in **fill-out** mode. The same tip will be displayed for all radio buttons in the group.

**Radio Button Name** - This is a required field. Each radio button must have a unique name.

**Enabled by Default** - If this option is selected, this radio button will be selected by default.

**Required** - If this option is selected, the user will be required to select a radio button in this group.

**Read-Only** - If this option is selected, the user will not be able to select a radio button in this group.

**Width** and **Height** - These boxes specify the size of the field in units selected in the **Units** box. The size of a field cannot be 0.

- The width and height of the field are independent of each other.

- The width and height of the field can only be changed in proportion to each other.
X and Y - These boxes contain the horizontal and vertical coordinates of the field. The coordinates start from the top left corner of the page.

Units - The measurement units for the field dimensions specified in the Width and Height boxes. The width and height of a field can be specified in centimeters, inches, or points.

Appearance tab

On the Appearance tab, you can specify stroke thickness and color, fill color, and the color of the dot.

Dot Color - The color of the dot inside the selected radio button.

Fill Color - The fill color.

Stroke Color - The color of the frame enclosing the radio button.

Thickness - The thickness of the frame enclosing the radio button.

Set as Default Style - The current settings will be used for any new radio buttons that you create.
Button

**Button** allows the user to initiate an action associated with a given button.

To add a button onto your form, switch to form editing mode and click the **Button** tool.

See also: [Adding interactive fields](#)

To edit a button, right-click the button and select **Properties...** on the shortcut menu.

See also: [Editing interactive fields](#)

---

**Button properties**

**General tab**
On the **General** tab, you can specify the general properties of the button (field name, button text, pop-up tip, button size, etc.).

Field Name - This is a required property. It will be displayed above the field in form editing mode. Each field must have a unique name. Field names must not start or end with a full stop or contain two or more consecutive full stops.

Tooltip - The text of the tip that appears when you point to the field in **fill-out** mode.

Button Text - The text to be displayed on the button.

Read-Only - If this option is selected, the user will not be able to click the button.

**Width** and **Height** - These boxes specify the size of the button in units selected in the **Units** box. The size of a button cannot be 0.

- The width and height of the button are independent of each other.

- The width and height of the button can only be changed in proportion to each other.

**X** and **Y** - These boxes contain the horizontal and vertical coordinates of the button. The coordinates start from the top left corner of the page.

**Units** - The measurement units for the button dimensions specified in the **Width** and **Height** boxes. The width and height of a button can be specified in centimeters, inches, or points.

**Appearance tab**
On the **Appearance** tab, you can specify frame thickness and color, fill color, and font size and color.

**Button Properties**

<table>
<thead>
<tr>
<th>General</th>
<th>Appearance</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill Color:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stroke Color:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thickness:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Font Color:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Font Name:</td>
<td>Arial</td>
<td></td>
</tr>
<tr>
<td>Font Size:</td>
<td>11</td>
<td></td>
</tr>
</tbody>
</table>

**Fill Color** - The fill color.

**Stroke Color** - The color of the frame enclosing the button.

**Thickness** - The thickness of the frame enclosing the button.

**Font Color** - The color of text on the button.

**Font Name** - The font to be used for the text on the button.

**Font Size** - The size of the text on the button.

**Set as Default Style** - The current settings will be used for any new buttons that you create.

**Actions tab**
On the **Actions** tab, you can add, delete, or modify actions triggered by certain events caused by user activity.

**Actions** lists all the actions triggered by certain user activity.

**Create...** adds a new action.

**Edit...** modifies the selected action.

**Delete** deletes the selected action.

Adding a new action
To add a new action for your button:

1. Switch to [form editing mode](#).

2. Open the Properties dialog box for the desired button and click the Actions tab.

3. Click Create... This will open the New Action dialog box.

4. Select an event that will trigger an action.
   - **Click** - The user clicks the button.
   - **Drop** - The user releases the left mouse button while the mouse pointer is placed over the button on the form.
   - **Mouse Over** - The user places the mouse pointer over the button on the form.
   - **Mouse Out** - The user removes the mouse pointer from the button on the form.
   - **Focus** - The user places focus on the button using the Tab key.
   - **Focus Out** - The user removes focus on the button using the Tab key.

5. Select an action that will be triggered by the event.

6. Click Save to save the action. The action will appear in the Actions section of the Button Properties window.
   - Actions are grouped by event. An event may initiate a sequence of actions.
   - You can move actions between groups with the mouse.
7. Click **OK** to save your changes.

List of possible actions
• **Add pages from scanner** opens the scanning dialog box, where the user can select a scanning device and specify scanning parameters. Newly scanned pages will be appended at the end of the PDF document.

• **Save form as...** opens the document saving dialog box, where the user can save the form as a PDF, FDF, XFDF, or HTML document.

• **Close document** closes the current document.

• **Print form...** opens the printing dialog box.

• **Exit application** closes the current application.

• **Search document...** opens the search pane.

• **Go to first page** goes to the first page in the current document.

• **Go to last page** goes to the last page in the current document.

• **Go to next page** goes to the next page in the current document.

• **Go to previous page** goes to the previous page in the current document.

• **Go back** goes to the page that was open before the user opened the current page.

• **Go forward** goes to the page from which the user returned to the current page.

• **Select a page to go to...** opens a dialog box where the user can enter the number of the page that he/she wants to open.

• **Set one-page view** switches to One-Page View.

• **Set two-page view** switches to Two-Page View.

• **Set one-page scrolling** enables One-Page Scrolling.

• **Set two-page scrolling** enables Two-Page Scrolling.

• **Zoom to 100%** displays the page in its actual size.

• **Fit page width to screen** fits the page into the screen horizontally.

• **Fit page to screen** displays the entire page.

• **Show/hide attachments** opens the Attachments pane.

• **Show/hide bookmarks** opens the Bookmarks pane.

• **Show/hide pages pane** opens the Pages pane.

• **Show/hide digital signatures** opens the Digital Signatures pane.
• Enter full screen mode switches to Full Screen view.

• View document properties... opens the Document Properties dialog box, where you can review the document’s metadata.

• Open file opens the document specified in the File box. Click Browse... to select the document that you want to open.

• Follow link opens the link specified in the Link box.

• Reset form clears the data from all the fields in the current form.
- **Send form** sends the form data to the e-mail address or server specified in the **Send to** box. In the **File Format** box, you can choose the format to be used when submitting a completed form. The following four choices are available: PDF, FDF, XFDF, or HTML.

![Send form action](image)

- **Go to page** opens the page specified in the **Page Number** box.

![Go to page action](image)

- **Run JavaScript** runs the code entered in the **JavaScript** box.

![Run JavaScript action](image)

Changing an action
To change an action associated with a button:

1. Switch to form editing mode.

2. Open the Properties dialog box for the desired button and click the Actions tab.

3. Click the action that you want to change and then click Edit... This will open the Edit Action dialog box.

4. Change the values in the Trigger Event and Action boxes.

5. Click Save. The changes you have made will be reflected in the Actions section of the Button Properties dialog box.

6. Click OK to save your changes.
Signature field

**Signature Field** allows the user to put his/her digital signature to the PDF document.

See also: [Digital signature](#)

To add a signature field onto your form, switch to form editing mode and click the tool.

See also: [Adding interactive fields](#)

To edit a signature field, right-click the field and select **Properties...** on the shortcut menu.

See also: [Editing interactive fields](#)

### Signature field properties

**General tab**
On the **General** tab, you can specify the general properties of the signature field (field name, pop-up tip, size, etc.).

![Signature Properties](image)

**Field Name** - This is a required property. It will be displayed above the field in form editing mode. Each field must have a unique name. Field names must not start or end with a full stop or contain two or more consecutive full stops.

**Tooltip** - The text of the tip that appears when you point to the field in **fill-out** mode.

**Required** - If this option is selected, the user will be required to put his/her digital signature to the document.

**Read-Only** - If this option is selected, the user will not be able to edit the field.

**Width** and **Height** - These boxes specify the size of the field in units selected in the **Units** box. The size of a field cannot be 0.

- The width and height of the field are independent of each other.

- The width and height of the field can only be changed in proportion to each other.

**X** and **Y** - These boxes contain the horizontal and vertical coordinates of the field. The coordinates start from the top left corner of the page.

**Units** - The measurement units for the field dimensions specified in the **Width** and **Height** boxes. The width and height of a field can be specified in centimeters, inches, or points.

**Appearance tab**
On the **Appearance** tab, you can specify frame thickness and color and fill color.

![Signature Properties](image)

- **Fill Color** - The fill color.
- **Stroke Color** - The color of the frame enclosing the field.
- **Thickness** - The thickness of the frame enclosing the field.
- **Set as Default Style** - The current settings will be used for any new signature fields that you create.
**List box**

**List Box** allows the user to select one or more values from a list.

To add a list box onto your form, switch to form editing mode and click the ![List Box](#) tool.

**See also:** [Adding interactive fields](#)

To edit a list box, right-click the list box and select **Properties...** on the shortcut menu.

**See also:** [Editing interactive fields](#)

---

**General tab**
On the **General** tab, you can specify the general properties of the list box (field name, pop-up tip, size, etc.).

**Field Name** - This is a required property. It will be displayed above the field in form editing mode. Each field must have a unique name. Field names must not start or end with a full stop or contain two or more consecutive full stops.

**Tooltip** - The text of the tip that appears when you point to the field in fill-out mode.

**Required** - If this option is selected, the field will be marked as **required**.

**Read-Only** - If this option is selected, the user will not be able to edit the field.

**Width** and **Height** - These boxes specify the size of the field in units selected in the **Units** box. The size of a field cannot be 0.

- The width and height of the field are independent of each other.

- The width and height of the field can only be changed in proportion to each other.

**X** and **Y** - These boxes contain the horizontal and vertical coordinates of the field. The coordinates start from the top left corner of the page.

**Units** - The measurement units for the field dimensions specified in the **Width** and **Height** boxes. The width and height of a field can be specified in centimeters, inches, or points.
Appearance tab

On the **Appearance** tab, you can specify frame thickness and color, fill color, and font size and color.

![List Box Properties dialog box](image)

- **Fill Color** - The fill color.
- **Stroke Color** - The color of the frame enclosing the field.
- **Thickness** - The thickness of the frame enclosing the field.
- **Font Color** - The color of text items selected from the list.
- **Font Name** - The font to be used for text items selected from the list.
- **Font Size** - The size of text items selected from the list.
- **Set as Default Style** - The current settings will be used for any new list boxes that you create.

List Items tab
On the List Items tab, you can edit the list of items by adding, deleting or modifying items. You can also move an item up or down, make an item the default choice, or allow the user to select multiple items from the list.

List Items - Displays all the items that will appear in the list box.

Add - Adds a new item at the end of the list.

Edit - Modifies the selected item.

Delete - Deletes the selected item from the list.

To delete multiple items, click them one by one while holding down the Ctrl key and then click Delete.

Set as Default - Make the selected item the default choice. If the user clears data from all the fields, the default choice will be restored.

To specify a different item as the default choice, click that item and then click Set as Default.

Unset as Default - Removes the default status from the item that was previously made the default choice.

Use this button if you no longer need to suggest a default choice.

Up - Moves the selected item up in the list.

Down - Moves the selected item down in the list.
Allow multiple selection - Allows the user to select multiple items from the list.

Signing PDF documents

The PDF Editor allows you to sign documents digitally and to validate any digital signature in a document. You can also add text and picture signatures.

Chapter contents

- **Digital signature** [168]
- **Text signature** [170]
- **Picture signature** [171]
Digital signature

Video: How to Sign PDFs Digitally

The PDF Editor allows you to sign documents digitally and to validate any digital signature in a document. A digital signature is used to establish the identity of the person that signed the document. Additionally, a digital signature can be used to make sure that a signed document has not been altered.

To sign a document:

1. On the toolbar in the Security tab, click > Add Digital Signature....

2. Select the area where you want to place the signature or simply click the desired location.

3. Select the certificate to be used from the Sign as drop-down list. To view the properties of a certificate, select it and click Show Certificate....
   - If the certificate you want to use is not in the list, you will have to install it. To install a certificate, right-click it in Windows Explorer, click Install Certificate on the shortcut menu, and follow the instructions in the Certificate Import Wizard.

4. If required, use the Reason drop-down list to specify the reason for signing the document. The Location and Contact fields are used to specify the location where the document was signed and your contact information respectively.
   - In the Reason field, you can either select a value from the drop-down list or enter a custom text.

5. The following can also be specified in a signature: the date and time of signing, signature owner information, as well as the name and version number of the FineReader program that was used.
   - You can also choose which information is displayed in the signature by unchecking the names of fields that you do not want to be displayed.
   - If you do not want field names to be displayed in the signature, uncheck Show labels.

6. If required, click Set up Time Stamp Server and specify the server URL. If login credentials are required to establish a connection, enter a login and a password.

7. Select the Borders and background option to add a border and a grey background to your signature.

8. Select Add custom image to digital signature if you want your signature to include an image. Then click the Select Image... button to browse to an image file. The image will appear to the left of the signature.

9. Click Save and sign.

10. Save the document.
This will add a digital signature with the specified parameters to the document.

A signature contains information about the version of the document at the time of signing. If you add a new signature to an already signed document, the previously added signatures will remain valid.

To view the properties of a signature in a document:

- Right-click the signature and click Show Signature Properties... on the shortcut menu, or
- Double-click the signature in the Digital Signatures pane.

When you open a PDF document, ABBYY FineReader automatically validates the digital signatures in the document, if any. Validation results will be displayed in the Digital Signatures pane, which also contains detailed information about the signatures used in the document.

To delete a signature:

- Right-click the signature and click Remove Signature on the shortcut menu.

✓ You can only delete a signature from a document if you have the corresponding digital certificate.

💡 You can add more than one digital signature to a document.

**Time Stamp Server Settings**

The use of timestamps decreases the possibility of a signature being invalid. Marking a PDF document with a timestamp requires a connection to a timestamp server. To set up a timestamp server connection, click Set up Time Stamp Server and specify one of the following server options in the dialog box that will appear:

- **Default** to use the default timestamp server.
- **Custom** to specify the URL of a custom timestamp server. If credentials are required to establish a connection to that server, enter your login and password and click OK. Your login and password will be encrypted and saved on your computer in a Windows storage called Windows Credentials (Credential Manager > Windows Credentials). You will not be required to enter your credentials when connecting to the server a second time.

This will specify the timestamp server time at which the document was signed after the document signature.
Text signature

The PDF Editor allows you to add text signatures to your PDF documents.

1. On the toolbar in the **Security** tab, click ![Signature] > **Create Text Signature**....
   - If you have already created some text signatures, select a signature from the list of available signatures. Alternatively, click **Other Signature** > **Create Text Signature**....

2. In the **Create Text Signature** dialog box that opens, enter some text for the signature.

3. Change the style of the signature, if required.

4. Click **Save**.

5. Place the signature where you want it to appear on the page.

6. You can change the size of the signature, rotate it, or move it to another location in the document.

As a result, your text signature will appear in the document.

Editing signatures

1. On the toolbar in the **Security** tab, click ![Signature] > **Other Signature** > **Manage Signatures**....

2. In the dialog box that opens, select a signature and click **Edit**....
   - You can edit both text and picture signatures.

3. In the dialog box that opens, change the parameters of your signature and click **Save**.
   - If you want to add the edited signature to the document, click **Use** and place the signature where you want it to appear on the page.

Deleting signatures

To delete a signature:

- Select the signature on the document and press the Delete key, or
- Right-click the signature on the document and click **Delete**... on the shortcut menu.

To delete a signature from the list of available signatures:

1. On the toolbar in the **Security** tab, click ![Signature] > **Other Signature** > **Manage Signatures**....

2. In the dialog box that opens, select the signature you want to delete and click **Delete**....
   - You can delete both text and picture signatures.
You can add more than one signature to a document.

**Picture signature**

ABBYY FineReader allows you to add picture signatures to your PDF documents.

1. On the toolbar in the **Security** tab, click **Create Signature from Image**. If you have already created some signatures, select a signature from the list of available signatures. Alternatively, click **Other Signature > Create Signature from Image**.

2. In the **Create Signature from Image** dialog box, click **Open** to select an image file or click **Paste from Clipboard** to paste the signature currently stored on the Clipboard.

3. You can change the size of your signature and make the background transparent.

4. Click **Save**.

5. Place the signature where you want it to appear on the page.

6. You can change the size of the signature, rotate it, or move it to another location in the document.

As a result, your picture signature will appear in the document.

You can add any number of signatures to a document.

You can edit or delete a picture signature. See also: **Text signature**.

**Protecting PDF documents with passwords**

When you create a PDF document, you can set passwords to protect it from unauthorized access, editing, and printing.

**Chapter contents**

- **Passwords and permissions**
- **Deleting confidential information from PDF documents**
Passwords and permissions

When you create a PDF document, you can set passwords to protect it from unauthorized access, editing, and printing. A PDF document can be protected with a Document Open password and/or Permissions Password.

If a PDF document is protected from unauthorized access, it can only be opened after entering the Document Open Password that was specified by the document's author. If the document is protected from unauthorized editing and printing, these actions will only be possible after entering the Permissions Password specified by the author. The Permissions Password can also be used to open a protected PDF document.

Follow the instructions below to protect a document with a password.

1. Click the Password Security button on the toolbar in the Security tab or click Security > Password Security....
   The Security Settings dialog box will open.

2. If you want to protect your document from unauthorized opening, select the Restrict access with a Document Open password option.

3. Type a Document Open password and confirm it.
   🗝️ You can disable the Hide characters option. In this case, the characters you enter will be displayed on the screen and you won't have to retype your password.

4. If you want to prevent unauthorized printing, editing or copying of your document, select the Restrict printing and editing with a Permissions password option.

5. Type a Permissions Password and confirm it.
   ✔️ The Document Open Password and the Permissions Password must be different.

6. From the Printing drop-down list, select a printing resolution for your document.

7. From the Editing drop-down list, select allowed editing operations.

8. If you want to allow other users to copy and edit the content of your document, select the corresponding options.

9. Select an encryption level and components to encrypt.

10. Click OK.

You will be prompted to confirm the passwords again. You can save the changes to the open document or create a new document.
Deleting confidential information from PDF documents

Video: [How to Protect and Redact a PDF File](#)

You can use the PDF Editor to remove confidential information from PDF documents before publishing them. Both text and images can be redacted.

1. On the toolbar in the **Security** tab, click ![Redact](#).

2. If you want to change the color of rectangles that will be painted over redacted text, click one of the seven color boxes on the toolbar or click the arrow and select any other desired color from the palette. For even more colors, click **More colors...**

3. Select the text and/or images you want to remove.

As a result, the selected content will be removed from the document and their respective occurrences painted over with the color of your choice.

You can delete objects and data that do not occur in the body text of your document (e.g. comments, annotations, bookmarks, attachments, metadata, etc.):

1. On the toolbar in the **Security** tab, click ![Delete Objects and Data...](#).

2. In the dialog box that opens, select the objects and data to delete and click **Apply**.

[![ABBYY FineReader also allows you to use the Search feature to remove sensitive data.](#)](#)
Creating PDF documents

Video: How to Create and Merge PDF

Chapter contents

- Creating PDF documents from selected pages

For detailed instructions on creating PDF documents from files, scans, or digital photos, see: Creating PDF documents and Scanning to PDF.

Creating PDF documents from selected pages

The PDF Editor allows you to create PDF documents from selected pages by doing one of the following:

- In the Pages pane, select the appropriate pages and click Create PDF from Selected Pages in the context menu.

- Navigate to the Organize Pages tab, select the appropriate pages, and click Create PDF from Selected Pages in the context menu.

This will create a new PDF document using the selected pages and open it in a new PDF Editor window in ABBYY FineReader.

Saving and exporting PDF documents

The PDF Editor allows you to save, print, and e-mail PDF documents or send them to the OCR Editor for further processing.

Chapter contents

- Saving PDF documents
- Saving in PDF/A
- Saving in other formats
- Reducing the size of your PDF documents
- Sending PDF documents to the OCR Editor
- E-mailing PDF documents
- Printing PDF documents
Saving PDF documents

The PDF Editor allows you to save entire PDF documents or only selected pages. Various saving options are available.

- To save the changes you have made to your current PDF document, click **File > Save** in the main menu. Alternatively, click on the toolbar in the **Document** tab.

- To save your current PDF document under a different name or to a different folder, click **File > Save As > PDF Document...** in the main menu. Alternatively, click on the toolbar in the **Document** tab and then click **PDF Document...**.

- To save your document as a PDF document where users will be able to select, copy, and edit content, click **File > Save As > Searchable PDF Document**. Alternatively, click **Save As** on the toolbar in the **Document** tab and then click **Searchable PDF Document**. As a result, your PDF document will be converted to searchable PDF using the currently selected saving options. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **PDF** tab.

- To save a PDF document without a text layer (such PDF documents cannot be searched and their content cannot be selected, copied or edited) click **File > Save As > Image-Only PDF Document**. Alternatively, click **Save As** on the toolbar in the **Document** tab and then click **Image-Only PDF Document**. As a result, your PDF document will be converted to image-only PDF using the currently selected saving options. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **PDF** tab.

- To convert only some pages of a document, in the **Pages** pane, select the pages that you want to save and click **Save As** on the shortcut menu. Alternatively, navigate to the **Organize Pages** tab, select the appropriate pages, and click the arrow next to the **Save As** button in the toolbar.
Saving in PDF/A

The PDF Editor allows you to save documents in PDF/A, a format intended for long-term storage.

PDF/A documents contain all the information required for their correct display:

- All fonts are embedded into the document (except for non-visible text).
- Only embeddable fonts are used.
- Colors are displayed correctly irrespective of the device.
- The metadata used in the document comply with the applicable standards.

The following are not supported:

- audio, video, and 3D objects
- scripts
- encryption
- links to external content
- copyrighted content (e.g. LZW).

To save a PDF document in PDF/A:

1. Click **File > Save As > PDF Document**. Alternatively, click the **button on the toolbar in the **Document** tab and then click **PDF Document**.

2. In the dialog box that opens, specify a name and location for your document.

3. Select **Create PDF/A** and then select a PDF/A version from the drop-down list.

4. Click **Save**.

You can create PDF/A-compliant documents from various formats. See also: **Creating PDF documents**.

<table>
<thead>
<tr>
<th>PDF/A-1</th>
<th>PDF/A-2</th>
<th>PDF/A-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>B, A</td>
<td>B, A, U</td>
<td>B, A, U</td>
</tr>
</tbody>
</table>

- 2005: **PDF/A-1** is based on PDF 1.4 and supports the following features:
- A – accessible – additional document requirements (tags)
- B – basic – basic compliance level


- 2011: PDF/A-2 is based on PDF 1.7 and supports additional features:
  - Unicode
  - JPEG2000 compression
  - transparency
  - PDF/A attachments
  - digital signatures


- 2012: PDF/A-3 supports additional features:
  - file attachments in any format

Saving in other formats

The PDF Editor allows you to save entire PDF documents or individual pages in various formats: Microsoft Word, Microsoft Excel, Microsoft PowerPoint, HTML, images formats, and many more.

1. Click **File > Save As** and then click a desired format. Alternatively, click the arrow next to the **button on the toolbar in the Document tab, and then click a desired format.

2. In the dialog box that opens, specify a name and location for your document.

3. Open the drop-down list next to **File options** and specify whether you want to create one file for all pages or a separate file for each page.

4. Click **Save**.

5. As a result, your PDF- document will be converted into the format of your choice using the currently selected saving options.

To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options. Alternatively, click **File > Options... > Format Settings**. The options dialog box will open, displaying the tab of the format that you selected.

To convert only some of the pages in the document, in the **Pages** pane, select the pages that you want to convert, right-click them, click **Save As** on the shortcut menu, and then click an output format. Alternatively, navigate to the **Organize Pages** tab, select the appropriate pages, click the arrow next to the **button, and select the required format from the drop-down list.

You can convert PDF and image files into documents in various formats. See also: Creating Microsoft Word documents, Creating Microsoft Excel documents, and Other formats.
Reducing the size of your PDF documents

PDF documents that contain page images or a lot of pictures can be very large. The PDF Editor allows you to reduce the size of such documents.

1. Click **File > Reduce File Size...**

2. In the dialog box that opens, the following options are available:

   - **Image quality** - Select this option if you want to reduce the size of the file by lowering the quality of the pictures inside the document.

   - **Use MRC compression (specify OCR languages below)** - Select this option if you want to apply the MRC compression algorithm to recognized pages, which considerably reduces file size while preserving the visual quality the page images.

   - **OCR languages** - Be sure to select the right OCR language(s).

3. Click **Apply**.

The compressed PDF document will be opened in a new window.
Sending PDF documents to the OCR Editor

The PDF Editor allows you to send PDF documents to the OCR Editor, where you can draw recognition areas, check recognized text, train the program to recognize non-standard fonts and characters, and use other advanced features offered by ABBYY FineReader.

- To send a PDF document to the OCR Editor, do one of the following:
  - On the toolbar in the Document tab, click the button and select Recognize and Verify in OCR Editor from the drop-down list.
  - In the main menu, select Document > Recognize Document > Recognize and Verify in OCR Editor.

- To send specific pages to the OCR Editor, do one of the following:
  - On the Pages pane, choose the appropriate pages and select Send Selected Pages to OCR Editor in the context menu.
  - Navigate to the Organize Pages tab, choose the appropriate pages, click the arrow next to the button on the toolbar, and select Send Selected Pages to OCR Editor in the drop-down list.

💡 When sending the document to the OCR Editor, some of these document objects will be lost:

- attachments
- bookmarks
- comments
- annotations

✔ Once you are done working with the document in the OCR Editor, you can send it back to the PDF Editor. To do this, click the arrow next to the button and then click Send to PDF Editor. Alternatively, click File > Send To > PDF Editor.
E-mailing PDF documents

The PDF Editor allows you to send PDF documents by e-mail.

1. Click the \[\text{E-mail}\] button on the toolbar in the Document tab or click File > E-mail.\[
2. In the dialog box that opens, change the name of the document if required.
3. Select the pages that you want to e-mail.
4. Click Create E-mail Message.

An e-mail message will be created and the PDF document will be attached to this message. Type in the recipient's address and send the message.

Printing PDF documents

The PDF Editor allows you to print PDF documents. Before printing, please make sure your computer has a local or network printer connected to it and that the drivers for the printer are installed.

1. Click the \[\text{Print}\] button on the toolbar in the Document tab or click File > Print.\[
2. In the dialog box that opens, specify desired printing settings:
   - **Printer** - Select one of the available printing devices.
   - **Copies** - Specify the number of copies to be printed.
   - **Pages to print** - Specify the pages to be printed (you can choose to print all of the pages, selected pages or a range of pages).
   - **Page setup** - Specify paper size and orientation.
   - **Scaling and position** - Specify the number of document pages to place on one printed page and other printing settings, such as scaling and positioning.
   - **Comments and markup** - Select the appropriate action from the list to print comments and markups. To view all comments in the document, click Show Comments.\[
   - **Manually print on both sides** - Select this option if you use duplex printing.
   - **Black and white** - Select this option if you want to print your document in black and white.
3. Click Print.
Splitting PDF documents

Video: How to Split a PDF

The PDF Editor allows you to split a PDF document into several documents of a smaller size. You can split a document by file size, page count, or top level bookmarks.

Chapter contents:

- Splitting by file size
- Splitting by page count
- Splitting by bookmarks
Splitting by file size

To split a PDF document by file size, do the following:

1. Use the PDF Editor to open the document and select Organize Pages > Split Document... in the main menu. Alternatively, navigate to the Organize Pages tab and click the Split button on the toolbar.

2. In the dialog box that will open:
   a. Select **Split method** > **By file size**.
   b. Specify the **File size**, which is the maximum allowed file size for each new document.

   - The specified file size should be less than the size of the original file.
   - The size of the new document can turn out to be greater than the specified size depending on the contents of the PDF document (e.g. if the document contains a large number of images, fonts, interactive forms, etc.).
   - Change the **File name** if needed. The names of all new documents are numerated at the end in order to keep them unique. Enable numeration before or after the name and specify the number of digits.

   - E.g. the parameters "**Name**: Document, **Numeration**: After name, **Number of digits**: 3" will generate the following document names: Document001.pdf, Document002.pdf, Document003.pdf, etc.
   - The name of the source document is used by default.
   c. **Save the new documents to the source document folder or specify a different location.**

   - Attached files will be sent to a separate folder called **Attachments** in the same directory. Bookmarks are not retained in the new documents.

3. Click **Split**.

Once the splitting has been finished, the folder containing the new files will open in a new window.
Splitting by page count

To split a document by page count, do the following:

1. Use the PDF Editor to open the document and select Organize Pages > Split Document... in the main menu. Alternatively, navigate to the Organize Pages tab and click the button on the toolbar.

2. In the dialog box that will open:
   a. Select Split method > By page count.
   b. Specify the Page count, which is the maximum allowed number of pages for each new document.
   c. Change the File name if needed. The names of all new documents are numerated at the end in order to keep them unique. Enable numeration before or after the name and specify the number of digits.

   ![E.g. the parameters "Name: Document, Numeration: After name, Number of digits: 3" will generate the following document names: Document001.pdf, Document002.pdf, Document003.pdf, etc.]

   ![The name of the source document is used by default.]

   d. Save the new documents to the source document folder or specify a different location.

   ![Attached files will be sent to a separate folder called Attachments in the same directory. Bookmarks are not retained in the new documents.]

3. Click Split.

Once the splitting has been finished, the folder containing the new files will open in a new window.
Splitting by bookmarks

The PDF Editor lets you split a PDF document using only its top level bookmarks. One new document will be created for each top level bookmark.

To split a PDF document by bookmarks, do the following:

1. Use the PDF Editor to open the document and then select *Organize Pages* > *Split Document*... in the main menu. Alternatively, navigate to the *Organize Pages* tab and click the \( \text{Split} \) button on the toolbar.

2. In the dialog box that will open:
   a. Specify the *Split method* > *By bookmarks (first level only)*.
   b. Select the file naming method from the *File name* drop-down list:
      - **Same as bookmark name** names the new documents according to the bookmarks. By default, new document names are numerated. Enable numeration before or after the name and specify the number of digits.
        - E.g. the parameters "**Numeration**: After name, **Number of digits**: 3" will generate the following document names: Introduction001.pdf, Chapter_1002.pdf, Chapter_2003.pdf etc., where Introduction, Chapter_1, and Chapter_2 are bookmark names.
        - Unchecking **Add numeration** will disable the numeration.
      - **Use Custom name** to change the document name if needed. The names of all new documents are numerated at the end in order to keep them unique. Enable numeration before or after the name and specify the number of digits.
        - E.g. the parameters "**Name**: Document, **Numeration**: After name, **Number of digits**: 3" will generate the following document names: Document001.pdf, Document002.pdf, Document003.pdf, etc.
        - The name of the source document is used by default.
   c. Save the new documents to the source document folder or specify a different location.
      - Attached files will be sent to a separate folder called **Attachments** in the same directory. Bookmarks are not retained in the new documents.

3. Click **Split**.

Once the splitting has been finished, the folder containing the new files will open in a new window.
OCR Editor

The OCR Editor uses Optical Character Recognition technology for advanced conversion of document scans, PDF documents, and image files (including digital photos) into editable formats.

In the OCR Editor, you can draw recognition areas, check recognized text, train the program to recognize non-standard characters and fonts, and use some other advanced features to achieve maximum OCR quality.

Chapter contents

- Launching the OCR Editor
- OCR Editor interface
- Obtaining documents
- Recognizing documents
- Improving OCR results
- Checking and editing texts
- Copying text, tables and pictures from PDF documents
- Saving OCR results

Launching the OCR Editor

There are several ways to launch the OCR Editor:

- In the New Task window, click:
  - New Task > Open > Open in OCR Editor
  - or New Task > Tools > OCR Editor
  - or New Task > File > Open in OCR Editor...
- In the PDF Editor, click:
  - PDF Editor > Tools > OCR Editor.
- Open the Windows Start menu and click ABBYY FineReader PDF > ABBYY FineReader OCR Editor (or click Start > All Programs > ABBYY FineReader PDF > ABBYY FineReader OCR Editor in Windows 10).

Tip. You can set up the OCR Editor to either open the last used project or create a new project when it is launched. To do this, click New Task > Options > General and select either Open a new OCR project or Open the last used OCR project.
OCR Editor interface

The OCR Editor window displays your current OCR project. For more information on working with OCR projects, see [OCR projects](#).

- The **Pages** pane shows the pages contained in the OCR project. Two page views modes are available: thumbnails (shown above) and details, which shows a list of document pages and their properties. To switch between the views, right-click anywhere in the **Pages** pane and select **Navigation Pane > Thumbnails** or **Navigation Pane > Details**. Alternatively, use the **View** menu at the top of the OCR Editor window.

- The **Image** pane displays the image of the current page. Here you can edit **recognition areas** and change **area properties**.

- The **Text** pane displays the recognized text. Here you can check the spelling and edit the recognized text.

- The **Zoom** pane displays an enlarged image of the current line of text or any other image area you are currently working on. In the **Image** pane you see the entire page, whereas in the **Zoom** pane you can examine certain image fragments in greater detail, e.g. compare the image of a character with its recognized counterpart in the **Text** window. To scale the image up or down, use the controls at the bottom of the pane.
Toolbars

There are several toolbars in the OCR Editor. The toolbar buttons provide easy access to program commands. The same commands can also be invoked by pressing their corresponding keyboard shortcuts.

The **Main Toolbar** features a set of buttons for the most commonly used operations. Using these buttons, you can open a document, scan a page, open an image, recognize pages, and save the results. The main toolbar cannot be customized.

The **Quick Access Bar** is fully customizable and contains the buttons that you use the most. This toolbar is hidden by default. To make it visible, click **View > Toolbars** and select **Quick Access Bar**. Alternatively, right-click anywhere on the main toolbar and select **Quick Access Bar**.

To customize the **Quick Access Bar**:

1. Click **View > Customize...** to open the **Customize Toolbars and Shortcuts** dialog box.

2. On the **Toolbars** tab, select a category from the **Categories** drop-down list.
   - The set of commands available in the **Commands** list will change accordingly. The commands are grouped in the same manner as in the main menu.

3. From the **Commands** list, select a command and click **>>** to add it onto the **Quick Access Bar** or click **<<** to remove it.

4. Click **OK** to save the changes.

5. If you want to reset the **Quick Access Bar** to its default state, click the **Reset All** button.

The toolbars in the **Pages**, **Image**, and **Text** panes contain buttons for commands applicable to objects that can be displayed in the respective pane:

The **Warnings** pane displays warnings and error messages.

To show the **Warnings** pane, click **View >**

**Show Warnings**
or click the button in the lower left-hand corner of the OCR Editor window.

Warnings and errors are displayed for the page that is currently selected in the Pages pane. To scroll through the warnings and errors and delete unwanted messages, use the buttons.

Customizing the OCR Editor workspace

- You can temporarily hide the panes that you do not need. To show/hide panes, use the View menu or the following keyboard shortcuts:
  - F5 — shows or hides the Pages pane.
  - F6 — shows or hides the Image pane.
  - F7 — shows or hides the Image and Text panes.
  - F8 — shows or hides the Text pane.
  - Ctrl+F5 — shows or hides the Zoom pane.

- To change the size of a pane, hover the mouse cursor on one of its borders until a double-headed arrow appears and drag the border in the desired direction.

- To change the position of the Pages or Zoom pane, use the View menu or the shortcut menu of the pane.

- To show or hide the Warnings pane, click View and select or clear the Show Warnings item.

- To show or hide the Properties bar at the bottom of the Image or Text pane, select or clear the Properties item in the context menu of the pane or click the button.

- Some of the pane properties can be customized on the Areas and Text tab of the Options dialog box.

All of the pages of your current OCR project are displayed in the Pages pane. Two page views are available.

To change the way the pages are displayed in the Pages pane:

- Use the and buttons in the Pages pane.

- Click View > Navigation Pane.

- Right-click anywhere in the Pages pane, click Navigation Pane in the context menu, and then select the desired item.
To open a page, double-click its thumbnail in the **Pages** pane (in **Thumbnails** view) or double-click its number (in **Details** view). The image of the selected page will be shown in the **Image** pane. If OCR has already been performed on this page, the recognized text will appear in the **Text** pane.

**Obtaining documents**

After you launch the OCR Editor, you need to open an image file or PDF. This chapter provides instructions on how you can obtain images and PDF documents for subsequent processing in the OCR Editor.

**Chapter contents**

- [Opening images and PDF documents](#)
- [Scanning paper documents](#)

The quality of OCR depends on the quality of images and PDF documents that you open with ABBYY FineReader. For information on scanning and taking photos of documents and on how to remove common defects from scans and photographs, see [Image processing options](#) and [Editing images manually](#).
Opening images and PDFs

ABBYY FineReader allows you to open PDF and image files in any of the supported formats.

Complete the following steps to open an image or PDF file:

1. In the OCR Editor, click **Open** on the main toolbar or click **File > Open Image**.
2. In the dialog box that opens, select one or more image or PDF files.
3. If you select a file that contains multiple pages, you can specify a range of pages to open.
4. Select **Automatically process page images as they are added** if you want the image to be processed automatically.

**Tip.** You can specify which manipulations the program should perform on the image, e.g. what image defects should be rectified or whether the document should be analyzed and recognized automatically. To specify image processing options, click the **Options** button. See [Image processing options](#) for details.

- If an OCR project is already open when you open new pages, the selected pages will be appended to the end of this project. If no OCR project is currently open, a new one will be created from the selected pages.
- For more information on working with pages and OCR projects, see [OCR projects](#).
- Access to some PDF files may be restricted by their authors. Such restrictions include password protection and restrictions on opening the document or copying its content. When opening such files, ABBYY FineReader will request a password.
Scanning paper documents

To scan a document:

1. In the OCR Editor, click on the main toolbar or click File > Scan Pages.

2. Select a scanning device and specify scanning settings.

3. Click the Preview button or click anywhere inside the image.

4. Review the image. If it is not satisfactory, change the scanning settings and click the Preview button again.

5. Click Settings... and specify image processing options. These options determine the appearance and properties of the output document.

6. Click Scan.

7. If an OCR project is already open when you scan new pages, the scanned pages will be appended to the end of this project. If no OCR project is currently open, a new one will be created from the scanned pages.

See Scanning tips for some tips on selecting the optimal scanning settings.
Recognizing documents

ABYY FineReader uses Optical Character Recognition (OCR) technology to convert document images into editable text. Prior to OCR, the program analyzes the structure of the entire document and detects the areas that contain text, barcodes, pictures, and tables. For best OCR results, be sure to select the right OCR language, recognition mode, and print type.

By default, images contained in an OCR project are recognized automatically using the settings currently selected in the program.

**Tip.** You can disable automatic analysis and OCR for newly added images on the Image Processing tab of the Options dialog box (click Tools > Options... to open this dialog box).

In some cases, the OCR process must be started manually. This may be necessary, for example, if you disable automatic OCR, manually draw areas on an image, or change any of the following parameters in the Options dialog box:

- the OCR language on the Languages tab
- the OCR options on the OCR tab
- the fonts to be used on the OCR tab

To launch the OCR process manually:

- Click the Recognize button on the main toolbar, or
- Click Recognize > Recognize All Pages.

**Tip.** To recognize a selected area or page, use the Area or Recognize menu or right-click the area or page to call up the context menu.

See also:

- OCR options
- Document features to consider prior to performing OCR
- Editing areas
- Improving OCR results
OCR projects

While working with the program, you can save your interim results in an OCR project so that you can resume your work where you left off. An OCR project contains the source images, the text that has been recognized on the images, your program settings, and any user patterns, languages or language groups that you have created.

This section covers the following topics:

- Opening a previously saved OCR project
- Using settings from earlier versions of ABBYY FineReader
- Adding images to an OCR project
- Removing pages from an OCR project
- Removing blank pages from an OCR project
- Saving an OCR project
- Closing an OCR project
- Splitting an OCR project into several projects
- Reordering pages in an OCR project
- Working with document metadata
- Working with patterns and languages

Opening an OCR project

When you launch the OCR Editor, a new OCR project is created by default. You can either work this new OCR project or open an existing one.

To open an existing OCR project:

1. Click File > Open OCR Project....
2. In the dialog box that opens, select the OCR project that you want to open.

If you open an OCR project that was created in an earlier version of the program, ABBYY FineReader will try to convert it into the new format used by the current version. This conversion cannot be undone, so you will be prompted to save your OCR project under a different name. The recognized text from the old project will not be carried over into the new project. To recognize the pages in the OCR project, click the Recognize button.
Tip. If you want the last used OCR project to open when you launch the OCR Editor, select **Open the last used OCR project** on the General tab of the Options dialog box (click **Tools > Options...** to open this dialog box).

You can also right-click an OCR project in Windows Explorer and select **Open OCR project in ABBYY FineReader PDF**. OCR projects are marked with the **##** icon.

**Using settings from earlier versions of ABBYY FineReader**

ABBYY FineReader lets you import user dictionaries and program settings from files created in earlier versions of the program.

To use dictionaries created in ABBYY FineReader 10, 11, 12 or 14:

1. Click **Tools > View Dictionaries...**
2. In the User Dictionaries dialog box, select the language of the dictionary and click **View...**
3. In the Dictionary for... dialog box, click **Import...** and specify the path to the dictionary.
4. Select the dictionary file and click **Open**.

**Adding images to an OCR project**

1. Click **File > Open Image...**
2. In the dialog box that opens, select one or more images and click **Open**. The images will be appended to the end of the open OCR project, and their copies will be saved in the OCR project folder.

You can also right-click images in Windows Explorer and select **Convert with ABBYY FineReader PDF > Open in OCR Editor** on the shortcut menu. The selected files will be added to a new OCR project.

You can also add document scans. **See also:** [Scanning paper documents](#).

**Removing pages from an OCR project**

- In the Pages pane, select a page and click **Delete**, or
- Click **Edit > Delete Pages...**, or
- Right-click a page in the Pages pane and select **Delete...** on the shortcut menu

You can select and delete more than one page in the Pages pane.

**Removing blank pages from an OCR project**

1. In the Edit menu, select **Delete Blank Pages**.
2. In the dialog box that will open, select all pages that need to be deleted. By default, all pages identified by ABBYY FineReader as blank are selected. You can use the + and – hotkeys to view the pages.

💡 Before you delete the selected pages, make sure that they do not contain any handwritten notes, pictures, or other data that may be important.

3. Click **Delete selected pages**.

### Saving an OCR project

1. Click **File > Save OCR Project**.

2. In the dialog box that opens, enter a name for your OCR project and specify a folder where it should be stored.

💡 When you save an OCR project, not only the page images and recognized text are saved, but also any patterns and languages you created while working on the project.

### Closing an OCR project

- To close an OCR project, click **File > Close**.

### Splitting an OCR project into several projects

When processing large numbers of multi-page documents, it is often more practical to scan all the documents first and only then analyze and recognize them. However, to preserve the original formatting of each paper document correctly, ABBYY FineReader must process each of them as a separate OCR project. ABBYY FineReader includes tools for grouping scanned pages into separate OCR projects.

To split an OCR project:

1. Right-click anywhere in the **Pages** pane and select **Move Pages to New OCR Project** on the shortcut menu.

2. In the dialog box that opens, create the necessary number of OCR projects by clicking the **Add OCR Project** button.

3. Move pages from the **Pages** pane to another OCR project using one of the following methods:
   - Select the pages and drag them with the mouse.
     You can also use drag-and-drop to move pages between OCR projects.
   - Use the **Move** and **Return** buttons. The **Move** button will move the pages to the current project.
Press Ctrl+Right Arrow to move the selected pages from the Pages pane to the current OCR project or press Ctrl+Left Arrow or Delete to move them back to their original project.

4. When you are done, click Create to create a new OCR project or Create All to create all projects in one go.

Tip. You can also drag-and-drop selected pages from the Pages pane into another instance of the OCR Editor. The selected pages will be appended to the end of the OCR project.

Reordering pages in an OCR project

1. In the Pages pane, select one or more pages.

2. Right-click anywhere in the Pages pane and select Reorder Pages... on the shortcut menu.

3. In the Reorder Pages dialog box, choose one of the following:

   - **Reorder pages (cannot be undone)**
     This changes all page numbers successively, starting with the selected page.

   - **Restore original page order after duplex scanning**
     This option restores the original page numbering of a document with double-sided pages. This option is useful if you use a scanner with an automatic feeder to first scan all the odd-numbered pages and then all the even-numbered pages. You can choose between the normal and the reverse order for the even-numbered pages.
     🎈 This option will only work if three or more consecutively numbered pages are selected.

   - **Swap book pages**
     This option is useful if you scan a book written in a left-to-right script and then split the facing pages without specifying the correct language.
     🎈 This option will only work if two or more consecutively numbered pages are selected and if at least two of them are facing pages.
     ✗ To cancel this operation, select Undo last operation.

4. Click OK.

The pages in the Pages pane will be rearranged in accordance with their new numbers.

In Thumbnails view, you can change page numbering simply by dragging selected pages to the desired place in the OCR project.

Metadata
Document metadata contain detailed information about the document such as its author, subject, and keywords. Document metadata can be used to sort files and to review document properties. Documents can also be searched by their metadata.

When recognizing PDF documents and certain types of image files, ABBYY FineReader will export the metadata of the source document. You can edit these metadata if necessary.

To add or modify document metadata:

1. Open the Format Settings tab of the Options dialog box (click Tools > Options... to open this dialog box).
2. Click the Edit Metadata... button and in the dialog box that opens, enter the name, author, subject, and keywords for the document.
3. Click OK.

**Working with patterns and languages**

You can save and load user patterns and languages.

For more about patterns, see If your document contains non-standard fonts. For more about user languages, see If the program failed to recognize some of the characters.

To save patterns and languages to a file:

1. Open the OCR tab of the Options dialog box (click Tools > Options... to open this dialog box).
2. Click the Save Patterns and Languages...
3. In the dialog box that opens, type a name for your file and click Save.

This file will contain the path to the folder where your user languages, language groups, dictionaries, and patterns are stored.

To load patterns and languages:

1. Open the OCR tab of the Options dialog box (click Tools > Options... to open this dialog box).
2. Click the Load Patterns and Languages...
3. In the Load Options dialog box, select the required *.fbt/*.fbtx file and click Open.
Group work with OCR projects

ABBYY FineReader provides tools for working on documents together with other users over a network. Multiple users can share the same user languages and dictionaries created for these languages.

To make user dictionaries and languages available to multiple users:

1. Create/open an OCR project and select desired scanning and OCR options for the project.

2. Specify a folder where user dictionaries will be stored. This folder should be accessible to all users.
   - By default, user dictionaries are stored in `%Userprofile% \AppData\Roaming\ABBYY\FineReader\16\FineReaderShell\UserDictionaries`.
   - To specify a different folder for user dictionaries:
     a. On the Areas and Text tab of the Options dialog box (click Tools > Options...), click the User Dictionaries... button.
     b. In the dialog box that opens, click the Browse... button and specify the path to your folder.

3. Save the user patterns and languages to a file (*.fbtx):
   a. Click the OCR tab in the Options dialog box (click Tools > Options... to open this dialog box).
   b. Click Save Patterns and Languages....
   c. In the Save Options dialog box, specify a folder where the file will be stored. This folder should be accessible to all users.

4. Now other users can access the user languages and dictionaries. To do so, they need to load the *.fbtx file you created in step 3 and specify the path to the folder with the user dictionaries you created in step 2.
   - To be able to access the user dictionaries, patterns, and languages, users must have read/write permissions for the folders where they are stored.

To see the list of available user languages and their parameters, click the OCR tab in the Options dialog box (click Tools > Options... to open this dialog box).

When a user language is being used by several users, users can add words or delete words from the corresponding dictionary, but they cannot change the properties of this language.

When a user dictionary is being edited by a user, other users can use this dictionary to perform OCR and check spelling, but they cannot add or remove words.
Any changes a user makes to a user dictionary will become available to all users who have selected the folder where this dictionary is stored. For the changes to come into effect, users will need to restart ABBYY FineReader.

### Improving OCR results

**Contents:**

- If your document image has defects and OCR accuracy is low
- If areas are not detected properly
- If the complex structure of a paper document is not reproduced
- If you are processing a large number of documents with identical layouts
- If tables and pictures are not detected
- If a barcode is not detected
- If an incorrect font is used or some characters are replaced with "?" or "□"
- If your printed document contains non-standard fonts
- If your document contains many specialized terms
- If the program fails to recognize certain characters
- If vertical or inverted text was not recognized
If your document image has defects and OCR accuracy is low

Distorted text lines, skew, noise, and other defects commonly found in scanned images and digital photos can lower OCR quality. ABBYY FineReader provides a variety of automated and manual tools for removing these defects.

How to edit images manually

If you disabled automatic preprocessing features or want to preprocess specific pages, you can use the Image Editor to manually edit page images.

Follow the instructions below to edit an image manually:

1. Open the OCR Editor and then open the Image Editor:

2. Click on the toolbar of the Image pane, or

3. Click Edit > Edit Page Images....

4. The Image Editor will open and display the currently selected page. The rightmost panel of the Image Editor contains tools for editing images.
5. Click the tool you want to use and apply it to the image. The resulting changes will be displayed in the Image pane. Most of the tools can be applied both to specific pages and to all of the pages in the document. You can specify which pages you want to edit using the Selection drop-down list of the tool, where you can select all odd/even pages, the current page or the selected pages if multiple pages are selected in the Pages pane.

6. After you finish editing images, click the Exit Image Editor button at the top of the Image Editor.

The image editor contains the following tools:

- **Recommended Preprocessing**
  Depending on the type of your image, the program will automatically determine and apply the necessary corrections. Corrections that may be applied include noise and blur removal, color inversion to make the background color lighter than the text, skew correction, straightening of text lines, correction of trapezoid distortions, and cropping of image borders.

- **Deskew**
  Corrects image skew.

- **Straighten Text Lines**
  Straightens any curved text lines on the image.

- **Photo Correction**
  Tools in this group let you straighten text lines, remove noise and blur, and change the document's background color to white.

- **Correct Trapezoid Distortion**
  Corrects trapezoid distortions and removes image edges that don't contain any useful data. When this tool is selected, a blue grid appears on the image. Drag the grid's corners to the corners of the image so that the grid's horizontal lines become parallel to the text lines. Click the Correct button to apply the changes.

- **Rotate & Flip**
  Tools in this group let you rotate images and flip them vertically or horizontally to get the text on the image facing in the right direction.

- **Split**
  Tools in this group let you split the image into parts. This can be useful if you are scanning a book and need to split facing pages.

- **Crop**
  Removes image edges that don't contain any useful information.
- **Invert**
  Inverts image colors. This can be useful if you're dealing with non-standard text coloring (light text on a dark background).

- **Resolution**
  Changes the resolution of the image.

- **Brightness & Contrast**
  Changes the brightness and contrast of the image.

- **Levels**
  This tool lets you adjust the color levels of the images by changing the intensity of shadows, light, and halftones.

  To increase the contrast of an image, move the left and right sliders on the **Input levels** histogram. The range of colors between lightest and darkest is divided into 255 increments.

  The left slider sets the color that will be considered to be the blackest part of the image, and the right slider sets the color that will be considered to be the whitest part of the image.

  Moving the middle slider to the right will darken the image, and moving it to the left will lighten the image.

  Adjust the output level slider to decrease the contrast of the image.

- **Eraser**
  Erases a part of the image.

- **Remove Color Marks**
  Removes any color stamps and marks made in pen to facilitate the OCR of the text obscured by such marks. This tool is intended for scanned documents with a white background, and should not be used on digital photos and documents with color backgrounds.
If areas are detected incorrectly

ABYY FineReader analyzes page images prior to OCR and detects different types of areas on these images, specifically text, picture, background picture, table, and barcode areas. This analysis determines which areas will be recognized and in what order. In the user interface, different area types are distinguished by the colors of their borders.

If you click on an area, it will be highlighted and will become active. You can also navigate areas by pressing the Tab key. The areas' numbers determine the order in which they are selected when the Tab key is pressed. By default, these area numbers are not visible in the Image pane, but you can view them in the Area Properties pane of each area. Area numbers will appear on areas when the Order Areas tool is selected.

The tools for drawing and editing areas manually can be found on the toolbar at the top of the Image pane and on the pop-up toolbars of the text, picture, background picture, and table areas (select an area to view its pop-up toolbar).

Once you have adjusted the position or changed the type of an area, be sure to recognize the image again.

You can use area editing tools to:

- Create a new area
- Adjust area borders
- Add or remove parts of areas
- Select one or more areas
- Move areas
- Reorder areas
- Delete areas
- Change the orientation of text in an area
- Change the color of area borders

Creating a new area
1. Select one of the tools on the toolbar at the top of the Image pane:
   - \( \text{ recognition area } \)
   - \( \text{ text area } \)
   - \( \text{ picture area } \)
   - \( \text{ background picture area } \)
   - \( \text{ table area } \)

2. Hold down the left mouse button and move the mouse pointer to draw an area.

**Tip.** New areas can be drawn without selecting a tool from the Image pane toolbar. You can draw an area on the image using one of the following key combinations:

- Ctrl+Shift draws a text area.
- Alt+Shift draws a picture area.
- Ctrl+Alt draws a table area.
- Ctrl+Shift+Alt draws a background picture area.

You can change the type of an area. Right-click the area whose type you want to change, click **Change Area Type To** on the shortcut menu, and select the desired area type.

**Adjusting area borders**

1. Place the mouse pointer on an area border.
2. Hold down the left mouse button and drag the border in the desired direction.

- You can simultaneously adjust the vertical and horizontal borders of an area by placing the mouse pointer on a corner of the area.

**Adding/removing area parts**

1. Select the \( \text{ selection tool } \) or \( \text{ selection tool } \) tool on the toolbar of a text, picture or background picture area.
2. Place the mouse pointer inside an area and select a part of the image. This segment will be added to or deleted from the area.
3. Adjust the area border if necessary.

**Note:**

1. These tools are only available for text, picture, and background picture areas. Area segments cannot be added to or deleted from table or barcode areas.
2. Area borders can also be adjusted by using sizing handles. The resulting segments can be dragged in any direction using the mouse. To add a new sizing handle, place the mouse pointer on the desired point on the border while holding down Ctrl+Shift (this will change the mouse pointer to crosshairs) and click the border. A new sizing handle will appear on the area border.

Selecting one or more areas

- Select the , , , , , or tool on the toolbar at the top of the Image pane and click the areas you want to select while holding down the Ctrl key. To remove an area from the selection, click it again.

Moving an area

- Select an area and drag it while holding down the Ctrl key.

Reordering areas

1. Select the tool on the toolbar at the top of the Image pane or click Area > Reorder Areas.

2. Select the areas in the order in which their content should appear in the output document.

   - The areas are automatically numbered from left to right during page analysis, regardless of the direction of the text on the image.

Deleting an area

- Select the areas you want to delete and press the Delete key.

- Select the areas you want to delete, right-click one of them, and click Delete on the shortcut menu.

- Select the tool and click the areas you want to delete.

To delete all areas:

- Right-click anywhere inside the Image pane and click Delete Areas and Text on the shortcut menu.

   - Deleting an area from an image that has already been recognized will also delete all text from that area in the Text pane.

Changing text orientation
- Right-click an area and click **Properties** on the shortcut menu to display its properties in the **Area Properties** pane. In this dialog box, select the desired text orientation from the **Orientation** drop-down list.

For more information about editing text properties in text areas, see "Editing area properties[208]."

To change the colors of area borders:

1. Click **Tools > Options...** to open the **Options** dialog box and click the **Areas and Text** tab.

2. Select an area whose color you want to change and then select the desired color.
**Editing area properties**

When performing automatic document analysis, ABBYY FineReader detects different area types on document pages, such as table, picture, text, and barcode areas. The program also analyzes the document structure and identifies headings and other layout elements, such as headers, footers, and captions.

You can manually change incorrectly defined properties in some text and table areas.

1. Select an area in the **Image** or **Zoom** pane to display its properties in the **Area Properties** pane. This pane displays the following editable properties:

   - **Language**
     See [OCR languages](#).

   - **Function**
     Displays the function of the text, i.e. whether it is a header or a footer, a footnote, etc. (applies only to text areas).

   - **Orientation**
     See [If vertical or inverted text was not recognized](#).

   - **Print type**
     See [Document features to consider prior to OCR](#).

   - **Inversion**
     See [If vertical or inverted text was not recognized](#).

   - **Direction of CJK text**
     See [Working with complex-script languages](#).

**Note:**

a. Use the / buttons to navigate the properties dialog box if the **Image** pane is not wide enough to fit the entire dialog box.

b. Some properties of text in text areas can be changed using the shortcut menu of these areas.

2. After you have made the desired changes, be sure to recognize the document again so that the changes you made to the areas are reflected in the recognized text.

✔ For more information about areas, see [Editing areas](#).
If the complex structure of a paper document is not reproduced

Before running the OCR process, ABBYY FineReader PDF analyzes the logical structure of the document and detects areas containing text, pictures, tables, and barcodes. The program then relies on this analysis to identify which parts of the image need to be recognized and the order in which they should be recognized. This information helps recreate the formatting of the original document.

By default, ABBYY FineReader PDF will analyze documents automatically. In the case of very complex layouts, the program may occasionally make mistakes when determining the type of an area type or locating it's borders. It is often easier to correct faulty areas manually rather than drawing all areas anew.

Use the following tools and commands to correct areas:

- The manual area adjustment tools on the toolbar at the top of the Image pane.
- The shortcut menu commands available by right-clicking the selected area in the Image pane or the Zoom pane.
- Commands on the Area menu.

Make sure you recognize the document again after making the desired adjustments, so that the changes you have made to the areas are reflected in the recognized text.

For more information about areas, see Editing areas.

OCR settings, area properties, and selected saving options also have an effect on how well the layout of the original document is retrained. See also: OCR options, Editing area properties, Saving OCR results.
If you are processing a large number of documents with identical layouts

If you are processing a large number of documents with identical layouts (e.g. forms or questionnaires), analyzing the layout of every page will be very time consuming. To save time, you can analyze only one document in a set of similar documents and save the detected areas as a template. Then you can use this template for the other documents in the set.

To create an area template:

1. Open an image in the OCR Editor and either let the program analyze the layout automatically or draw the areas manually.

2. Click **Area > Save Area Template...**. In the dialog box that opens, specify a name for the area template and click **Save**.

💡 To be able to use an area template, you must scan all the documents in the set using the same resolution value.

To apply an area template:

1. In the **Pages** pane, select the pages to which you want to apply the template.

2. Click **Area > Load Area Template...**.

3. In the **Open Area Template** dialog box, select the desired template file (*.blk/*.blkx).

4. In the same dialog box, next to **Apply to**, select **Selected pages** to apply the template to the selected pages.

**Tip.** If you want to apply the template to all pages in the document, select **All pages**.

5. Click **Open**.
If tables and pictures are not detected

If a table is not detected

Table areas contain tables and text that is arranged in a table-like manner. If the program fails to correctly draw a table area around a table, use the Table tool to draw the area manually.

1. Click on the toolbar at the top of the Image pane and use the mouse pointer to draw a table area around the table.

2. Right-click the table and click Analyze Table Structure on the shortcut menu, or click on the pop-up toolbar of the table area.

3. Use the pop-up toolbar, the shortcut menu of the table area, or the commands on the Area menu to edit the results.

4. Run the OCR process again.

You can also assign the Table type to an area of a different type. To do this, right-click the area and click Change Area Type To > Table on the shortcut menu.

If ABBYY FineReader failed to correctly detect the rows and columns in a table automatically, you can adjust the layout manually and run the OCR process again.
• You can use commands on the **Area** menu and the shortcut menu of a table area to:

  o **Analyze Table Structure** (automatically analyzes the structure of a table and saves you the trouble of drawing vertical and horizontal separators manually).

  o **Split Cells, Merge Cells, Merge Rows** (allow you to correct any wrongly identified rows or columns).

• Use the pop-up toolbar of the selected table area to add a horizontal or vertical separator, delete table separators, analyze table structure, split table cells, or merge table cells or rows.

To do this, click the table area and then click the appropriate tool on the pop-up toolbar:

![Tool icons](image)

**Tip.** Click the ![Select tool](image) tool on the pop-up toolbar to select objects.

**Note:**

1. The cell splitting command can only be applied to table cells that were previously merged.

2. To merge or split table cells or rows, select them on the image and then click the appropriate tool or menu command.

3. If the table contains vertical text cells, you may need to change the text properties first.

4. If a table cell only contains an image, select the **Treat selected cells as picture** option on the **Area Properties** pane (to open this pane, right-click an area and click **Properties** on the shortcut menu).

If a cell contains a combination of images and text, select the image to turn it into a dedicated area inside the cell.

**See also:**

- *If vertical or inverted text was not recognized* [221]

- *Editing areas* [204]

- *Editing area properties* [208]

**If a picture is not detected**

**Picture areas** contain pictures. You can also use picture areas for text fragments that you don't want to be recognized. If the program fails to correctly draw a picture area around a picture, use the **Picture** tool to draw the area manually.

1. Select the ![Select tool](image) tool on the toolbar at the top of the **Image** pane and use the mouse pointer to draw a picture area around the picture.
2. Run the OCR process again.

If there is text printed over a picture in your document, draw a background picture area around the picture.

1. Select the tool on the toolbar at the top of the Image pane and use the mouse pointer to draw a background picture area around the background picture.

2. Run the OCR process again.

You can also assign the Picture or Background Picture type to an area of a different type that was detected automatically. To do this, right-click the area whose type you want to change and click Change Area Type To > Picture (or Background Picture) on the shortcut menu.

For more on areas, area types, and how to edit them, see Editing areas.
If a barcode is not detected

Barcode areas[^1] contain barcodes. If your document contains a barcode that you would like to render as a sequence of letters and digits rather than as an image, select the barcode and change the area type to **Barcode**.

Bar code recognition is disabled by default. To enable it, click **Tools** > **Options...** to open the **Options** dialog box, click the **OCR** tab, and select the **Convert barcodes into strings** option.

To draw a barcode area and recognize it:

1. Draw an area around a barcode in the **Image** or **Zoom** pane.
2. Right-click the area and click **Change Area Type To** > **Barcode** on the shortcut menu.
3. Run the OCR process.

ABBYY FineReader PDF can read the following types of barcode:

- Code 3 of 9
- Check Code 3 of 9
- Code 3 of 9 without asterisk
- Codabar
- Code 93
- Code 128
- EAN 8
- EAN 13
- IATA 2 of 5
- Interleaved 2 of 5
- Check Interleaved 2 of 5
- Matrix 2 of 5
- Postnet
- Industrial 2 of 5
- UCC-128
- UPC-A
- UPC-E
• PDF417
• Aztec Code
• Data Matrix
• QR code
• Patch code

The default barcode type is **Autodetect**, which means that barcode types are to be detected automatically. However, not all barcode types can be detected automatically, and sometimes you may need to select the appropriate type manually on the **Area Properties** pane.

ABBYY FineReader can automatically detect the following types of barcode: Code 3 of 9, Code 93, Code 128, EAN 8, EAN 13, Postnet, UCC-128, UPC-E, PDF417, UPC-A, QR code.

**If an incorrect font is used or some characters are replaced with "?" or "□"**

If you see "?" or "□" instead of letters in the **Text** pane, check to see if the fonts selected to display the recognized text contain all the characters used in your text.

See also: **Required fonts**.

You can change the font of a recognized text without running the OCR process again.

To change the font in a short document:

1. Select a text fragment where some characters have the wrong font.
2. Right-click the selection and click **Properties** on the shortcut menu.
3. Select the desired font from the **Font** drop-down list in the **Text Properties** pane. The font in the selected text fragment will change accordingly.

To change the font in a long document where styles are used:

1. Click **Tools > Style Editor**....
2. In the **Style Editor** dialog box, select the style you want to edit and change its font.
3. Click **OK**. The font in all of the text fragments using this style will change accordingly.

If an OCR project was recognized or edited on another computer, the text in the document may be displayed incorrectly on your computer. If this is the case, make sure that all the fonts used in this OCR project are installed on your computer.
If your printed document contains non-standard fonts

If a document you want to recognize contains decorative fonts or special characters (e.g. mathematical symbols), we recommend using the training mode to improve OCR accuracy.

It is not advisable to use the training mode in other cases, as the gains in OCR quality will be insignificant compared to the time and effort you will spend on training.

In training mode, a user pattern is created, which can be used when performing OCR on the entire text.

- **Using user patterns**
- **Creating and training a user pattern**
- **Selecting a user pattern**
- **Editing a user pattern**

**Using user patterns**

To use a user pattern to recognize a document:

1. Click **Tools > Options...** to open the **Options** dialog box and click the **OCR** tab.

2. Select the **Use user patterns** option.

3. Click the **Pattern Editor...** button.

4. In the **Pattern Editor** dialog box, select a pattern and click **OK**.

5. Click the **Recognize** button on the main toolbar at the top of the OCR Editor window.

**Creating and training a user pattern**

To train a user pattern to recognize new characters and ligatures:

1. Click **Tools > Options...** to open the **Options** dialog box and click the **OCR** tab.

2. Select the **Use training to recognize new characters and ligatures** option.

3. Click the **Pattern Editor...** button.

Pattern training is not supported for Asian languages.
4. In the **Pattern Editor** dialog box, click the **New...** button.

5. In the **Create Pattern** dialog box, specify a name for the new pattern and click **OK**.

6. Click **OK** in the **Pattern Editor** dialog box and then click **OK** in the **Options** dialog box.

7. Click the ![](Recognize Page.png) button in the toolbar at the top of the **Image** pane.

   If the program encounters a character it does not recognize, the **Pattern Training** dialog will open and display this character.

8. Teach the program to read new **characters** and **ligatures**.

   A ligature is a combination of two or three characters that are "glued together" (for example, fi, fl, ffi, etc.) and are difficult for the program to separate. In fact, better results can be obtained by treating them as single compound characters.

   - Words printed in bold or italic type or words in superscript/subscript may be retained in the recognized text by selecting the corresponding options under **Effects**.

   To go back to a previously trained character, click the **Back** button. The frame will jump to its previous location and the latest trained "character image - keyboard character" pairing will be removed from the pattern. The **Back** button navigates between the characters of one word and will not navigate between words.

   **Important!**

   - You can only train ABBYY FineReader PDF to read the characters included in the alphabet of the OCR language. To train the program to read characters that cannot be entered from the keyboard, use a combination of two characters to denote these non-existent characters or copy the desired character from the **Insert Character** dialog box (click ![Insert Character](...) to open this dialog box).
Each pattern may contain up to 1,000 new characters. However, avoid creating too many ligatures, as this may adversely affect OCR quality.

**Selecting a user pattern**

ABBYY FineReader lets you use patterns to improve OCR quality.

1. Click **Tools > Pattern Editor...**

2. In the **Pattern Editor** dialog box, select one of the patterns in the list and click the **Set Active** button.

Some important points to remember:

1. Sometimes the program will not differentiate between very similar yet different characters and recognize them as one and the same character. For example, the straight (’), left (‘), and right (’) quotes will be stored in a pattern as a single character (straight quote). This means that left and right quotes will never be used in the recognized text, even if you try to train them.

2. For some character images, ABBYY FineReader PDF will select the corresponding keyboard character based on the surrounding context. For example, an image of a small circle will be recognized as the letter O if there are letters immediately next to it, and as the number 0 if there are digits next to it.

3. A pattern can only be used for documents that have the same font, font size, and resolution as the document used to create the pattern.

4. You can save your pattern to a file and use it in other OCR projects. See also: [OCR projects](#).

5. To recognize texts set in a different font, be sure to disable the user pattern. To do this, click **Tools > Options...** to open the **Options** dialog box, click the **OCR** tab, and select the **Use built-in patterns** option.

**Editing a user pattern**

You may wish to edit your newly created pattern before launching the OCR process. An incorrectly trained pattern may adversely affect OCR quality. A pattern should contain only entire characters or ligatures. Characters with cut edges and characters with incorrect letter pairings should be removed from the pattern.

1. Click **Tools > Pattern Editor...**

2. In the **Pattern Editor** dialog box, select the pattern you want to edit and click the **Edit...** button.

3. In the **User Pattern** dialog box, select a character and click the **Properties...** button.
In the dialog box that opens:

- In the **Character** field, enter the letter that corresponds to the character.
- In the **Effects** field, specify the desired font effect (bold, italic, superscript or subscript).

To delete a character that has been trained incorrectly, click the **Delete** button in the **User Pattern** dialog box.

**If your document contains many specialized terms**

ABBYY FineReader PDF checks recognized words against its internal dictionary. If your text contains too many specialized terms, abbreviations or proper names, you can improve OCR quality by adding them to a user dictionary.

1. Click **Tools > View Dictionaries...**
2. In the **User Dictionaries** dialog box, select the appropriate language and click **View...**
3. In the dialog box that opens, type the word you want to add and click the **Add word** button (or select a word you want to delete and click the **Delete** button).

If the dictionary already contains the word you are trying to add, a warning message will be displayed.

You can import user dictionaries created in ABBYY FineReader 9.0, 10, 11, 12 and 14:

1. Click **Tools > View Dictionaries...** button.
2. In the **User Dictionaries** dialog box, select the appropriate language and click the **View...**
3. In the dialog box that opens, click the **Import...** button and select the user dictionary you want to import (it will have the *.pmd, *.txt or *.dic extension).
If the program fails to recognize certain characters

ABYY FineReader PDF uses data about the document language when recognizing text. The program may fail to recognize some characters in documents with uncommon elements (e.g., code numbers) because the document language might not contain these characters. To recognize such documents, you can create a custom language that has all of the necessary characters. You can also create groups of several OCR languages and use these groups when recognizing documents.

How to create a user language

1. Open the Options dialog box (click Tools > Options... to open this dialog box), click the Languages tab.

2. Click the New... button.

3. In the dialog box that opens, select the Create a new language based on an existing one option, select the language which you want to use as a base for the new language, and click OK.

4. The Language Properties dialog box will open. In this dialog box:

   a. Type a name for your new language.

   b. The language you selected in the New Language or Group dialog box is displayed in the Source language drop-down list. You can select a different language from this drop-down list.

   c. The Alphabet contains the alphabet of the base language. If you want to edit the alphabet, click the button.

   d. The Dictionary option group contains several options for the dictionary that will be used by the program when recognizing text and checking the result:

      - None
        The language will not have a dictionary.

      - Built-in dictionary
        The program's built-in dictionary will be used.

      - User dictionary
        Click the Edit... button to specify dictionary terms or import an existing custom dictionary or a text file with Windows-1252 encoding (terms must be separated by spaces or other characters that are not in the alphabet).

        ✔ Words from the user dictionary will not be marked as misspelled when the spelling in the recognized text is checked. They may be written in all lower-case or all upper-case letters, or may begin with an upper-case letter.
<table>
<thead>
<tr>
<th>Word in the dictionary</th>
<th>Words that will not be considered misspelled during a spelling check</th>
</tr>
</thead>
<tbody>
<tr>
<td>abc</td>
<td>abc, Abc, ABC</td>
</tr>
<tr>
<td>Abc</td>
<td>abc, Abc, ABC</td>
</tr>
<tr>
<td>ABC</td>
<td>abc, Abc, ABC</td>
</tr>
<tr>
<td>Abc</td>
<td>aBc, abc, Abc, ABC</td>
</tr>
</tbody>
</table>

- The **Regular expression** allows you to create a user dictionary using regular expressions.
  
  ![See also: Regular expressions](image)

- Languages can have several additional properties. To change these properties, click the **Advanced...** button to open the **Advanced Language Properties** dialog box, where you can specify:
  
  - Characters that can begin or end a word
  - Non-letter characters that appear separately from words
  - Characters that may appear inside words but should be ignored
  - Characters that cannot appear in texts that are recognized using this language (prohibited characters)
  
  - The **Text may contain Arabic numerals, Roman numerals, and abbreviations** option

5. You can now select the newly created language when choosing OCR languages.
  
  ![For more on OCR languages, see OCR languages](image)

By default, the user language is saved in the folder of the OCR project. You can also save all user patterns and languages as a single file. To do this, open the **Options** dialog box (click **Tools > Options...** to open this dialog box), click the **OCR** tab, and then click the **Save Patterns and Languages...** button.

**Creating a language group**

If you are going to use a particular language combination regularly, you may wish to group the languages together for convenience.

1. Open the **Options** dialog box (click **Tools > Options...** to open this dialog box) and click the **Languages** tab.

2. Click the **New...** button.
3. In the **New Language or Group** dialog box, select the **Create a new group of languages** option, and click **OK**.

4. The **Language Group Properties** dialog box will open. In this dialog box, specify a name for the language group and select the languages you want to include in the group.
   - If you know that your text will not contain certain characters, you may wish to explicitly specify these so-called prohibited characters. Doing this can increase the speed and accuracy of OCR. To specify these characters, click the **Advanced...** button in the **Language Group Properties** dialog box and enter the prohibited characters in the **Prohibited characters** field.

5. Click **OK**.

The new group will appear in the drop-down list of languages on the main toolbar.

By default, user language groups are saved in the folder of the **OCR project**. You can also save all user patterns and languages as a single file. To do this, open the **Options** dialog box (click **Tools > Options...** to open this dialog box), click the **OCR** tab, and then click the **Save Patterns and Languages...** button.

**Tip.** You can use the drop-down list of languages on the main toolbar to select a language group.

1. Select **More languages...** from the drop-down list of languages on the main toolbar.

2. In the **Language Editor** dialog box, select the **Specify OCR languages manually** option.

3. Select the desired languages and click **OK**.

**If vertical or inverted text was not recognized**

A fragment of recognized text may contain a large number of errors if the orientation of the fragment was detected incorrectly or if the text in the fragment is inverted (i.e. light text is printed on a dark background).

To solve this problem:

1. In the **Image** pane, select the area or the table cell that contains vertical or inverted text.

2. Right-click the area and click **Properties** on the shortcut menu to open the **Area Properties** pane. Next:
   - Select the direction of the text from the **Direction of CJK text** drop-down list, or
   - Select **Inverted** from the **Inversion** drop-down list.

3. Run the OCR process again.

**For more information about areas, see** [Editing areas](#).
Checking and editing texts

Once the OCR process is completed, the recognized text appears in the **Text** pane. The characters recognized with low confidence are highlighted, so that you can easily spot any OCR errors and correct them.

You can edit recognized text either directly in the **Text** pane or in the **Verification** dialog box (click **Recognize > Verify Text...** to open this dialog box). In the **Verification** dialog box, you can review low-confidence words, correct spelling errors, and add new words to the user dictionary.

ABBYY FineReader also allows you to change the formatting of output documents.

To change the formatting of recognized texts, use the buttons on the main toolbar of the **Text** pane and the buttons in the **Text Properties** pane (right-click anywhere in the **Text** pane and then click **Properties** on the shortcut menu to display this pane).

When recognizing a text, ABBYY FineReader identifies the styles used in the text. All the identified styles are displayed in the **Text Properties** pane. You can edit the styles to change the formatting of the entire text. When saving recognized texts in DOCX, ODT or RTF, all the existing styles can be preserved.

**See also:**

- *Checking recognized text* [224]
- *Using styles* [227]
- *Editing hyperlinks* [228]
- *Editing tables* [229]
- *Removing confidential information* [230]
- *Saving editable documents* [234]
Checking recognized text

You can edit recognized text either directly in the Text pane or in the Verification dialog box (click Recognize > Verify Text... to open this dialog box). In the Verification dialog box, you can review low-confidence words, correct spelling errors, and add new words to the user dictionary.

Checking texts in the Text pane

You can check, edit, and format OCR results in the Text pane.

The toolbar of the Text pane contains buttons that let you check the spelling in recognized texts. Use the buttons to go to the next/previous low-confidence word or character. If the low-confidence characters are not highlighted, click the button on the toolbar at the top of the Text window.

To verify a low-confidence word in the Text pane:

1. Click the word in the Text pane. The image area with this word will be highlighted in the Image pane. At the same time, the Zoom pane will display a magnified image of the word.

2. Correct the word in the Text window, if necessary.

Tip. You can insert symbols that are not on available on your keyboard by clicking the button. Alternatively, use the Verification dialog box.

This method is convenient when you need to compare the source and output documents.

The text formatting tools can be found:

- on the toolbar at the top of the Text pane
- in the Text Properties pane (right-click anywhere in the Text pane and then click Properties on the shortcut menu to display this pane)

Use the buttons to move around the Text Properties pane if the Text window is too narrow and you cannot see the entire pane.

To learn how you can change the appearance of the main window and the tools available on its toolbars, see OCR Editor Window and Toolbars.

Checking the recognized text in the Verification dialog box
ABBYY FineReader offers a **Verification** dialog box, where you can check and correct words that contain low-confidence characters. To open the **Verification** dialog box, click 🔄 Verify on the main toolbar or click Recognize > Verify Text....

In the **Verification** dialog box, you can:

- Skip a highlighted word without making any changes. When you click **Skip**, the highlighting is removed. Replace the highlighted word with one of the suggested variants.

- Simply select the correct suggestion in the box to the right and click **Replace**.

- Add the highlighted word to the dictionary by clicking the **Add to Dictionary** button. Next time the program encounters this word, it will no longer treat it as an error.
  
  See also: Working with user dictionaries

- Change the font and apply font effects.

- Insert non-keyboard characters into the text. Click the 📒 and select **More Symbols**.... In the dialog box that opens, from the **Subset** drop-down list, select the subset that contains the symbol that you need (e.g. Basic Greek or Currency Symbols). Next, double-click the character that you wish to insert. Alternatively, you can specify the Unicode code point of the character in the **Character code** field.

  **Tip.** To change the checking options, click **Options**....

When checking texts written in Chinese, Japanese or Korean, the program will suggest similar-looking characters for characters recognized with low confidence.
Working with user dictionaries

When recognizing a text, ABBYY FineReader checks recognized words against its dictionaries. If your text contains too many specialized terms, abbreviations or proper names, you can improve OCR quality by adding them to a user dictionary.

- User dictionaries may not be available for some of the supported languages.

To add a word to the user dictionary, do one of the following:

- In the Verification dialog box (click Recognize > Verify Text... to open this dialog box), click the Add to Dictionary button, or

- In the Text window, right-click the word you wish to add and then click Add to Dictionary on the shortcut menu

- When adding a word to a user dictionary, make sure that the right language is selected.
Using styles

When recognizing a text, ABBYY FineReader detects the styles and formatting used in the original document. These styles and formatting are reproduced in the output document. You can review and edit the document styles and create new styles in the Text pane.

To apply a style to a text fragment:

1. Select the desired text fragment in the Text pane.
2. Right-click the selected fragment and click Properties on the shortcut menu.
3. Select the desired style in the Text Properties pane.

When saving recognized texts in DOCX, ODT or RTF, all the existing styles can be preserved. See also: DOC(X)/RTF/ODT format.

To create, change, and merge styles:

1. Click Tools > Style Editor....
2. In the Style Editor dialog box, select the desired style and modify its name, font, font size, character spacing, and scale.
3. To create a new style, click the New button. The newly created style will be added to the list of existing styles, where you can modify it.
4. To merge multiple styles into one, select the styles to merge and click the Merge... button. In the Merge Styles dialog box, specify the style into which to merge the selected styles.
5. Click OK to save the changes.

You can navigate between text fragments printed in identical styles. To do this, in the Style Editor dialog box, select the desired style and click Previous Fragment or Next Fragment.
Editing hyperlinks

ABBYY FineReader detects hyperlinks and recreates their destination addresses in the output document. Detected hyperlinks are underlined and displayed in blue.

When viewing the recognized document in the Text pane, rest the mouse pointer on a hyperlink to view its address. To follow a hyperlink, right-click it and click the Open Hyperlink command on its shortcut menu, or click the hyperlink while holding down the Ctrl key.

To add, delete or change the text or address of a hyperlink:

1. In the Text pane, select the text of the desired hyperlink.

2. To delete a hyperlink, right-click it and then click Remove Hyperlink on the shortcut menu.

3. To add a hyperlink or change the text of a hyperlink, right-click it and click the Hyperlink... command on its shortcut menu, or click on the main toolbar at the top of the Text pane. In the Edit Hyperlink dialog box, you can:
   - Edit the text of the link in the Text to display field.
   - Select or change the hyperlink type in the Link to group:
     - Select Web page to link to an Internet page.
       In the Address field, specify the protocol and the URL of the page (e.g. http://www.abbyy.com).
     - Select Local file to link to a file.
       Click Browse... to browse for the file that the hyperlink will point to (e.g. file://D:/MyDocuments/ABBYY FineReaderGuide.pdf).
     - Select E-mail address if you want users to be able to send an e-mail message to the address contained in the hyperlink by simply clicking it.
       In the Address field, specify the protocol and the e-mail address (e.g. mailto:office@abbyy.com).
Editing tables
You can edit recognized tables in the **Text** pane. The following commands are available:

- **Merge table cells**
  Use the mouse to select the table cells to be merged and click **Area > Merge Table Cells**.

- **Split table cells**
  Click a table cell to split and click **Area > Split Table Cells**.
  🔄 This command can only be applied to table cells that have been previously merged.

- **Merge table rows**
  Use the mouse to select the table cells to be merged and click **Area > Merge Table Rows**.

- **Delete cell contents**
  Select the cell or cells whose contents you want to delete and press the Delete key.

 création

- **Display table editing tools on the toolbar**
  By default, the table editing tools are not displayed on the toolbar. You can add the table editing tools to the toolbar in the **Customize Toolbars and Shortcuts** dialog box (click **View > Toolbars > Customize...** to open this dialog box).

- **For detailed instructions on how to add buttons to the toolbars**, see [Toolbars](#).

Removing confidential information
With ABBYY FineReader PDF, you can remove confidential information from recognized texts.

1. Click **Tools > Redaction Mode** or click the ![Redaction Mode](image) button on the main toolbar at the top of the **Text** pane.

2. In the **Text** pane, use the marker to black out the text you wish to obliterate.

**Tip.** If you black out some characters by mistake, you can undo the last redaction by pressing Ctrl+Z on the keyboard or by clicking the **Undo** button on the main toolbar.

3. Save your document.

The redacted text will appear as dots in the output document. If the saving format you selected supports text and background colors, the redacted text fragments will appear as black rectangles.

To switch off the redaction mode, either

- **Click the **Tools > Redaction Mode** once again, or**

- **Click the ![Redaction Mode](image) button on the main toolbar once again.**
Copying content from documents

ABYY FineReader allows you to copy text, pictures, and tables from documents and paste them to other applications. You can copy content from scanned pages and images without recognizing the entire document or converting it to an editable format. The selected content will be copied to the Clipboard. You can then paste it into any application that supports pasting from the Clipboard.

To copy content:

1. Use the , , , or tool in the Image pane to select the fragment of the document you want to copy.

2. Right-click the fragment and click Recognize and Copy Text on the shortcut menu or click button on the pop-up toolbar.

3. Paste the content into another application.

To save several pages:

1. Select the pages in the Pages pane.

2. Right-click the selected pages, click Save As, and select a desired format, or select Send To and select the application into which you want to insert the recognized pages.
Saving OCR results

OCR results can be saved to a file, sent to another application or to the PDF Editor, copied to the Clipboard, or e-mailed. You can also send OCR results to Kindle.com, where they will be converted to the Kindle format and become available for download onto your Kindle device. You can save either the entire document, or selected pages only.

💡 Be sure to select the appropriate saving options before clicking Save.

To save recognized text:

1. On the main toolbar, click the arrow next to the Save button and select a document saving mode and page objects to preserve.

![Save Options](image)

Available file formats are listed beneath each mode.

There are five format saving modes:

- **Exact copy** produces a document whose formatting corresponds to that of the original. Recommended for documents with complex formatting, such as promotion booklets. Note, however, that this option limits your ability to change the text and format of the output document.

- **Editable copy** produces a document whose formatting may differ slightly from that of the original. Documents produced in this mode are easy to edit.

- **Formatted text** retains the fonts, font sizes, and paragraphs, but does not retain the exact spacing or locations of the objects on the page. The text produced will be left-aligned (texts in right-to-left scripts will be right-aligned).
  - Vertical texts will be changed to horizontal in this mode.

- **Plain text** does not retain text formatting.

- **Flexible layout** produces an HTML document with the positions of the objects as close to the original as is technically possible.

2. On the Format Settings tab of the Options dialog box, select the desired saving options and click OK.

3. On the main toolbar, click the arrow to the right of the Save button and select the appropriate option, or use the commands on File menu.

✔ ABBYY FineReader allows you to save pages as images. See also: Saving images.

**Supported applications:**

- Microsoft Word 365, 2019, 2016 (16.0), 2013 (15.0)
- Microsoft Excel 365, 2019, 2016 (16.0), 2013 (15.0)
To ensure the best compatibility between ABBYY FineReader and the applications listed above, make sure you install the latest available updates for these applications.

See also:

- Saving in PDF
- Saving editable documents
- Saving tables
- Saving e-books
- Saving in HTML
- Saving an image of a page
- Sending OCR results to the PDF Editor
- E-mailing OCR results
- Sending OCR results to Kindle
Saving in PDF

ABYY FineReader allows you to save entire PDF documents or selected pages. Various saving options are available.

- To save a PDF document that will allow users to select, copy, and edit its content, click the arrow next to the Save As button on the main toolbar and select Searchable PDF Document. Alternatively, click File > Save As > Save as Searchable PDF Document....

  The document will be saved as a searchable PDF. To change the saving options, click the Options... button in the saving dialog box and select desired saving options on the PDF tab.

- To save a PDF document that will not allow users to select, copy, and edit its content, click the arrow next to the Save As button on the main toolbar and select Image-Only PDF Document. Alternatively, click File > Save As > Save as Image-Only PDF Document....

  The document will be saved as an image-only PDF. To change the saving options, click the Options... button in the saving dialog box and select desired saving options on the PDF tab.

  To save only some pages of the document, on the Pages pane, select the pages that you want to save and on the shortcut menu, click Save As > Searchable PDF Document (or Image-Only PDF Document).

  You can select additional saving options on the Format Settings > PDF tab of the Options dialog box (click Tools > Options... to open this dialog box).
Saving editable documents

ABYY FineReader allows you to save OCR results in editable formats. When choosing a format, consider how you intend to use the document.

- **Saving documents in DOC(X)/RTF/ODT**
- **Saving documents in PPTX**
- **Saving plain text (TXT)**

### DOC(X)/RTF/ODT

To save your text in DOCX/RTF/ODT:

- Click the arrow next to the **Save As** button on the main toolbar and select **Microsoft Word Document**, **RTF Document** or **ODT Document**. If the format that you need is not displayed in the list, select **Save in Other Formats...** and in the dialog that opens, select the required format. Alternatively, click **File > Save As** and select the desired saving format.

The document will be saved in the format that you specified. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **DOC(X)/RTF/ODT** tab.

☑ To save only some pages of the document, on the **Pages** pane, select the pages that you want to save and on the shortcut menu, click **Save As > Microsoft Word Document, RTF Document, ODT Document**.

💡 You can select additional saving options on the **Format Settings > DOC(X) / RTF / ODT** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box).

### PPTX

To save your text in PPTX:

- Click the arrow next to the **Save As** button on the main toolbar and select **Microsoft PowerPoint Presentation**. If the format that you need is not displayed in the list, select **Save in Other Formats...** and in the dialog that opens, select the required format. Alternatively, click **File > Save As > Microsoft PowerPoint Presentation**.

The document will be saved in the PPTX format. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **PPTX** tab.

☑ To save only some pages of the document, on the **Pages** pane, select the pages that you want to save and on the shortcut menu, click **Save As > Microsoft PowerPoint Presentation**.

💡 You can select additional saving options on the **Format Settings > PPTX** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box).
TXT

To save your text in TXT:

- Click the arrow next to the **Save As** button on the main toolbar and select **TXT Document**. If the format that you need is not displayed in the list, select **Save in Other Formats...** and in the dialog that opens, select the required format. Alternatively, click **File > Save As > TXT Document**.

The document will be saved in the TXT format. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **TXT** tab.

- To save only some pages of the document, on the **Pages** pane, select the pages that you want to save and on the shortcut menu, click **Save As > Text Document**.

💡 You can select additional saving options on the **Format Settings > TXT** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box).
Saving tables

ABBYY FineReader allows you to save tables in the XLS, XLSX, and CSV formats.

XLS and XLSX

To save your text in XLS or XLSX:

- Click the arrow next to the **Save As** button on the **main toolbar** and select **Microsoft Excel Workbook**. If the format that you need is not displayed in the list, select **Save in Other Formats...** and in the dialog that opens, select the required format. Alternatively, click **File > Save As > Microsoft Excel Workbook**.

The document will be saved in the format that you specified. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **XLS(X)** tab.

- To save only some pages of the document, on the **Pages** pane, select the pages that you want to save and on the shortcut menu, click **Save As > Microsoft Excel Workbook**.

💡 You can select additional saving options on the **Format Settings** > **XLS(X)** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box).

CSV

To save your text in CSV:

- Click the arrow next to the **Save As** button on the **main toolbar** and select **CSV Document**. If the format that you need is not displayed in the list, select **Save in Other Formats...** and in the dialog that opens, select the required format. Alternatively, click **File > Save As > CSV Document**.

The document will be saved in the CSV format. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **CSV** tab.

- To save only some pages of the document, on the **Pages** pane, select the pages that you want to save and on the shortcut menu, click **Save As > CSV Document**.

💡 You can select additional saving options on the **Format Settings** > **CSV** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box).
Saving e-books

ABBYY FineReader PDF allows you to scan paper books and convert them into the EPUB, FB2, and DjVu formats. You will be able to read the resulting e-books on tablets (including iPads), and on other mobile devices and upload them to your Kindle.com account.

✓ You can also save an e-book in the HTML format. For details, see Saving in HTML.

Saving in FB2 or EPUB

To save your text in FB2 or EPUB:

- Click the arrow next to the Save As button on the main toolbar and select FB2 Document or EPUB Document. If the format that you need is not displayed in the list, click Save in Other Formats... and select the required format. Alternatively, click File > Save As > FB2 Document (or EPUB Document).

The document will be saved in the format that you specified. To change the saving options, click the Options... button in the saving dialog box and select desired saving options on the EPUB/FB2 tab.

✓ To save only some pages of the document, on the Pages pane, select the pages that you want to save and on the shortcut menu, click Save As > Electronic Publication (EPUB) (or FictionBook (FB2)).

💡 You can select additional saving options on the Format Settings > EPUB / FB2 tab of the Options dialog box (click Tools > Options... to open this dialog box).

Saving in DjVu

To save your text in DjVu:

- Click the arrow next to the Save As button on the main toolbar and select DjVu Document. If the format that you need is not displayed in the list, select Save in Other Formats... and in the dialog that opens, select the required format. Alternatively, click File > Save As > DjVu Document.

The document will be saved in the format that you specified. To change the saving options, click the Options... button in the saving dialog box and select desired saving options on the DjVu tab.

✓ To save only some pages of the document, on the Pages pane, select the pages that you want to save and on the shortcut menu, click Save As > DjVu Document.

💡 You can select additional saving options on the Format Settings > DjVu tab of the Options dialog box (click Tools > Options... to open this dialog box).
Saving in HTML

To save your text in HTML:

- Click the arrow next to the **Save As** button on the main toolbar and select **HTML Document**. If the format that you need is not displayed in the list, select **Save in Other Formats**... and in the dialog that opens, select the required format. Alternatively, click **File > Save As > HTML Document**.

The document will be saved in the format that you specified. To change the saving options, click the **Options...** button in the saving dialog box and select desired saving options on the **HTML** tab.

☐ To save only some pages of the document, on the **Pages** pane, select the pages that you want to save and on the shortcut menu, click **Save As > HTML Document**.

💡 You can select additional saving options on the **Format Settings > HTML** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box).
Saving images

ABYY FineReader allows you to save both recognized text and page images, including scans.

To save one or more images:

1. In the Pages pane, select the pages you want to save.

2. Click File > Save As > Page Images....

3. In the dialog box that opens, select the disk and folder to save the file to.

4. Select an image format you want to save the image in.
   - If you want to save multiple pages to one file, choose the TIFF format and select Create a single file for all pages.
   - For details, see Supported document formats.

5. Specify a file name and click Save.

Tip. When saving in TIFF, you can select the image format and compression method. Image compression lets you decrease file size. Methods used for image compression differ by compression rate and data loss. Two factors define the choice of compression method: the resulting image quality and file size.

ABYY FineReader offers the following compression methods:

- **ZIP** No data loss occurs. This compression algorithm is used for images containing large sections in one color. For example, this compression algorithm is suitable for screenshots and black-and-white images.

- **JPEG** This compression algorithm is used for gray and color images such as photos. This method provides high-density compression but causes data loss and results in poorer image quality (blurred outlines and poor color palette).

- **CCITT Group 4** No data loss occurs. This compression algorithm is commonly used for black-and-white images created in graphical programs or for scanned images. CCITT Group 4 is a commonly used compression method that is suitable for virtually all images.

- **Packbits** No data loss occurs. This compression algorithm is used for black-and-white scans.

- **LZW** No data loss occurs. This compression algorithm is used for graphic design and grayscale images.

When saving to image-only PDF, the program uses the parameters you specified on the Format Settings > PDF tab of the Options dialog box (click Tools > Options... to open this dialog box).
Sending OCR results to the PDF Editor

ABYY FineReader allows you to send OCR results from the OCR Editor to the PDF Editor, where you can add notes and comments to the document and use other features offered by ABBYY FineReader for working with PDF documents.

To send OCR results to the PDF Editor:

- On the toolbar, click the arrow next to the Send button and select Send to PDF Editor...

- Click File > Send To > PDF Editor...

Once you are done working with the document in the PDF Editor, you can send it back to the OCR Editor. To do this, on the toolbar at the top of the OCR Editor window, click the arrow next to the Recognize button and from the drop-down list, select Recognize and Verify in OCR Editor. To send only some pages of the document, on the Pages pane, select the pages that you want to send, right-click them and click Send Selected Pages to OCR Editor on the shortcut menu.

When sending the document back to the OCR Editor, the following document objects will be lost:

- attachments
- bookmarks
- comments
- annotations
E-mailing OCR results

ABBYY FineReader allows you to e-mail OCR results in any of the supported formats with the exception of HTML.

To e-mail a document:

1. Click File > E-mail > Document....
2. In the dialog box that opens, select:
   - A saving format
   - One of the three saving options: save all pages to one file, save each page to a separate file, or split the document into files based on blank pages
3. Click OK. An e-mail message with an attachment will be created. Specify the recipient and send the message.

You can also e-mail the images of document pages.

To e-mail page images:

1. Click File > E-mail > Images....
2. In the dialog box that opens, select:
   - A saving format
   - Send as multi-page image file if you want to send the images as a multi-page image file.
3. Click OK. An e-mail message with an attachment (or attachments) will be created. Specify the recipient and send the message.
Sending OCR results to Kindle

ABBYY FineReader allows you to send OCR results to the Kindle.com server, where they will be converted into the Kindle format and made available for download onto your Kindle device.

💡 To use this feature, you need a Kindle account on Kindle.com.

1. Click the arrow next to the **Save As** button on the main toolbar and then click **Send to Amazon Kindle...**

2. In the dialog box that opens, specify:
   - The address of your Kindle account
   - One of the three saving options: save all pages to one file, save each page to a separate file, or split the document into files based on blank pages
   - A name for the file

3. Click **OK**.

An e-mail message with an attachment (or attachments) will be created. Send this e-mail message to Kindle.com and the converted file will soon be available for download onto your Kindle device.
Integration with other applications

FineReader PDF integrates with Windows Explorer, allowing you to initiate the processing of PDF documents, office documents, and image files by simply right-clicking them.

ABYY FineReader PDF integrates with Microsoft Office, allowing you to create PDF documents and launch conversion and comparison of documents directly from Microsoft Word, Microsoft Excel, Microsoft PowerPoint, and Microsoft Outlook.

You can also make and save changes to PDF documents stored on a Microsoft SharePoint server; create documents using the FineReader PDF mobile application and continue working with them in FineReader PDF on your computer; process PDF documents from cloud storage clients such as OneDrive, Google Drive, and Dropbox.

Chapter contents

- Integration with Windows Explorer
- Integration with Microsoft Office
- Integration with Microsoft SharePoint
- Integration with the mobile application
- Cloud storage
Integration with Windows Explorer

ABYY FineReader integrates with Windows Explorer. As a result, ABBYY FineReader commands will appear when you right-click a file in any of the supported formats, enabling you to open and edit PDF documents, perform OCR on image files, convert files, combine multiple files into one PDF, and compare files.

To open and process a PDF directly from Windows Explorer:

1. In Windows Explorer, select one or more PDF files.
2. Right-click the files(s) and select one of the following commands:

   - **Edit with ABBYY FineReader PDF** opens PDF files in the PDF Editor
     - For more information on working with PDF documents in the PDF Editor, see *Working with PDF documents*.

   - **Convert with ABBYY FineReader PDF** - converts PDF files into various formats:
     - Convert to searchable PDF document
     - Convert to image-only PDF document
     - Convert to Microsoft Word document
     - Convert to Microsoft Excel document
     - Convert to another format

   - **Open in OCR Editor** opens PDF files in the OCR Editor.
     - For more information on working with the OCR Editor, see *Working with the OCR Editor*.

   - **Compare with...** opens PDF files in the ABBYY Compare Documents application.
     - For more information about comparing documents, see *ABBYY Compare Documents*.

   - **Combine into one PDF...** combines multiple files into one PDF.

   - **Compare documents...** compares two versions of the same document.

To process files in editable formats directly from Windows Explorer:

1. In Windows Explorer, select one or more files in editable formats.
2. Right-click the files(s) and select one of the following commands:

- **Convert to PDF with ABBYY FineReader PDF...** converts files to PDF. When creating PDF documents from Microsoft Word, Microsoft Excel, and Microsoft PowerPoint files, ABBYY FineReader will preserve the structure of the original document, and any bookmarks and hyperlinks.

- **Convert to PDF and send...** converts files to PDF and attaches them to an e-mail message.

- **Compare with...** opens files in the ABBYY Compare Documents application.

- **Combine into one PDF...** combines multiple files into one PDF.

- **Compare documents...** compares two versions of the same document.

To process image files directly from Windows Explorer:

1. In Windows Explorer, select one or more image files.

2. Right-click the files(s) and select one of the following commands:

- **Convert with ABBYY FineReader PDF** converts image files into various formats
  - **Convert to searchable PDF document**
  - **Convert to image-only PDF document**
  - **Convert to Microsoft Word document**
  - **Convert to Microsoft Excel document**
  - **Convert to another format**

- **Open in OCR Editor** opens image files in the OCR Editor.

- **Combine into one PDF...** combines multiple files into one PDF.

- **Compare with...** opens image files in the ABBYY Compare Documents application.

☑️ The commands actually available to you on the Windows Explorer shortcut menu depend on the number and format of the selected files.

If you don’t see the ABBYY FineReader commands on the Windows Explorer shortcut menu...
If you can't see the ABBYY FineReader commands on the Windows Explorer shortcut menu, this means that you chose not to integrate ABBYY FineReader with Windows Explorer when installing the program.

To integrate ABBYY FineReader with Windows Explorer:

1. Click **Start** > **Settings** > **Control Panel** (or click **Start** > **Settings** > **System** > **Apps & features** in Windows 10) and then click **Programs and Features**.

2. In the list of installed applications, select **ABBYY FineReader** and click **Change/Remove**.

3. Follow the instructions of the setup program.
Integration with Microsoft Office
When you install ABBYY FineReader, it is integrated with Microsoft Office. As a result, the ABBYY FineReader PDF add-in will appear in Microsoft Word, Microsoft Excel, Microsoft PowerPoint, and Microsoft Outlook, allowing you to create PDF documents and launch conversions and comparisons of documents directly from these applications.

The tab's features vary depending on the application itself.

Integration is carried out with both Microsoft Office 365 and Microsoft Office 2019.

If the ABBYY FineReader PDF Ribbon tab is missing from your Microsoft Office toolbar...

The ABBYY FineReader PDF Ribbon tab may be missing from the application's toolbar if the corresponding add-in was not enabled in the Microsoft Office parameters. If this is the case, do the following (if you are using Microsoft Word):

- In the Word Options window (File > Options), navigate to the Add-ins tab. Next, select COM Add-ins in the Manage drop-down list and click Go... In the dialog box that will appear, select ABBYY FineReader MSWord COM Add-In and click OK.

This will make the ABBYY FineReader PDF Ribbon tab appear in your Microsoft Word toolbar.

If the ABBYY FineReader MSWord COM Add-In option is missing from the COM Add-ins dialog, Microsoft Office integration was either disabled during the installation of ABBYY FineReader or has been deleted.

To install the add-in, do the following:

1. Navigate to Programs and Features (Start > Settings > Control Panel or Start > Settings > System > Apps & features, if you are using Windows 10).

2. From the list of installed programs, select ABBYY FineReader PDF and click Change/Remove.

3. In the Custom Installation dialog, select the appropriate components.

4. After that, follow the instructions of the setup wizard.

In this section:

- Integration with Microsoft Word
- Integration with Microsoft Excel
- Integration with Microsoft PowerPoint
- Integration with Microsoft Outlook
Integration with Microsoft Word

Video: How to create a PDF from Microsoft® Word, Excel, or PowerPoint

With Microsoft Word integration, you can easily do any of the following: use a Word document to create a PDF file and send it via e-mail, create a Word document from image files or paper documents, launch a comparison of a Word document with its pervious version directly in Microsoft Word.

1. Create or open an appropriate Word document in Microsoft Word.
2. In the ABBYY FineReader PDF toolbar, click one of the following:
   - Create PDF to create and save a PDF document using the active Word document;
   - Create PDF and Send by E-mail to create and send a PDF document created using the active Word document via e-mail;
   - Scan to Word to create a Word document using a scanner or a camera;
   - Convert to Word to create a Word document using image files;
     Video: How to open a PDF or a scan in Microsoft® Word
   - Compare document with... to compare the active Word document with its previous version.
     Video: How to compare a document in Word with a scanned copy

In this section:

- Creating a PDF document using a Word document
- Creating a Word document using image files
- Comparing Word documents
Creating a PDF document using a Word document

Video: How to create a PDF from Microsoft® Word, Excel, or PowerPoint

How to use a Word document to create a PDF document

To create and save a PDF document, do the following:

1. Create or open an appropriate Word document in Microsoft Word.
2. In the ABBYY FineReader PDF toolbar, click Create PDF.
3. In the dialog box that will open:
   a. Specify a name and folder for the output PDF document.
   b. Select Open document if you need to open the output document in a PDF viewer.
   c. Click Save.

If required, click Preferences in the ABBYY FineReader PDF toolbar and specify the PDF creation settings.

This will save your current Word document as a PDF document with the specified settings.

How to use a Word document to create a PDF document and send it via e-mail

To create a PDF document and send it via e-mail, do the following:

1. Create or open an appropriate Word document in Microsoft Word.
2. In the ABBYY FineReader PDF toolbar, click Create PDF and Send by E-mail.

This will attach the PDF document to a new blank e-mail.

If required, you can specify a range for pages that will be used to create the PDF document. To do so, click Preferences in the ABBYY FineReader PDF toolbar and select Ask to specify pages in the dialog box that will appear. Enabling this option will bring up a page selection dialog every time you create a new PDF document. You can also specify other PDF creation settings.

PDF creation settings for Word documents

This dialog contains the following groups of settings:

- **Create PDF/A**
  Select this option to create a PDF/A-compatible document. Select the required PDF/A type in the drop-down list on the right.

- **Create PDF/UA**
  Select this option to create a PDF/UA-compatible document. The appearance of such a document may differ from the original document.
• **Password-protect documents**
  Select this option if you need to set passwords to protect your PDF document from unauthorized viewing, printing, and editing. Next, click **Settings**... and specify the appropriate security parameters in the dialog that will open.

• **Create PDF tags**
  Creating a PDF document automatically creates PDF tags as well. Aside from text and images, PDF files can also contain information about the structure of the document: logical structure, illustrations, and tables. This information is stored in the form of PDF tags, ensuring that the PDF document can be comfortably viewed on screens of varying size, e.g. handheld devices.

• **Create bookmarks from headings**
  Creating a PDF document will also create a table of contents based on the structure of the document.

• **Apply to pages**
  The specified pages will be used when creating a PDF document.

    - **All**
      Selecting this option will use all pages to create the PDF document.

    - **Ask to specify pages**
      A page selection dialog box will appear every time you create a new PDF document.
Creating a Word document using image files

Video: How to open a PDF or a scan in Microsoft® Word

To create a Word document using image files or paper documents, do the following:

1. Launch Microsoft Word.
2. In the ABBYY FineReader PDF toolbar, click:
   - **Scan to Word** to create a Word document using a scanner or a camera.
     This will open the ABBYY FineReader PDF scanner image conversion dialog box. In this dialog box, specify all required scanning settings and parameters and scan the appropriate images.
   - **Convert to Word** to create a Word document using image files.
     Specify the following in the dialog box that will appear:
     1. **Document languages**. For more information, see Recognition languages.
     2. **Document layout**. Select the appropriate setting depending on how you plan to use the output document.
     3. Click **Options** to open Format Settings in the DOC(X)/RTF/ODT bookmark in the Options dialog (Tools > Options...) and specify additional options.
     4. Click **OK**.

   In the dialog box that will appear, select all appropriate images and then wait for the conversion to finish.
   The output Microsoft Word document will be displayed on your screen. Make any required changes and save the document.

Comparing Word documents

Video: How to compare a document in Word with a scanned copy

To compare a Word document with its previous version, do the following:

1. Create or open an appropriate Word document in Microsoft Word.
2. In the ABBYY FineReader PDF toolbar, click **Compare document with...**
3. This will open the specified document in the ABBYY Compare Documents window. Next, select a second document to compare it with. For more information about comparing documents, see comparing documents.
Integration with Microsoft Excel

Video: [How to create a PDF from Microsoft® Word, Excel, or PowerPoint](#)

With Microsoft Excel integration, you can easily use an Excel document to create a PDF document and send it via e-mail directly from Microsoft Excel.

**How to use an Excel document to create a PDF document**

To create and save a PDF document, do the following:

1. Create or open an appropriate document in Microsoft Excel.
2. In the **ABBYY FineReader PDF** toolbar, click **Create PDF**.
3. In the dialog box that will appear, do the following:
   a. Specify a name and folder for the output PDF document.
   b. Select **Open document** if you need to open the output document in a PDF viewer.
   c. Click **Save**.

If required, click **Preferences** in the **ABBYY FineReader PDF** toolbar and specify the PDF creation settings.

This will save the PDF document in the specified folder and open it in a PDF viewer if specified.

**How to use an Excel document to create a PDF document and send it via e-mail**

To create a PDF document and send it via e-mail, do the following:

1. Create or open an appropriate document in Microsoft Excel.
2. In the **ABBYY FineReader PDF** toolbar, click **Create PDF and Send by E-mail**.

This will attach the PDF document to a new blank e-mail.

If required, you can use specific document sheets to create a PDF document. To do so, click **Preferences** in the **ABBYY FineReader PDF** toolbar and select **Ask to specify spreadsheets** in the dialog box that will appear. Enabling this option will always bring up a sheet selection dialog every time you create a new PDF document. You can also specify other PDF creation settings.

**PDF creation settings for Excel documents**

This dialog contains the following groups of settings:

- **Create PDF/A**
  Select this option to create a PDF/A-compatible document. Select the required PDF/A type in the drop-down list on the right.
• **Create PDF/UA**
  Select this option to create a PDF/UA-compatible document. The appearance of such a document may differ from the original document.

• **Password-protect documents**
  Select this option if you need to set passwords to protect your PDF document from unauthorized viewing, printing, and editing. Next, click **Settings...** and specify the appropriate security parameters in the dialog box that will appear.

• **Apply to the following spreadsheets**
  Select this option to only use the sheets you specify to create the PDF document: active sheet, all sheets, selected area. If you want the sheet selection dialog to always appear when you create a PDF document, select **Ask to specify spreadsheets**.
Integration with Microsoft PowerPoint

Video: How to create a PDF from Microsoft® Word, Excel, or PowerPoint

With Microsoft PowerPoint integration, you can easily use a Microsoft PowerPoint presentation to create a PDF document directly from PowerPoint.

How to use a PowerPoint presentation to create a PDF document

To create and save a PDF document, do the following:

1. Create or open an appropriate presentation in Microsoft PowerPoint.
2. In the ABBYY FineReader PDF toolbar, click Create PDF.
3. In the dialog box that will appear, do the following:
   a. Specify a name and folder for the output PDF document.
   b. Select Open document if you need to open the output document in a PDF viewer.
   c. Click Save.

If required, specify the numbers of the slides that will be used to create your PDF file. To do so, click Preferences in the ABBYY FineReader PDF toolbar and select Ask to specify slides in the dialog box that will appear. Enabling this option will always bring up a slide selection dialog every time you create a new PDF document. You can also specify other PDF creation settings.

This will save the output PDF document in the specified folder and open it in a PDF viewer if specified.

PDF creation settings for PowerPoint presentations

This dialog contains the following groups of settings:

- **Convert speaker notes**
  Select this option to save the author's comments.

- **Include hidden slides**
  Select this option to automatically save hidden slides when creating your PDF document.

- **Create PDF/A**
  Select this option to create a PDF/A-compatible document. Select the required PDF/A type in the drop-down list on the right.

- **Create PDF/UA**
  Select this option to create a PDF/UA-compatible document. The appearance of such a document may differ from the original document.
• **Password-protect documents**
  Select this option if you need to set passwords to protect your PDF document from unauthorized viewing, printing, and editing. Next, click **Settings...** and specify the appropriate security parameters in the dialog box that will appear.

• **Create PDF tags**
  Creating a PDF document automatically creates PDF tags as well. Aside from text and images, PDF files can also contain information about the structure of the document: logical structure, illustrations, and tables. This information is stored in the form of PDF tags, ensuring that the PDF document can be comfortably viewed on screens of varying size, e.g. handheld devices.

• **Apply to the following slides**
  The specified slides will be used when creating a PDF document.
    - **All**
      Selecting this option will use all slides to create the PDF document.
    - **Ask to specify slides**
      A page selection dialog will appear every time you create a new PDF document.
      - The **Ask to specify slides** option is available only when the **Convert speaker notes** option is deselected.
Integration with Microsoft Outlook

Video: How to save emails as PDF

With Microsoft Outlook integration, you can easily use e-mails, e-mail folders, and e-mail attachments to create a PDF document directly from Microsoft Outlook.

How to use the body of an e-mail to create a PDF document

To create a PDF document using the body of an e-mail, do the following:

1. In Microsoft Outlook, select an e-mail that will be used to create your PDF document.
2. In the ABBYY FineReader PDF toolbar, click Convert to PDF. If you want to use several e-mails to create a PDF document, select all of them at once.
3. In the dialog box that will appear, specify a name and folder for the output PDF document and select Open document, if you need to open the output document in a PDF viewer. You can also specify relevant commands in the context menu of the selected e-mail or e-mails.

If required, click Preferences in the ABBYY FineReader PDF toolbar and specify the PDF creation settings. This will save the output PDF document in the specified folder and open it in a PDF viewer if specified.

All e-mail attachments will be saved in the output PDF document as PDF attachments.

How to use an e-mail folder to create a PDF document

To create a PDF document using an e-mail folder, do the following:

1. In Microsoft Outlook, specify the e-mail folder that will be used to create the PDF document.
2. In the ABBYY FineReader PDF toolbar, click Create PDF from folder or select the appropriate command in the folder context menu.
3. Specify a name and location for the output PDF document.
4. Select Open document if you need to open the resulting document in a PDF viewer.

If required, click Preferences in the ABBYY FineReader PDF toolbar and specify the PDF creation settings. This will save the output PDF document in the specified folder and open it in a PDF viewer if specified.

All e-mail attachments will be saved in the output PDF document as PDF attachments.
How to use e-mail attachments to create a PDF document

To create a PDF document using e-mail attachments, do the following:

1. In Microsoft Outlook, select one or several e-mails, the attachments of which you want to use to create PDF documents.

2. Select Create PDF from attachments in the ABBYY FineReader PDF toolbar or in the context menu for an e-mail message.

   To create a PDF document using one or several e-mail attachments, select the appropriate attachments and select Create PDF from attachments in the context menu.

3. The ABBYY FineReader PDF image conversion window will appear. In this window, specify the appropriate conversion parameters and settings and click Convert to PDF.

4. Specify a folder where your output PDF documents will be saved.

This will save your output PDF documents to the specified folder.

PDF creation settings

This dialog contains the following groups of settings:

- **Create PDF/A**
  Select this option to create a PDF/A-compatible document. Select the required PDF/A type in the drop-down list on the right.

- **Password-protect documents**
  Select this option if you need to set passwords to protect your PDF document from unauthorized viewing, printing, and editing. Next, click Settings... and specify the appropriate security parameters in the dialog box that will appear.
Integration with Microsoft SharePoint

ABYY FineReader allows you to open, edit, and save files stored in Microsoft SharePoint document libraries.

To process a PDF document stored on a Microsoft SharePoint server:

1. Use ABBYY FineReader PDF Editor to open the PDF document stored on the Microsoft SharePoint server.

2. Check out the document to prevent other users from changing it by doing the following:
   - Click the Check Out button in the message that appears in the top part of the screen,
   - Alternatively, click File > SharePoint® > Check Out.

   - If the document has already been checked out by another user, save a copy of the document on your computer.

3. Edit the PDF document.
   - For more information on working with PDF documents in the PDF Editor, see Working with PDF documents.

4. Check in the document, so that other users can see your changes. To do this, click File > SharePoint® > Check In....
   - If you don't want to save the changes to the server, click Discard Check Out...

5. In the dialog box that opens, select Version type of the document if version control is enabled on the server and enter your comment.
   - Select the Keep the document checked out after checking in the current version option if you want to upload all of your changes to the server without checking in the document.

6. Click Check In.

Note. If you are using OneDrive cloud storage, you will not be able to check out documents stored there. OneDrive Client creates copies of files locally on your computer and synchronizes them with the server. In this case, PDF documents will be treated as regular files.

Integration with the mobile application

Video: How to send scans from FineReader PDF for iOS to FineReader PDF for Windows

Video: How to send scans from FineReader PDF for Android to FineReader PDF for Windows

ABYY FineReader integrates with the FineReader PDF mobile application, allowing you to create documents on your smartphone and continue working with them on your computer.
To create documents on your smartphone and send them to your computer for further editing, you will need to install and set up the FineReader PDF mobile application on your smartphone (iOS or Android), as well as a Google Drive cloud storage client:

1. Install the FineReader PDF mobile application for iOS or Android (available in App Store and Google Play).
   ☑️ For more information about the scanning and text recognition features of the FineReader PDF mobile application, see the ABBYY website.

2. Install and set up a Google Drive cloud storage client on your computer.
   ☑️ Download Google Drive for Windows from the Google website.
   ☑️ For more information about setting up a cloud storage client, see Cloud storage.

Once the environment has been set up, do the following:

   on your smartphone

1. Open the mobile application and create a document.

2. Send the document to your computer using export to Google Drive (FineReader).
   🤔 This step requires you to be authenticated in Google Drive.
3. Select an appropriate format and size for the document being exported. 
   You can send your document either as a JPG file or as a PDF file.

   on your computer

4. Use ABBYY FineReader to open the appropriate document from the local FineReader folder created on your PC by the Google Drive storage client. To do so:

   a. On the home screen, click Select folder in the Mobile application tab.
b. Select the FineReader folder in your local Google Drive cloud storage.

If there is no FineReader folder in your local Google Drive storage, open the document in your mobile application and send it to your PC using export to Google Drive (FineReader).

Once this is done, all files and folders that you have created using your mobile application will be displayed in the FineReader PDF application screen. The documents and folders will be sorted by creation date, with the document or folder created most recently displayed at the top of the list.

c. From the list of mobile application documents and folders that will appear, select the appropriate document or folder.
Selecting a PDF file will open the document in the ABBYY FineReader PDF editor for viewing and editing;

Selecting a folder containing document images will open a dialog for creating a PDF document from JPG files.

For more information about converting images to a PDF file, see Creating PDF documents.

If files of other supported formats are selected, FineReader PDF creates a PDF document and opens it in the PDF editor for viewing and editing.

Creating a PDF file from files of other formats is not available in some versions of FineReader PDF.

5. Make your changes and save the document.

Once you have saved your document, its local copy will be synchronized with the server.

If required, you can set up FineReader to work with a different cloud storage (e.g. OneDrive or Dropbox). To do so, install the appropriate cloud storage client and select the folder that the client has created on your PC. For more information about setting up a cloud storage client, see Cloud storage.
Cloud storage

ABBYY FineReader is able to process PDF documents stored on the following cloud storage services: OneDrive, Google Drive, and Dropbox. The cloud storage client creates copies of files locally on your computer and synchronizes them with the server. As such, you can work with cloud PDF documents like you would with regular documents.

To process a cloud PDF document, do the following:

1. Install and set up the appropriate cloud storage client:
   - Microsoft OneDrive; For more information about using the OneDrive client, see the official Microsoft website.
   - Google Drive; For more information about using the Google Drive client, see the official Google website.
   - Dropbox. For more information about using the Dropbox client, see the official Dropbox website.

   After you have set up your client, a folder should appear in Windows Explorer containing all files that have been uploaded to your cloud storage.

2. In ABBYY FineReader, open the appropriate PDF document from this new folder, edit, and save it. For more information, see PDF Editor.

The following is an example of how you can work with a PDF document hosted on the OneDrive cloud storage service.

After you have installed and set up your OneDrive client, you should be able to see the following folder on your computer's hard drive:

The icon will appear in the notification area, and your files will begin to be synchronized with the server.
Such files will be marked with the icon. They do not take up space on your hard drive and will be downloaded while you are working with ABBYY FineReader.

1. In ABBYY FineReader, open a document from the folder.
   - Once you open a file, it will be downloaded to your computer and will be marked with the icon.

2. Make your changes to the document and save it.
   - Next, the local copy of the file will be synchronized with the copy hosted on the server. The file will then be marked with the icon.

3. Once the file has been uploaded to OneDrive, it is once again marked with the icon.
   - To mark the most important files and always have access to them, select Always keep on this device from the drop-down menu for that file. This will mark the files with the icon and will make them available even when you are offline.

💡 Note that the actual process of using any cloud storage service may differ from the one described above.

**Automating and scheduling OCR**

- **Automating document processing with ABBYY FineReader**
  Processing multiple documents often involves repeating the same actions multiple times. ABBYY FineReader includes built-in automated tasks. If you need more flexibility, you can create custom automated tasks from a wide range of available processing steps.

- **Scheduled processing**
  ABBYY FineReader includes ABBYY Hot Folder, a scheduling agent that lets you process documents when your computer is not in use, e.g. overnight. Scheduled tasks can be created for specific folders. You can specify all the necessary image opening, OCR, and saving options for a task.
Automating document processing with ABBYY FineReader

(Not available in some versions of ABBYY FineReader. See also: http://www.ABBYY.com/FineReader)

In ABBYY FineReader, you can use built-in and custom automated tasks to process your documents. You can organize your tasks in the Automated Tasks dialog box.

- To open the Automated Tasks dialog box, click Tools > Automated Tasks.

The toolbar at the top of the Automated Tasks dialog box contains buttons for creating, modifying, copying, deleting, importing, and exporting tasks.

To process a document using an automated task, start the task in Tasks window.

Creating Custom Automated Tasks

You can create your own automated tasks if you need to include processing steps that are not available in the built-in automated tasks. The order of steps in an automated task must correspond to the order of processing operations in the OCR Editor.

1. On the toolbar, click New.

2. In the left-hand pane, choose an OCR project to be used:

   - Create new OCR project
     If you choose this option, a new OCR project will be created when you start the task. You will also need to specify which document options to use when processing your documents: the global options specified in the program or the options specified in this particular task.
3. Choose how you will obtain images:

- **Select existing OCR project**
  Select this option if you want the task to process images from an existing OCR project.

- **Use current OCR project**
  Select this option if you want the task to process images from the current OCR project.

4. Add the **Analyze** step to detect areas on the images and configure this step:

- **Analyze the layout automatically**
  ABBYY FineReader will analyze the images and identify the areas based on their content.

- **Draw areas manually**
  ABBYY FineReader will ask you to draw the appropriate areas manually.

- **Use an area template**
  Select this option if you want an existing area template to be used when the program analyzes the document. You will need to either specify a template or choose to have the program prompt you to select one every time the task starts. For details, see *If you are processing a large number of documents with identical layouts*.

5. Add an **OCR** step if you need the images to be recognized. The program will use the OCR options you selected in the **OCR project** step.

   When you add an **OCR**, step the **Analyze** step is added automatically.

6. Add an **OCR** step to save the recognized text in a format of your choice, e-mail the text or images, or create a copy of the OCR project. A task may include multiple saving steps:
• **Save document**  
Here you can specify the name of the file, its format, file options and the folder where the file should be saved.  
☑ To avoid specifying a new folder each time the task is started, select **Create a time-stamped subfolder**.

• **Send document**  
Here you can select the application in which to open the resulting document.

• **E-mail document**  
Here you can specify the name of the file, its format, file options, and the e-mail address to which the file should be sent.

• **Save images**  
Here you can specify the name of the file, its format, file options, and the folder where the image file should be saved.  
☑ To save all images to one file, select **Save as one multi-page image file** (applicable only to images in TIFF, PDF, JB2, JBIG2, and DCX).

• **E-mail images**  
Here you can specify the name of the file, its format, file options, and the e-mail address to which the image file should be sent.

• **Save OCR project**  
Here you can specify the folder to which the OCR project should be saved.  
Specify which options the program should use to save the results. You can choose between the global options specified in the program at the time of saving or the options which you specified for this particular task.

7. Remove any unnecessary steps from the task by clicking the ❌ button.  
☑ Sometimes, removing one step will also cause another step to be removed. For instance, if you remove the **Analyze** step, the **OCR** step will also be removed, as OCR cannot be carried out without analyzing an image.

8. Once you have configured all the required steps, click **Finish**.

The newly created task will appear in the **Tasks** window.

☑ To save an automated task, click **Export** on the toolbar at the top of the **Automated Tasks** dialog box and specify a name and folder for the task.

☑ To load a previously created automated task, click **Import** on the toolbar at the top of the **Automated Tasks** and select the file of the task that you want to import.
ABBYY Hot Folder

(Not available in some versions of ABBYY FineReader. See also: http://www.ABBYY.com/FineReader)

ABBYY FineReader includes ABBYY Hot Folder, a scheduling agent that allows you to select a folder with images that ABBYY FineReader should process automatically. You can schedule ABBYY FineReader to process documents when you don’t use your computer, e.g. overnight.

To process images in a folder automatically, create a processing task for that folder and specify the image opening, OCR, and saving options. You must also specify how often ABBYY FineReader should check the folder for new images (at regular intervals or only once) and set the start time for the task.

💡 For tasks to start, your computer must be turned on and you must be logged on.

Installing ABBYY Hot Folder

By default, ABBYY Hot Folder is installed on your computer together with ABBYY FineReader PDF. If, during custom installation of ABBYY FineReader PDF, you chose not to install the ABBYY Hot Folder component, you can install the it later by following the instructions below.

To install ABBYY Hot Folder:

1. Click the Start button on Control Panel and then click Control Panel.
2. Click Programs and Features.
   - If you use Windows 10, click Start > Settings > System > Apps & features.
3. Select ABBYY FineReader PDF from the list of installed programs and click Change.
4. In the Custom Setup dialog box, select the ABBYY Hot Folder item.
5. Follow the instruction in the installation wizard.

Launching ABBYY Hot Folder

To launch ABBYY Hot Folder:

- Click Start > ABBYY FineReader PDF and then click ABBYY Hot Folder (Start > All Programs > ABBYY FineReader PDF > ABBYY Hot Folder, if you use Windows 10), or
- click in ABBYY FineReader PDF and then click Hot Folder, or
- click the icon on the Windows taskbar (this icon will appear after you have set up at least one task).

When you launch ABBYY Hot Folder, its main window opens.
Use the toolbar buttons at the top of the window to set up, copy, and delete tasks, to initiate processing, and to view reports.

The set-up tasks are displayed in the ABBYY Hot Folder main window. For each task, the complete path to its folder, its status, and the time of the next processing session are displayed.

A task may have one of the following statuses:

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>❗️ Running...</td>
<td>The images in the folder are being processed.</td>
</tr>
<tr>
<td>❗️ Scheduled</td>
<td>You chose to check the hot folder for images only once at start time. The start time is indicated in the <strong>Next Start Time</strong> column.</td>
</tr>
<tr>
<td>❗️ Watching...</td>
<td>You chose to check the hot folder for images repeatedly. The start time is indicated in the <strong>Next Start Time</strong> column.</td>
</tr>
<tr>
<td>❌ Stopped</td>
<td>The processing has been paused by the user.</td>
</tr>
<tr>
<td>✔️ Completed</td>
<td>The processing is completed.</td>
</tr>
<tr>
<td>🔴 Error (see log)</td>
<td>An error occurred when processing images in this folder. The full text of the error can be found in the task log. To find out the cause of the error, select the failed folder and click the <strong>View Log</strong> button on the toolbar.</td>
</tr>
</tbody>
</table>

You can save any task for future use:

1. Click ➕ Export...

2. In the dialog box that opens, specify the name of the task and the folder where it should be stored.
3. Click **Save**.

To load a previously saved task:

1. Click $\rightarrow$ $\downarrow$ $\rightarrow$ **Import...**

2. In the dialog box that opens, select a task and click **Open**.

**To create a new task:**

1. On the ABBYY Hot Folder toolbar, click the **New** button.

2. In the **Task name** field, type a name for the task.

3. Specify a schedule for the task:
   - **Run once** (the task will be run once at the time you specify)
   - **Recurring** (the task will be run every minute, once a day, once week or once a month at the specified time).

4. Specify the folder or OCR project that contains the images to be processed.
   - **File from folder** allows you to process images in local and network folders.
   - **File from FTP** allows you to process images in folders on an FTP server. If login and password are required in order to access the FTP folder, enter them in the **User name** and **Password** fields respectively. If no login and password are required, select the **Anonymous user** option.
   - **File from Outlook** allows you to process images in your mail box.
   - **OCR project** opens images stored in an OCR project.
     
     - For more about document colors, see [Document features to consider prior to OCR](#)

     Under **Original files** specify whether original files should be kept, deleted or moved.

5. In the **Analyze and recognize images** step, configure the document analysis and OCR options.
   - From the **Document language** drop-down list, select the language of the texts to be recognized.
     - You can select more than one OCR language.
   - Under **Document processing settings**, specify whether a document should be recognized or analyzed or whether its page images should be preprocessed. If required, specify additional OCR and image preprocessing options by clicking **Recognition Options...** or **Preprocessing Options...** respectively.
Specify whether the program should detect areas automatically or use an area template for the purpose.

To automatically delete blank pages from documents, select the **Automatically delete blank pages** option in the **Deleting blank pages** group.

💡 You can use the **Move deleted blank pages to the following folder** option to save the images of all deleted blank pages to the specified folder.

6. From the **Save results** drop-down list, select how documents should be saved.

   a. From the **Save as** drop-down list, select a destination format.

   **Tip.** Click **Options...** if you want to specify additional saving options.

   ✔ When saving to PDF, specify whether the text on the images should be recognized or whether the images should be converted to image-only PDF documents.

   b. In the **Folder** field, specify a folder where documents should be saved after processing.

   c. From the **Output** drop-down list, select a saving method:

      - **Create a separate document for each file (retains folder hierarchy)** creates a separate document for each file.

      - **Create a separate document for each folder (retains folder hierarchy)** creates one document for all files stored in a particular folder.

      - **Create one document for all files** creates one document for all files.

   d. In the **File name** field, enter a name to be assigned to documents after processing.

   **Tip.** You can specify several saving steps for a folder in order to save processing results in multiple formats.

7. Click **Create Task**.

   The configured task will be displayed in the ABBYY Hot Folder main window.

   ✔ Task files are stored in `%Userprofile%\AppData\Local\ABBYY\FineReader\16\HotFolder`.

   🎉 For tasks to start, your computer must be turned on and you must be logged on.

   To see a notification message each time a task has been completed, click ⚡.

   A notification message will be displayed in a pop-up window above the Windows taskbar.

### Changing task properties

You can change the properties of an existing task.
1. Stop the task whose properties you wish to change.

2. Click Modify on the toolbar at the top of the ABBYY Hot Folder window.

3. Make the necessary changes and click Create Task.

**Processing log**

Images in a hot folder are processed according to your defined settings. ABBYY Hot Folder keeps a detailed log of all the operations.

The log file contains the following information:

- The name of the task and its settings
- Errors and warnings (if any)
- Statistics (number of processed pages, number of errors and warnings, number of uncertain characters)

To enable logging, click on the toolbar.

The log will be saved as a TXT file in the same folder that contains the files with recognized text.

To view a log:

1. In the ABBYY Hot Folder main window, select the task you wish to inspect.
2. Click the Log button on the toolbar at the top of the ABBYY Hot Folder window.
ABBYY Compare Documents

ABBYY Compare Documents is a universal software solution that allows you to compare two different versions of the same document in different formats.

ABBYY Compare Documents lets you detect significant inconsistencies in the text and helps prevent the approval or publication of the wrong version of a document.

Main features

- Compare documents that are in different formats. You can compare a Microsoft Word document with its PDF version, a scan with its ODT version, and any other combination of formats that are supported by ABBYY FineReader PDF.

- Examine the differences in a handy side-by-side view. Clicking a difference in the results pane will immediately highlight the corresponding fragment in both versions.

- View only substantial changes such as deleted, added or edited text. Minor differences in formatting, fonts, spaces, and tabs will be ignored.

- Save documents as Microsoft Word files where the differences will be shown using the Track Changes feature.
  **Note:** a saved document is a recognized version of the original document, meaning that there can be visual differences and recognition errors. Hence, a document of this type should only be used for viewing the differences.

- Save documents as PDF files, with each difference marked with a comment.

- Save comparison results as a Microsoft Word table containing the differences.

Chapter contents

- Launching ABBYY Compare Documents[274]

- Comparing documents[275]

- The main window[277]

- Improving comparison results[278]

- Viewing comparison results[280]

- Saving comparison results[282]
Launching ABBYY Compare Documents

There are many ways to launch ABBYY Compare Documents:

- Open the **New Task** window, click the **Compare** tab and then click the **Open ABBYY Compare Documents** task.

- In the **New Task** window, click **Tools > Compare Documents** (similarly, ABBYY Compare Documents can be launched from the **PDF Editor** and the **OCR Editor**).

- Click **Start > ABBYY FineReader PDF > ABBYY Compare Documents**. (In Windows 10, click **Start** and then click **All Programs > ABBYY FineReader PDF > ABBYY Compare Documents**.)

There are several other ways to open a document in ABBYY Compare Documents:

- In the PDF Editor, click **File > Compare Documents**.
  The document that is open in the PDF Editor will be opened in ABBYY Compare Documents. You will then need to open another version of this document to compare the two.

- In **Windows Explorer**, right-click a file and click **Compare with...** on the shortcut menu.

- In Windows Explorer, select two files, right-click one of them, and click **Compare documents...** on the shortcut menu.

💡 ABBYY Compare Documents is not available in some versions of ABBYY FineReader. See also: [http://www.ABBYY.com/FineReader](http://www.ABBYY.com/FineReader)
Comparing documents

Video: How to Track Changes in PDF vs. Microsoft Word Document

To compare two versions of a document, complete these steps:

1. Launch ABBYY Compare Documents.

See also: Launching ABBYY Compare Documents

2. Open the documents in ABBYY Compare Documents. The documents have to be in one of the supported formats.

To open a document, do one of the following:

- Drag and drop a document onto one of the two of the display areas.
- Click anywhere on a display area and browse to the file location.
- Click the button on the toolbar of a display area and browse to the desired document.
- Click one of the display areas and then click on the File > Open Document....
  ✓ You can switch between the display areas by pressing Ctrl+Tab or Alt+1/Alt+2.
- ABBYY Compare Documents remembers recently compared pairs of documents. To open one of the recently compared documents, select it from the drop-down list at the top of a display area.
- To open a recently compared pair of documents, click File > Recent Comparisons and select a pair of documents from the list.
  ✓ You can also open a pair of recently compared documents from the New Task window: click the Compare tab and then select a pair of documents under Recent Comparisons.

3. Select the language of the documents from the list on the Compare tab.
4. Click the **Compare** button on the **COMPARE** tab of the rightmost pane or click the **Compare Documents** command on the **Compare** menu. A window will be displayed, showing a progress bar, comparison tips, and warnings.

   ![](ABBYY Compare Documents)

   Comparing documents. Please wait...
   Processing document 1

   ![Cancel button]

   After the documents have been compared, a list of differences will appear in the **Differences** tab. All differences will be highlighted in both documents.

   You can **Save the Comparison Results**:

   - As a Microsoft Word file where the differences will be shown using the Track Changes feature.
     
     **Note**: a saved document is a recognized version of the original document, meaning that there can be visual differences and recognition errors. Hence, a document of this type should only be used for viewing the differences.
   - As a PDF document with comments.
   - As a Microsoft Word table containing the differences.

   To save the comparison results, click the **Save...** button in the **Differences** tab. By default, the differences will be saved in the last selected file format. If you want to save the differences in a different format, choose the appropriate format in the drop-down list next to the **Save...** button.

   ![Save button]

   See also:  
   - Viewing comparison results
   - Saving comparison results
The main window

When you launch ABBYY Compare Documents, its main window opens.

Display Area 1 shows the first document.

Display Area 2 shows the second document.

Tip. You can change the way the documents are displayed:

- Zoom in by pressing Ctrl+ =, zoom out by pressing Ctrl+-, or reset the zoom level by pressing Ctrl+0. You can also do this using the commands on the shortcut menu of the document and the buttons above the document.

- Change the way the display areas are shown by clicking View > Split Document Pane Horizontally. This will split the display pane horizontally, i.e. one document will be displayed above the other.

- The Compare tab of the rightmost pane contains comparison settings.

- The Differences tab of the rightmost pane contains a list of differences between the documents (the list only appears after you compare the documents).

For more about the types of differences that can be detected and how to navigate them, see Viewing comparison results.
Improving comparison results

ABYY Compare Documents offers a number of additional options to achieve more accurate document comparison. To configure these options, do one of the following:

- Click the **Compare** tab in the rightmost pane.
- Click **Compare > Advanced**.

**Compare tab**
This tab contains the following settings:

- **Find differences in punctuation**
  Select this option to detect differences in punctuation and hyphenation.

- **Find one-letter differences**
  Select this option to detect differences in spelling.

**Advanced options**

The following advanced options are available:

- **PDF recognition mode**
  Selecting the right recognition mode is crucial for accurate comparison of PDF documents. ABBYY Compare Documents offers three PDF recognition modes:

  o **Use Only Text from PDF**
    This is the default mode for PDF documents with a text layer. ABBYY Compare Documents will use the text layer for comparison.

  o **Automatically Choose between OCR and Text from PDF**
    When this mode is selected, ABBYY Compare Documents will check the quality of the original text layer. If the program determines the original text layer is good enough, it will use the original text layer. Otherwise, it will recognize the document and use the resulting text layer instead.

  o **Use OCR**
    In this mode, the program uses optical character recognition to extract text from documents.
    The documents will take longer to compare in this mode, but the comparison results will be more reliable.
    These options are intended for PDF documents that contain a text layer and pictures. Such PDF documents are typically created by converting editable document files to PDF. Other kinds of PDF documents, such as searchable or image-only PDF documents, do not require any additional OCR options and are always processed in the **Use OCR** mode.

- **Find Headers and Footers Automatically**
  Disable this option if the document has no headers or footers.

- **Reset Advanced Options**
  Select this command to revert to the default settings.
Viewing comparison results

The differences that the program has detected are highlighted in the two texts and are also listed separately in the pane on the right.

ABBYY Compare Documents can find the following types of differences:

- Text deleted
- Text added
- Text edited

Each item in the list of differences contains a deleted, inserted or edited text fragment and the numbers of the pages where this text occurs in each document. To copy a difference to the Clipboard, right-click it and click Copy Difference on the shortcut menu or select it and click Edit > Copy Difference.

If a text fragment has been edited, both the old and the new versions of the fragment will be listed in the rightmost pane.

The number of detected differences is displayed in two locations:

- On the red bar that appears at the top of the display area after you compare the documents:

  Differences found in body text: 7. Total: 9.

- Next to the title of the Differences tab of the rightmost pane:

  Differences (58)

When you select a difference on the Differences tab, the differing text will be displayed in both documents side-by-side.
To navigate the differences, do one of the following:

- Click a difference in one of the two documents.
- Use the following keyboard shortcuts: Ctrl+Right Arrow/Ctrl+Left Arrow.
- Use the \( \downarrow \) and \( \uparrow \) buttons on the Differences tab.
- Click Compare and then click Next Difference or Previous Difference.

You can also scroll the two versions simultaneously to see the changes in a side-by-side view. Simultaneous scrolling is enabled by default. To disable it, click Fit to Width on the View and clear the Synchronize Scrolling item, or right-click a document and disable the Synchronize Scrolling option on the shortcut menu, or click the \( \leftrightarrow \) button above one of the documents.

**Grouping differences**

ABBYY Compare Documents groups detected differences so that you can ignore minor changes and focus on substantial discrepancies.

Detected differences may be placed in one of three groups:

- **Body text**
  This group contains the substantial differences found in the body text of the two documents.

- **Headers and footers**
  This group contains the differences in the headers and footers of the two documents (e.g. differences in page numbers).

- **Numbering**
  This group contains the differences in the numbers contained in the two documents, e.g. differences in the numbering of lists.

To disable the grouping of differences, click the \( \text{} \) button on the Differences tab of the rightmost pane.

To remove a difference from the list, do one of the following:

- Click the \( \text{} \) button on the Differences tab.
- Right-click the difference and click Ignore Difference on the shortcut menu.

To remove several differences at a time, select them while holding down the Ctrl key.

To ignore all identical differences, choose the Ignore Identical Differences command in the shortcut menu.
Any differences that you have removed from the list will not be shown in the comparison report.

**Saving comparison results**

Video: [How to Track Changes in PDF vs. Microsoft Word Document](#)

You can save:

1. One of the documents as a Microsoft Word file where the differences will be shown using the Track Changes feature.
   To do this, click the **Save...** button in the **Differences** tab and choose the **DOCX in Track Changes Mode** for **Document 1** / **Document 2**.

   ![Compare and Differences](#)

   **Note:** a saved document is a recognized version of the original document, meaning that there can be visual differences and recognition errors. Hence, a document of this type should only be used for viewing the differences.

2. One of the documents as a PDF file with the detected differences as comments.
   To do this, click the **Save...** button in the **Differences** tab and choose the **PDF with Comments** for **Document 1** / **Document 2**.

3. The difference list as a Microsoft Word table.
   To do this, click the **Save...** button in the **Differences** tab and choose **Comparison Report**.
**ABBYY Screenshot Reader**

ABBYY Screenshot Reader is an easy-to-use application for creating screenshots and capturing text from the screen.

**ABBYY Screenshot Reader features:**

- Create screenshots
- Turn screenshots into editable text
- All the benefits of ABBYY OCR technology

ABBYY Screenshot Reader has a straightforward and intuitive interface, which means that you do not need any specialist knowledge to be able to make screenshots and recognize text in them. Simply open any window of any application and select the section of the computer screen which you wish to "photograph." You can then recognize the screenshot and save the image and the recognized text.

ABBYY Screenshot Reader is available to registered users of certain ABBYY products. For details on how to register your copy of ABBYY FineReader PDF, see [Registering ABBYY FineReader](#).

- Installing and starting ABBYY Screenshot Reader
- Making screenshots and recognizing text
- Additional options
- Tips

**Installing and starting ABBYY Screenshot Reader**

By default, ABBYY Screenshot Reader is installed on your computer together with ABBYY FineReader PDF.

To start ABBYY Screenshot Reader, click the ABBYY Screenshot Reader icon on the taskbar.

There are several other ways to start ABBYY Screenshot Reader:

- Open the **New Task** window of ABBYY FineReader PDF and click **Screenshot Reader** on the **Tools** menu.

- Open the PDF Editor and click **Screenshot Reader** on the **Tools** menu.

- Open the OCR Editor and click **Screenshot Reader** on the **Tools** menu.

- In Microsoft Windows, click the **Start** button and then click **ABBYY FineReader PDF** > **ABBYY Screenshot Reader** on the **Start** menu. If you are using Windows 10, click the button and then click **All Programs** > **ABBYY FineReader PDF** > **ABBYY Screenshot Reader** on the **Start** menu.
Making screenshots and recognizing text

ABYY Screenshot Reader can create screenshots of selected areas on the screen of your computer and save them to a file, copy them to the Clipboard, or send them to the OCR Editor.

When you launch ABBYY Screenshot Reader, the ABBYY Screenshot Reader window appears on the screen of your computer.

The ABBYY Screenshot Reader window contains tools for recognizing text and tables on the screen of your computer, for creating screenshots of selected screen areas, and for setting up the application.

To make a screenshot or to recognize a text fragment:

1. Select a screen capture method from the Capture drop-down list.
   - **Area**: Lets you select an area to capture.
   - **Window**: Captures a specific part of the screen (e.g. a window, a part of a window, or a toolbar).
   - **Screen**: Captures the entire screen.
   - **Timed Screen**: Captures the entire screen after a 5-second delay.

2. Select the language of the text you want to recognize from the Language drop-down list.

3. In the Send drop-down list, select the application to which you want to send the image or recognized text.
   The text and screenshots will be:
   - Copied to the clipboard (when you select **Text to Clipboard**, **Table to Clipboard**, or **Image to Clipboard** from the Send drop-down list).
   - Placed in a new document (when you select **Text to Microsoft Word** [1] or **Table to Microsoft Excel** [2] from the Send drop-down list).
- Saved as a file (when you select Text to File, Table to File or Image to File from the Send drop-down list). The Save As dialog box will open and you will need to specify the name and format of the file.

- Opened in the OCR Editor of ABBYY FineReader PDF (when you select Image to OCR Editor [3] from the Send drop-down list). Select this item if the screen area contains both text and pictures.

- Attached to a newly created e-mail message as a *.bmp file (when you select Image to E-mail from the Send drop-down list).

💡 This item requires:

[1] Microsoft Word
[3] ABBYY FineReader PDF

4. Click the button.

Depending on the item you select in the Screenshot list, the screenshot will be created automatically or a capture tool will appear enabling you to select the desired area:

- If you selected Area from the Capture drop-down list, an area of the screen will be selected.

- To adjust the borders of an area, place the mouse pointer on a border and drag it while holding down the left mouse button. To move an area, select the area and drag it to the desired location. When you have selected the desired area, click the Capture button.

- If you selected Window from the Capture drop-down list, place the mouse pointer over the desired area and when a color frame appears, click the left mouse button.

- If you selected Screen or Timed Screen from the Capture drop-down list, the screenshot will be created without any further input.

Notes.

1. To cancel screen capture, press the Esc key or click the right mouse button.

2. To cancel recognition, click the Stop button or press the Esc key.

Additional options

To select additional options, right-click on the ABBYY Screenshot Reader icon on the taskbar and then click Options. The following options are available:
• **Always on Top**
  Keeps the ABBYY Screenshot Reader toolbar on top of all the other windows when switching between applications.

• **Run at Startup**
  Launches ABBYY Screenshot Reader each time you start your computer.

• **Enable Sounds**
  Plays a sound notification when ABBYY Screenshot Reader copies a screen area to the Clipboard.

**Tips**

1. Working with texts written in several languages
   
   Select a text fragment written entirely in one language. Before starting the recognition process, make sure that the language you selected from the Language drop-down list is the same as the language of the text fragment. Select the correct language if it isn't.

2. If the required language is not in the list, select More languages... from the Language drop-down list and select the desired language in the dialog box that opens.

   If you cannot find the required language in the list of available languages:

   - ABBYY Screenshot Reader does not support this language. For a full list of supported languages, please see [http://www.abbyy.com](http://www.abbyy.com). The list of supported languages may vary in different editions of the application.

   - This language may have been disabled during custom installation. To install OCR languages:

     a. Open the Control Panel by clicking the **Start > Control Panel**.

     b. In the **Control Panel** window, click the **Add or Remove Programs** item.

        ☑ If you are using Windows 10, click the **Settings > System > Apps & features**.

     c. Select **ABBYY FineReader PDF** from the list of installed software and click the **Change** button.

     d. Select desired languages in the **Custom Setup** dialog box.

     e. Follow the on-screen instructions in the setup program.
3. If the selected area contains both text and pictures:
   In the **Send** drop-down list, click **Image to OCR Editor**. The screenshot will be added to an OCR project in the OCR Editor of ABBYY FineReader PDF, where you can process and recognize it. If the OCR Editor is already open, the image will be added to the current OCR project. Otherwise, a new OCR project will be created and the image will be added to this new project.

### Reference

This chapter provides answers to some frequently asked questions.

#### Chapter contents

- **Types of PDF documents**[256]
- **Scanning tips**[253]
- **Taking photos of documents**[256]
- **Options dialog box**[259]
- **Format settings**[262]
- **Supported OCR and document comparison languages**[317]
- **Supported document formats**[324]
- **Document features to consider prior to OCR**[327]
- **Image processing options**[330]
- **OCR options**[333]
- **Working with complex-script languages**[336]
- **Supported interface languages**[342]
- **Current date and time on stamps and in Bates numbers**[343]
- **Fonts required for the correct display of texts in supported languages**[346]
- **Regular expressions**[348]
- **Using the command line**[350]
How to set ABBYY FineReader PDF 16 as your default PDF viewer

To set ABBYY FineReader PDF as your default PDF viewer:

1. Right-click any PDF file in Windows Explorer and click **Properties** in the shortcut menu. The **Properties** dialog box will open.
2. On the **General** tab click the **Change** button to change the application that you use to open PDF files.
   
   A list of applications will open.

   **How do you want to open .pdf files from now on?**

   **Keep using this app**

   ![Microsoft Edge](image)
   
   *Open PDFs right in your web browser.*

   **Other options**

   ![ABBYY FineReader](image)
   
   *New*

   ![Look for an app in the Store](image)

   ![More apps](image)

   ![OK](image)

3. In the list of applications, select ABBYY FineReader PDF.
   
   **Note.** If you don't see ABBYY FineReader PDF in the list, try scrolling down. To see more applications, click **More apps**.

4. Click **OK**.
Types of PDF documents

The features of a PDF document depend on the program in which it was created. Some PDF documents are searchable and have text you can copy, while in other documents this only becomes possible when you open them in special applications like ABBYY FineReader. There are three types of PDF documents.

Image-only PDF documents

Image-only PDF documents are created from scans of hard-copy documents. They only contain the images of pages and don't have a text layer. Image-only PDFs are not searchable, and the text they contain cannot be modified or marked up in PDF viewing applications.

ABBYY FineReader PDF uses a special background OCR process that creates a temporary text layer in image-only documents, making it possible to search and copy their text and even edit page images. Moreover, ABBYY FineReader PDF lets you save this text layer in the document so that the text in the document can be searched and copied into other applications. See also: PDF settings.

Searchable PDF documents

Searchable PDF documents consist of the images of pages with an invisible text layer placed underneath. Documents of this type are usually created by scanning a paper document, recognizing it, and saving the recognized text into a text layer.

When you open a PDF document in ABBYY FineReader, it will analyze the document to determine if it contains a usable text layer. See also: OCR options. If a text layer is present, the text in the document can be searched and copied in any PDF application. Unlike many other PDF applications, ABBYY FineReader also lets you edit the text in searchable PDF documents.

In ABBYY FineReader, searchable PDF documents can be created by:

1. Adding a text layer to an image-only PDF document.

2. Converting PDF documents and image files to the searchable PDF format. To do this, enable the Text under the page image option in the Searchable PDF settings group of options in the PDF format settings. See also: PDF settings.
PDF documents that were created in other applications

Searchable PDF documents can be created from documents in various editable formats (such as DOCX). Documents of this type contain a text layer and pictures, but do not contain page images. These documents are searchable and their text and pictures can be copied and edited, provided that such actions do not require entering a password or that the user knows the password.

PDF documents if this type can be created by:

1. Opening an editable document in the program where it was created and saving it in PDF.

2. Converting another type of PDF document or a document in another format into this type of PDF using ABBYY FineReader (in the PDF format settings, enable the Text and pictures only option in the Searchable PDF settings group of options). See also: [PDF settings](#).

The resulting document will be easier to edit than other types of PDF documents but may be visually different from the original.
Scanning tips

You can set the scanning settings in the ABBYY FineReader scanning dialog box.

- Make sure that the scanner is properly connected to your computer and turn it on. Consult your scanner documentation to ensure it is set up correctly. Be sure to install the software provided with your scanner. Some scanners have to be turned on before turning on the computer they are connected to.

- Try to make sure that the pages in the scanner are positioned as straight as possible. Place your documents face down on the scanner, making sure they are properly adjusted. Skewed images may be converted incorrectly.

- If you need to scan documents that were printed with a regular printer, use the grayscale mode and a resolution of 300 dpi for best results. Recognition quality depends on the quality of the hard-copy document and on the settings used for scanning the document. Poor image quality may have an adverse effect on the quality of conversion. Be sure to select the scanning parameters appropriate for your document.

There are several ways to open the scanning interface:

- Open the New Task screen, click the Scan tab, and then click OCR Editor or another task on this tab.

- In the OCR Editor, click the Scan button on the main toolbar.

- In the PDF Editor, click the button on the main toolbar and then click Add from Scanner... on the menu shown below.

You can specify the following scanning settings:

Color mode
Lets you select the scanning mode: color, grayscale (the best mode for OCR) or black-and-white.
**Brightness**
Changes the scanning brightness.

ABBY FineReader will display a warning message during scanning if the brightness setting is too low or too high. You may also need to adjust the brightness setting when scanning in black-and-white mode.

- The 50% setting works well in most cases.

If the resulting image contains too many "sketchy" or "thick" letters, troubleshoot using the table below.

<table>
<thead>
<tr>
<th>Image defect</th>
<th>Recommendations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightness</td>
<td>This image is suitable for text recognition.</td>
</tr>
<tr>
<td>Brightness</td>
<td>• Lower the brightness to make the image darker.</td>
</tr>
<tr>
<td></td>
<td>• Use the grayscale scanning mode (brightness is</td>
</tr>
<tr>
<td>Characters are very thin and sketchy</td>
<td>adjusted automatically in this mode).</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Brightness</td>
<td>• Increase the brightness to make the image lighter.</td>
</tr>
<tr>
<td>Characters are very thick and are stuck together</td>
<td>• Use the grayscale scanning mode (brightness is</td>
</tr>
<tr>
<td></td>
<td>adjusted automatically in this mode).</td>
</tr>
</tbody>
</table>

**Scanning resolution**
Changes the scanning resolution.

Recognition quality depends on the resolution of the document image. Poor image quality may have an adverse effect on the quality of conversion.

We recommend scanning documents at 300 dpi.

- For best recognition results, vertical and horizontal resolutions must be the same.

Setting the resolution too high (over 600 dpi) slows down OCR. Increasing the resolution beyond this point does not yield substantially improved OCR results.

Setting an extremely low resolution (less than 150 dpi) adversely affects OCR quality.

You may need to adjust the resolution of your images if:

- The resolution of your image is less than 250 dpi or higher than 600 dpi.

- If the image has a non-standard resolution.

Some faxes, for example, have a resolution of 204 by 96 dpi.

**Crop Image**
Lets you select a preset scanning area size or specify the scanning area manually.
Multi-page document scanning options:
Specify settings for scanning multi-page documents if your scanner supports the following features: duplex scanning, automatic document feeding (ADF), delays between automatic scans, etc.

Scanning facing pages

When you scan a book, a scanned image will typically contain two facing pages.

To improve OCR quality, images with facing pages need to be split into two separate images. ABBYY FineReader PDF features a special mode that automatically splits such images into separate pages within the OCR project.

Follow the instructions below to scan facing pages from a book or to scan dual pages.

1. Click **Tools > Options...** to open the **Options** dialog box and then click the **Image Processing** tab.

2. Select the **Split facing pages** option in the **Image preprocessing settings (apply to conversion and OCR)** group of options.
   Make sure your scans have the correct orientation or enable the **Correct page orientation** option. If a scan with facing pages does not have the correct orientation (e.g. it is upside-down), facing pages will not be split.

3. Scan the facing pages.

   There are other image processing options you can specify. See also: *[Image processing options](#)*

You can also split facing pages manually:

1. Open the Image Editor by clicking the **Edit Image** button on the toolbar of the **Image** pane.

2. Use the tools in the **Split** section of the leftmost pane to split the page.

   See also:

   - *[Image processing options](#)*
   - *[Document features to consider prior to OCR](#)*
   - *[If your document image has defects and OCR accuracy is low](#)*
Taking photos of documents

Scanning isn't the only way to acquire images of your documents. You can photograph documents with a camera or a mobile phone and then open the photographs in ABBYY FineReader and recognize them.

When taking pictures of documents, a number of factors should be kept in mind to make the photo better suited for OCR. These factors are described in detail in the sections that follow:

- **Camera requirements**
- **Lighting**
- **Taking photos**
- **How to improve an image**

**Camera requirements**

Your camera should meet the following requirements in order to obtain document images that can be reliably recognized.

**Recommended camera characteristics**

- Image sensor: 5 million pixels for A4 pages. Smaller sensors may be sufficient for taking pictures of smaller documents such as business cards.
- Flash disable feature
- Manual aperture control, i.e. availability of Av or full manual mode
- Manual focusing
- An anti-shake (image stabilization) feature or ability to use a tripod
- Optical zoom

**Minimum requirements**

- Image sensor: 2 million pixels for A4 pages
- Variable focal distance

For detailed information about your camera, please refer to the documentation supplied with your device.

**Lighting**

Lighting greatly affects the quality of the resulting photo.
Best results can be achieved with bright and evenly distributed light, preferably daylight. On a bright sunny day, you can increase the aperture number to get a sharper picture.

**Using a flash and additional lighting sources**

- When using artificial lighting, use two light sources positioned so as to avoid shadows or glare.

- If there is enough light, turn the flash off to prevent sharp highlights and shadows. When using the flash in poor lighting conditions, be sure to take photos from a distance of approximately 50 cm.

💡 We advise against using the flash when taking pictures of documents printed on glossy paper. Compare an image with glare and a good quality image:

---

**If the image is too dark**

- Set a lower aperture value to open up the aperture.

- Set a higher ISO value.

- Use manual focus, as automatic focus may fail in poor lighting conditions.

Compare an image that is too dark with a good quality image:

---

**Taking photos**
To obtain good quality photos of documents, be sure to position the camera correctly and follow these simple recommendations.

- Use a tripod whenever possible.

- The lens should be positioned parallel to the page. The distance between the camera and the document should be selected so that the entire page fits within the frame when you zoom in. In most cases, this distance will be between 50 and 60 cm.

- Even out the paper document or book pages (especially in the case of thick books). The text lines should not be skewed by more than 20 degrees, otherwise the text may not be converted properly.

- To get sharper images, focus on the center of the image.

- Enable the anti-shake feature, as longer exposures in poor lighting conditions may cause blur.

- Use the automatic shutter release feature. This will prevent the camera from moving when you press the shutter release button. The use of automatic shutter release is recommended even if you use a tripod.

**How to improve an image if:**

- The image is too dark or its contrast is too low.
  **Solution:** Try using brighter lighting. If that is not an option, try setting a lower aperture value.

- The image is not sharp enough.
  **Solution:** Autofocus may not work properly in poor lighting or when taking pictures from a close distance. Try using brighter lighting. Use a tripod and self-timer to avoid moving the camera when taking the picture.

If an image is only slightly blurry, the Photo Correction tool in the Image Editor of the OCR Editor may help get better results. See also: If your document image has defects and OCR accuracy is low.
A part of the image is not sharp enough.

**Solution:** Try setting a higher aperture value. Take pictures from a greater distance at maximum optical zoom. Focus on a point between the center and the edge of the image.

The flash causes glare.

**Solution:** Disable the flash or try using other light sources and increasing the distance between the camera and the document.

### Options dialog box

The **Options** dialog box contains a variety of options that let you decide how documents will be scanned, opened, recognized, and saved into various formats, as well as change OCR languages, the language of the interface, the print type of input documents, and some other options.

💡 There are several ways to open the **Options** dialog box:

- In the **New Task** screen, click the **Options** button in the lower-left corner.
- In the **New Task** screen, click **Tools > Options**.
- In the PDF Editor, click **Tools > Options**.
- In the OCR Editor, click **Tools > Options**.

Buttons, links or commands that open the **Options** dialog box will also be available when you convert or scan files in the **New Task** screen, on toolbars and on shortcut menus of toolbars in the PDF Editor and the OCR Editor, and in the dialog boxes that appear when you save documents.

The **Options** dialog box has seven tabs, each of which contains settings specific to certain ABBYY FineReader functionality.

#### General

On this tab, you can:

- Choose which part of the program will open when you start ABBYY FineReader PDF: the **New Task** screen, the OCR Editor with a new OCR project, or the OCR Editor with the most recently used OCR project.

- Specify which device you want to use to get images, and choose a scanning interface. ABBYY FineReader uses a built-in dialog box to display the scanning settings. If the scanning interface of ABBYY FineReader PDF is incompatible with your scanner, you can use your scanner's native interface. The scanner's documentation should contain a description of this dialog box and its elements.

- Make FineReader the default program for opening PDF documents.
Image Processing

This tab contains three groups of options:

- **Enable background recognition in the PDF Editor**
  When this option is enabled, all pages that are opened in the PDF Editor will be recognized automatically. This process runs in the background and adds a temporary text layer to PDF documents, making it possible to search them and copy their text. Use the link at the bottom of this group to specify the language(s) of your document.

- **Automatically process page images as they are added to the OCR Editor**
  This option enables or disables automatic processing of newly added pages. If automatic processing is enabled, you can select general document processing options and image preprocessing settings to be used when scanning and opening images:

  - **Recognize page images (includes preprocessing and analysis)**
    Newly added images in the OCR Editor will be preprocessed using the settings specified in the **Image preprocessing settings (apply to conversion and OCR)** group of options. Analysis and recognition will also be performed automatically.

  - **Analyze page images (includes preprocessing)**
    Image preprocessing and document analysis are performed automatically, but OCR has to be started manually.

  - **Preprocess page images**
    Only preprocessing is carried out automatically. Analysis and OCR have to be started manually.

  - **Image preprocessing settings (apply to conversion and OCR)**
    ABBYY FineReader PDF lets you automatically remove common defects from scans and digital photos.

See also: **Background recognition**, **Image processing options**, and **Working with complex-script languages**.

Languages

This tab contains OCR language options. See also: **Document features to consider prior to OCR**.

OCR

On this tab, you can select recognition options:

- The **PDF recognition mode**

- Whether to use thorough or fast recognition

- The **type of the document**
• Whether the program should detect structural elements (lets you choose which elements to preserve when exporting results to Microsoft Word)

• Whether the program should recognize barcodes

• Training (lets you use user patterns when recognizing texts)

• Fonts (lets you choose the fonts to be used in recognized texts)

See also: **OCR options** If the printed document contains non-standard fonts

**Format Settings**

On this tab, you can adjust the settings of output file formats. See also: **Format settings**

**Other**

On this tab, you can:

• Specify the interface language of ABBYY FineReader PDF.

• Specify how many processor cores FineReader may use for OCR.

• Specify whether ABBYY FineReader PDF should automatically check for and install updates.

• Specify whether you want to send anonymized ABBYY FineReader PDF configuration data to ABBYY for purposes of improving the software.

• Specify whether you want to see marketing messages in ABBYY FineReader PDF dialog boxes.

• Enable or disable JavaScript in PDF documents.

• Specify whether ABBYY FineReader PDF should automatically detect URLs in PDF documents.

Click **Reset...** at the bottom of the dialog box if you want to revert to the default settings.

**Areas and Text**

On this tab you can:

• Specify verification settings for low-confidence characters.

• Specify verification settings for non-dictionary words:

• Ignore words with digits and special characters.

• Check non-dictionary compounds.

  ✓ A compound word is a word made up of two or more words.

• Specify whether you want to correcting spaces before and after punctuation marks.
• View and edit user dictionaries.

• Choose a font for displaying plain text.

• Choose the color and thickness of frames of different area types in the Image window, the highlight color for low-confidence characters, and other display options.

See also: Checking recognized text, If the program fails to recognize certain characters, Editing area properties.

* This tab is only available in the OCR Editor.

Format settings

ABYY FineReader offers flexible format settings which determine the look and feel of output documents.

• PDF settings

• DOC(X)/RTF/ODT settings

• XLS(X) settings

• PPTX settings

• CSV settings

• TXT settings

• HTML Settings

• EPUB/FB2 settings

• DjVu settings
PDF settings

The following settings are available:

Image quality

If your text contains a lot of pictures or if you choose to save the page image together with the recognized text, the resulting PDF file may be quite large. The quality of the pictures and the size of the resulting file can be tweaked using the options in the **Image quality** drop-down list:

- **Best quality**
  Select this option to retain the quality of the pictures or the page image. The original resolution of the source image will be preserved.

- **Balanced**
  Select this option to reduce the size of the PDF file while keeping the quality of the pictures or page image at a reasonably high level.

- **Compact size**
  Select this option to greatly reduce the size of the output PDF file. The resolution of the pictures and page image will be reduced to 300 dpi, affecting their quality.

- **Custom...**
  Select this option if you want to specify custom image quality settings. In the **Custom Settings** dialog box, select the desired settings and click **OK**.

Create PDF/A

Enable this option if you want to create a PDF/A document and select the PDF/A version that you want to use.

Create PDF/UA (requires OCR)

Enable this option if you want to create a PDF/UA document. Please be aware that the resulting document may not look exactly like the original.

Protect documents with passwords
This option allows you to protect your PDF document with a password to prevent unauthorized opening, printing, or editing. Click the Settings... button and specify protection settings in the dialog box that opens:

- **Document Open password**
  If your document has a Document Open password, users will be able to open it only after entering the password you specify. To set a password for your document:

  1. Enable the **Restrict access with a Document Open password** option.
  2. Type the password and confirm it.
     Disable the **Hide characters** option if you want the characters of your password to be visible in the Document Open password field.

- **Permissions password**
  This password protects the PDF document from unauthorized editing and printing and prevents users who do not know the password from copying its content into another application. Users will be able to perform all of these actions only after entering the password you specify. To set this password:

  1. Enable the **Restrict printing and editing with a Permissions password** option.
  2. Type the password and confirm it.
     Disable the **Hide characters** option if you want the characters of your password to be visible in the Permissions password field.

  Next, select the actions you want to allow users to perform.

  o The **Printing** drop-down list contains options that allow or restrict printing the document.
  o The **Editing** drop-down list contains options that allow or restrict editing the document.
  o The **Allow copying text, images, and other content** option allows users to copy content (text, pictures, etc.) from your document. If you want to prohibit such actions, make sure this option is not selected.
  o The **Allow screen readers to read text** option allows screen reader software to read text from the document when it is open. If you want to prohibit such actions, make sure this option is not selected.

- **Encryption level**
  The **Encrypt** drop-down list contains options that encrypt password-protected documents.

  - **128-bit AES** is a fairly strong encryption algorithm based on the AES standard.
• **256-bit AES** is a strong encryption algorithm based on the AES standard.

Select one of the options from the **Encrypt** drop-down list. **All document contents** encrypts the entire document, while **All document contents except metadata** leaves the document’s data unencrypted and readable.

**Delete objects and data**

Enable this option if you don't want to preserve various objects contained in the PDF document, then click the **Select...** button to select which objects you don't want to keep:

- **Comments and markup**
  Notes, annotations, shapes, and text blocks will not be saved.

- **Links, media, actions, scripts, and form data**
  Interactive elements will not be saved.

- **Bookmarks**
  Bookmarks will not be saved.

- **Attachments**
  Attached files will not be saved.

**Use one paper size for all page images**

If this option is disabled, the original paper size of the page images will be retained. Enable this option if you want to use a specific paper size in your PDF document.

**Use MRC compression (requires OCR)**

Selecting this option will apply the MRC compression algorithm, which greatly reduces file size and preserves the visual quality the image.

- The **Use MRC compression (requires OCR)** option is available for searchable PDF documents when the **Text under the page image** option is enabled.

**Apply ABBYY PreciseScan to smooth characters on page images**
Enable this option if you want to use the ABBYY PreciseScan technology to smooth out the characters in the document. As a result, characters will not look pixelated even when you zoom in on the page.

**Searchable PDF settings**

This group of options lets you decide what elements of your PDF document you want to save. Depending on how you are planning to use your document, select one of the following options:

- **Text and pictures only**
  This option saves only the recognized text and the associated pictures. The page will be fully searchable and the size of the PDF file will be small. The appearance of the resulting document may slightly differ from the original.

- **Text over the page image**
  This option saves the background and pictures of the original document and places the recognized text over them. Usually, this PDF type requires more disk space than **Text and pictures only**. The resulting PDF document will be fully searchable. In some cases, the appearance of the resulting document may slightly differ from the original.

- **Text under the page image**
  This option saves the entire page as an image and places the recognized text underneath. The text layer makes it possible to search the document and copy text, while the page images insure that the document looks virtually the same as the original.

**Create bookmarks from headings**

Select this option if you wish to create a table of contents from the document headings.

**Create PDF tags**
Select this option to add PDF tags to the output PDF document.

Apart from text and pictures, PDF files can contain information about the document structure, such as logical parts, pictures, and tables. This information is stored in PDF tags. A PDF file equipped with PDF tags may be reflowed to fit different screen sizes and will display well on handheld devices.

**Fonts**

When saving texts in PDF, you can use either Adobe fonts or the Windows fonts installed on your computer. To specify the font set to be used, select one of the following items from the drop-down list:

- **Use predefined fonts**
  The PDF file will use Adobe fonts, for example: Times New Roman, Arial, Courier New.

- **Use Windows fonts**
  The file will use the Windows fonts installed on your computer.

To embed fonts in the PDF document, select the Embed fonts option. This will make the document file larger, but the document will look the same on all computers.

*The Embed fonts is only available for Text and pictures only and Text over the page image PDF documents.

**Preserve document metadata, such as authors and keywords**

Preserves the metadata of the document when it is saved in the PDF format. This option is enabled by default.

If you want to make changes to the document's metadata, click the Edit Metadata... button, make the desired changes, and click OK.

**DOC(X)/RTF/ODT settings**

The following settings are available:

**Document layout**
Select the appropriate setting depending on how you plan to use the output document.

1. **Exact copy**
   Preserves the formatting of the original document. This setting is recommended for documents with complex layouts, such as promotion booklets. Note, however, that it limits your ability to change the text and formatting in the output document.

2. **Editable copy**
   Produces a document in which the formatting may differ slightly from that of the original. Documents produced in this mode are easy to edit.

3. **Formatted text**
   Retains paragraphs but does not retain the exact positions of objects on the page and line spacing. The text produced will be left-aligned. Texts in right-to-left scripts will be right-aligned.
   - Vertical texts will become horizontal.

4. **Plain text**
   Discards most formatting. Preserves only the font styles if the **Keep bold, italic, and underlined text styles in plain text** option is enabled.

**Default paper size**
You can select the paper size to be used for saving in RTF, DOC, DOCX, or ODT format from the **Default paper size** drop-down list.

**Picture settings**

Documents containing a large number of pictures can be very large. The quality of the pictures and the size of the resulting file can be tweaked using the options in the **Keep pictures** drop-down list.

**Tip.** To change the picture saving settings, click **Custom...**, specify the desired settings in the **Custom Settings** dialog box, and click **OK**.

**Text settings**

- **Keep headers, footers, and page numbers**
  Retains the headers, footers, and page numbers in the output text.

- **Keep line breaks and hyphens**
  Retains the original arrangement of text lines in the output text.

- **Keep page breaks**
  Retains the original page arrangement.

- **Keep line numbers**
  Retains the original line numbering (if any). The line numbers will be saved in a separate field that remains unchanged when you edit the text.
  
  ✓ This feature is available only if the **Editable copy** option is selected in the **Document layout** drop-down list.

- **Keep text and background colors**
  Select this option to retain the font color and background color.

- **Keep bold, italic, and underlined text styles in plain text**
  Retains font styles when the **Plain text** option is selected in the **Document layout** drop-down list.

  ✓ If you disable the detection of headers, footers, the table of contents, numbered lists, and footnotes on the **OCR** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box), these elements will be saved as body text.

**Low-confidence characters**

Enable the **Highlight low-confidence characters** option if you plan to edit the document in Microsoft Word and not in the **Text** pane of the OCR Editor. When this option is selected, all low-confidence characters will be highlighted in the Microsoft Word document.

**Tip.** You can change the color use for low-confidence characters on the **Areas and Text** tab of the **Options** dialog box (click **Tools > Options...** to open this dialog box).

**Preserve document metadata, such as authors and keywords**
Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document's metadata, click the **Edit Metadata...** button, make the desired changes, and click **OK**.

**XLS(X) settings**

The following settings are available:

**Document layout**

Select the appropriate setting depending on how you plan to use the output document.

1. **Formatted text**
   
   Retains the fonts, font sizes, and paragraphs, but does not retain the exact line spacing or locations of the objects on the page. The text produced will be left-aligned. Texts in right-to-left scripts will be right-aligned.
   
   - Vertical texts will become horizontal.

2. **Plain text**
   
   Does not retain the formatting.

**Picture settings**

You can save pictures in XLSX documents. Documents containing a large number of pictures can be very large. The quality of the pictures and the size of the resulting file can be tweaked using the options in the **Keep pictures (XLSX only)** drop-down list.

**Tip.** To change the picture saving settings, click **Custom...**, select the desired settings in the **Custom Settings** dialog box, and click **OK**.

**Text settings**

- **Keep headers and footers**
  
  Enable this option if you want to keep the headers and footers. If this option is disabled, the headers and footers will not be preserved.

- **Ignore text outside tables**
  
  Saves only the tables and ignores the rest.

- **Convert numeric values to numbers**
  
  Converts numbers into the "Numbers" format in the XLSX document. Microsoft Excel can perform arithmetic operations on such cells.

- **Create separate sheet for each page (XLSX only)**
  
  Select this option to save pages from the source document as separate worksheets.

**Preserve document metadata, such as authors and keywords**
Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document’s metadata, click the Edit Metadata... button, make the desired changes, and click OK.

**PPTX settings**

The following settings are available:

**Picture settings**

Documents containing a large number of pictures can be very large. The quality of the pictures and the size of the resulting file can be tweaked using the options in the Keep pictures drop-down list.

**Tip.** To change the picture saving settings, click Custom.... In the Custom Settings dialog box, select the desired settings and click OK.

**Text settings**

- **Keep headers and footers**
  Preserves the headers and footers in the output document.

- **Keep line breaks**
  Retains the original arrangement of text lines. If this option is not selected, the output document will have a single line containing all of the text.

- **Shrink text on overflow**
  Decreases the font size of text if the text does not fit into a text block.

**Preserve document metadata, such as authors and keywords**

Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document’s metadata, click the Edit Metadata... button, make the desired changes, and click OK.

**CSV settings**

The following settings are available:

**Text settings**

- **Ignore text outside tables**
  Saves only the tables and ignores the rest.

- **Insert page break character (#12) as page separator**
  Saves the original page arrangement.

**Delimiter**

Specifies the character that will be used to separate the data columns in the output CSV document.

**Encoding**
ABBYY FineReader detects the code page automatically. To change the code page, select the desired code page from the Encoding drop-down list.

**Preserve document metadata, such as authors and keywords**
Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document's metadata, click the *Edit Metadata...* button, make the desired changes, and click **OK**.

**TXT settings**
The following settings are available:

**Document layout**
Select the appropriate setting depending on how you plan to use the output document.

1. **Formatted text**
   Retains the paragraphs but does not retain the exact positions of the objects and line spacing. Additionally, white spaces are used to reproduce paragraph indentations and tables. The text produced will be left-aligned. Texts in right-to-left scripts will be right-aligned.
   - Vertical texts will become horizontal.

2. **Plain text**
   Does not retain the formatting.

**Text settings**

- **Keep line breaks**
  Retains the original arrangement of text lines. If this option is not selected, each paragraph will be saved as a single line of text.

- **Insert page break character (#12) as page break**
  Saves the original page arrangement.

- **Use blank line as paragraph separator**
  Separates the paragraphs with blank lines.

- **Keep headers and footers**
  Preserves the headers and footers in the output document.

**Encoding**
ABBYY FineReader detects the code page automatically. To change the code page, select the desired code page from the Encoding drop-down list.

**Preserve document metadata, such as authors and keywords**
Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document's metadata, click the Edit Metadata... button, make the desired changes, and click OK.

**HTML settings**

The following settings are available:

**Document layout**

Select the appropriate setting depending on how you plan to use the output document.

- **Flexible layout**
  Preserves the formatting of the original. The output HTML document can be easily edited.

- **Formatted text**
  Retains the fonts, font sizes, font styles, and paragraphs, but does not retain the exact line spacing or locations of the objects on the page. The text produced will be left-aligned. Texts in right-to-left scripts will be right-aligned.
  ✓ Vertical texts will become horizontal.

- **Plain text**
  Does not retain the formatting.

**Picture settings**

Documents containing a large number of pictures can be very large. The quality of the pictures and the size of the resulting file can be tweaked using the options in the Keep pictures drop-down list.

**Tip.** To change the picture saving settings, click Custom.... In the Custom Settings dialog box, select the desired settings and click OK.

**Text settings**

- **Keep line breaks**
  Retains the original arrangement of text lines. If this option is disabled, the output document will have a single line containing all of the text.

- **Keep text and background colors**
  Select this option to retain the font color and background color.

- **Keep headers and footers**
  Preserves the headers and footers in the output document.

**Encoding**
ABBYY FineReader detects the code page automatically. To change the code page, select the desired code page from the Encoding drop-down list.

**Book settings**

If you are converting a hard-copy book to HTML, enable the **Generate a table of contents and use it to divide the document into files** option. The book can be split into chapters in one of the following ways:

- **Automatically create files based on headings**
  ABBYY FineReader PDF will automatically split the document into parts of roughly equal size, save them as separate HTML files, and create links to them in the table of contents.

- **Create files based on level 1 headings**
  ABBYY FineReader PDF will automatically split the document into separate HTML files using the highest-level headings.

- **Create files based on level 2 headings**
  ABBYY FineReader PDF will automatically split the document into separate HTML files using the highest-level headings and the headings of the next level.

**Preserve document metadata, such as authors and keywords**

Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document's metadata, click the **Edit Metadata...** button, make the desired changes, and click **OK**.

**EPUB/FB2 settings**

The following settings are available:

**Document layout**
Select the appropriate setting depending on how you plan to use the output document.

- **Formatted text**
  Retains the paragraphs but does not retain the exact positions of the objects and line spacing. The text produced will be left-aligned. Texts in right-to-left scripts will be right-aligned.
  - Vertical texts will become horizontal.
  - Font styles will be retained only in the EPUB format.

- **Plain text**
  Does not retain the formatting.

If you are saving to the EPUB format, you can preserve fonts by selecting the **Formatted text** option from the **Document layout** drop-down list and enabling the **Retain fonts and font sizes (EPUB only)** option below. Select the **Embed fonts** option to embed the document's fonts in the resulting e-book.
  - Some devices and software cannot display embedded fonts.

**Create cover**
Enable the **Use the first page as the e-book cover** option if you want to use the first page in the document as its cover.

**Picture settings**
Documents containing a large number of pictures can be very large. The quality of the pictures and the size of the resulting file can be tweaked using the options in the **Keep pictures** drop-down list.

**Tip.** To change the picture saving settings, click **Custom...**. In the **Custom Settings** dialog box, select the desired settings and click **OK**.

**EPUB Settings**
You can choose which version of the EPUB format you want to use.

**Preserve document metadata, such as authors and keywords**
Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document's metadata, click the **Edit Metadata...** button, make the desired changes, and click **OK**.

**DjVu settings**
The following settings are available:

**Save mode**
Select the appropriate setting depending on how you plan to use the output document.

- **Text under the page image**
  This option saves the entire page as an image and places the recognized text underneath. As a result, you get a searchable DjVu document that looks almost exactly like the original.

- **Page image only**
  This option saves the exact image of the page. The output document will look almost exactly like the original, but the text in the document will not be searchable.

**Picture settings**

Documents containing a large number of pictures can be very large. The quality of the pictures and the size of the resulting file can be tweaked using the options in the **Image quality** drop-down list.

**Tip.** To change the picture saving settings, click **Custom...** In the **Custom Settings** dialog box, select the desired settings and click **OK**.

**Multiple layers**

The DjVu format uses a special compression technique which separates a page image into layers and applies different compression methods to each of them. By default, ABBYY FineReader will automatically determine whether multi-layer compression must be used on a page (i.e. the **Multiple layers** option is set to **Automatic**). Set the **Multiple layers** option to **Always on** if you want to use multi-layer compression on all pages or to **Always off** if you do not want to use multi-layer compression.

**Preserve document metadata, such as authors and keywords**

Preserves the metadata when you save the document. This option is enabled by default.

If you want to make changes to the document's metadata, click the **Edit Metadata...** button, make the desired changes, and click **OK**.
Supported OCR and document comparison languages

ABYY FineReader PDF supports 201 OCR languages:

- **Natural languages**
- **Artificial languages**
- **Formal languages**

⚠️ Supported languages may vary in different versions of the product.

**Natural languages**

- Abkhaz
- Avar
- Agul
- Adyghe
- Azeri (Cyrillic), Azeri (Latin)
- Aymara
- Albanian
- Altai
- English phonetic transcriptions
- English
- Arabic (Saudi Arabia)
- Armenian (Eastern, Western, Grabar)
- Afrikaans
- Nahuatl
- Basque
- Bashkir
- Belarusian
- Bemba
- Blackfoot
- Bulgarian
• Breton
• Bugotu
• Buryat
• Welsh
• Hungarian*, **
• Wolof
• Vietnamese*, **
• Hawaiian
• Gagauz
• Galician
• Ganda
• Greek*, **
• Guarani
• Kawa
• Scottish Gaelic
• Dakota
• Dargwa
• Danish*, **
• Tun
• Dungan
• Zulu
• Hebrew*
• Yiddish
• Ingush
• Indonesian*, **
• Irish
- Icelandic
- Spanish*, **
- Italian*, **
- Kabardian
- Kazakh
- Kalmyk
- Karakalpak
- Karachay-balkar
- Catalan*, **
- Kashubian
- Quechua (Bolivia)
- Kikuyu
- Kirghiz
- Chinese Simplified**, Chinese Traditional
- Kongo
- Korean, Korean (Hangul)
- Corsican
- Koryak
- Xhosa
- Kpelle
- Crow
- Crimean Tatar
- Kumyk
- Kurdish
- Lak
- Latin*
- Latvian*,**
- Lezgi
- Lithuanian*,**
- Luba
- Sorbian
- Maya
- Macedonian
- Malagasy
- Malay (Malaysian)
- Malinke
- Maltese
- Mansi
- Maori
- Mari
- Minangkabau
- Mohawk
- Romanian (Moldova)
- Mongol
- Mordvin
- Miao
- German (Luxembourg)
- German**, German (New Spelling)*,**
- Nenets
- Nivkh
- Dutch**, Dutch (Belgian)*,**
- Nogay
- Norwegian (Nynorsk)**, Norwegian (Bokmal)*, **
- Nyanja
- Ojibway
- Ossetian
- Papiamento
- Polish*, **
- Portuguese**, Portuguese (Brazilian)*, **
- Occitan
- Rhaeto-Romanic
- Rwanda
- Romanian*, **
- Rundi
- Russian*, **
- Russian (Old Spelling)
- Russian with stress marks
- Sami (Lappish)
- Samoan
- Zapotec
- Swazi
- Cebuano
- Selkup
- Serbian (Cyrillic), Serbian (Latin)
- Slovak*, **
- Slovenian*, **
- Somali
- Swahili
- Sunda
- Tabasaran
- Tagalog
- Tajik
- Tahitian
- Thai
- Tatar*, **
- Tok Pisin
- Tongan
- Tswana
- Tuvinian
- Turkish*, **
- Turkmen (Cyrillic), Turkmen (Latin)
- Udmurt
- Uighur (Cyrillic), Uighur (Latin)
- Uzbek (Cyrillic), Uzbek (Latin)
- Ukrainian*, **
- Faroese
- Fijian
- Finnish*, **
- French*, **
- Frisian
- Friulian
- Khakass
- Hani
- Khanty
- Hausa
- Croatian*, **
- Jingpo
- Romany
- Chamorro
- Chechen
- Czech*, **
- Chuvash
- Chukchee
- Swedish*, **
- Shona
- Evenki
- Even
- Eskimo (Cyrillic), Eskimo (Latin)
- Estonian*, **
- Sotho
- Yakut
- Japanese
- Old English*
- Old French*
- Old German*
- Old Italian*
- Old Spanish*
- Latvian Gothic

Artificial languages
- Ido
- Interlingua
- Occidental
- Esperanto

**Formal languages**

- Basic
- C/C++
- COBOL
- Fortran
- Java
- Pascal
- Simple math formulas
- Numbers

To find out which fonts are required to display the characters of a specific language, see Fonts required for the correct display of texts in supported languages.

*Dictionaries are available for this language, enabling ABBYY FineReader to identify unreliably recognized characters and detect spelling errors in texts written in this language.

**Document comparison language. ABBYY FineReader can compare documents written in 37 languages. See also: ABBYY Compare Documents.

**Supported document formats**

The table below lists the formats supported by ABBYY FineReader PDF.

<table>
<thead>
<tr>
<th>Format</th>
<th>File extension</th>
<th>Input formats for the OCR Editor</th>
<th>Input formats for the PDF Editor / for ABBYY Compare Documents</th>
<th>Saving formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>PDF document</td>
<td>*.pdf</td>
<td>+</td>
<td>+</td>
<td>+</td>
</tr>
</tbody>
</table>

**Editable text formats**
<table>
<thead>
<tr>
<th>Format</th>
<th>Files</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Word Document</td>
<td>*.doc, *.docx</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Microsoft Excel 97-2003 Workbook</td>
<td>*.xls, *.xlsx</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Microsoft PowerPoint Presentation</td>
<td>*.pptx</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Microsoft Visio Drawing</td>
<td>*.vdx, *.vsdx</td>
<td>-</td>
<td>+ / -</td>
<td>-</td>
</tr>
<tr>
<td>HTML Document</td>
<td>*.htm, *.html</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Rich Text Format</td>
<td>*.rtf</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Text Document</td>
<td>*.txt</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Microsoft Office Excel Comma-Separated Values File</td>
<td>*.csv</td>
<td>-</td>
<td>-</td>
<td>+</td>
</tr>
<tr>
<td>OpenDocument Text</td>
<td>*.odt</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td></td>
<td>*.ods</td>
<td>-</td>
<td>+</td>
<td>-</td>
</tr>
<tr>
<td></td>
<td>*.odp</td>
<td>-</td>
<td>+</td>
<td>-</td>
</tr>
<tr>
<td>FB2 Document</td>
<td>*.fb2</td>
<td>-</td>
<td>-</td>
<td>+</td>
</tr>
<tr>
<td>EPUB Document</td>
<td>*.epub</td>
<td>-</td>
<td>-</td>
<td>+</td>
</tr>
</tbody>
</table>

**Non-editable formats**

<table>
<thead>
<tr>
<th>Format</th>
<th>Files</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>XPS (requires Microsoft .NET Framework 4)</td>
<td>*.xps</td>
<td>+</td>
<td>+</td>
<td>-</td>
</tr>
<tr>
<td>DjVu Document</td>
<td>*.djvu, *.djv</td>
<td>+</td>
<td>+</td>
<td>+</td>
</tr>
</tbody>
</table>

**Images**

<table>
<thead>
<tr>
<th>Format</th>
<th>Files</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>JPEG</td>
<td>*.jpg, *.jpeg</td>
<td>+</td>
<td>+</td>
<td>+</td>
</tr>
</tbody>
</table>
To be able to edit texts in a particular format, you must have the appropriate version of Microsoft Office or LibreOffice installed on your computer.

ABYY Compare Documents can save comparison results in the following formats:

- PDF document (*.pdf)
  To view PDF files, you must have a PDF viewing application installed on your computer. To see the list of differences, open the Comments pane.

- Microsoft Word Document (*.docx)

If the metadata of a document contain information about the compliance with the PDF/A or PDF/UA standard, this will be displayed in the Document Properties window.
Document features to consider prior to OCR

The quality of images has a significant impact on OCR quality. This section explains what factors you should take into account before recognizing images.

- **OCR languages**

- **Print type**

- **Print quality**

- **Color mode**

**OCR languages**

ABBYY FineReader can recognize both single- and multi-language documents (e.g. written in two or more languages). For multi-language documents, you need to select several OCR languages.

To select OCR languages, click **Options > Languages** and select one of the following options:

- **Automatically select OCR languages from the following list**

  ABBYY FineReader will automatically select the appropriate languages from the user-defined list of languages. To edit the list of languages:

  1. Make sure the **Automatically select OCR languages from the following list** option is selected.

  2. Click the **Specify...** button.

  3. In the **Languages** dialog box, select the desired languages and click **OK**.

  4. In the **Options** dialog box, click **OK**.

- **Specify OCR languages manually**

  Select this option if the language you need is not in the list.

  In the dialog box below, specify one or more languages. If you often use a particular language combination, you can create a new group for these languages.

If a language is not in the list, it is either:

1. Not supported by ABBYY FineReader, or

   For a complete list of supported languages, see **Supported OCR languages**.

2. Not supported by your version of the product.

   The complete list of languages available in your version of the product can be found in the **Licenses** dialog box (click **Help > About > License Info** to open this dialog box).

In addition to using built-in languages and language groups, you can create your own languages and groups. See also: **If the program fails to recognize certain characters**.
Print type

Documents may be printed using various devices such as typewriters and fax machines. OCR quality may vary depending on how a document was printed. You can improve OCR quality by selecting the correct print type in the Options dialog box.

For most documents, the program will detect their print type automatically. For automatic print type detection, the Auto option must be selected in the Document type group of options in the Options dialog box (click Tools > Options… > OCR to access these options). You can process documents in full-color or black-and-white mode.

You may also choose to manually select the print type as needed.

<table>
<thead>
<tr>
<th>Software</th>
<th>An example of typewritten text. All letters are of equal width (compare, for example, “w” and “t”). For texts of this type, select Typewriter.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software</td>
<td>An example of a text produced by a fax machine. As you can see from the example, the letters are not clear in some places. There is also some noise and distortion. For texts of this type, select Fax.</td>
</tr>
</tbody>
</table>

After recognizing typewritten texts or faxes, be sure to select Auto before processing regular printed documents.

Print quality

Poor-quality documents with “noise” (i.e. random black dots or speckles), blurred and uneven letters, or skewed lines and shifted table borders may require specific scanning settings.

<table>
<thead>
<tr>
<th>Fax</th>
<th>Newspaper</th>
</tr>
</thead>
</table>

Poor-quality documents are best scanned in grayscale. When scanning in grayscale, the program will select the optimal brightness value automatically.
The grayscale scanning mode retains more information about the letters in the scanned text to achieve better OCR results when recognizing documents of medium to poor quality. You can also correct some of the defects manually using the image editing tools available in the Image Editor. See also: If your document image has defects and OCR accuracy is low.

**Color mode**

If you do not need to preserve the original colors of a full-color document, you can process the document in black-and-white mode. This will greatly reduce the size of the resulting OCR project and speed up the OCR process. However, processing low-contrast images in black-and-white may result in poor OCR quality. We also do not recommend black-and-white processing for photos, magazine pages, and texts in Chinese, Japanese, and Korean.

**Tip.** You can also speed up the OCR of color and black-and-white documents by selecting Fast recognition on the OCR tab of the Options dialog box. For more about the recognition modes, see OCR Options.

For some additional recommendations on selecting the right color mode, see Scanning tips.

💡 Once the document is converted to black-and-white, you will not be able to restore the colors. To get a color document, open a file with color images or scan the paper document in color mode.
Image processing options

To customize the scanning and opening of pages in ABBYY FineReader, you can:

- enable/disable **background recognition in the PDF Editor**

- enable/disable **automatic analysis and recognition** of pages when they are added into the OCR Editor

- specify **image preprocessing settings**

You can select desired options either when opening a PDF document, images or scans in the New Task Window or on the Image Processing tab of the Options dialog box (click **Tools > Options** to open this dialog box).

💡 Any changes you make in the Options dialog box will only be applied to newly scanned/opened images.

The Image Processing tab of the Options dialog box contains the following options:

**Enable background recognition in the PDF Editor**

Background recognition will be used for all pages you open in the PDF Editor. Background recognition allows you to search and copy text even in documents that do not have a text layer (e.g. documents that contain only scans or that were created from images). No permanent changes are made to the document itself.

On this tab, you can also specify the **OCR languages**.

-if you want to enable other users to carry out text searches in this document, click **File > Recognize Document > Recognize Document**.

**Automatic analysis and recognition of images added into the OCR Editor**

By default, pages are analyzed and recognized automatically, but you can change this behavior. The following modes are available:

- **Recognize page images (includes preprocessing and analysis)**
  When images are opened in the OCR Editor, they will be automatically preprocessed using the settings selected in the **Image preprocessing settings (apply to conversion and OCR)** group of settings. Analysis and OCR are also performed automatically.

- **Analyze page images (includes preprocessing)**
  Image preprocessing and document analysis are performed automatically, but OCR has to be started manually.

- **Preprocess page images**
  Only preprocessing is carried out automatically. Analysis and OCR have to be started manually. This mode is commonly used for documents with complex structures.
If you do not want the images you add to be automatically processed, clear the **Automatically process page images as they are added to the OCR Editor** option. This lets you quickly open large documents, recognize only select pages in a document, and save documents as images.

**Image preprocessing settings**

By default, ABBYY FineReader lets you automatically correct common defects on scan and digital photos.

Select **Specify settings manually** to manually specify settings recommended for improving recognition quality:

- **Split facing pages**
  The program will automatically split images that contain facing pages into two images containing one page each.

- **Correct page orientation**
  The orientation of pages that are added to an OCR project will be automatically detected and corrected if necessary.

- **Use recommended settings for better OCR**
  The program will automatically choose and apply the required preprocessing settings.

To display all the settings, click **Show Custom Settings**:

- **Deskew images**
  The program will automatically detect skewed pages and correct skew if necessary.

- **Straighten text lines**
  The program will automatically detect uneven text lines on images and straighten them without correcting trapezoid distortions.

- **Correct image resolution**
  The program will automatically detect and determine the best resolution for images and will change the resolution of images when necessary.

- **Detect page edges** *
  The program will automatically detect and crop image edges.

- **Whiten background** *
  The program will automatically whiten backgrounds and select the best brightness setting.

- **Reduce ISO noise** *
  The program will automatically remove noise from photographs.

- **Remove motion blur** *
  The sharpness of blurry digital photos will be increased.
• Correct trapezoid distortions *
  The program will automatically detect trapezoid distortions and uneven text lines on digital photographs and scans of books.

• Fix inverted colors on image
  When appropriate, the program will invert the colors of an image so that dark text is printed on a light background.

• Convert to black and white
  The program will convert color images to black-and-white. This will greatly reduce the size of the resulting OCR project and speed up OCR. We do not recommend black-and-white conversion for photos, magazine pages, and texts in Chinese, Japanese, and Korean.

• Remove color marks
  The program will detect and remove any color stamps and marks made in pen to facilitate the recognition of the text obscured by such marks. This option is designed for scanned documents with dark text printed on a white background. Do not select this option for digital photos and documents with color backgrounds.

* For digital photos only.

To display only the recommended settings, click Hide Custom Settings.

Select No preprocessing option to disable all of these options when scanning or opening document pages. You can still apply any desired preprocessing in the Image Editor of the OCR Editor.

See also: If your document image has defects and OCR accuracy is low.
OCR options

Selecting the right OCR options is important if you want fast and accurate results. When deciding which options you want to use, you should consider not only the type and complexity of your document, but also how you intend to use the results. The following groups of options are available:

- **PDF recognition modes**
- **Balance between OCR speed and accuracy**
- **Document type**
- **Detection of structural elements**
- **Barcodes**
- **Patterns and languages**
- **Fonts to be used in recognized text**

You can find the OCR options on the **OCR** tab of the **Options** dialog box (click **Tools** > **Options...** to open this dialog box).

💡 ABBYY FineReader automatically recognizes any pages you add to an OCR project. The currently selected options will be used for OCR. You can turn off automatic analysis and OCR of newly added images on the **Image Processing** tab of the **Options** dialog box (click **Tools** > **Options...** to open this dialog box).

✅ If you change the OCR options after a document has been recognized, run the OCR process again to recognize the document with the new options.

**PDF recognition modes**

These settings are intended for PDF documents with text layers and pictures. Such PDF documents are usually created from documents in editable formats. Other types of PDF documents, such as searchable PDFs and image-only PDFs, are always processed in **Use OCR** mode, which is the default mode for these types of PDF. No additional settings are required to process such PDFs.

Three recognition modes are available:

- **Automatically Choose between OCR and Text from PDF**
  The program will examine the text layer and use the existing text layer if it contains good-quality text. Otherwise, OCR will be used to create a new text layer.

- **Use OCR**
  OCR will be used to create a new text layer. This mode takes more time but is more suitable for documents with poor-quality text layers.
• **Use Only Text from PDF**
  This is the default mode for PDF documents with text layers. The program will use the original text layer without running OCR.

**balance between OCR speed and accuracy**

ABBYY FineReader PDF allows you to perform:

• **Thorough recognition**
  In this mode, ABBYY FineReader analyzes and recognizes both simple documents and documents with complex layouts, even those with text printed on a colored background and documents with complex tables (including tables with white grid lines and tables with color cells).

**Thorough recognition** requires more time but delivers better quality.
• **Fast recognition**
  This mode is recommended for processing large documents with simple layouts and good quality images.

**Print type**

Specifies the type of device that was used for printing the document. See also: *Document features to consider prior to OCR*. See also: Document features to consider prior to OCR.

**Detect structural elements**

Select the structural elements you want the program to detect: headers and footers, footnotes, tables of contents, and lists. The selected elements will be clickable when the document is saved.

**Barcodes**

If your document contains barcodes and you wish them to be converted into strings of letters and digits rather than saved as pictures, select **Convert barcodes into strings**. This feature is disabled by default.

**Patterns and languages**

Recognition with training is used to recognize the following types of text:

- Texts with special symbols (e.g. mathematical symbols)
- Text with decorative elements
- Large volumes of text from low-quality images (over 100 pages)

Training is disabled by default. Enable **Use training to recognize new characters and ligatures** to train ABBYY FineReader while performing OCR.

You can use either built-in or your own patterns for recognition.

You can save and load settings for user patterns and languages. See also: *OCR project*. See also: OCR project.

**Fonts**

Here you can select the fonts to be used when saving recognized text.

To select fonts:

1. Click the **Select Fonts...** button.
2. Select the desired fonts and click **OK**.
Working with complex-script languages

With ABBYY FineReader, you can recognize documents in Arabic, Hebrew, Yiddish, Thai, Chinese, Japanese, and Korean. Some additional factors must be taken into account when working with documents in Chinese, Japanese or Korean and with documents in which a combination of CJK and European languages is used.

- Recommended fonts
- Disabling automatic image processing
- Recognizing documents written in more than one language
- If non-European characters are not displayed in the Text window
- Changing the direction of recognized text

Recommended fonts

Recognition of text in Arabic, Hebrew, Yiddish, Thai, Chinese, Japanese, and Korean may require additional fonts to be installed. The table below lists the recommended fonts for texts in these languages.

<table>
<thead>
<tr>
<th>OCR languages</th>
<th>Recommended font</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arabic</td>
<td>Arial™ Unicode™ MS</td>
</tr>
<tr>
<td>Hebrew</td>
<td>Arial™ Unicode™ MS</td>
</tr>
<tr>
<td>Yiddish</td>
<td>Arial™ Unicode™ MS</td>
</tr>
<tr>
<td>Thai</td>
<td>Arial™ Unicode™ MS</td>
</tr>
<tr>
<td></td>
<td>Aharoni</td>
</tr>
<tr>
<td></td>
<td>David</td>
</tr>
<tr>
<td></td>
<td>Levenim mt</td>
</tr>
<tr>
<td></td>
<td>Miriam</td>
</tr>
<tr>
<td></td>
<td>Narkisim</td>
</tr>
<tr>
<td></td>
<td>Rod</td>
</tr>
</tbody>
</table>
### The sections below contain advice on improving recognition accuracy.

#### Disabling automatic image processing

By default, any pages you add to an OCR project are automatically recognized.

However, if your document contains text in a CJK language combined with a European language, we recommend disabling automatic detection of page orientation and using the dual page splitting option only if all of the page images have the correct orientation (e.g. they were not scanned upside down).

You can enable/disable the Correct page orientation and Split facing pages options on the Image Processing tab of the Options dialog box (click Tools > Options... to open this dialog box).

> To split facing pages in Arabic, Hebrew, or Yiddish, be sure to select the corresponding OCR language first and only then select the Split facing pages option. You can also restore the original page numbering by selecting the Swap book pages option. See also: OCR projects.

If your document has a complex structure, we recommend disabling automatic analysis and OCR for images and performing these operations manually.

You can turn off automatic analysis and OCR of newly added images on the Image Processing tab of the Options dialog box (click Tools > Options... to open this dialog box).

1. Click Tools > Options... to open the Options dialog box.
2. On the Image Processing tab, clear the Automatically process page images as they are added to the OCR Editor option.
Recognizing documents written in more than one language

The instructions below are provided as an example and explain how to recognize a document that contains both English and Chinese text. Documents that contain other languages can be recognized in a similar manner.

1. On the main toolbar, select More languages... from the list of languages. In the Language Editor dialog box, select Specify OCR languages manually and select Chinese and English from the list of languages.

2. Scan your pages or open your images.

3. If the program fails to detect all of the areas on an image:
   - Specify areas manually using the area editing tools.
   - Specify any areas that only contain one language and on the Area Properties select English or Chinese as appropriate. 🚫 A language can only be specified for areas of the same type. If you selected areas of different types, such as Text and Table, you will not be able to specify a language.
   - If necessary, select the text direction from the Orientation drop-down list (for details, see If vertical or inverted text was not recognized)
   - For texts in CJK languages, the program provides a selection of the text directions in the Direction of CJK text drop-down list (for details, see Editing area properties).

If non-European characters are not displayed in the Text pane

If text in a CJK language is displayed incorrectly in the Text pane, you may have selected the Plain text mode.

To change the font used in Plain text mode:

1. Click Tools > Options... to open the Options dialog box.
2. Click the Areas and Text tab.
3. Select Arial Unicode MS from the Font used to display plain text drop-down list.
4. Click OK.

If this did not help and text in the Text window is still displayed incorrectly, see Incorrect font is used or some characters are replaced with "?" or "□".

Changing the direction of recognized text
ABBYY FineReader detects text direction automatically, but you can also specify text direction manually.

1. Activate the Text pane.
2. Select one or more paragraphs.
3. Click the button on the toolbar in the Text pane.

You can use the Direction of CJK text drop-down list in the Image pane to specify the direction of text prior to OCR. See also: Editing area properties.

**Recognition of text written using a Gothic script**

ABBYY FineReader can help you recognize historical documents and books that have been written using a Gothic typeface in the English, German, French, Italian, Spanish, and Latvian languages. Working with such documents is different in several respects, as described below.

- Gothic script recognition languages
- Supported Gothic fonts
- Instructions for recognizing text written in Gothic script

**Gothic script recognition languages**

To recognize text written in a Gothic typeface, the program uses the following 6 languages:

1. **Old English.**
2. **Old French.**
3. **Old German.**
4. **Old Italian.**
5. **Old Spanish.**
6. **Latvian Gothic.**
 Supported Gothic fonts

You may need to install additional Windows fonts in order to have the text displayed in a Gothic typeface in the recognition results.

<table>
<thead>
<tr>
<th>Textur</th>
<th>Fraktur</th>
<th>Schwabacher</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>a</td>
<td>a</td>
</tr>
<tr>
<td>d</td>
<td>d</td>
<td>d</td>
</tr>
<tr>
<td>g</td>
<td>g</td>
<td>g</td>
</tr>
<tr>
<td>n</td>
<td>n</td>
<td>n</td>
</tr>
<tr>
<td>o</td>
<td>o</td>
<td>o</td>
</tr>
<tr>
<td>A</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>B</td>
<td>B</td>
<td>B</td>
</tr>
<tr>
<td>H</td>
<td>H</td>
<td>H</td>
</tr>
<tr>
<td>S</td>
<td>S</td>
<td>S</td>
</tr>
</tbody>
</table>

ABYY FineReader supports the following Gothic scripts:

1. Textur/Textualis — blackletter typeface.
2. Fraktur — blackletter typeface with angular strokes.
3. Schwabacher — "broken" typeface with rounded strokes in some letters.

If no Gothic fonts are installed, the recognition results will be displayed in either Arial, Times, or Courier.

Instructions for recognizing text written in Gothic script

To recognize a document that contains Gothic typeface text, do the following:

1. In the OCR Editor window, select More languages... from the Languages drop-down list on the main toolbar. In the Language Editor dialog that opens, select the Specify OCR languages manually option and specify the appropriate language from the list. Then click OK.

   🌐 Selecting several recognition languages at the same time (e.g. English and Old English or German and old German) may negatively affect the recognition results. To avoid this, specify only the language that will be used to recognize the Gothic text.

   ✔️ For more information on how to launch the OCR Editor, see Launching the OCR Editor.

2. Scan or open the images.

   ✔️ For more information, see Obtaining documents.

3. Click the Recognize button on the main toolbar.

The recognition results will be displayed in the Text window.
Recognition results will be displayed in a Gothic font if the source document was written using a supported font that is installed on your machine. Otherwise, either Arial, Times, or Courier will be used.

If necessary, change the font of the results:

1. Select the appropriate text.
2. Click Properties in the context menu for that text.
3. On the Text Properties panel, select the appropriate font from the list.

The document text will be displayed in the specified font.
Supported interface languages

The interface language is selected when ABBYY FineReader is installed. This language will be used for all the messages, dialog boxes, buttons, and menu items. To change the interface language, follow the instructions below:

1. Click **Options...** on the **Tools** menu to open the **Options** dialog box and then select the **Other** tab.

2. Select the desired language from the **Interface language** drop-down menu.

3. Click **OK**.

4. Restart ABBYY FineReader.

ABYY FineReader PDF supports 22 GUI languages:

- **English**
- **Bulgarian**
- **Hungarian**
- **Vietnamese**
- **Dutch**
- **Greek**
- **Danish**
- **Spanish**
- **Italian**
- **Chinese Traditional**
- **Chinese Simplified**
- **Korean**
- **German**
- **Polish**
- **Portuguese (Brazilian)**
- **Slovak**
- **Turkish**
- **Ukrainian**
Current date and time on stamps and in headers and footers

You can create stamps and Bates numbers that display the current date. Use the following tags in the stamp manager or Bates number manager.

<table>
<thead>
<tr>
<th>Tag</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;d/&gt;</td>
<td>Date in short format</td>
</tr>
<tr>
<td>&lt;date/&gt;</td>
<td>Date in long format</td>
</tr>
<tr>
<td>&lt;t12/&gt;</td>
<td>Time in 12-hour format</td>
</tr>
<tr>
<td>&lt;t24/&gt;</td>
<td>Time in 24-hour format</td>
</tr>
<tr>
<td>&lt;time/&gt;</td>
<td>Time in HH:MM:SS format</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tag</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;d/&gt;</td>
<td>Date in short format</td>
</tr>
<tr>
<td>&lt;date/&gt;</td>
<td>Date in long format</td>
</tr>
<tr>
<td>&lt;t12/&gt;</td>
<td>Time in 12-hour format</td>
</tr>
<tr>
<td>&lt;t24/&gt;</td>
<td>Time in 24-hour format</td>
</tr>
<tr>
<td>&lt;time/&gt;</td>
<td>Time in HH:MM:SS format</td>
</tr>
</tbody>
</table>

By default, the regional settings of your computer will determine the date and time formats. You can specify a different format. For example, <d=RUS/>, <date=USA/>, or <time=ENG/>. The result will be immediately displayed in the preview pane.

Click here to see some examples

<
| <d=USA/ | 2/7/2013                      |
| <d=ENG/ | 07/02/2013                     |
| <d=RUS/ | 07.02.2013                    |
| <d=DEU/ | 07.02.2013                    |
| <d=FRA/ | 07/02/2013                     |
| <d=ITA/ | 07/02/2013                     |
You can specify custom date and time formats.

**Click here to see some examples**

- `<date=USA %A/>` Friday
- `<date=DEU %B, %Y/>` February, 2013
- `<time %Hh %Mm/>` 09h 22m

You can specify date and time formats using the `<date/>` and `<time/>` tags.

<table>
<thead>
<tr>
<th><code>&lt;date/&gt;</code> parameters</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Year</strong></td>
<td></td>
</tr>
<tr>
<td>%y</td>
<td>The year as a number from 01 to 99 (with leading zeros)</td>
</tr>
<tr>
<td>%#y</td>
<td>The year as a number from 1 to 99 (no leading zeros)</td>
</tr>
<tr>
<td>%Y</td>
<td>The year as a number from 0001 to 9999 (with leading zeros)</td>
</tr>
<tr>
<td>%#Y</td>
<td>The year as a number from 1 to 9999 (no leading zeros)</td>
</tr>
<tr>
<td><strong>Month</strong></td>
<td></td>
</tr>
<tr>
<td>%b</td>
<td>Abbreviated names of the months</td>
</tr>
<tr>
<td>%B</td>
<td>Full names of the months</td>
</tr>
<tr>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>%m</td>
<td>The month as a number from 01 to 12 (with leading zeros)</td>
</tr>
<tr>
<td>%#m</td>
<td>The month as a number from 1 to 12 (no leading zeros)</td>
</tr>
</tbody>
</table>

**Day of month**

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%d</td>
<td>The day as a number from 01 to 31 (with leading zeros)</td>
<td>07</td>
</tr>
<tr>
<td>%#d</td>
<td>The day as a number from 1 to 31 (no leading zeros)</td>
<td>7</td>
</tr>
</tbody>
</table>

**Day of week**

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%a</td>
<td>Abbreviated names of the days</td>
<td>Tu</td>
</tr>
<tr>
<td>%A</td>
<td>Full names of the months</td>
<td>Tuesday</td>
</tr>
</tbody>
</table>

**<time/> parameters**

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%H</td>
<td>Hours in 24-hour format (from 00 to 23, with leading zeros)</td>
<td>07</td>
</tr>
<tr>
<td>%#H</td>
<td>Hours in 24-hour format (from 0 to 23, no leading zeros)</td>
<td>7</td>
</tr>
<tr>
<td>%I</td>
<td>Hours in 12-hour format (from 01 to 12, with leading zeros)</td>
<td>05</td>
</tr>
<tr>
<td>%#I</td>
<td>Hours in 12-hour format (from 1 to 12, no leading zeros)</td>
<td>5</td>
</tr>
<tr>
<td>%p</td>
<td>A.M./P.M. indication for 12-hour format*</td>
<td>AM</td>
</tr>
</tbody>
</table>

**Minutes and seconds**

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%M</td>
<td>Minutes as a number from 00 to 59 (with leading zeros)</td>
<td>04</td>
</tr>
<tr>
<td>%#M</td>
<td>Minutes as a number from 0 to 59 (no leading zeros)</td>
<td>4</td>
</tr>
<tr>
<td>%S</td>
<td>Seconds as a number from 00 to 59 (with leading zeros)</td>
<td>04</td>
</tr>
<tr>
<td>%#S</td>
<td>Seconds as a number from 0 to 59 (no leading zeros)</td>
<td>4</td>
</tr>
</tbody>
</table>

**Additional parameter**

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>%%</td>
<td>Percentage symbol</td>
</tr>
</tbody>
</table>

**Changing your regional settings**
1. Click **Start** > **Control Panel** > **Regional and Language Options**

2. On the **Formats** tab, select a format to be used for date and time, or click **Options** to create your own date and time format.

   In Windows 10, click **Start** > **PC Settings** > **Time and Language** > **Region and language**.

* Available only for the USA, ENG, HUN, and CZ regions.

**Fonts required for the correct display of texts in supported languages**

<table>
<thead>
<tr>
<th>OCR languages</th>
<th>Font</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abkhaz</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Avar</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Agul</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Adyghe</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Altaic</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Arabic</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Armenian (Eastern, Western, Grabar)*</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Bashkir*</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Vietnamese</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Gagauz</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Dargwa</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Zulu</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Hebrew</td>
<td>Arial Unicode MS(*) Aharoni, David, Levenim mt, Miriam, Narkisim, Rod</td>
</tr>
<tr>
<td>Yiddish</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Ingush</td>
<td>Arial Unicode MS(*)</td>
</tr>
<tr>
<td>Language</td>
<td>Font Family</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Kabardian</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Chinese (Simplified), Chinese (Traditional)</td>
<td>Arial Unicode MS, SimSun fonts</td>
</tr>
<tr>
<td>Chinese (Simplified), Chinese (Traditional)</td>
<td>Example SimSun (Founder Extended), SimSun-18030, NSimSun.</td>
</tr>
<tr>
<td>Chinese (Simplified), Chinese (Traditional)</td>
<td>Simhei, YouYuan, PMingLiU, MingLiU, Ming(for-ISO10646), STSong</td>
</tr>
<tr>
<td>Korean, Korean (Hangul)</td>
<td>Arial Unicode MS, SimSun fonts</td>
</tr>
<tr>
<td>Korean, Korean (Hangul)</td>
<td>Example SimSun (Founder Extended), SimSun-18030, NSimSun.</td>
</tr>
<tr>
<td>Korean, Korean (Hangul)</td>
<td>Simhei, YouYuan, PMingLiU, MingLiU, Ming(for-ISO10646), STSong</td>
</tr>
<tr>
<td>Koryak</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Lak</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Lezgi</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Mansi</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Mari</td>
<td>Arial Unicode MS</td>
</tr>
<tr>
<td>Ossetian</td>
<td>Arial Unicode MS, Palatino Linotype</td>
</tr>
<tr>
<td>Russian (old spelling)</td>
<td>Arial Unicode MS, Palatino Linotype</td>
</tr>
<tr>
<td>Tabasaran</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Tajik</td>
<td>Arial Unicode MS, Palatino Linotype</td>
</tr>
<tr>
<td>Thai</td>
<td>Arial Unicode MS</td>
</tr>
<tr>
<td>Udmurt</td>
<td>Arial Unicode MS</td>
</tr>
<tr>
<td>Khakass</td>
<td>Arial Unicode MS</td>
</tr>
<tr>
<td>Khanty</td>
<td>Arial Unicode MS</td>
</tr>
<tr>
<td>Hausa</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Chechen</td>
<td>Arial Unicode MS, Lucida Sans Unicode</td>
</tr>
<tr>
<td>Chuvash</td>
<td>Arial Unicode MS</td>
</tr>
</tbody>
</table>
Where to find/supplied with

(*) Microsoft Office 2000 or later

Regular expressions
The table below lists the regular expressions that can be used to create a dictionary for a custom language.

<table>
<thead>
<tr>
<th>Item name</th>
<th>Conventional regular expression symbol</th>
<th>Usage examples and explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any character</td>
<td>.</td>
<td>c.t— denotes &quot;cat,&quot; &quot;cot,&quot; etc.</td>
</tr>
<tr>
<td>Character from group</td>
<td>[ ]</td>
<td>[b-d]ell— denotes &quot;bell,&quot; &quot;cell,&quot; &quot;dell,&quot; etc.; [ty]ell— denotes &quot;tell&quot; and &quot;yell&quot;</td>
</tr>
<tr>
<td>Character not from group</td>
<td>[^]</td>
<td>[^y]ell— denotes &quot;doll,&quot; &quot;cell,&quot; &quot;tell,&quot; but forbids &quot;yell&quot;; [^n-s]ell — denotes &quot;bell,&quot; &quot;cell,&quot; but forbids &quot;nell,&quot; &quot;oell,&quot; &quot;pell,&quot; &quot;qell,&quot; &quot;rell,&quot; and &quot;sell&quot;</td>
</tr>
<tr>
<td>Or</td>
<td></td>
<td>c(a</td>
</tr>
<tr>
<td>0 or more matches</td>
<td>*</td>
<td>10*— denotes numbers 1, 10, 100, 1000, etc.</td>
</tr>
<tr>
<td>1 or more matches</td>
<td>+</td>
<td>10+— allows numbers 10, 100, 1000, etc.</td>
</tr>
<tr>
<td>Letter or digit</td>
<td>[0-9a-zA-ZА-Я]</td>
<td>[0-9a-zA-ZА-ЯА-Я]— allows any single character; [0-9a-zA-ZА-ЯА-Я]+— allows any word</td>
</tr>
<tr>
<td>Capital Latin letter</td>
<td>[A-Z]</td>
<td></td>
</tr>
<tr>
<td>Small Latin letter</td>
<td>[a-zA-Z]</td>
<td></td>
</tr>
<tr>
<td>Capital Cyrillic letter</td>
<td>[А-Я]</td>
<td></td>
</tr>
<tr>
<td>------------------------</td>
<td>-------</td>
<td></td>
</tr>
<tr>
<td>Small Cyrillic letter</td>
<td>[а-я]</td>
<td></td>
</tr>
<tr>
<td>Digit</td>
<td>[0-9]</td>
<td></td>
</tr>
<tr>
<td>@</td>
<td>Reserved.</td>
<td></td>
</tr>
</tbody>
</table>

**Note:**

1. To use a regular expression symbol as a normal character, precede it with a back slash. For example, \[t-v\]x+ stands for tx, txx, etc., ux, uxx, etc., and vx, vxx, etc., but \[t-v\]x stands for \[t-v\]x, \[t-v\]xx, \[t-v\]xxx, etc.

2. To group regular expression elements, use brackets. For example, (a|b)+|c stands for c or any combinations like abbbabbb, ababab, etc. (a word of any non-zero length in which there may be any number of a’s and b’s in any order), while a|b+|c stands for a, c, b, bb, bbb, etc.

**Examples**

Suppose you are recognizing a table with three columns: birth dates, names, and e-mail addresses. In this case, you can create two new languages, Data and Address, and specify the following regular expressions for them.

**Regular expression for dates:**

The number denoting a day may consist of one digit (1, 2, etc.) or two digits (02, 12), but it cannot be zero (00 or 0). The regular expression for the day should then look like this: ((|0)[1-9])|([1|2][0-9])|(30)|(31).

The regular expression for the month should look like this: ((|0)[1-9])|(10)|(11)|(12).

The regular expression for the year should look like this: ([19][0-9][0-9])|([0-9][0-9]).

Now all we need to do is combine all this together and separate the numbers by period. The period is a regular expression symbol, so you must put a back slash (\) before it.

The regular expression for the full date should then look like this:

((|0)[1-9])|([1|2][0-9])|(30)|(31).\((|0)[1-9])|(10)|(11)|(12).((19)[0-9][0-9])|([0-9][0-9])

**Regular expression for e-mail addresses:**

[a-zA-Z0-9._-]+@[a-z0-9.-]+
Using the command line

You can use the command line to convert scanned documents, PDF files, and image files to supported formats. You can also use it to launch a comparison of two versions of a document in different formats without having to specifically open either the OCR Editor window or ABBYY Compare Documents.

To process documents using the command line, follow the steps below:

1. Open the command line interface by pressing the **Win+R** key combination. Next, enter "**cmd**" into the command line and click **OK**.

2. Enter a command for either converting or comparing your documents, and press the **Enter** key. An ABBYY FineReader dialog window will appear on the screen. It will contain a progress bar, as well as any relevant hints and warnings.

3. After your documents have been processed, the results will be opened in the appropriate application.

   To save the conversion results, you will need to manually launch the save procedure.

Chapter contents:

- Command line parameters for converting documents
- Command line parameters for comparing documents
- Saving the results via the command line
- LangName parameter values for the command line

Command line parameters for converting documents

To begin converting a document into an editable format, execute the following command:

```
FineReaderOCR.exe <ImageSourceCommands> <RecognitionCommands> <ExportCommands>
```

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FineReaderOCR.exe</td>
<td>The path to the FineReaderOCR.exe file in the program installation folder.</td>
</tr>
<tr>
<td></td>
<td>If the full path contains spaces, put it in quotation marks.</td>
</tr>
<tr>
<td>ImageSourceCommands</td>
<td>ImageFiles</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>/scan [SourceName]</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RecognitionCommands</th>
<th>/lang LangName</th>
<th>LangName is the recognition language.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>You can specify several recognition languages by separating them with spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For a list of supported command line recognition languages, see <a href="#">LangName parameter values for the command line</a>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify a custom recognition language if it is saved in the OCR project folder. To do so, place two &quot;@&quot; symbols before its name, e.g. &quot;@@ UserLang&quot;. A custom language name cannot contain non-alphanumeric symbols like &quot;!&quot; or &quot;.&quot;</td>
</tr>
<tr>
<td>&lt;ExportCommands&gt; - recognition results export</td>
<td>/send Target</td>
<td></td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>---------------</td>
<td></td>
</tr>
<tr>
<td>Target is the name of an external application, to which the recognition results will be sent. Replace &quot;Target&quot; with one of the following:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- MSWord - Microsoft Word;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- MSExcel - Microsoft Excel;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- OpenOffice - Apache OpenOffice;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Mail - your email application (results are in Microsoft Word format);</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Clipboard - the clipboard;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- WebBrowser - your default web browser;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- PDFViewer - your default PDF viewer;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- PowerPoint - Microsoft PowerPoint.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Sample command:

“C:\Program Files\ABBYY FineReader 16\FineReaderOCR.exe” D:\Documents\Guide_German.pdf /lang German /send MSWord

The above command will use the OCR Editor to convert and open the German-language Guide_German.pdf file in Microsoft Word.

To find out more about automatically saving your conversion results, see Using the command line to save the conversion results on program launch.

Command line parameters for comparing documents

To compare two versions of a single document in ABBYY Compare Documents, execute the following command:

Comparator.exe /compare <ImageSourceCommands> <ComparisonCommands>

<table>
<thead>
<tr>
<th>Comparator.exe /compare</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comparator.exe stands for the path to the Comparator.exe file in the program installation folder.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>&lt;ImageSourceCommands&gt; - documents to be compared</th>
</tr>
</thead>
<tbody>
<tr>
<td>/file1:File_1 /file2:File_2</td>
</tr>
<tr>
<td>File_k is the path to the document.</td>
</tr>
<tr>
<td>✓ If the full path contains spaces, put it in quotation marks.</td>
</tr>
<tr>
<td>&lt;ComparisonCommands&gt;</td>
</tr>
<tr>
<td>----------------------</td>
</tr>
<tr>
<td>comparison settings</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Additional options:</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
| Additional options: OptionsList | Replace OptionsList with one or several of the following (separated by commas):

- NoheadersFooters - does not search for headers or footers (the program searches for headers and footers by default);
- IgnorePunctDiff - ignores punctuation differences (the program searches for punctuation errors by default);
- IgnoreOneLetterDiff - ignores differences that are not greater than one letter (the program looks for spelling errors by default);
- UngroupDiff - does not group differences that have been found, including those in the text body, the headers and the footers (the program groups differences by default).

Sample command:

```
```

The above command will launch a comparison of the French-language documents called Document1.pdf and Document2.pdf, and will automatically determine whether to use OCR or the document text. ABBYY Compare Documents will ignore all punctuation differences and will not group the differences it finds.

To find out more about automatically saving comparison results, see [Using the command line to save the comparison results on program launch](#).
**Saving the results via the command line**

💡 Requires a suitable ABBYY FineReader license.

**Using the command line to save the conversion results on program launch**

To convert any scanned documents, PDF files, and/or image files to editable formats and save the results, execute the following command:

```
FineReaderOCR.exe <ImageSourceCommands> <RecognitionCommands> <ExportCommands> <OtherCommands>
```

<table>
<thead>
<tr>
<th>FineReaderOCR.exe</th>
<th>The path to the FineReaderOCR.exe file in the program installation folder.</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;ImageSourceCommands&gt;</td>
<td>- source documents for recognition</td>
</tr>
<tr>
<td></td>
<td>For more information, see <a href="#">Command line parameters for converting documents</a></td>
</tr>
<tr>
<td>&lt;RecognitionCommands&gt;</td>
<td>- recognition parameters</td>
</tr>
<tr>
<td></td>
<td>For more information, see <a href="#">Command line parameters for converting documents</a></td>
</tr>
<tr>
<td>&lt;ExportCommands&gt;</td>
<td>- saving the results</td>
</tr>
<tr>
<td>/out Out.Ext</td>
<td>Out.Ext is the path to the file that contains the recognition results, where .Ext is the file extension. If a file with this name already exists, it will be modified instead.</td>
</tr>
<tr>
<td></td>
<td>For a list of supported file formats, see <a href="#">Supported document formats</a></td>
</tr>
<tr>
<td>&lt;OtherCommands&gt;</td>
<td>/report ReportFile</td>
</tr>
<tr>
<td></td>
<td>Creates a report about the completed conversion task. ReportFile is the path to the report file.</td>
</tr>
</tbody>
</table>

Sample command:

```
"C:\Program Files\ABBYY FineReader 16\FineReaderOCR.exe" D:\Documents\Document1.pdf /lang French /out D:\Documents\Result.docx /report D:\Documents\ReportFile\log.txt
```

The above command will use the OCR Editor to convert and save a French-language file called Document1.pdf into a file called Result.docx. A report file called ReportFile will also be created.

**Using the command line to save the comparison results on program launch**
To compare of two versions of a document and save the result, execute the following command:

**Comparator.exe /compare <ImageSourceCommands> <ComparisonCommands> <ExportCommands>**

<table>
<thead>
<tr>
<th>Comparator.exe /compare</th>
<th>Comparator.exe is the path to the Comparator.exe file in the program installation folder.</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;ImageSourceCommands&gt;</td>
<td>For more information, see <a href="#">Command line parameters for comparing documents</a>.</td>
</tr>
<tr>
<td>- documents to be compared</td>
<td>For more information, see <a href="#">Command line parameters for comparing documents</a>.</td>
</tr>
<tr>
<td>&lt;ComparisonCommands&gt; - comparison settings</td>
<td>For more information, see <a href="#">Command line parameters for comparing documents</a>.</td>
</tr>
<tr>
<td>&lt;ExportCommands&gt; - saving the results</td>
<td>/saveFile:Out.Ext</td>
</tr>
<tr>
<td></td>
<td>/saveMode:SaveMode</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Sample command:

The above command will launch a comparison of the French-language documents Document1.pdf and Document2.pdf. The program will automatically determine whether to use OCR or the existing PDF text. ABBYY Compare Documents will ignore all punctuation differences, will not group any differences it finds, and will save the comparison results in a file called Comparison.docx (as a table).
LangName parameter values for the command line

Below is a list of values for the recognition language parameter when running ABBYY FineReader via the command line. Available comparison languages are marked with an asterisk (*).

- Abkhaz
- Adyghe
- Afrikaans
- Agul
- Albanian
- Altaic
- Arabic
- ArmenianEastern
- ArmenianGrabar
- ArmenianWestern
- Awar
- Aymara
- AzeriCyrillic
- AzeriLatin*
- Bashkir*
- Basic
- Basque
- Belarusian
- Bemba
- Blackfoot
- Breton
- Bugotu
- Bulgarian*
- Buryat
• C++
• Catalan*
• Chamorro
• Chechen
• Chemistry
• ChinesePRC
• ChineseTaiwan
• Chukcha
• Chuvash
• Cobol
• Corsican
• CrimeanTatar
• Croatian*
• Crow
• Czech*
• Danish*
• Dargwa
• Digits
• Dungan
• Dutch*
• DutchBelgian*
• English*
• EskimoCyrillic
• EskimoLatin
• Esperanto
• Estonian*
- Even
- Evenki
- Faeroese
- Fijian
- Finnish*
- Fortran
- French*
- Frisian
- Friulian
- GaelicScottish
- Gagauz
- Galician
- Ganda
- German*
- GermanLuxembourg
- GermanNewSpelling*
- Greek
- Guarani
- Hani
- Hausa
- Hawaiian
- Hebrew*
- Hungarian*
- Icelandic
- Ido
- Indonesian*
• Ingush
• Interlingua
• Irish
• Italian*
• Japanese
• Java
• Kabardian
• Kalmyk
• Karachay-Balkar
• Karakalpak
• Kasub
• Kawa
• Kazakh
• Khakas
• Khanty
• Kikuyu
• Kirgiz
• Kongo
• Korean*
• KoreanHangul*
• Koryak
• Kpelle
• Kumyk
• Kurdish
• Lak
• Lappish
- Latin
- Latvian*
- Lezgin
- Lithuanian*
- Luba
- Macedonian
- Malagasy
- Malay
- Malinke
- Maltese
- Mansi
- Maori
- Mari
- Mathematical
- Maya
- Miao
- Minankabaw
- Mohawk
- Mongol
- Mordvin
- Nahuatl
- Nenets
- Nivkh
- Nogay
- NorwegianBokmal*
- NorwegianNynorsk*
• Nyanja
• Occidental
• Ojibway
• Ossetic
• Papiamento
• Pascal
• PidginEnglish
• Polish*
• PortugueseBrazilian*
• PortugueseStandard*
• Provencal
• Quechua
• RhaetoRomanic
• Romanian*
• RomanianMoldavia
• Romany
• Ruanda
• Rundi
• Russian*
• RussianOldSpelling
• RussianWithAccent
• Samoan
• Selkup
• SerbianCyrillic
• SerbianLatin
• Shona
• Sioux
• Slovak*
• Slovenian*
• Somali
• Sorbian
• Sotho
• Spanish*
• Sunda
• Swahili
• Swazi
• Swedish*
• Tabassaran
• Tagalog
• Tahitian
• Tajik
• Tatar*
• Thai
• Tinpo
• Tongan
• TranscriptionEnglish
• Tswana
• Tun
• Turkish*
• Turkmen
• TurkmenLatin
• Tuvin
- Udmurt
- UighurCyrillic
- UighurLatin
- Ukrainian*
- UzbekCyrillic
- UzbekLatin
- Vietnamese*
- Visayan
- Welsh
- Wolof
- Xhosa
- Yakut
- Yiddish
- Zapotec
- Zulu
Installing, activating, and registering ABBYY FineReader PDF 16

Software piracy hurts software manufacturers and end users alike - using an illegal product is never safe. Legal software ensures that a third party cannot introduce detrimental code changes. ABBYY makes every effort to protect its intellectual property rights and the security of its customers.

ABBY software products include special protection technology which prevents unauthorized use by those who have not entered into a license agreement with ABBYY. To be able to run ABBYY FineReader without any limitations, you need to activate it.

Registration is optional and registered users enjoy certain benefits.

Chapter contents

- System requirements
- Installing and starting ABBYY FineReader
- Activating ABBYY FineReader
- Registering ABBYY FineReader
- Privacy Policy
**System requirements**

**Operating system:**

- Microsoft Windows 11 / 10 (64-bit),

The operating system must support the language you select for the user interface.

**Minimum requirements**

1. 1 GHz or faster x64 processor.
2. 2 GB of RAM: for multiprocessor systems, an additional 512 MB of RAM is required for each additional processor.
3. 1.6 GB of hard disk space for typical program installation and 1.6 GB of free space for optimal program operation.
4. Video card and monitor supporting a resolution 1024x768 or higher.
5. An Internet connection is required to activate your serial number.
6. Keyboard and mouse or other pointing device.

**Recommended requirements**

1. 1.5 GHz or faster x64 Intel® or AMD processor.
2. 4 GB of RAM.
3. 1.6 GB of hard disk space for typical program installation and 1.6 GB of free space for optimal program operation.
4. Video card and monitor supporting a resolution 1024x768 or higher.
5. An Internet connection is required to activate your serial number.
6. Keyboard and mouse or other pointing device.

**Terminal server support**

ABBYY FineReader PDF has been tested with the following terminal servers:


- Citrix Workspace App 1808 (using the *Installed application accessed from a server scenario*), Citrix Virtual Apps and Desktops
Software requirements

- Microsoft Office
- LibreOffice

✓ Install one of the recommended software for quick conversion tasks, comparing documents, or adding new pages in editable formats to PDF documents.

Scanners and MFPs

ABBY FineReader PDF supports TWAIN and WIA-compatible scanners and multi-function printers (MFPs).

✓ For a list of file formats supported by ABBYY FineReader PDF, see Supported document formats.
Installing and starting ABBYY FineReader

Installing ABBYY FineReader on one computer

1. Double-click the Setup.exe file on the installation disk or other distribution media.

2. Follow the on-screen instructions in the Installation Wizard.

Deploying ABBYY FineReader PDF in a LAN

ABBYY FineReader can be installed and used on a local area network*. The automated installation methods give you speed and flexibility when installing ABBYY FineReader on a local area network, as you do not have to install the program manually on each individual workstation.

The installation consists of two stages. First, the program is installed on the server. From the server, the program can be installed on workstations using one of the following four methods:

- Using Active Directory
- Using Microsoft System Center Configuration Manager (SCCM)
- From the command line
- Manually in interactive mode

For more information about installing ABBYY FineReader on workstations, using the License Manager, and working with the program in a local area network, please refer to the System Administrator's Guide.

Starting ABBYY FineReader

To start ABBYY FineReader PDF:

- Click the Start button in Windows and then click All Programs > ABBYY FineReader PDF (in Windows 10, click the Start > All Programs and then click ABBYY FineReader PDF).

- Alternatively, right-click a document file in Windows Explorer (it has to be in one of the supported formats) and then click Edit with ABBYY FineReader PDF or Convert with ABBYY FineReader PDF and select one of the conversion commands.

* This feature is not available in some editions of ABBYY FineReader. See also: FineReader page of the ABBYY website (http://www.ABBYY.com/FineReader/) for a list of editions and their features.
Activating ABBYY FineReader

After you install ABBYY FineReader PDF, you will need to activate the program to be able to run it in full mode. Unless you activate ABBYY FineReader PDF, the program will run in trial mode, which lets you try out the program but limits the number of pages you can save and stops working after a certain period of time.

To activate ABBYY FineReader PDF:

1. In the **New Task** window, click **Help > Activate...**

2. Enter your **serial number** or load a license file if you have one.

Select one of the four activation options displayed in the Activation Wizard:

- **Activation over the Internet**
  Activation is carried out automatically and takes only seconds to complete. An active Internet connection is required for this method.

- **Activation via the ABBYY website**
  1. Click the link in the Activation Wizard to open the activation page.

  2. Copy the **Product ID** in the Activation Wizard and paste it to the corresponding field on the page.

  3. Copy the serial number in the Activation Wizard and paste it to the corresponding field on the page.

  4. Save the license file to your hard disk.

  5. Click **Next** in the Activation Wizard and specify the path to the license file.

  6. Click **Next**.

  ABBYY FineReader PDF will be activated and will run in full mode from now on.

- **Activation by e-mail**
  1. The program will generate an e-mail message with all of the information required for activation.

  2. Send the e-mail message without changing its body text and subject. You will receive a reply message containing a license file.

  3. Save the license file to your hard disk.

  4. Specify the path to the license file in the Activation Wizard.

  ABBYY FineReader PDF will be activated and will run in full mode from now on.
**Activation by e-mail from another computer**

1. Select this activation method if you can't activate ABBYY FineReader PDF on the computer on which it is installed (e.g. if it does not have an Internet connection or cannot send e-mail messages).

2. Save the licensing information to a text file.

3. Create a new e-mail message on a computer that can send e-mail messages. Specify *Activation request* in the **Subject** field and **FineReader-activation@abbyy.com** in the **To** field.

4. Copy the contents of the text file to the e-mail message. Do not make any changes to ensure that your message will be processed automatically and you will receive a prompt reply.

5. Send the message. You will receive a reply message with a license file.

6. Save the license file to your hard disk.

7. Specify the path to the license file in the Activation Wizard.

ABBYY FineReader PDF will be activated and will run in full mode from now on.

After you activate ABBYY FineReader once, you will be able to install it on the same computer any number of times without having to activate it again. However, if significant changes are made to the computer's hardware configuration, its hard disk is formatted or its operating system is reinstalled, you may need to get a license file and activate ABBYY FineReader again.
Registering ABBYY FineReader

We invite you to register your copy of ABBYY FineReader PDF and receive special benefits available to registered users. Registration is optional.

You can register your copy of ABBYY FineReader:

- By providing your contact information when activating your copy of the product.
  - If you choose not to activate ABBYY FineReader during the activation process, you will be able to register it later at any convenient time.

- By clicking Help > Register... and providing your contact information in the registration dialog box

- By completing the registration process on the ABBYY website (https://www.abbyy.com/).

Registered users will receive the following benefits:

1. Free technical support*

2. ABBYY Screenshot Reader, an easy-to-use application for capturing screenshots and recognizing on-screen text.

3. A way to recover your serial number if you lose it (e.g. when reinstalling your operating system).

We will also send you notifications about updates and new versions of products if you indicate your consent to receive these notifications during the registration process.

* See also: the technical support page of the ABBYY website (https://www.abbyy.com/en-us/support/).

Data privacy

We respect your privacy and take great care to protect your information. We will collect, process, and use any data received from you under the condition of confidentiality and in accordance with this Privacy Policy.

We will send you e-mail messages containing product news, pricing information, special offers, and other company and product information only if you agree to receive such information from us by selecting the corresponding option in the product registration dialog box. You can ask us to delete your e-mail address from the mailing list at any time.
Appendix

Chapter contents

- Glossary [374]
- Keyboard shortcuts [380]
**Glossary**

**A**

**Abbreviation** A shortened form of a word or phrase (e.g. MS-DOS for Microsoft Disk Operating System, UN for United Nations, etc.).

**ABBYY FineReader task** A set of consecutive steps the program needs to perform in order to process a document. ABBYY FineReader PDF includes a number of built-in tasks for the most common document processing needs. Users can also create their own custom tasks. Built-in tasks can be launched in the New Task window.

**ABBYY Hot Folder** A scheduling agent that allows users to select a folder with images and specify the time for processing the images in this folder. ABBYY FineReader will automatically process the images from the selected folder.

**ABBYY Screenshot Reader** An application that enables users to create screenshots and recognize texts on them.

**activation** The process of obtaining a special code from ABBYY allowing the user to use his/her copy of the product in full mode on a given computer.

**active area** The currently selected area on an image. An active area can be deleted, moved or modified. To make an area active, click it. The frame enclosing an active area is bold and has sizing handles that can be dragged to change its size.

**ADF** (Automatic Document Feeder) A device that automatically feeds documents to a scanner. A scanner with an ADF can scan multiple pages without manual intervention. ABBYY FineReader can work with multi-page documents.

**ADRT** (Adaptive Document Recognition Technology) A technology that increases the quality of conversion of multi-page documents. For example, it can recognize such elements as headings, headers and footers, footnotes, page numbering, and signatures.

**area** A section of an image enclosed by a frame and containing a certain type of data. Before performing OCR, ABBYY FineReader detects text, picture, table, and barcode areas in order to determine which sections of the image should be recognized and in what order.

**area template** A template that contains information about the size and locations of the areas in similar-looking documents.

**Automated Tasks** A task managing component of ABBYY FineReader PDF that allows you to create, set up, and launch ABBYY FineReader tasks.

**B**
background picture area An image area that contains a picture with text printed over it.

barcode area An image area that contains a barcode.

base form The form of a word to which endings, prefixes or suffixes are added.

brightness An image parameter that reflects the amount of white in an image. Increasing brightness makes the image “whiter”. Specifying a suitable brightness value increases recognition quality. See also: Scanning tips.

C

code page A table of correspondences between characters and their codes. Users can select the characters they need from those available in a code page.

color mode A mode that determines whether document colors are to be retained. Black-and-white images produce smaller OCR projects and are faster to process.

compound word A word made up of two or more existing words. In ABBYY FineReader, a compound word is a word that the program cannot find in its dictionary but which it can create from two or more dictionary words.

D
document analysis The process of identifying the logical structure of a document and areas that contain various types of data. Document analysis can be carried out automatically or manually.

Document Open password A password that prevents users from opening a PDF document unless they type the password specified by the author.

dpi (dots per inch) A measure of image resolution.

document type A parameter that tells the program how the original text was printed (e.g. on a laser printer, on a typewriter, etc.). For laser-printed texts, select Auto, for typewritten texts, select Typewriter, for faxes, select Fax.

driver A software program that controls a computer peripheral (e.g., a scanner, a monitor, etc.).

F

font effects The appearance of a font (e.g. bold, italic, underlined, strikethrough, subscript, superscript, small caps).
headers and footers Images or text in the top or bottom margin of a page. Headers are located at the top of the page and footers are located at the bottom.

I

ignored characters Any non-letter characters found in words (e.g. syllable characters or stress marks). These characters are ignored during the spell check.

inverted image An image with white characters printed against a dark background.

K

keyboard shortcuts Keys or combinations of keys that trigger a specific action when pressed. Using keyboard shortcuts can significantly increase your productivity.
L

License Manager A utility used for managing ABBYY FineReader licenses and activating ABBYY FineReader PDF.

ligature A combination of two or more characters that are "stuck" together (e.g. fi, fl, ffi). Such characters are difficult for ABBYY FineReader to separate. Treating them as one character improves OCR accuracy.

low-confidence characters Characters that may have been recognized by the program incorrectly.

low-confidence words Words that contain one or more low-confidence characters.

M

monospaced font A font (such as Courier New) in which all characters are equally spaced. For better OCR results on monospaced fonts, on the OCR tab of the Options dialog box, select Typewriter in the Document type group of options.

O

OCR (Optical Character Recognition) A technology that enables computers to read text, detect pictures, tables, and other formatting elements.

OCR project A project created by ABBYY FineReader to process a document. It contains the images of the document pages, their recognized text (if any), and the program settings.

OCR project options The set of options that can be selected in the Options dialog box (click Tools>Options... to open this dialog box). These options also include user languages and patterns. OCR project options can be saved and then used in other OCR projects.

omnifont system A recognition system that recognizes characters set in any font without prior training.

optional hyphen An optional hyphen (¬) indicates exactly where a word or word combination should be split if it occurs at the end of a line (e.g. "autoformat" should be split into "auto" and "format"). ABBYY FineReader replaces all hyphens found in dictionary words with optional hyphens.

P

page layout The arrangement of text, tables, pictures, paragraphs, and columns on a page. The fonts, font sizes, font colors, text background, and text orientation are also part of the page layout.

paradigm All grammatical forms of a word.
pattern A set of associations between averaged character images and their respective names. Patterns are created when you train ABBYY FineReader on a specific text.

PDF (Portable Document Format) A commonly used document format. A PDF file looks the same no matter what computer it is displayed on thanks to the detailed descriptions of text, fonts, and graphics it contains.

PDF security settings Restrictions that prevent a PDF document from being opened, edited, copied or printed. These settings include document open passwords, permissions passwords, and encryption levels.

Permissions password A password that prevents other users from printing and editing a PDF document unless they type the password specified by the author. If some security settings are selected for the document, other users will not be able to change these settings until they type the password.

picture area An image area that contains a picture. This type of area may enclose an actual picture or any other object (e.g. a text fragment) that should be displayed as a picture.

product ID A product identifier that is automatically generated on the basis of the hardware configuration when activating ABBYY FineReader on a given computer. It does not contain any personal information or information about the software or data stored on your computer.

prohibited characters Characters that you think will never occur in a text to be recognized. Specifying prohibited characters increases the speed and quality of OCR.

recognition area An image area that ABBYY FineReader should analyze automatically.

resolution A scanning parameter measured in dots per inch (dpi). Resolution of 300 dpi should be used for texts set in 10 pt fonts and larger, 400 to 600 dpi is preferable for texts of smaller font sizes (9 pt and less).

scanner A device for inputting images into a computer.

scanning mode A scanning parameter that determines whether an image must be scanned in black and white, grayscale, or color.

separators Symbols that can separate words (e.g. /, \, dash) and that are separated by spaces from the words themselves.

serial number A unique number you receive when you purchase the program. It is used during activation.
shortcut menu The menu that appears when you right-click something, such as an area or another part of a document.

support ID The unique identifier of a serial number that contains information about the license and the computer on which it is used. A Support ID provides additional protection and is checked by the technical support staff before providing technical support.

table area An image area that contains data in tabular form. When the program reads this type of area, it draws vertical and horizontal separators inside the area to form a table. This area is then rendered as a table in the output text.

tagged PDF A PDF document that contains information about the document structure, such as its logical parts, pictures, and tables. The structure of a document is encoded in PDF tags. A PDF file with such tags may be reflowed to fit different screen sizes, and will display well on handheld devices.

text area An image area that contains text. Text areas should only contain single-column text.

training The process of establishing a correspondence between a character image and the character itself. See also:  If your printed document contains non-standard fonts [11].

Unicode An international text encoding standard developed by the Unicode Consortium (Unicode, Inc.). The Unicode standard provides an easily extendible 16-bit system for encoding symbols from almost all contemporary languages. It specifies how symbols should be encoded and determines which algorithms and character properties should be used during the encoding process.
**Keyboard shortcuts**

ABYY FineReader offers the following keyboard shortcuts for the most commonly used commands.

- **New Task window**
- **OCR Editor**
- **PDF Editor**
- **ABYY Compare Documents**

### New Task window

- **File**
- **Edit**
- **Help**

### File menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New PDF Document</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open PDF Document...</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Open in OCR Editor...</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Scan to OCR Editor</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>New OCR Project</td>
<td>Ctrl+Shift+N</td>
</tr>
<tr>
<td>Open OCR Project...</td>
<td>Ctrl+Shift+O</td>
</tr>
<tr>
<td>Options...</td>
<td>Ctrl+&gt;</td>
</tr>
<tr>
<td>Exit</td>
<td>Ctrl+Q</td>
</tr>
</tbody>
</table>

### Edit menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Up</td>
<td>Alt+↑</td>
</tr>
<tr>
<td>Move Down</td>
<td>Alt+↓</td>
</tr>
<tr>
<td>------------------</td>
<td>--------</td>
</tr>
<tr>
<td>Remove</td>
<td>Del</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Find Recent Documents</td>
<td>Ctrl+F</td>
</tr>
</tbody>
</table>

**Help menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
</tbody>
</table>

**OCR Editor**

- File
- Edit
- View
- Recognize
- Area
- Tools
- Help
- General

**File menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Task...</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open Image...</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Scan Pages...</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Save Page Images As...</td>
<td>Ctrl+Alt+S</td>
</tr>
<tr>
<td>Close</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>New OCR Project</td>
<td>Ctrl+Shift+N</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Open OCR Project...</td>
<td>Ctrl+Shift+O</td>
</tr>
<tr>
<td>Save OCR Project...</td>
<td>Ctrl+Shift+S</td>
</tr>
<tr>
<td>E-mail document</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>E-mail images</td>
<td>Ctrl+Alt+M</td>
</tr>
<tr>
<td>Print text</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Print image</td>
<td>Ctrl+Alt+P</td>
</tr>
<tr>
<td>Exit</td>
<td>Ctrl+Q</td>
</tr>
</tbody>
</table>

## Edit menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Recognize and Copy Text</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Copy Area as Image</td>
<td>Ctrl+Shift+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Cancel Selection</td>
<td>Ctrl+Shift+A</td>
</tr>
<tr>
<td>Delete Pages...</td>
<td>Ctrl+Backspace</td>
</tr>
<tr>
<td>Delete Areas and Text</td>
<td>Ctrl+Del</td>
</tr>
<tr>
<td>Delete Text</td>
<td>Ctrl+Shift+Del</td>
</tr>
<tr>
<td>Rotate Pages Right</td>
<td>Ctrl+Shift+&gt;</td>
</tr>
<tr>
<td>Rotate Pages Left</td>
<td>Ctrl+Shift+&lt;</td>
</tr>
<tr>
<td>Edit Page Images...</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Find...</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Find Next</td>
<td>F3</td>
</tr>
<tr>
<td>Replace...</td>
<td>Ctrl+H</td>
</tr>
</tbody>
</table>

**View menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Navigation Pane</td>
<td>F5</td>
</tr>
<tr>
<td>Show Zoom Pane</td>
<td>Ctrl+F5</td>
</tr>
<tr>
<td>Image Pane Only</td>
<td>F6</td>
</tr>
<tr>
<td>Image and Text Panes</td>
<td>F7</td>
</tr>
<tr>
<td>Text Pane Only</td>
<td>F8</td>
</tr>
<tr>
<td>Next Pane</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td>Previous Pane</td>
<td>Ctrl+Shift+Tab</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Ctrl++</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td>Best Fit</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Go to Page Number...</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Go to Next Page</td>
<td>Ctrl+↓</td>
</tr>
<tr>
<td>Go to Previous Page</td>
<td>Ctrl+↑</td>
</tr>
<tr>
<td>Go to First Page</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td>Go to Last Page</td>
<td>Ctrl+End</td>
</tr>
<tr>
<td>Close Page</td>
<td>Ctrl+F4</td>
</tr>
</tbody>
</table>

**Recognize menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recognize All Pages</td>
<td>Ctrl+Shift+R</td>
</tr>
<tr>
<td>Recognize Page</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Analyze All Pages</td>
<td>Ctrl+Shift+E</td>
</tr>
<tr>
<td>Analyze Page</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Verify Text...</td>
<td>Ctrl+F7</td>
</tr>
<tr>
<td>Next Error</td>
<td>Alt+↓</td>
</tr>
<tr>
<td>Previous Error</td>
<td>Alt+↑</td>
</tr>
<tr>
<td>Mark Text as Verified</td>
<td>Ctrl+T</td>
</tr>
</tbody>
</table>

**Area menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recognize Area</td>
<td>Ctrl+Shift+B</td>
</tr>
<tr>
<td>Change Area Type to Text</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Change Area Type to Table</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Change Area Type to Picture</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>Change Area Type to Background Picture</td>
<td>Ctrl+6</td>
</tr>
<tr>
<td>Change Area Type to Barcode</td>
<td>Ctrl+5</td>
</tr>
<tr>
<td>Change Area Type to Recognition Area</td>
<td>Ctrl+1</td>
</tr>
</tbody>
</table>

**Tools menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Dictionaries...</td>
<td>Ctrl+Alt+D</td>
</tr>
<tr>
<td>Redaction Mode</td>
<td>Ctrl+Shift+H</td>
</tr>
<tr>
<td>Hot Folder</td>
<td>Ctrl+Shift+F</td>
</tr>
<tr>
<td>Options...</td>
<td>Ctrl+&gt;</td>
</tr>
</tbody>
</table>

**Help menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
</table>
General

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make the selected text fragment <strong>bold</strong></td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Make the selected text fragment <em>italic</em></td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Underline the selected text fragment</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Go to table cell</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Switch to Pages pane</td>
<td>Alt+1</td>
</tr>
<tr>
<td>Switch to Image pane</td>
<td>Alt+2</td>
</tr>
<tr>
<td>Switch to Text pane</td>
<td>Alt+3</td>
</tr>
<tr>
<td>Switch to Zoom pane</td>
<td>Alt+4</td>
</tr>
</tbody>
</table>

You can also create your own keyboard shortcuts in the OCR Editor.

To create a shortcut in the OCR Editor:

1. Open the Customize Toolbars and Shortcuts dialog box by clicking View > Toolbars > Customize....
2. On the Keyboard Shortcuts tab, select a category in the Categories field.
3. In the Commands field, select the command for which you want to specify a keyboard shortcut.
4. Place the cursor in the Press new shortcut key field and press the keys to be used for this command.
5. Click Assign. The selected key combination will be added into the Current shortcut field.
6. Click OK to save the changes.
7. To return shortcuts to their default values, click Reset (for a selected command category) or Reset All (for all shortcut keys).

PDF Editor

- File menu
File menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Task...</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open...</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Save as PDF Document...</td>
<td>Ctrl+Shift+S</td>
</tr>
<tr>
<td>Close Document</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Print...</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Options...</td>
<td>Ctrl+&gt;</td>
</tr>
<tr>
<td>Exit</td>
<td>Ctrl+Alt+W</td>
</tr>
</tbody>
</table>

Edit menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>--------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Copy Area as Image</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Copy Area as Text</td>
<td>Ctrl+Shift+C</td>
</tr>
<tr>
<td>Copy Area as Table</td>
<td>Ctrl+Alt+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
</tbody>
</table>

**Document menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Note</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>Highlight</td>
<td>Ctrl+H</td>
</tr>
<tr>
<td>Underline</td>
<td>Ctrl+Shift+U</td>
</tr>
<tr>
<td>Strikethrough</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>Insert Text</td>
<td>Ctrl+J</td>
</tr>
<tr>
<td>Search and Mark Up</td>
<td>Alt+Shift+3</td>
</tr>
<tr>
<td>Recognize Document</td>
<td>Ctrl+Shift+R</td>
</tr>
<tr>
<td>Add Bookmark...</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Find...</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Find Next</td>
<td>F3</td>
</tr>
</tbody>
</table>

**Organize Pages menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Blank Page</td>
<td>Ctrl+Shift+B</td>
</tr>
<tr>
<td>Add Pages from PDF...</td>
<td>Ctrl+Shift+P</td>
</tr>
<tr>
<td>Add Pages from File...</td>
<td>Ctrl+Shift+O</td>
</tr>
<tr>
<td>Add Pages from Scanner...</td>
<td>Ctrl+Shift+K</td>
</tr>
<tr>
<td>Rotate Pages Right</td>
<td>Ctrl+Shift+&gt;</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Rotate Pages Left</td>
<td>Ctrl+Shift+&lt;</td>
</tr>
<tr>
<td>Correct Page Orientation</td>
<td>Ctrl+Shift+/</td>
</tr>
<tr>
<td>Crop Pages</td>
<td>Ctrl+Shift+X</td>
</tr>
<tr>
<td>Replace Pages</td>
<td>Ctrl+Shift+E</td>
</tr>
<tr>
<td>Move Pages</td>
<td>Ctrl+Shift+M</td>
</tr>
<tr>
<td>Delete Pages</td>
<td>Ctrl+Backspace</td>
</tr>
</tbody>
</table>

**Edit Content menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Link...</td>
<td>Ctrl+L</td>
</tr>
</tbody>
</table>

**Security menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redaction Mode</td>
<td>Ctrl+Shift+H</td>
</tr>
<tr>
<td>Erase Text and Pictures</td>
<td>Ctrl+R</td>
</tr>
</tbody>
</table>

**View menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Navigation Pane</td>
<td>F5</td>
</tr>
<tr>
<td>Pages</td>
<td>Alt+Shift+1</td>
</tr>
<tr>
<td>Bookmarks</td>
<td>Alt+Shift+2</td>
</tr>
<tr>
<td>Search</td>
<td>Alt+Shift+3</td>
</tr>
<tr>
<td>Attachments</td>
<td>Alt+Shift+4</td>
</tr>
<tr>
<td>Digital Signatures</td>
<td>Alt+Shift+5</td>
</tr>
<tr>
<td>Show Comments Pane</td>
<td>F7</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Ctrl++</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Best Fit</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Actual Size</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Fit to Width</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Go to Page Number…</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Next Page</td>
<td>Ctrl+↓</td>
</tr>
<tr>
<td>Previous Page</td>
<td>Ctrl+↑</td>
</tr>
<tr>
<td>First Page</td>
<td>Home</td>
</tr>
<tr>
<td>Last Page</td>
<td>End</td>
</tr>
<tr>
<td>Back</td>
<td>Alt+←</td>
</tr>
<tr>
<td>Forward</td>
<td>Alt+→</td>
</tr>
<tr>
<td>One-Page View</td>
<td>Ctrl+5</td>
</tr>
<tr>
<td>One-Page Scrolling</td>
<td>Ctrl+6</td>
</tr>
<tr>
<td>Two-Page View</td>
<td>Ctrl+7</td>
</tr>
<tr>
<td>Two-Page Scrolling</td>
<td>Ctrl+8</td>
</tr>
<tr>
<td>Full Screen</td>
<td>F11</td>
</tr>
</tbody>
</table>

**Help menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
</tbody>
</table>

**General**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Selected Pages</td>
<td>Ctrl+Alt+S</td>
</tr>
</tbody>
</table>

**ABBYY Compare Documents**

- File
Edit menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Comparison</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open Document...</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Close Document</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Save...</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Exit</td>
<td>Ctrl+Q</td>
</tr>
</tbody>
</table>

View menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom In</td>
<td>Ctrl++</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td>Fit to Width</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Next Page</td>
<td>Ctrl+↓</td>
</tr>
</tbody>
</table>
**Previous Page** | Ctrl + ↑

**Compare menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compare Documents</td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>Next Difference</td>
<td>Ctrl + →</td>
</tr>
<tr>
<td>Previous Difference</td>
<td>Ctrl + ←</td>
</tr>
<tr>
<td>Ignore Difference</td>
<td>Del</td>
</tr>
</tbody>
</table>

**Help menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
</tbody>
</table>
Technical support

If you have any questions regarding the use of ABBYY FineReader, which can't be answered using the information provided in the User's Guide and Help, please review the Frequently Asked Questions section in the ABBYY knowledge base.

If you still can't find the answer to your question, please contact the ABBYY technical support service. You can create a new support ticket using an online form at https://support.abbyy.com. Describe your problem in the ticket, and our experts will be glad to assist you.

In the case of a technical issue, please attach a system report file to your support ticket. To generate a system report, click Help > About > System Info... > Save....

If for some reason you are not able to generate a system report, please provide the following information in your support ticket:

- The serial number of your copy or Support ID (click Help > About > License Info to find out the serial number of your copy of the product);
- The build number of your copy (click Help > About);
- Your Windows version;
- Any other information that you think is relevant.

Before contacting the ABBYY technical support service, be sure to check for the latest updates available for your version of ABBYY FineReader and install them. To do this, click Help > Check for Updates.

Technical support is provided only to registered users subject to the Product Life Cycle and Technical Support Policy. To register your copy of the product, please visit our website or click Help > Register... in the product.

Third-party software

Third Party Software/Open Source Software Used in

ABBYY FineReader PDF 16 Release 3

© ABBYY 2023. ABBYY, FineReader and ABBYY FineReader are either registered trademarks or trademarks of ABBYY Development Inc. and/or its affiliates. These designations can also be logos, product or company names (or part of any of the above) of ABBYY Development Inc. and/or its affiliates and may not be used without consent of their respective owners.

This document contains licenses and notices for free/open source as well as third party software used in this product. If you have any questions related to free/open-source and third party software listed in this document, please contact us at legaloperations@abbyy.com.
In your requests please include the following reference number “FR16 for Win, R3 – 02.03.2023”

Licensed under the MIT license

**Little CMS (for Pdfium)**

Copyright (c) 1998-2020 Marti Maria Saguer

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

**expat-2.4.7**

Copyright (c) 1998-2000 Thai Open Source Software Center Ltd and Clark Cooper

Copyright (c) 2001-2019 Expat maintainers

**libexslt**

Copyright (C) 2001-2002 Thomas Broyer, Charlie Bozeman and Daniel Veillard

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

**libxslt**
Copyright (C) 2001-2002 Daniel Veillard. All Rights Reserved.
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

**Little CMS**
Copyright (c) 1998-2020 Marti Maria Saguer

**Anti-Grain Geometry (for Pdfium)**
Copyright (C) 2002-2005 Maxim Shemanarev ([http://www.antigrain.com](http://www.antigrain.com))

**vigra1.6.0**
Copyright 1998-2001 by Ullrich Koethe
Cognitive Systems Group, University of Hamburg, Germany

**mdds_0.3.1**
Copyright (c) 2010-2015 Kohei Yoshida

**libyaml**
Copyright (c) 2006-2016 Kirill Simonov

**jsoncpp**
Copyright (c) 2007-2010 Baptiste Lepilleur
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
Licensed under the MIT-like license

curl-7.66.0
Copyright (c) 1996 - 2018, Daniel Stenberg, <daniel@haxx.se>, and many contributors, see the THANKS file. All rights reserved.
Curl contains pieces of source code that is Copyright (c) 1998, 1999 Kungliga Tekniska Högskolan. COPYRIGHT AND PERMISSION NOTICE
Copyright (c) 1996 - 2021, Daniel Stenberg, daniel@haxx.se, and many contributors, see the THANKS file. https://curl.se/docs/thanks.html

libxslt-1.1.34
Copyright (C) 2001-2002 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

Licensed under the Apache 2.0 License

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

google-diff-match-patch
Google Inc.

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any
form of electronic, verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.

3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:

You must give any other recipients of the Work or Derivative Works a copy of this License; and
You must cause any modified files to carry prominent notices stating that You changed the files; and
You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The
contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License.

8. Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses), even if such Contributor has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for
any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability.

END OF TERMS AND CONDITIONS

**raptor2-2.0.15**

Copyright (C) 2000-2014 David Beckett
Copyright (C) 2000-2005 University of Bristol

**apr-1.5.2**

* Copyright (c) 1987, 1993, 1994
  * The Regents of the University of California. All rights reserved.

/* Copyright (c) 1996 by Internet Software Consortium.
---------------------------------------------------------------
* Jens-Uwe Mager, Helios Software GmbH, Hannover, Germany.
---------------------------------------------------------------------------
Copyright (C) 2000 by Martin Pool <mbp@humbug.org.au>
---------------------------------------------------------------------------
Copyright(C) Caldera International Inc. 2001-2002. All rights reserved.
---------------------------------------------------------------------------

**crosextrafonts 20130214**

Copyright (C) 1994-2018 The FreeBSD Project. All rights reserved.

**BeanShell 2.0b6**

Copyright 1997-2012 Patrick Niemeyer

**apr-util-1.5.4**

Copyright 2002-2011 The Apache Software Foundation

**serf-1.2.1**
This product includes software developed by The Apache Software Foundation (http://www.apache.org/).

**stax-src-1.2.0**
Copyright 2004 BEA Systems, Inc.

**commons-lang-2.4-src**
Apache Commons Lang
Copyright 2001-2015 The Apache Software Foundation

This product includes software developed at The Apache Software Foundation (http://www.apache.org/).

This product includes software from the Spring Framework, under the Apache License 2.0 (see: StringUtils.containsWhitespace

**commons-logging-1.1.1-src**
Copyright 2003-2007 The Apache Software Foundation

**commons-codec-1.6-src**
Apache Commons Codec
Copyright 2002-2011 The Apache Software Foundation

This product includes software developed by The Apache Software Foundation (http://www.apache.org/).

-------------------------------------------------------------------------------------------------------------------------------------


Copyright (C) 2002 Kevin Atkinson (kevina@gnu.org). Verbatim copying and distribution of this entire article is permitted in any medium, provided this notice is preserved.
commons-httpclient-3.1-src
Copyright 2017 The Apache Software Foundation

Zxing - Code translated from Java to CPP (Apache 2.0)
Copyright (C) 2010 ZXing authors

rasqal-0.9.33
Copyright (C) 2003-2014 Dave Beckett
Copyright (C) 2003-2005 University of Bristol

redland-1.0.17
Copyright (C) 2000-2013 Dave Beckett
Copyright (C) 2000-2005 University of Bristol

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

Licensed under the Apache 2.0 License AND SUBCOMPONENTS

apache-tomcat-5.5.36-src
Copyright © The Apache Software Foundation

Apache Open Office
Copyright © The Apache Software Foundation
**Vulkan SDK Version 1.1.130.0**

See copyright here: [https://vulkan.lunarg.com/software/license/vulkan-1.1.130.0-linux-license-summary.txt](https://vulkan.lunarg.com/software/license/vulkan-1.1.130.0-linux-license-summary.txt)

The Vulkan SDK

Only the following portions of the Vulkan SDK are contained in the Software:

(for Windows)

./Include/vulkan/GLSL.std.450.h,GLSL.std.450.h,MIT,,
./Include/vulkan/spirv.h,spirv.h,MIT,,
./Include/vulkan/spirv.hpp,spirv.hpp,MIT,,
./Include/vulkan/spirv.hpp11,spirv.hpp11,Apache-2.0,,
./Include/vulkan/spirv.json,spirv.json,Apache-2.0,,
./Include/vulkan/spirv.lua,spirv.lua,Apache-2.0,,
./Include/vulkan/spirv.py,spirv.py,Apache-2.0,,
./Include/vulkan/vk_icd.h,vk_icd.h,Apache-2.0,,
./Include/vulkan/vk_layer.h,vk_layer.h,Apache-2.0,,
./Include/vulkan/vk_platform.h,vk_platform.h,Apache-2.0,,
./Include/vulkan/vk_sdk_platform.h,vk_sdk_platform.h,Apache-2.0,,
./Include/vulkan/vulkan.h,vulkan.h,Apache-2.0,,
./Include/vulkan/vulkan.hpp,vulkan.hpp,Apache-2.0,,
./Include/vulkan/vulkan_android.h,vulkan_android.h,Apache-2.0,,
./Include/vulkan/vulkan_core.h,vulkan_core.h,Apache-2.0,,
./Include/vulkan/vulkan_fuchsia.h,vulkan_fuchsia.h,Apache-2.0,,
./Include/vulkan/vulkan_ggp.h,vulkan_ggp.h,Apache-2.0,,
./Include/vulkan/vulkan_ios.h,vulkan_ios.h,Apache-2.0,,
./Include/vulkan/vulkan_macos.h,vulkan_macos.h,Apache-2.0,,
./Include/vulkan/vulkan_metal.h,vulkan_metal.h,Apache-2.0,,
./Include/vulkan/vulkan_vi.h,vulkan_vi.h,Apache-2.0,,
./Include/vulkan/vulkan_wayland.h,vulkan_wayland.h,Apache-2.0,,
./Include/vulkan/vulkan_win32.h,vulkan_win32.h,Apache-2.0,,
./Include/vulkan/vulkan_xcb.h,vulkan_xcb.h,Apache-2.0,,
./Include/vulkan/vulkan_xlib.h,vulkan_xlib.h,Apache-2.0,,
./Include/vulkan/vulkan_xlib_xrandr.h,vulkan_xlib_xrandr.h,Apache-2.0,
(for Linux)

./x86_64/include/vulkan/vk_icd.h,vk_icd.h,Apache-2.0,
./x86_64/include/vulkan/vk_layer.h,vk_layer.h,Apache-2.0,
./x86_64/include/vulkan/vk_platform.h,vk_platform.h,Apache-2.0,
./x86_64/include/vulkan/vk_sdk_platform.h,vk_sdk_platform.h,Apache-2.0,
./x86_64/include/vulkan/vulkan.h,vulkan.h,Apache-2.0,
./x86_64/include/vulkan/vulkan.hpp,vulkan.hpp,Apache-2.0,
./x86_64/include/vulkan/vulkan_android.h,vulkan_android.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_core.h,vulkan_core.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_fuchsia.h,vulkan_fuchsia.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_ggp.h,vulkan_ggp.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_ios.h,vulkan_ios.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_macos.h,vulkan_macos.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_metal.h,vulkan_metal.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_win32.h,vulkan_win32.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_xcb.h,vulkan_xcb.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_xlib.h,vulkan_xlib.h,Apache-2.0,
./x86_64/include/vulkan/vulkan_xlib_xrandr.h,vulkan_xlib_xrandr.h,Apache-2.0,

(for MacOS)

./macOS/include/vulkan/vk_icd.h,vk_icd.h,Apache-2.0,
./macOS/include/vulkan/vk_layer.h,vk_layer.h,Apache-2.0,
./macOS/include/vulkan/vk_platform.h,vk_platform.h,Apache-2.0,
./macOS/include/vulkan/vk_sdk_platform.h,vk_sdk_platform.h,Apache-2.0,
./macOS/include/vulkan/vulkan.h,vulkan.h,Apache-2.0,
./macOS/include/vulkan/vulkan.hpp,vulkan.hpp,Apache-2.0,
./macOS/include/vulkan/vulkan_android.h,vulkan_android.h,Apache-2.0,
./macOS/include/vulkan/vulkan_core.h,vulkan_core.h,Apache-2.0,
./macOS/include/vulkan/vulkan_fuchsia.h,vulkan_fuchsia.h,Apache-2.0,
Licensed under BSD-2-clause

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenJPEG (for Pdfium)

* The copyright in this software is being made available under the 2-clauses
* BSD License, included below. This software may be subject to other third party and contributor rights, including patent rights, and no such rights
* are granted under this license.
* Copyright (c) 2002-2014, Universite catholique de Louvain (UCL), Belgium

* Copyright (c) 2002-2014, Professor Benoit Macq

* Copyright (c) 2003-2014, Antonin Descampe

* Copyright (c) 2003-2009, Francois-Olivier Devaux

* Copyright (c) 2005, Herve Drolon, FreImage Team

* Copyright (c) 2002-2003, Yannick Verschueren

* Copyright (c) 2001-2003, David Janssens

* Copyright (c) 2011-2012, Centre National d'Etudes Spatiales (CNES), France

* Copyright (c) 2012, CS Systemes d'Information, France

* All rights reserved.

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

**STASM**

Stasm License Agreement

Copyright (C) 2005-2013, Stephen Milborrow All rights reserved.

Redistribution of Stasm in source and binary forms, with or without modification, is permitted provided that the following conditions are met: * Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimers.
* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimers in the documentation and/or other materials provided with the distribution.

A SIFT patent restriction may be in conflict with the copyright freedoms granted by this license. This license does not give you permission to infringe patents.

This software is provided by the copyright holders and contributors "as is" and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall the copyright holder be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.

**Licensed under BSD 3-clause**

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

**THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.**

**v8/Strongtalk**

Copyright (c) 1994-2006 Sun Microsystems Inc.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are
met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

- Redistribution in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

- Neither the name of Sun Microsystems or the names of contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

**haval**

The source code of HAVAL is released as open source under the BSD license. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

**PDFium**

Copyright 2014 The PDFium Authors

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

**jinja2 (for Pdfium)**

Copyright 2007 Pallets

**Adobe mapping-resources-pdf**

Copyright 1990-2019 Adobe. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of Adobe nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

**Adobe cmap resources**

Copyright 1990-2019 Adobe. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of Adobe nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenCV
Copyright (C) 2000-2019, Intel Corporation, all rights reserved.
Copyright (C) 2009-2011, Willow Garage Inc., all rights reserved.
Copyright (C) 2009-2016, NVIDIA Corporation, all rights reserved.
Copyright (C) 2010-2013, Advanced Micro Devices, Inc., all rights reserved.
Copyright (C) 2015-2016, OpenCV Foundation, all rights reserved.
Copyright (C) 2015-2016, Itseez Inc., all rights reserved.
Third party copyrights are property of their respective owners.

llvm-libcxxabi
Copyright (c) 2003-2019 University of Illinois at Urbana-Champaign.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal with the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
* Redistributions of source code must retain the above copyright notice, this list of conditions and
the following disclaimers.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions
and the following disclaimers in the documentation and/or other materials provided with the
distribution.

* Neither the names of the LLVM Team, University of Illinois at Urbana-Champaign, nor the names of
its contributors may be used to endorse or promote products derived from this Software without
specific prior written permission.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
CONTRIBUTORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS WITH THE SOFTWARE.

=================================================

Copyrights and Licenses for Third Party Software Distributed with LLVM:

=================================================

The LLVM software contains code written by third parties. Such software will
have its own individual LICENSE.TXT file in the directory in which it appears.
This file will describe the copyrights, license, and restrictions which apply
to that code.

The disclaimer of warranty in the University of Illinois Open Source License
applies to all code in the LLVM Distribution, and nothing in any of the
other licenses gives permission to use the names of the LLVM Team or the
University of Illinois to endorse or promote products derived from this
Software.

The following pieces of software have additional or alternate copyrights, licenses, and/or restrictions:

<table>
<thead>
<tr>
<th>Program</th>
<th>Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>-------</td>
<td>---------</td>
</tr>
</tbody>
</table>
Google Test llvmlutils/unittest/googletest
OpenBSD regex llvmlib/support/reg, COPYRIGHT.regex
pyyaml tests llvmlib/test/YAMLParser/*data, LICENSE.TXT
ARM contributions llvmlib/target/ARM/LICENSE.TXT
md5 contributions llvmlib/support/MD5.cpp llvmlib/include/llvm/Support/MD5.h
Downloads are available at: https://releases.llvm.org/

**GDCM**

Copyright (c) 2006-2016 Mathieu Malaterre

Copyright (c) 1993-2005 CREATIS

(CREATIS = Centre de Recherche et d'Applications en Traitement de l'Image). All rights reserved.

**hsqldb_1_8_0**

Copyright (c) 2001-2005, The HSQL Development Group. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of the HSQL Development Group nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL HSQL DEVELOPMENT GROUP, HSQLDB.ORG, OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
libtextcat-2.2

Copyright (c) 2003, WiseGuys Internet B.V.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

- Neither the name of the WiseGuys Internet B.V. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

BRISK

Copyright (C) 2011 The Autonomous Systems Lab (ASL), ETH Zurich, Stefan Leutenegger, Simon Lynen and Margarita Chli.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the ASL nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE

**AGAST++**

Copyright (c) 2010, Elmar Mair. All rights reserved

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the ASL nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE

**FAST detector**
Copyright (c) 2006, 2008, 2009, 2010 Edward Rosten

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the University of Cambridge nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

AKAZE

Copyright (c) 2013, Pablo Fernandez Alcantarilla, Jesus Nuevo. All Rights Reserved

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the ASL nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE

**KAZE**

Copyright (c) 2012, Pablo Fernández Alcantarilla. All Rights Reserved

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the ASL nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE

**Licensed under Mozilla Public License 2.0.**

**Eigen**

The source code version of Eigen may be found at https://github.com/eigenteam/eigen-git-mirror

Mozilla Public License
1. Definitions

1.1. “Contributor”
means each individual or legal entity that creates, contributes to the creation of, or owns Covered Software.

1.2. “Contributor Version”
means the combination of the Contributions of others (if any) used by a Contributor and that particular Contributor’s Contribution.

1.3. “Contribution”
means Covered Software of a particular Contributor.

1.4. “Covered Software”
means Source Code Form to which the initial Contributor has attached the notice in Exhibit A, the Executable Form of such Source Code Form, and Modifications of such Source Code Form, in each case including portions thereof.

1.5. “Incompatible With Secondary Licenses”
means

a. that the initial Contributor has attached the notice described in Exhibit B to the Covered Software; or

b. that the Covered Software was made available under the terms of version 1.1 or earlier of the License, but not also under the terms of a Secondary License.

1.6. “Executable Form”
means any form of the work other than Source Code Form.

1.7. “Larger Work”
means a work that combines Covered Software with other material, in a separate file or files, that is not Covered Software.

1.8. “License”
means this document.

1.9. “Licensable”
means having the right to grant, to the maximum extent possible, whether at the time of the initial grant or subsequently, any and all of the rights conveyed by this License.

1.10. “Modifications”
means any of the following:

a. any file in Source Code Form that results from an addition to, deletion from, or modification of the contents of Covered Software; or

b. any new file in Source Code Form that contains any Covered Software.

1.11. “Patent Claims” of a Contributor

means any patent claim(s), including without limitation, method, process, and apparatus claims, in any patent Licensable by such Contributor that would be infringed, but for the grant of the License, by the making, using, selling, offering for sale, having made, import, or transfer of either its Contributions or its Contributor Version.

1.12. “Secondary License”

means either the GNU General Public License, Version 2.0, the GNU Lesser General Public License, Version 2.1, the GNU Affero General Public License, Version 3.0, or any later versions of those licenses.

1.13. “Source Code Form”

means the form of the work preferred for making modifications.

1.14. “You” (or “Your”)

means an individual or a legal entity exercising rights under this License. For legal entities, “You” includes any entity that controls, is controlled by, or is under common control with You. For purposes of this definition, “control” means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2. License Grants and Conditions

2.1. Grants

Each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license:

a. under intellectual property rights (other than patent or trademark) Licensable by such Contributor to use, reproduce, make available, modify, display, perform, distribute, and otherwise exploit its Contributions, either on an unmodified basis, with Modifications, or as part of a Larger Work; and
b. under Patent Claims of such Contributor to make, use, sell, offer for sale, have made, import, and otherwise transfer either its Contributions or its Contributor Version.

2.2. Effective Date

The licenses granted in Section 2.1 with respect to any Contribution become effective for each Contribution on the date the Contributor first distributes such Contribution.

2.3. Limitations on Grant Scope

The licenses granted in this Section 2 are the only rights granted under this License. No additional rights or licenses will be implied from the distribution or licensing of Covered Software under this License. Notwithstanding Section 2.1(b) above, no patent license is granted by a Contributor:

a. for any code that a Contributor has removed from Covered Software; or

b. for infringements caused by: (i) Your and any other third party’s modifications of Covered Software, or (ii) the combination of its Contributions with other software (except as part of its Contributor Version); or

c. under Patent Claims infringed by Covered Software in the absence of its Contributions.

This License does not grant any rights in the trademarks, service marks, or logos of any Contributor (except as may be necessary to comply with the notice requirements in Section 3.4).

2.4. Subsequent Licenses

No Contributor makes additional grants as a result of Your choice to distribute the Covered Software under a subsequent version of this License (see Section 10.2) or under the terms of a Secondary License (if permitted under the terms of Section 3.3).

2.5. Representation
Each Contributor represents that the Contributor believes its Contributions are its original creation(s) or it has sufficient rights to grant the rights to its Contributions conveyed by this License.

2.6. Fair Use

This License is not intended to limit any rights You have under applicable copyright doctrines of fair use, fair dealing, or other equivalents.

2.7. Conditions

Sections 3.1, 3.2, 3.3, and 3.4 are conditions of the licenses granted in Section 2.1.

3. Responsibilities

3.1. Distribution of Source Form

All distribution of Covered Software in Source Code Form, including any Modifications that You create or to which You contribute, must be under the terms of this License. You must inform recipients that the Source Code Form of the Covered Software is governed by the terms of this License, and how they can obtain a copy of this License. You may not attempt to alter or restrict the recipients’ rights in the Source Code Form.

3.2. Distribution of Executable Form

If You distribute Covered Software in Executable Form then:

a. such Covered Software must also be made available in Source Code Form, as described in Section 3.1, and You must inform recipients of the Executable Form how they can obtain a copy of such Source Code Form by reasonable means in a timely manner, at a charge no more than the cost of distribution to the recipient; and

b. You may distribute such Executable Form under the terms of this License, or sublicense it under different terms, provided that the license for the Executable Form does not attempt to limit or alter the recipients’ rights in the Source Code Form under this License.

3.3. Distribution of a Larger Work
You may create and distribute a Larger Work under terms of Your choice, provided that You also comply with the requirements of this License for the Covered Software. If the Larger Work is a combination of Covered Software with a work governed by one or more Secondary Licenses, and the Covered Software is not Incompatible With Secondary Licenses, this License permits You to additionally distribute such Covered Software under the terms of such Secondary License(s), so that the recipient of the Larger Work may, at their option, further distribute the Covered Software under the terms of either this License or such Secondary License(s).

3.4. Notices

You may not remove or alter the substance of any license notices (including copyright notices, patent notices, disclaimers of warranty, or limitations of liability) contained within the Source Code Form of the Covered Software, except that You may alter any license notices to the extent required to remedy known factual inaccuracies.

3.5. Application of Additional Terms

You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Covered Software. However, You may do so only on Your own behalf, and not on behalf of any Contributor. You must make it absolutely clear that any such warranty, support, indemnity, or liability obligation is offered by You alone, and You hereby agree to indemnify every Contributor for any liability incurred by such Contributor as a result of warranty, support, indemnity or liability terms You offer. You may include additional disclaimers of warranty and limitations of liability specific to any jurisdiction.

4. Inability to Comply Due to Statute or Regulation

If it is impossible for You to comply with any of the terms of this License with respect to some or all of the Covered Software due to statute, judicial order, or regulation then You must: (a) comply with the terms of this License to the maximum extent possible; and (b) describe the limitations and the code they affect. Such description must be placed in a text file included with all distributions of the Covered Software under this License. Except to the extent prohibited by statute or regulation, such description must be sufficiently detailed for a recipient of ordinary skill to be able to understand it.

5. Termination

5.1. The rights granted under this License will terminate automatically if You fail to comply with any of its terms. However, if You become compliant, then the rights granted under this License from a particular Contributor are reinstated (a) provisionally, unless and until such Contributor explicitly and
finally terminates Your grants, and (b) on an ongoing basis, if such Contributor fails to notify You of
the non-compliance by some reasonable means prior to 60 days after You have come back into
compliance. Moreover, Your grants from a particular Contributor are reinstated on an ongoing basis if
such Contributor notifies You of the non-compliance by some reasonable means, this is the first time
You have received notice of non-compliance with this License from such Contributor, and You become
compliant prior to 30 days after Your receipt of the notice.

5.2. If You initiate litigation against any entity by asserting a patent infringement claim (excluding
declaratory judgment actions, counter-claims, and cross-claims) alleging that a Contributor Version
directly or indirectly infringes any patent, then the rights granted to You by any and all Contributors for
the Covered Software under Section 2.1 of this License shall terminate.

5.3. In the event of termination under Sections 5.1 or 5.2 above, all end user license agreements
(excluding distributors and resellers) which have been validly granted by You or Your distributors
under this License prior to termination shall survive termination.

6. Disclaimer of Warranty

Covered Software is provided under this License on an "as is" basis, without warranty of any kind,
either expressed, implied, or statutory, including, without limitation, warranties that the Covered
Software is free of defects, merchantable, fit for a particular purpose or non-infringing. The entire risk
as to the quality and performance of the Covered Software is with You. Should any Covered Software
prove defective in any respect, You (not any Contributor) assume the cost of any necessary servicing,
repair, or correction. This disclaimer of warranty constitutes an essential part of this License. No use of
any Covered Software is authorized under this License except under this disclaimer.

7. Limitation of Liability

Under no circumstances and under no legal theory, whether tort (including negligence), contract, or
otherwise, shall any Contributor, or anyone who distributes Covered Software as permitted above, be
liable to You for any direct, indirect, special, incidental, or consequential damages of any character
including, without limitation, damages for lost profits, loss of goodwill, work stoppage, computer
failure or malfunction, or any and all other commercial damages or losses, even if such party shall
have been informed of the possibility of such damages. This limitation of liability shall not apply to
liability for death or personal injury resulting from such party's negligence to the extent applicable law
prohibits such limitation. Some jurisdictions do not allow the exclusion or limitation of incidental or
consequential damages, so this exclusion and limitation may not apply to You.

8. Litigation
Any litigation relating to this License may be brought only in the courts of a jurisdiction where the defendant maintains its principal place of business and such litigation shall be governed by laws of that jurisdiction, without reference to its conflict-of-law provisions. Nothing in this Section shall prevent a party's ability to bring cross-claims or counter-claims.

9. Miscellaneous

This License represents the complete agreement concerning the subject matter hereof. If any provision of this License is held to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable. Any law or regulation which provides that the language of a contract shall be construed against the drafter shall not be used to construe this License against a Contributor.

10. Versions of the License

10.1. New Versions

Mozilla Foundation is the license steward. Except as provided in Section 10.3, no one other than the license steward has the right to modify or publish new versions of this License. Each version will be given a distinguishing version number.

10.2. Effect of New Versions

You may distribute the Covered Software under the terms of the version of the License under which You originally received the Covered Software, or under the terms of any subsequent version published by the license steward.

10.3. Modified Versions

If you create software not governed by this License, and you want to create a new license for such software, you may create and use a modified version of this License if you rename the license and remove any references to the name of the license steward (except to note that such modified license differs from this License).

10.4. Distributing Source Code Form that is Incompatible With Secondary Licenses

If You choose to distribute Source Code Form that is Incompatible With Secondary Licenses under the terms of this version of the License, the notice described in Exhibit B of this License must be attached.
Exhibit A - Source Code Form License Notice

This Source Code Form is subject to the terms of the Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with this file, You can obtain one at https://mozilla.org/MPL/2.0/.

If it is not possible or desirable to put the notice in a particular file, then You may include the notice in a location (such as a LICENSE file in a relevant directory) where a recipient would be likely to look for such a notice.

You may add additional accurate notices of copyright ownership.

Exhibit B - “Incompatible With Secondary Licenses” Notice

This Source Code Form is “Incompatible With Secondary Licenses”, as defined by the Mozilla Public License, v. 2.0.

Licensed under OpenSSL License

OpenSSL 1.0.2c

Copyright (c) 1998-2011 The OpenSSL Project. All rights reserved.

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).

Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)

Eric Young is the author of the parts of the library used.

This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Redistribution and use in source and binary forms, with or without * modification, are permitted provided that the following conditions * are met: * * 1. Redistributions of source code must retain the above copyright * notice, this list of conditions and the following disclaimer. * * 2. Redistributions in binary form must reproduce the above copyright * notice, this list of conditions and the following disclaimer in * the documentation and/or other materials provided with the * distribution. * * 3. All advertising materials mentioning features or use of this * software must display the following acknowledgment:* "This product includes software developed by the OpenSSL Project * for use in
the OpenSSL Toolkit. (http://www.openssl.org/) ** 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to * endorse or promote products derived from this software without * prior written permission. For written permission, please contact openssl-core@openssl.org. ** 5. Products derived from this software may not be called "OpenSSL" * nor may "OpenSSL" appear in their names without prior written * permission of the OpenSSL Project. ** 6. Redistributions of any form whatsoever must retain the following * acknowledgment: * "This product includes software developed by the OpenSSL Project * for use in the OpenSSL Toolkit (http://www.openssl.org/) ** THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT "AS IS" AND ANY * EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED * OF THE POSSIBILITY OF SUCH DAMAGE. *

====================================================================

= ** This product includes cryptographic software written by Eric Young * (eay@cryptsoft.com). This product includes software written by Tim * Hudson (tjh@cryptsoft.com). ** /

Original SSLeay License -----------------------
/* Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) * All rights reserved. ** This package is an SSL implementation written * by Eric Young (eay@cryptsoft.com). * The implementation was written so as to conform with Netscapes SSL. ** This library is free for commercial and non-commercial use as long as * the following conditions are heared to. The following conditions * apply to all code found in this distribution, be it the RC4, RSA, * lhash, DES, etc., code; not just the SSL code. The SSL documentation * included with this distribution is covered by the same copyright terms * except that the holder is Tim Hudson (tjh@cryptsoft.com). ** Copyright remains Eric Young's, and as such any Copyright notices in * the code are not to be removed. ** If this package is used in a product, Eric Young should be given attribution * as the author of the parts of the library used. ** This can be in the form of a textual message at program startup or * in documentation (online or textual) provided with the package. ** Redistribution and use in source and binary forms, with or without * modification, are permitted provided that the following conditions * are met: ** 1. Redistributions of source code must retain the copyright * notice, this list of conditions and the following disclaimer. ** 2. Redistributions in binary form must reproduce the above copyright * notice, this list of conditions and the following disclaimer in the * documentation and/or other materials provided with the distribution. ** 3. All advertising materials mentioning features or use of this software * must display the following acknowledgement: ** "This product includes cryptographic software written by * Eric Young (eay@cryptsoft.com)" ** The word 'cryptographic' can be left out if the rouines from the library * being used are not cryptographic related :-) ** 4. If you include any Windows specific code (or a * derivative thereof) from * the apps directory (application code) you must include an * acknowledgement: ** "This product includes software written by Tim Hudson (tjh@cryptsoft.com)" ** THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND * ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. * * The licence and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution licence [including the GNU Public Licence.] */

**OpenSSL 1.1.1d**

Copyright 1999-2019 The OpenSSL Project Authors. All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

   "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. ([http://www.openssl.org/](http://www.openssl.org/))"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment:

   "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit ([http://www.openssl.org/](http://www.openssl.org/))"

   THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT `AS IS` AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License

Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)

All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are aheared to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, Ihash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed.

If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

   "This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)"

The word 'cryptographic' can be left out if the rouines from the library being used are not cryptographic related :-).

4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement:
This product includes software written by Tim Hudson (tjh@cryptsoft.com)

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The licence and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution licence [including the GNU Public Licence.]

Licensed under the Microsoft licenses

SharePoint Server 2013 Client Components SDK

The Software accompanied by this documentation contains redistributable parts of SharePoint Server 2013 Client Components SDK.

© Microsoft Corporation. All rights reserved. Microsoft is either registered trademark or trademark of Microsoft Corporation in the United States and/or other countries. Licensed under the terms of Microsoft Software License Terms.

Export restrictions. The Microsoft Technologies are subject to United States export laws and regulations. The Developer must comply with all domestic and international export laws and regulations that apply to the Microsoft Technologies. These laws include restrictions on destinations, end users and end use. For additional information, see www.microsoft.com/exporting.

Microsoft Windows SDK for Windows 7

MICROSOFT SOFTWARE LICENSE TERMSMICROSOFT WINDOWS SOFTWARE DEVELOPMENT KIT FOR WINDOWS 7 and .NET FRAMEWORK 4

These license terms are an agreement between Microsoft Corporation (or based on where you live, one of its affiliates) and you.

Please read them. They apply to the software named above, which includes the media on which you received it, if any. The terms also apply to any Microsoft updates, supplements, Internet-based services, and support services for this software, unless other terms accompany those items. If so, those terms apply.

BY USING THE SOFTWARE, YOU ACCEPT THESE TERMS. IF YOU DO NOT ACCEPT THEM, DO NOT USE THE SOFTWARE. If you comply with these license terms, you have the rights below.

1. INSTALLATION AND USE RIGHTS.
a. **Installation and Use.** You may install and use any number of copies of the software on your
devices to design, develop and test your programs that run on a Microsoft Windows operating system.
Further, you may install, use and/or deploy via a network management system or as part of a desktop
image, any number of copies of the software on computer devices within your internal corporate
network to design, develop and test your programs that run on a Microsoft Windows operating
system. Each copy must be complete, including all copyright and trademark notices. You must require
end users to agree to the terms that protect the software as much as these License terms.
b. **Included Microsoft Programs.** The software contains other Microsoft programs. These license
terms apply to your use of those programs.

2. **ADDITIONAL LICENSING REQUIREMENTS AND/OR USE RIGHTS.**
a. **Distributable Code.** The software contains code that you are permitted to distribute in programs
you develop if you comply with the terms below.

i. Right to Use and Distribute. The code and text files listed below are “Distributable
Code.”  
· **REDIST.TXT Files.** You may copy and distribute the object code form of code listed in
   REDIST.TXT files, plus any files listed on the REDIST list located at <http://go.microsoft.com/fwlink/?
   LinkID=185268&clcid=0x409>.
· **Sample Code.** You may modify, copy, and distribute the source and object code form of code marked
   as “sample.”  
· **Sample Code for Microsoft Bing Maps AJAX Control.** The software contains sample code
   that makes use of the Bing Maps AJAX Control. Your use and access of the Bing Maps AJAX Control is
   subject to the “Microsoft Bing Maps Platform API’s Terms of Use” which is located at:
   <http://go.microsoft.com/fwlink/?LinkID=185267&clcid=0x409>.
· **Microsoft Merge Modules.** You may copy and distribute the unmodified output of Microsoft Merge
   Modules.
· **Third Party Distribution.** You may permit distributors of your programs to copy and distribute the
   Distributable Code as part of those programs.

ii. Distribution Requirements.

For any Distributable Code you distribute, you must:

· add significant primary functionality to it in your programs;
· for any Distributable Code having a filename extension of .lib, distribute only the results of running
  such Distributable Code through a linker with your application;
· distribute Distributable Code included in a setup program only as part of that setup program
  without modification;
· require distributors and external end users to agree to terms that protect it at least as much as this
  agreement;
· display your valid copyright notice on your programs;
· for Distributable Code from the Windows Media Services SDK portions of the software, include in
  your program’s Help-About box (or in another obvious place if there is no box) the following
copyright notice: “Portions utilize Microsoft Windows Media Technologies. Copyright (c) 2006 Microsoft Corporation. All Rights Reserved”;

• and indemnify, defend, and hold harmless Microsoft from any claims, including attorneys’ fees, related to the distribution or use of your programs.

iii. Distribution Restrictions. You may not alter any copyright, trademark or patent notice in the Distributable Code; use Microsoft’s trademarks in your programs’ names or in a way that suggests your programs come from or are endorsed by Microsoft; distribute Distributable Code to run on a platform other than the Windows platform; include Distributable Code in malicious, deceptive or unlawful programs; or modify or distribute the source code of any Distributable Code so that any part of it becomes subject to an Excluded License. An Excluded License is one that requires, as a condition of use, modification or distribution, that the code be disclosed or distributed in source code form; or others have the right to modify it.

b. Additional Functionality. Microsoft may provide additional functionality for the software. Other license terms and fees may apply.

3. INTERNET-BASED SERVICES. Microsoft provides Internet-based services with the software. It may change or cancel them at any time. You may not use this service in any way that could harm it or impair anyone else’s use of it. You may not use the service to try to gain unauthorized access to any service, data, account or network by any means.

4. Scope of License. The software is licensed, not sold. This agreement only gives you some rights to use the software. Microsoft reserves all other rights. Unless applicable law gives you more rights despite this limitation, you may use the software only as expressly permitted in this agreement. In doing so, you must comply with any technical limitations in the software that only allow you to use it in certain ways. For more information, see www.microsoft.com/licensing/userights <http://www.microsoft.com/licensing/userights>.

You may not work around any technical limitations in the software; reverse engineer, decompile or disassemble the software, except and only to the extent that applicable law expressly permits, despite this limitation; make more copies of the software than specified in this agreement or allowed by applicable law, despite this limitation; publish the software for others to copy; rent, lease or lend the software; or use the software for commercial software hosting services.

5. BACKUP COPY. You may make one backup copy of the software. You may use it only to reinstall the software.

6. DOCUMENTATION. Any person that has valid access to your computer or internal network may copy and use the documentation for your internal, reference purposes.

7. TRANSFER TO A THIRD PARTY. The first user of the software may transfer it, and this agreement, directly to a third party. Before the transfer, that party must agree that this agreement applies to the transfer and use of the software. The first user must uninstall the software before transferring it separately from the device. The first user may not retain any copies.

8. Export Restrictions. The software is subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the software.
These laws include restrictions on destinations, end users and end use. For additional information, see www.microsoft.com/exporting <http://www.microsoft.com/exporting>.

9. SUPPORT SERVICES. Because this software is “as is,” we may not provide support services for it.

10. Entire Agreement. This agreement, and the terms for supplements, updates, Internet-based services and support services that you use, are the entire agreement for the software and support services.

11. Applicable Law.

a. United States. If you acquired the software in the United States, Washington state law governs the interpretation of this agreement and applies to claims for breach of it, regardless of conflict of laws principles. The laws of the state where you live govern all other claims, including claims under state consumer protection laws, unfair competition laws, and in tort.

b. Outside the United States. If you acquired the software in any other country, the laws of that country apply.

12. Legal Effect. This agreement describes certain legal rights. You may have other rights under the laws of your country. You may also have rights with respect to the party from whom you acquired the software. This agreement does not change your rights under the laws of your country if the laws of your country do not permit it to do so.

13. Disclaimer of Warranty. The software is licensed “as-is.” You bear the risk of using it. Microsoft gives no express warranties, guarantees or conditions. You may have additional consumer rights under your local laws which this agreement cannot change. To the extent permitted under your local laws, Microsoft excludes the implied warranties of merchantability, fitness for a particular purpose and non-infringement.

14. Limitation on and Exclusion of Remedies and Damages. You can recover from Microsoft and its suppliers only direct damages up to U.S. $5.00. You cannot recover any other damages, including consequential, lost profits, special, indirect or incidental damages. This limitation applies to anything related to the software, services, content (including code) on third party Internet sites, or third party programs; and claims for breach of contract, breach of warranty, guarantee or condition, strict liability, negligence, or other tort to the extent permitted by applicable law. It also applies even if Microsoft knew or should have known about the possibility of the damages. The above limitation or exclusion may not apply to you because your country may not allow the exclusion or limitation of incidental, consequential or other damages.

**Mapifolders**

Whereas the ABBYY Software incorporates MICROSOFT Outlook 2010: MAPI Header Files or its components (hereinafter referred to as the "Microsoft Technologies"), You agree to be bound by the following Microsoft Software License Terms (the full text may be found at http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=12905):

The Microsoft Technologies or its components are licensed, not sold. This agreement only gives you some rights to use the Microsoft Technologies or its components. Microsoft reserves all other rights.
Unless applicable law gives you more rights despite this limitation, you may use the Microsoft Technologies or its components only as expressly permitted in the Microsoft Software License Terms. In doing so, you must comply with any technical limitations in the Microsoft Technologies or its components that only allow you to use it in certain ways. You may not

* alter any copyright, trademark or patent notice in the Microsoft Technologies or its components;

* use Microsoft's trademarks in Software names or in a way that suggests your Software comes from or is endorsed by Microsoft;

* distribute the Microsoft Technologies to run on a platform other than the Windows platform;

* include the Microsoft Technologies or its components in malicious, deceptive or unlawful programs;

* modify or distribute the source code of the Microsoft Technologies or its components so that any part of it becomes subject to an Excluded License. An Excluded License is one that requires, as a condition of use, modification or distribution, that

* the code be disclosed or distributed in source code form; or

* others have the right to modify it.

* work around any technical limitations in the Microsoft Technologies;

* reverse engineer, decompile or disassemble the Microsoft Technologies, except and only to the extent that applicable law expressly permits, despite this limitation;

* make more copies of the Microsoft Technologies than specified in this Agreement or allowed by applicable law, despite this limitation;

* publish the Microsoft Technologies or its components for others to copy;

* rent, lease or lend the Microsoft Technologies its components;

* use the Microsoft Technologies for commercial software hosting services.

* transfer the Microsoft Technologies or its components to any third party other than as expressly permitted by this Agreement.

EXPORT RESTRICTIONS. The Microsoft Technologies or its components are subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the Microsoft Technologies or its components. These laws include restrictions on destinations, end users and end use. For additional information, see [www.microsoft.com/exporting](http://www.microsoft.com/exporting).

**Licensed under the LibPNG licenses:**

**libjpeg-turbo (for PDFium)**

This component consists of 3 parts each covered by separate licenses - [https://github.com/libjpeg-turbo/libjpeg-turbo/blob/2.1.4/LICENSE.md](https://github.com/libjpeg-turbo/libjpeg-turbo/blob/2.1.4/LICENSE.md).
The IJG (Independent JPEG Group) License

This software is copyright (C) 1991-2020, Thomas G. Lane, Guido Vollbeding.
All Rights Reserved except as specified below.

LEGAL ISSUES

In plain English:

1. We don't promise that this software works. (But if you find any bugs, please let us know!)
2. You can use this software for whatever you want. You don't have to pay us.
3. You may not pretend that you wrote this software. If you use it in a program, you must acknowledge somewhere in your documentation that you've used the IJG code.

In legalese:

The authors make NO WARRANTY or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided "AS IS", and you, its user, assume the entire risk as to its quality and accuracy.

Permission is hereby granted to use, copy, modify, and distribute this software (or portions thereof) for any purpose, without fee, subject to these conditions:

(1) If any part of the source code for this software is distributed, then this README file must be included, with this copyright and no-warranty notice unaltered; and any additions, deletions, or changes to the original files must be clearly indicated in accompanying documentation.

(2) If only executable code is distributed, then the accompanying documentation must state that "this software is based in part on the work of the Independent JPEG Group".

(3) Permission for use of this software is granted only if the user accepts full responsibility for any undesirable consequences; the authors accept NO LIABILITY for damages of any kind.

These conditions apply to any software derived from or based on the IJG code, not just to the unmodified library. If you use our work, you ought to acknowledge us.

Permission is NOT granted for the use of any IJG author's name or company name in advertising or publicity relating to this software or products derived from it. This software may be referred to only as "the Independent JPEG Group's software".
We specifically permit and encourage the use of this software as the basis of commercial products, provided that all warranty or liability claims are assumed by the product vendor.

The Modified (3-clause) BSD License. This license covers the TurboJPEG API library and associated programs, as well as the build system.

Copyright (C)2009-2020 D. R. Commander. All Rights Reserved. Copyright (C)2015 Viktor Szathmáry. All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of the libjpeg-turbo Project nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS", AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The zlib License. This license is a subset of the other two, and it covers the libjpeg-turbo SIMD extensions.

The ZLIB software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.
LibPNG 1.0.7.

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE:

If you modify libpng you may insert additional notices immediately following this sentence.

This code is released under the libpng license.

libpng versions 1.0.7, July 1, 2000 through 1.6.23, June 9, 2016 are Copyright (c) 2000-2002, 2004, 2006-2016 Glenn Randers-Pehrson, are derived from libpng-1.0.6, and are distributed according to the same disclaimer and license as libpng-1.0.6 with the following individuals added to the list of Contributing Authors:

Simon-Pierre Cadieux
Eric S. Raymond
Mans Rullgard
Cosmin Truta
Gilles Vollant
James Yu

and with the following additions to the disclaimer:

There is no warranty against interference with your enjoyment of the library or against infringement. There is no warranty that our efforts or the library will fulfill any of your particular purposes or needs. This library is provided with all faults, and the entire risk of satisfactory quality, performance, accuracy, and effort is with the user.

Some files in the "contrib" directory and some configure-generated files that are distributed with libpng have other copyright owners and are released under other open source licenses.

libpng versions 0.97, January 1998, through 1.0.6, March 20, 2000, are Copyright (c) 1998-2000 Glenn Randers-Pehrson, are derived from libpng-0.96, and are distributed according to the same disclaimer and license as libpng-0.96, with the following individuals added to the list of Contributing Authors:
libpng versions 0.89, June 1996, through 0.96, May 1997, are Copyright (c) 1996-1997 Andreas Dilger, are derived from libpng-0.88, and are distributed according to the same disclaimer and license as libpng-0.88, with the following individuals added to the list of Contributing Authors:

- John Bowler
- Kevin Bracey
- Sam Bushell
- Magnus Holmgren
- Greg Roelofs
- Tom Tanner

Some files in the "scripts" directory have other copyright owners but are released under this license.

libpng versions 0.5, May 1995, through 0.88, January 1996, are Copyright (c) 1995-1996 Guy Eric Schalnat, Group 42, Inc.

For the purposes of this copyright and license, "Contributing Authors" is defined as the following set of individuals:

- Andreas Dilger
- Dave Martindale
- Guy Eric Schalnat
- Paul Schmidt
- Tim Wegner

The PNG Reference Library is supplied "AS IS". The Contributing Authors and Group 42, Inc. disclaim all warranties, expressed or implied, including, without limitation, the warranties of merchantability and of fitness for any purpose. The Contributing Authors and Group 42, Inc. assume no liability for direct, indirect, incidental, special, exemplary, or consequential damages, which may result from the use of the PNG Reference Library, even if advised of the possibility of such damage.
Permission is hereby granted to use, copy, modify, and distribute this source code, or portions hereof, for any purpose, without fee, subject to the following restrictions:

1. The origin of this source code must not be misrepresented.

2. Altered versions must be plainly marked as such and must not be misrepresented as being the original source.

3. This Copyright notice may not be removed or altered from any source or altered source distribution.

The Contributing Authors and Group 42, Inc. specifically permit, without fee, and encourage the use of this source code as a component to supporting the PNG file format in commercial products. If you use this source code in a product, acknowledgment is not required but would be appreciated.

END OF COPYRIGHT NOTICE, DISCLAIMER, and LICENSE.

LibPNG 1.2.6.

libpng versions 1.2.6, August 15, 2004, through 1.2.29, May 8, 2008, are Copyright (c) 2004, 2006-2008 Glenn Randers-Pehrson, and are distributed according to the same disclaimer and license as libpng-1.2.5 with the following individual added to the list of Contributing Authors

Cosmin Truta

libpng versions 1.0.7, July 1, 2000, through 1.2.5 - October 3, 2002, are Copyright (c) 2000-2002 Glenn Randers-Pehrson, and are distributed according to the same disclaimer and license as libpng-1.0.6 with the following individuals added to the list of Contributing Authors

Simon-Pierre Cadieux

Eric S. Raymond

Gilles Vollant

and with the following additions to the disclaimer:
There is no warranty against interference with your enjoyment of the library or against
infringement. There is no warranty that our efforts or the library will fulfill any of your particular
purposes or needs. This library is provided with all faults, and the entire risk of satisfactory quality,
performance, accuracy, and effort is with the user.

libpng versions 0.97, January 1998, through 1.0.6, March 20, 2000, are Copyright (c) 1998, 1999 Glenn
Randers-Pehrson, and are distributed according to the same disclaimer and license as libpng-0.96,
with the following individuals added to the list of Contributing Authors:

  Tom Lane
  Glenn Randers-Pehrson
  Willem van Schaik

libpng versions 0.89, June 1996, through 0.96, May 1997, are Copyright (c) 1996, 1997 Andreas Dilger
Distributed according to the same disclaimer and license as libpng-0.88, with the following individuals
added to the list of Contributing Authors:

  John Bowler
  Kevin Bracey
  Sam Bushell
  Magnus Holmgren
  Greg Roelofs
  Tom Tanner

libpng versions 0.5, May 1995, through 0.88, January 1996, are Copyright (c) 1995, 1996 Guy Eric
Schalnat, Group 42, Inc.

For the purposes of this copyright and license, "Contributing Authors" is defined as the following set of
individuals:

  Andreas Dilger
  Dave Martindale
  Guy Eric Schalnat
  Paul Schmidt
  Tim Wegner
libpng (for Pdfium)

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE

===============================================

PNG Reference Library License version 2

* Copyright (c) 1995-2019 The PNG Reference Library Authors.
* Copyright (c) 2018-2019 Cosmin Truta.
* Copyright (c) 1996-1997 Andreas Dilger.
* Copyright (c) 1995-1996 Guy Eric Schalnat, Group 42, Inc.

The software is supplied "as is", without warranty of any kind, express or implied, including, without limitation, the warranties of merchantability, fitness for a particular purpose, title, and non-infringement. In no event shall the Copyright owners, or anyone distributing the software, be liable for any damages or other liability, whether in contract, tort or otherwise, arising from, out of, or in connection with the software, or the use or other dealings in the software, even if advised of the possibility of such damage.

Permission is hereby granted to use, copy, modify, and distribute this software, or portions hereof, for any purpose, without fee, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated, but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This Copyright notice may not be removed or altered from any source or altered source distribution.

PNG Reference Library License version 1 (for libpng 0.5 through 1.6.35)

===============================================

440
libpng versions 1.0.7, July 1, 2000, through 1.6.35, July 15, 2018 are Copyright (c) 2000-2002, 2004,
2006-2018 Glenn Randers-Pehrson, are derived from libpng-1.0.6, and are distributed according to the
same disclaimer and license as libpng-1.0.6 with the following individuals added to the list of
Contributing Authors:

Simon-Pierre Cadieux
Eric S. Raymond
Mans Rullgard
Cosmin Truta
Gilles Vollant
James Yu
Mandar Sahastrabuddhe
Google Inc.
Vadim Barkov

and with the following additions to the disclaimer:

There is no warranty against interference with your enjoyment of the library or against
infringement. There is no warranty that our efforts or the library will fulfill any of your particular
purposes or needs. This library is provided with all faults, and the entire risk of satisfactory quality,
performance, accuracy, and effort is with the user.

Some files in the "contrib" directory and some configure-generated files that are distributed with
libpng have other copyright owners, and are released under other open source licenses.

libpng versions 0.97, January 1998, through 1.0.6, March 20, 2000, are Copyright (c) 1998-2000 Glenn
Randers-Pehrson, are derived from libpng-0.96, and are distributed according to the same disclaimer
and license as libpng-0.96, with the following individuals added to the list of Contributing Authors:

Tom Lane
Glenn Randers-Pehrson
Willem van Schaik

libpng versions 0.89, June 1996, through 0.96, May 1997, are Copyright (c) 1996-1997 Andreas Dilger,
are derived from libpng-0.88, and are distributed according to the same disclaimer and license as
libpng-0.88, with the following individuals added to the list of Contributing Authors:
Some files in the "scripts" directory have other copyright owners, but are released under this license.

libpng versions 0.5, May 1995, through 0.88, January 1996, are Copyright (c) 1995-1996 Guy Eric Schalnat, Group 42, Inc.

For the purposes of this copyright and license, "Contributing Authors" is defined as the following set of individuals:

Andreas Dilger
Dave Martindale
Guy Eric Schalnat
Paul Schmidt
Tim Wegner

The PNG Reference Library is supplied "AS IS". The Contributing Authors and Group 42, Inc. disclaim all warranties, expressed or implied, including, without limitation, the warranties of merchantability and of fitness for any purpose. The Contributing Authors and Group 42, Inc. assume no liability for direct, indirect, incidental, special, exemplary, or consequential damages, which may result from the use of the PNG Reference Library, even if advised of the possibility of such damage.

Permission is hereby granted to use, copy, modify, and distribute this source code, or portions hereof, for any purpose, without fee, subject to the following restrictions:

1. The origin of this source code must not be misrepresented.

2. Altered versions must be plainly marked as such and must not be misrepresented as being the original source.
3. This Copyright notice may not be removed or altered from any source or altered source distribution.

The Contributing Authors and Group 42, Inc. specifically permit, without fee, and encourage the use of this source code as a component to supporting the PNG file format in commercial products. If you use this source code in a product, acknowledgment is not required but would be appreciated.

**libtiff (for Pdfium)**

Copyright (c) 1988-1997 Sam Leffler

Copyright (c) 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon Graphics. THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

**Licensed under Intel Simplified Software License:**

**Intel Math Kernel Library 2018 Update 4**

Intel Simplified Software License (Version April 2018)

Copyright (c) 2018 Intel Corporation.

Use and Redistribution. You may use and redistribute the software (the “Software”), without modification, provided the following conditions are met:

* Redistributions must reproduce the above copyright notice and the following terms of use in the Software and in the documentation and/or other materials provided with the distribution.

* Neither the name of Intel nor the names of its suppliers may be used to endorse or promote products derived from this Software without specific prior written permission.

* No reverse engineering, decompilation, or disassembly of this Software is permitted.
Limited patent license. Intel grants you a world-wide, royalty-free, non-exclusive license under patents it now or hereafter owns or controls to make, have made, use, import, offer to sell and sell ("Utilize") this Software, but solely to the extent that any such patent is necessary to Utilize the Software alone. The patent license shall not apply to any combinations which include this software. No hardware per se is licensed hereunder.

Third party and other Intel programs. "Third Party Programs" are the files listed in the "third-party-programs.txt" text file that is included with the Software and may include Intel programs under separate license terms. Third Party Programs, even if included with the distribution of the Materials, are governed by separate license terms and those license terms solely govern your use of those programs.

DISCLAIMER. THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT ARE DISCLAIMED. THIS SOFTWARE IS NOT INTENDED FOR USE IN SYSTEMS OR APPLICATIONS WHERE FAILURE OF THE SOFTWARE MAY CAUSE PERSONAL INJURY OR DEATH AND YOU AGREE THAT YOU ARE FULLY RESPONSIBLE FOR ANY CLAIMS, COSTS, DAMAGES, EXPENSES, AND ATTORNEYS' FEES ARISING OUT OF ANY SUCH USE, EVEN IF ANY CLAIM ALLEGES THAT INTEL WAS NEGLIGENT REGARDING THE DESIGN OR MANUFACTURE OF THE MATERIALS.

LIMITATION OF LIABILITY. IN NO EVENT WILL INTEL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

YOU AGREE TO INDEMNIFY AND HOLD INTEL HARMLESS AGAINST ANY CLAIMS AND EXPENSES RESULTING FROM YOUR USE OR UNAUTHORIZED USE OF THE SOFTWARE.

No support. Intel may make changes to the Software, at any time without notice, and is not obligated to support, update or provide training for the Software.

Termination. Intel may terminate your right to use the Software in the event of your breach of this Agreement and you fail to cure the breach within a reasonable period of time.

Feedback. Should you provide Intel with comments, modifications, corrections, enhancements or other input ("Feedback") related to the Software Intel will be free to use, disclose, reproduce, license or otherwise distribute or exploit the Feedback in its sole discretion without any obligations or restrictions of any kind, including without limitation, intellectual property rights or licensing obligations.

Compliance with laws. You agree to comply with all relevant laws and regulations governing your use, transfer, import or export (or prohibition thereof) of the Software.

Governing law. All disputes will be governed by the laws of the United States of America and the State of Delaware without reference to conflict of law principles and subject to the exclusive jurisdiction of the state or federal courts sitting in the State of Delaware, and each party agrees that it submits to the personal jurisdiction and venue of those courts and waives any objections. The United Nations Convention on Contracts for the International Sale of Goods (1980) is
specifically excluded and will not apply to the Software.

*Other names and brands may be claimed as the property of others.

**Intel® Integrated Performance Primitives (Intel® IPP) 2018**

Intel Simplified Software License (Version April 2018)

Copyright (c) 2018 Intel Corporation.

Use and Redistribution. You may use and redistribute the software (the “Software”), without modification, provided the following conditions are met:

* Redistributions must reproduce the above copyright notice and the following terms of use in the Software and in the documentation and/or other materials provided with the distribution.

* Neither the name of Intel nor the names of its suppliers may be used to endorse or promote products derived from this Software without specific prior written permission.

* No reverse engineering, decompilation, or disassembly of this Software is permitted.

Limited patent license. Intel grants you a world-wide, royalty-free, non-exclusive license under patents it now or hereafter owns or controls to make, have made, use, import, offer to sell and sell (“Utilize”) this Software, but solely to the extent that any such patent is necessary to Utilize the Software alone. The patent license shall not apply to any combinations which include this software. No hardware per se is licensed hereunder.

Third party and other Intel programs. “Third Party Programs” are the files listed in the “third-party-programs.txt” text file that is included with the Software and may include Intel programs under separate license terms. Third Party Programs, even if included with the distribution of the Materials, are governed by separate license terms and those license terms solely govern your use of those programs.

**DISCLAIMER.** THIS SOFTWARE IS PROVIDED “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT ARE DISCLAIMED. THIS SOFTWARE IS NOT INTENDED FOR USE IN SYSTEMS OR APPLICATIONS WHERE FAILURE OF THE SOFTWARE MAY CAUSE PERSONAL INJURY OR DEATH AND YOU AGREE THAT YOU ARE FULLY RESPONSIBLE FOR ANY CLAIMS, COSTS, DAMAGES, EXPENSES, AND ATTORNEYS’ FEES ARISING OUT OF ANY SUCH USE, EVEN IF ANY CLAIM ALLEGES THAT INTEL WAS NEGLIGENT REGARDING THE DESIGN OR MANUFACTURE OF THE MATERIALS.

**LIMITATION OF LIABILITY.** IN NO EVENT WILL INTEL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. YOU AGREE TO INDEMNIFY AND HOLD INTEL HARMLESS AGAINST ANY CLAIMS AND EXPENSES RESULTING FROM YOUR USE OR UNAUTHORIZED USE OF THE SOFTWARE.
No support. Intel may make changes to the Software, at any time without notice, and is not obligated to support, update or provide training for the Software.

Termination. Intel may terminate your right to use the Software in the event of your breach of this Agreement and you fail to cure the breach within a reasonable period of time.

Feedback. Should you provide Intel with comments, modifications, corrections, enhancements or other input (“Feedback”) related to the Software Intel will be free to use, disclose, reproduce, license or otherwise distribute or exploit the Feedback in its sole discretion without any obligations or restrictions of any kind, including without limitation, intellectual property rights or licensing obligations.

Compliance with laws. You agree to comply with all relevant laws and regulations governing your use, transfer, import or export (or prohibition thereof) of the Software.

Governing law. All disputes will be governed by the laws of the United States of America and the State of Delaware without reference to conflict of law principles and subject to the exclusive jurisdiction of the state or federal courts sitting in the State of Delaware, and each party agrees that it submits to the personal jurisdiction and venue of those courts and waives any objections. The United Nations Convention on Contracts for the International Sale of Goods (1980) is specifically excluded and will not apply to the Software.

*Other names and brands may be claimed as the property of others.

*Intel® Integrated Performance Primitives (Intel® IPP) Library 2020*

Intel Simplified Software License (Version February 2020)

Copyright (c) 2020 Intel Corporation.

Use and Redistribution. You may use and redistribute the software (the “Software”), without modification, provided the following conditions are met:

Redistributions must reproduce the above copyright notice and the following terms of use in the Software and in the documentation and/or other materials provided with the distribution.

Neither the name of Intel nor the names of its suppliers may be used to endorse or promote products derived from this Software without specific prior written permission.

No reverse engineering, decompilation, or disassembly of this Software is permitted.

Limited patent license. Intel grants you a world-wide, royalty-free, non-exclusive license under patents it now or hereafter owns or controls to make, have made, use, import, offer to sell and sell (“Utilize”) this Software, but solely to the extent that any such patent is necessary to Utilize the Software alone. The patent license shall not apply to any combinations which include this software. No hardware per se is licensed hereunder.
Third party programs. The Software may contain Third Party Programs. "Third Party Programs" are third party software, open source software or other Intel software listed in the “third-party-programs.txt” or other similarly named text file that is included with the Software. Third Party Programs, even if included with the distribution of the Software, may be governed by separate license terms, including without limitation, third party license terms, open source software notices and terms, and/or other Intel software license terms. These separate license terms may govern your use of the Third Party Programs.

DISCLAIMER. THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT ARE DISCLAIMED. THIS SOFTWARE IS NOT INTENDED FOR USE IN SYSTEMS OR APPLICATIONS WHERE FAILURE OF THE SOFTWARE MAY CAUSE PERSONAL INJURY OR DEATH AND YOU AGREE THAT YOU ARE FULLY RESPONSIBLE FOR ANY CLAIMS, COSTS, DAMAGES, EXPENSES, AND ATTORNEYS' FEES ARISING OUT OF ANY SUCH USE, EVEN IF ANY CLAIM ALLEGES THAT INTEL WAS NEGLIGENT REGARDING THE DESIGN OR MANUFACTURE OF THE MATERIALS.

LIMITATION OF LIABILITY. IN NO EVENT WILL INTEL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. YOU AGREE TO INDEMNIFY AND HOLD INTEL HARMLESS AGAINST ANY CLAIMS AND EXPENSES RESULTING FROM YOUR USE OR UNAUTHORIZED USE OF THE SOFTWARE.

No support. Intel may make changes to the Software, at any time without notice, and is not obligated to support, update or provide training for the Software.

Termination. Intel may terminate your right to use the Software in the event of your breach of this Agreement and you fail to cure the breach within a reasonable period of time.

Feedback. Should you provide Intel with comments, modifications, corrections, enhancements or other input ("Feedback") related to the Software Intel will be free to use, disclose, reproduce, license or otherwise distribute or exploit the Feedback in its sole discretion without any obligations or restrictions of any kind, including without limitation, intellectual property rights or licensing obligations.

Compliance with laws. You agree to comply with all relevant laws and regulations governing your use, transfer, import or export (or prohibition thereof) of the Software.
Governing law. All disputes will be governed by the laws of the United States of America and the State of Delaware without reference to conflict of law principles and subject to the exclusive jurisdiction of the state or federal courts sitting in the State of Delaware, and each party agrees that it submits to the personal jurisdiction and venue of those courts and waives any objections. The United Nations Convention on Contracts for the International Sale of Goods (1980) is specifically excluded and will not apply to the Software.

*Other names and brands may be claimed as the property of others.

**Intel Math Kernel Library 2017 Update 2**

Intel Simplified Software License


This license applies to the following products:

Intel® Math Kernel Library (intel® MKL)
Intel® Integrated Performance Primitives (Intel® IPP)
Intel® Distribution for Python
Intel® Machine Learning Scaling Library (Intel® MLSL)

Copyright © 2017 Intel Corporation.

Use and Redistribution. You may use and redistribute the software (the "Software"), without modification, provided the following conditions are met:

Redistributions must reproduce the above copyright notice and the following terms of use in the Software and in the documentation and/or other materials provided with the distribution.

Neither the name of Intel nor the names of its suppliers may be used to endorse or promote products derived from this Software without specific prior written permission.

No reverse engineering, decompilation, or disassembly of this Software is permitted.

Limited patent license. Intel grants you a world-wide, royalty-free, non-exclusive license under patents it now or hereafter owns or controls to make, have made, use, import, offer to sell and sell ("Utilize") this Software, but solely to the extent that any such patent is necessary to Utilize the Software alone. The patent license shall not apply to any combinations which include this software. No hardware per se is licensed hereunder.
Third party and other Intel programs. "Third Party Programs" are the files listed in the "third-party-programs.txt" text file that is included with the Software and may include Intel programs under separate license terms. Third Party Programs, even if included with the distribution of the Materials, are governed by separate license terms and those license terms solely govern your use of those programs.

DISCLAIMER. THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT ARE DISCLAIMED. THIS SOFTWARE IS NOT INTENDED NOR AUTHORIZED FOR USE IN SYSTEMS OR APPLICATIONS WHERE FAILURE OF THE SOFTWARE MAY CAUSE PERSONAL INJURY OR DEATH.

LIMITATION OF LIABILITY. IN NO EVENT WILL INTEL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. YOU AGREE TO INDEMNIFY AND HOLD INTEL HARMLESS AGAINST ANY CLAIMS AND EXPENSES RESULTING FROM YOUR USE OR UNAUTHORIZED USE OF THE SOFTWARE.

No support. Intel may make changes to the Software, at any time without notice, and is not obligated to support, update or provide training for the Software.

Termination. Intel may terminate your right to use the Software in the event of your breach of this Agreement and you fail to cure the breach within a reasonable period of time.

Feedback. Should you provide Intel with comments, modifications, corrections, enhancements or other input ("Feedback") related to the Software Intel will be free to use, disclose, reproduce, license or otherwise distribute or exploit the Feedback in its sole discretion without any obligations or restrictions of any kind, including without limitation, intellectual property rights or licensing obligations.

Compliance with laws. You agree to comply with all relevant laws and regulations governing your use, transfer, import or export (or prohibition thereof) of the Software.

Governing law. All disputes will be governed by the laws of the United States of America and the State of Delaware without reference to conflict of law principles and subject to the exclusive jurisdiction of the state or federal courts sitting in the State of Delaware, and each party agrees that it submits to the personal jurisdiction and venue of those courts and waives any objections. The United
Nations Convention on Contracts for the International Sale of Goods (1980) is specifically excluded and will not apply to the Software.

*Other names and brands may be claimed as the property of others.

**Licensed under Boost Software License-1.0.**

*boost_1.55.0*

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and accompanying documentation covered by this license (the "Software") to use, reproduce, display, distribute, execute, and transmit the Software, and to prepare derivative works of the Software, and to permit third-parties to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above license grant, this restriction and the following disclaimer, must be included in all copies of the Software, in whole or in part, and all derivative works of the Software, unless such copies or derivative works are solely in the form of machine-executable object code generated by a source language processor.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

**Licensed under Zlib**

*zlib*

Copyright (C) 1995-2022 Jean-loup Gailly and Mark Adler

Licensed under the zlib license.

This software was altered by ABBYY Dev Inc. Respective notices are placed to the altered source files.

This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.
Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgement in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

zte-1.2.7
/* zlib.h -- interface of the 'zlib' general purpose compression library

version 1.2.7, May 2nd, 2012

Copyright (C) 1995-2012 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be

   appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly        Mark Adler
jloup@gzip.org          madler@alumni.caltech.edu
The data format used by the zlib library is described by RFCs (Request for Comments) 1950 to 1952 in the files http://tools.ietf.org/html/rfc1950 (zlib format), rfc1951 (deflate format) and rfc1952 (gzip format).

*/

Part of OpenCV - Zlib 1.2.8

/* zlib.h -- interface of the 'zlib' general purpose compression library
   version 1.2.11, January 15th, 2017

   Copyright (C) 1995-2017 Jean-loup Gailly and Mark Adler

   This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

   Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

   1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

   2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

   3. This notice may not be removed or altered from any source distribution.

   Jean-loup Gailly    Mark Adler
   jloup@gzip.org      madler@alumni.caltech.edu

Part of DjVu - Zlib 1.2.7

/* zlib.h -- interface of the 'zlib' general purpose compression library
   version 1.2.11, January 15th, 2017

   Copyright (C) 1995-2017 Jean-loup Gailly and Mark Adler
This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly  Mark Adler
jloup@gzip.org    madler@alumni.caltech.edu

zlib (for Pdium) 1.2.13

zlib.h -- interface of the 'zlib' general purpose compression library
version 1.2.13, October 13th, 2022

Copyright (C) 1995-2022 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.
3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly        Mark Adler
jloup@gzip.org          madler@alumni.caltech.edu

**zlib 2.3.1**

* Copyright (c) 2002-2014, Universite catholique de Louvain (UCL), Belgium
* Copyright (c) 2002-2014, Professor Benoit Macq
* Copyright (c) 2003-2014, Antonin Descampe
* Copyright (c) 2003-2009, Francois-Olivier Devaux
* Copyright (c) 2005, Herve Drolon, Freimage Team
* Copyright (c) 2002-2003, Yannick Verschueren
* Copyright (c) 2001-2003, David Janssens
* Copyright (c) 2011-2012, Centre National d'Etudes Spatiales (CNES), France
* Copyright (c) 2012, CS Systemes d'Information, France

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

**Licensed under commercial licenses**
Cuminas Caminova Celartem DjVu 3 (Commercial)

Portions of this computer program are copyright © 2008 Celartem, Inc. All rights reserved.
Portions of this computer program are copyright © 2011 Caminova, Inc. All rights reserved.
Portions of this computer program are copyright © 2013 Cuminas, Inc. All rights reserved.
DjVu is protected by U.S. Patent No. 6,058,214. Foreign Patents Pending.
Powered by AT&T Labs Technology.

Cuminas DjVu® SDK

Portions of this computer program are copyright © 2008 Celartem, Inc. All rights reserved. Portions of
this computer program are copyright © 2011 Caminova, Inc. All rights reserved. Portions of this
computer program are copyright © 2013 Cuminas, Inc. All rights reserved. DjVu is protected by U.S.

You, as the End-User, have the right to use DjVu SDK as part of the SOFTWARE for the entire period of
such SOFTWARE copyright or for another lesser term of use, stated in the EULA.

You may not perform or make it possible for other persons to perform reverse engineer, disassemble,
decompile (i.e. reproduce and transform the object code into source code) or otherwise attempt to
derive the source code for the SOFTWARE or any part, except, and only to the extent, that such activity
is expressly permitted by applicable law notwithstanding this limitation. If applicable law prohibits the
restriction of such activities, any information so discovered must not be disclosed to third parties with
the exception that such disclosure is required by law and such information must be promptly disclosed
to ABBYY. All such information shall be deemed to be confidential and proprietary information of
ABBYY.

ABBYY MAKES NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS (EXPRESS OR IMPLIED
WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE) AS TO ANY MATTER,
INCLUDING WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD PARTY RIGHTS,
MERCHANTABILITY, INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR
PURPOSE, OR THAT THE SOFTWARE WILL CARRY NO ERRORS, MEET YOUR REQUIREMENTS, OR THAT
THE SOFTWARE WILL FUNCTION PROPERLY WHEN USED IN CONJUNCTION WITH ANY OTHER
SOFTWARE OR HARDWARE. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE OR
RESULT YOU MAY OBTAIN BY USING THE SOFTWARE. THE ENTIRE RISK AS TO THE QUALITY AND
PERFORMANCE OF THE SOFTWARE LIES WITH YOU. FURTHERMORE ABBYY MAKES NO WARRANTIES
FOR ANY THIRD PARTY SOFTWARE PRODUCTS WHICH MAY BE SUPPLIED WITHIN THE SOFTWARE.

IN NO EVENT WILL ABBYY BE LIABLE TO YOU FOR ANY DAMAGES, BUSINESS INTERRUPTION, LOSS
OF DATA OR INFORMATION OF ANY KIND, BUSINESS OR OTHERWISE, CLAIMS OR COSTS
WHATSOEVER, OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL DAMAGE, OR ANY LOST PROFITS
OR LOST SAVINGS RESULTING FROM AND/OR RELATING TO THE USE OF THE SOFTWARE, OR
DAMAGES CAUSED BY POSSIBLE ERRORS OR MISPRINTS IN THE SOFTWARE, EVEN IF AN ABBYY
REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR
COSTS, OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS
APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ABBYY’S SOLE AND
AGGREGATE LIABILITY UNDER OR IN CONNECTION WITH THIS EULA SHALL BE LIMITED TO THE PURCHASE PRICE ORIGINALLY PAID FOR THE SOFTWARE, IF ANY.

Limitations for SOFTWARE obtained at the USA.

Government Use. If use is made of the SOFTWARE by the United States Government or any US Government agency, the following additional terms shall apply: (1) Restricted Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; and (2) any use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

Export rules. You agree that You shall not export or re-export the SOFTWARE in violation of any export provisions in the laws of the country in which this SOFTWARE was purchased or otherwise acquired. In addition, You represent and warrant that You are not prohibited under applicable laws from receiving the SOFTWARE.

Third-Party Code:

Oniguruma Copyright © 2002-2006 K.Kosako <sndgk393 AT ybb DOT ne DOT jp>. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

MD5 A portion of this software is derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Mersenne Twister Copyright © 2006,2007 Mutsuo Saito, Makoto Matsumoto and Hiroshima University. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the Hiroshima University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Adobe Color Profile

© Copyright 2000 Adobe Systems, Inc

DEFINITIONS In this Agreement, "Adobe" means Adobe Systems Incorporated, a Delaware corporation, located at 345 Park Avenue, San Jose, California 95110. "Software" means the software and related items with which this Agreement is provided.

LICENSE Subject to the terms of this Agreement, Adobe hereby grants you the worldwide, non-exclusive, nontransferable, royalty-free license to use, reproduce and publicly display the Software. Adobe also grants you the rights to distribute the Software only (a) as embedded within digital image files and (b) on a standalone basis. No other distribution of the Software is allowed; including, without limitation, distribution of the Software when incorporated into or bundled with any application software. All individual profiles must be referenced by their ICC Profile description string. You may not modify the Software. Adobe is under no obligation to provide any support under this Agreement, including upgrades or future versions of the Software or other items. No title to the intellectual property in the Software is transferred to you under the terms of this Agreement. You do not acquire any rights to the Software except as expressly set forth in this Agreement.

DISTRIBUTION If you choose to distribute the Software, you do so with the understanding that you agree to defend, indemnify and hold harmless Adobe against any losses, damages or costs arising from any claims, lawsuits or other legal actions arising out of such distribution, including without limitation, your failure to comply with this Section 3. If you distribute the Software on a standalone basis, you will do so under the terms of this Agreement or your own license agreement which (a) complies with the terms and conditions of this Agreement; (b) effectively disclaims all warranties and conditions, express or implied, on behalf of Adobe; (c) effectively excludes all liability for damages on behalf of Adobe; (d) substantially states that any provisions that differ from this Agreement are offered by you alone and not Adobe and (e) substantially states that the Software is available from you or Adobe and informs licensees how to obtain it in a reasonable manner on or through a medium customarily used for software exchange. Any distributed Software will include the Adobe copyright notices as included in the Software provided to you by Adobe.

DISCLAIMER OF WARRANTY Adobe licenses the Software to you on an "AS IS" basis. Adobe makes no representation as to the adequacy of the Software for any particular purpose or to produce any particular result. Adobe shall not be liable for loss or damage arising out of this Agreement or from the distribution or use of the Software or any other materials. ADOBE AND ITS SUPPLIERS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU MAY OBTAIN BY USING THE
SOFTWARE, EXCEPT FOR ANY WARRANTY, CONDITION, REPRESENTATION OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, ADOBE AND ITS SUPPLIERS MAKE NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS, EXPRESS OR IMPLIED, WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE AS TO ANY OTHER MATTERS, INCLUDING BUT NOT LIMITED TO NON-INFRINGEMENT OF THIRD PARTY RIGHTS, INTEGRATION, SATISFACTORY QUALITY OR FITNESS FOR ANY PARTICULAR PURPOSE. YOU MAY HAVE ADDITIONAL RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION. The provisions of Sections 4 and 5 shall survive the termination of this Agreement, howsoever caused, but this shall not imply or create any continued right to use the Software after termination of this Agreement.

LIMITATION OF LIABILITY IN NO EVENT WILL ADOBE OR ITS SUPPLIERS BE LIABLE TO YOU FOR ANY DAMAGES, CLAIMS OR COSTS WHATSOEVER OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL DAMAGES, OR ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN ADOBE REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ADOBE’S AGGREGATE LIABILITY AND THAT OF ITS SUPPLIERS UNDER OR IN CONNECTION WITH THIS AGREEMENT SHALL BE LIMITED TO THE AMOUNT PAID FOR THE SOFTWARE. Nothing contained in this Agreement limits Adobe’s liability to you in the event of death or personal injury resulting from Adobe’s negligence or for the tort of deceit (fraud). Adobe is acting on behalf of its suppliers for the purpose of disclaiming, excluding and/or limiting obligations, warranties and liability as provided in this Agreement, but in no other respects and for no other purpose.

TRADEMARKS Adobe grants you a worldwide, nonexclusive, nontransferable, personal right to use the “Adobe” word trademark (the “Trademark”) solely to identify Adobe as the source of the Adobe RGB (1998) product or Adobe RGB technology, so long as such use complies with the terms of this Agreement, the trademark guidelines available at the “Permissions and trademarks” pages of the Adobe web site (www.adobe.com) and the “Adobe Trademark Guidelines for third parties who license, use or refer to Adobe trademarks,” also available from the Adobe web site. You acknowledge the validity of the Trademark and Adobe’s ownership of the Trademark. Nothing in this Agreement shall give you any right, title or interest in the Trademark, other than the license rights granted in this Agreement. You recognize the value of the goodwill associated with the Trademark and acknowledge that such goodwill exclusively inures to the benefit of and belongs to Adobe. Adobe and the Adobe logo are either registered trademarks or trademarks of Adobe in the United States and/or other countries. With the exception of referential use and the rights granted in this Agreement, you will not use such trademarks or any other Adobe trademark or logo without separate prior written permission granted by Adobe.

TERM This Agreement is effective until terminated. Adobe has the right to terminate this Agreement immediately if you fail to comply with any term hereof. Upon any such termination, you must return to Adobe all full and partial copies of the Software in your possession or control.

GOVERNMENT REGULATIONS If any part of the Software is identified as an export controlled item under the United States Export Administration Act or any other export law, restriction or regulation (the “Export Laws”), you represent and warrant that you are not a citizen, or otherwise located within,
an embargoed nation (including without limitation Iran, Iraq, Syria, Sudan, Libya, Cuba, North Korea, and Serbia) and that you are not otherwise prohibited under the Export Laws from receiving the Software. All rights to use the Software are granted on condition that such rights are forfeited if you fail to comply with the terms of this Agreement.

GOVERNING LAW This Agreement will be governed by and construed in accordance with the substantive laws in force in the State of California as such laws are applied to agreements entered into and to be performed entirely within California between California residents. This Agreement will not be governed by the conflict of law rules of any jurisdiction or the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly excluded. All disputes arising out of, under or related to this Agreement will be brought exclusively in the state Santa Clara County, California, USA.

GENERAL You may not assign your rights or obligations granted under this Agreement without the prior written consent of Adobe. None of the provisions of this Agreement shall be deemed to have been waived by any act or acquiescence on the part of Adobe, its agents, or employees, but only by an instrument in writing signed by an authorized signatory of Adobe. When conflicting language exists between this Agreement and any other agreement included in the Software, the terms of such included agreement shall apply. If either you or Adobe employs attorneys to enforce any rights arising out of or relating to this Agreement, the prevailing party shall be entitled to recover reasonable attorneys’ fees. You acknowledge that you have read this Agreement, understand it, and that it is the complete and exclusive statement of your agreement with Adobe which supersedes any prior agreement, oral or written, between Adobe and you with respect to the licensing to you of the Software. No variation of the terms of this Agreement will be enforceable against Adobe unless Adobe gives its express consent, in writing, signed by an authorized signatory of Adobe.

Full text of the license agreement can be found on -

APDFL
© 2000-2012 Datalogics, Inc.
Datalogics®, The DL Logo®, PDF2IMG™ and DLE™ are trademarks of Datalogics, Inc.
© 1984-2012 Adobe Systems Incorporated and its licensors. All rights reserved.
Adobe®, The Adobe Logo®, Adobe® PDF Library™, Powered by Adobe PDF Library logo, Reader® are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Kakadu Software
Portions of this software are copyright © 2021 Kakadu Software Pty Ltd All rights reserved.

DjVu
Portions of this computer program are copyright © 2008 Celartem, Inc. All rights reserved.
Portions of this computer program are copyright © 2011 Caminova, Inc. All rights reserved.
Portions of this computer program are copyright © 2013 Cuminas, Inc. All rights reserved.
DjVu is protected by U.S. Patent No. 6,058,214. Foreign Patents Pending.

Powered by AT&T Labs Technology.

Licensed under ICU Licenses

**ICU - International Components for Unicode (forPdfium)**

Copyright © 1991-2022 Unicode, Inc. All rights reserved.

Distributed under the Terms of Use in [https://www.unicode.org/copyright.html](https://www.unicode.org/copyright.html)

Permission is hereby granted, free of charge, to any person obtaining a copy of the Unicode data files and any associated documentation (the "Data Files") or Unicode software and any associated documentation (the "Software") to deal in the Data Files or Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Data Files or Software, and to permit persons to whom the Data Files or Software are furnished to do so, provided that either (a) this copyright and permission notice appear with all copies of the Data Files or Software, or (b) this copyright and permission notice appear in associated Documentation.

THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF ERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS.

IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE DATA FILES OR SOFTWARE.

 Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in these Data Files or Software without prior written authorization of the copyright holder.

**ICU - International Components for Unicode**

Copyright © 1991-2020 Unicode, Inc. All rights reserved.

Distributed under the Terms of Use in [https://www.unicode.org/copyright.html](https://www.unicode.org/copyright.html).
Permission is hereby granted, free of charge, to any person obtaining a copy of the Unicode data files and any associated documentation (the "Data Files") or Unicode software and any associated documentation (the "Software") to deal in the Data Files or Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Data Files or Software, and to permit persons to whom the Data Files or Software are furnished to do so, provided that either
(a) this copyright and permission notice appear with all copies of the Data Files or Software, or (b) this copyright and permission notice appear in associated Documentation.

THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE DATA FILES OR SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in these Data Files or Software without prior written authorization of the copyright holder.

ICU License - ICU 1.8.1 and later

COPYRIGHT AND PERMISSION NOTICE

Copyright (c) 1995-2008 International Business Machines Corporation and others

All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.

All trademarks and registered trademarks mentioned herein are the property of their respective owners.

**ICU - International Components for Unicode**

ICU License - ICU 1.8.1 and later

COPYRIGHT AND PERMISSION NOTICE

Copyright (c) 1995-2008 International Business Machines Corporation and others

All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.

All trademarks and registered trademarks mentioned herein are the property of their respective owners.

**Licensed under SIL Open Font License**

**SIL OPEN FONT LICENSE**

Version 1.1 - 26 February 2007

**PREAMBLE**

The goals of the Open Font License (OFL) are to stimulate worldwide development of collaborative font projects, to support the font creation efforts of academic and linguistic communities, and to provide a free and open framework in which fonts may be shared and improved in partnership with others.

The OFL allows the licensed fonts to be used, studied, modified and redistributed freely as long as they are not sold by themselves. The fonts, including any derivative works, can be bundled, embedded, redistributed and/or sold with any software provided that any reserved names are not used by derivative works. The fonts and derivatives, however, cannot be released under any other type of license. The requirement for fonts to remain under this license does not apply to any document created using the fonts or their derivatives.

**DEFINITIONS**

"Font Software" refers to the set of files released by the Copyright Holder(s) under this license and clearly marked as such. This may include source files, build scripts and documentation.

"Reserved Font Name" refers to any names specified as such after the copyright statement(s).

"Original Version" refers to the collection of Font Software components as distributed by the Copyright Holder(s).
"Modified Version" refers to any derivative made by adding to, deleting, or substituting — in part or in whole — any of the components of the Original Version, by changing formats or by porting the Font Software to a new environment.

"Author" refers to any designer, engineer, programmer, technical writer or other person who contributed to the Font Software.

PERMISSION & CONDITIONS
Permission is hereby granted, free of charge, to any person obtaining a copy of the Font Software, to use, study, copy, merge, embed, modify, redistribute, and sell modified and unmodified copies of the Font Software, subject to the following conditions:

1) Neither the Font Software nor any of its individual components, in Original or Modified Versions, may be sold by itself.

2) Original or Modified Versions of the Font Software may be bundled, redistributed and/or sold with any software, provided that each copy contains the above copyright notice and this license. These can be included either as stand-alone text files, human-readable headers or in the appropriate machine-readable metadata fields within text or binary files as long as those fields can be easily viewed by the user.

3) No Modified Version of the Font Software may use the Reserved Font Name(s) unless explicit written permission is granted by the corresponding Copyright Holder. This restriction only applies to the primary font name as presented to the users.

4) The name(s) of the Copyright Holder(s) or the Author(s) of the Font Software shall not be used to promote, endorse or advertise any Modified Version, except to knowledge the contribution(s) of the Copyright Holder(s) and the Author(s) or with their explicit written permission.

5) The Font Software, modified or unmodified, in part or in whole, must be distributed entirely under this license, and must not be distributed under any other license. The requirement for fonts to remain under this license does not apply to any document created using the Font Software.

TERMINATION
This license becomes null and void if any of the above conditions are not met.

DISCLAIMER
THE FONT SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF COPYRIGHT, PATENT, TRADEMARK, OR OTHER RIGHT. IN NO EVENT SHALL THE COPYRIGHT HOLDER BE LIABLE FOR ANY CLAIM, DAMAGES OR
OTHER LIABILITY, INCLUDING ANY GENERAL, SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF THE USE OR INABILITY TO USE THE FONT SOFTWARE OR FROM OTHER DEALINGS IN THE FONT SOFTWARE.

**Bad Script (font)**

Designed by Roman Shchyukin from Gaslight

This Font Software is licensed under the SIL Open Font License, Version 1.1.

Nicolas Spalinger & Victor Gaultney, 2007-02-26

This license is copied below, and is also available at: [https://scripts.sil.org/cms/scripts/page.php?item_id=OFL](https://scripts.sil.org/cms/scripts/page.php?item_id=OFL)

**Miama Nueva Medium (font)**

This Font Software is licensed under the SIL Open Font License, Version 1.1.

Nicolas Spalinger & Victor Gaultney, 2007-02-26

This license is copied below, and is also available at: [https://scripts.sil.org/cms/scripts/page.php?item_id=OFL_web](https://scripts.sil.org/cms/scripts/page.php?item_id=OFL_web)

**Pecita (font)**

This Font Software is licensed under the SIL Open Font License, Version 1.1.

Nicolas Spalinger & Victor Gaultney, 2007-02-26

This license is copied below, and is also available at: [https://scripts.sil.org/cms/scripts/page.php?item_id=OFL_web](https://scripts.sil.org/cms/scripts/page.php?item_id=OFL_web)

**croscorefonts 1.31.0**

This Font Software is licensed under the SIL Open Font License, Version 1.1.

This license is copied below, and is also available with a FAQ at: [http://scripts.sil.org/OFL](http://scripts.sil.org/OFL)

**Licensed under other licenses**

**libcxxabi (llvm-project)**

D: Minor patches and fixes

University of Illinois/NCSA Open Source License Copyright (c) 2009-2019 by the contributors listed in CREDITS.TXT:
N: Jon Roelofs
E: jonathan@jroelofs.com
E: jroelofs@jroelofs.com
D: ARM EHABI Unwind & Exception Handling, Bare-metal
N: Nico Weber

All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

v8

Copyright 2014 the V8 project authors. All rights reserved.

This license applies to all parts of V8 that are not externally maintained libraries. The externally maintained libraries used by V8 are:

- PCRE test suite, located in test/mjsunit/third_party/regexp-pcre/regexp-pcre.js. This is based on the test suite from PCRE-7.3, which is copyrighted by the University of Cambridge and Google, Inc. The copyright notice and license are embedded in regexp-pcre.js.

- Layout tests, located in test/mjsunit/third_party/object-keys. These are based on layout tests from webkit.org which are copyrighted by Apple Computer, Inc. and released under a 3-clause BSD license.

- Strongtalk assembler, the basis of the files assembler-arm-inl.h,
assembler-arm.cc, assembler-arm.h, assembler-ia32-inl.h,
assembler-ia32.cc, assembler-ia32.h, assembler-x64-inl.h,
assembler-x64.cc, assembler-x64.h, assembler-mips-inl.h,
assembler-mips.cc, assembler-mips.h, assembler.cc and assembler.h.
This code is copyrighted by Sun Microsystems Inc. and released under a 3-clause BSD license.

- Valgrind client API header, located at src/third_party/valgrind/valgrind.h
  This is released under the BSD license.

- The Wasm C/C++ API headers, located at third_party/wasm-api/wasm.{h, hh}
  This is released under the Apache license. The API's upstream prototype implementation also formed the basis of V8's implementation in src/wasm/c-api.cc.

These libraries have their own licenses; we recommend you read them, as their terms may differ from the terms below.

Further license information can be found in LICENSE files located in sub-directories. All the licenses can be seen on the following link - https://github.com/v8/v8/blob/master/LICENSE

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  * Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  * Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  * Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Adobe Glyph List License (MIT)


Permission is hereby granted, free of charge, to any person obtaining a copy of this documentation file to use, copy, publish, distribute, sublicense, and/or sell copies of the documentation, and to permit others to do the same, provided that:

- No modification, editing or other alteration of this document is allowed; and
- The above copyright notice and this permission notice shall be included in all copies of the documentation.

Permission is hereby granted, free of charge, to any person obtaining a copy of this documentation file, to create their own derivative works from the content of this document to use, copy, publish, distribute, sublicense, and/or sell the derivative works, and to permit others to do the same, provided that the derived work is not represented as being a copy or version of this document.

Adobe shall not be liable to any party for any loss of revenue or profit or for indirect, incidental, special, consequential, or other similar damages, whether based on tort (including without limitation negligence or strict liability), contract or other legal or equitable grounds even if Adobe has been advised or had reason to know of the possibility of such damages. The Adobe materials are provided on an "AS IS" basis. Adobe specifically disclaims all express, statutory, or implied warranties relating to the Adobe materials, including but not limited to those concerning merchantability or fitness for a particular purpose or non-infringement of any third party rights regarding the Adobe materials.

mythes-1.2.0

Copyright 2003 Kevin B. Hendricks, Stratford, Ontario, Canada And Contributors. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. All modifications to the source code must be clearly marked as such. Binary redistributions based on modified source code must be clearly marked as modified versions in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY KEVIN B. HENDRICKS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL KEVIN B. HENDRICKS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;

LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

SampleICC-1.3.2

This product includes software developed by the The International Color Consortium (www.color.org) Copyright (c) 2003-2006 The International Color Consortium. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment:

"This product includes software developed by the The International Color Consortium (www.color.org)" Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear.

4. In the absence of prior written permission, the names ""ICC"" and ""The International Color Consortium"" must not be used to imply that the ICC organization endorses or promotes products derived from this software.
THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE INTERNATIONAL COLOR CONSORTIUM OR ITS CONTRIBUTING MEMBERS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This software consists of voluntary contributions made by many individuals on behalf of the The International Color Consortium.

Membership in the ICC is encouraged when this software is used for commercial purposes.

For more information on The International Color Consortium, please see <http://www.color.org/>.

xsltml_2.1.2

Copyright (C) 2001-2003 Vasil Yaroshevich

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the ``Software''), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the names of individuals credited with contribution to this software shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from the individuals in question.

Any stylesheet derived from this Software that is publically distributed will be identified with a different name and the version strings in any derived Software will be changed so that no possibility of confusion between the derived package and this Software will exist.

**Microsoft Universal CRT Library**

The technologies of Microsoft Corporation or their parts (hereinafter referred to as the "Microsoft Technologies") listed hereof are used in the SOFTWARE. The Microsoft Technologies are distributed under the Microsoft Software License Terms accompanying the Microsoft Technologies.

Technologies of Microsoft Corporation used in the SOFTWARE:

- Microsoft Universal CRT Library.

© Microsoft Corporation. All rights reserved. Microsoft is either registered trademark or trademark of Microsoft Corporation in the United States and/or other countries.

The Microsoft Technologies are licensed, not sold. This EULA only gives You some rights to use the Microsoft Technologies. Microsoft reserves all other rights. Unless applicable law gives You more rights despite this limitation, You may use the Microsoft Technologies only as expressly permitted in the Microsoft Software License Terms and in this EULA. In doing so, You must comply with any technical limitations in the Microsoft Technologies that only allow You to use it in certain ways. You may not:

* Except for the Microsoft .NET Framework, you must obtain Microsoft's prior written approval to disclose to a third party the results of any benchmark test of the Microsoft Technologies.

* Work around any technical limitations in the Microsoft Technologies;

* Reverse engineer, decompile or disassemble the Microsoft Technologies, except and only to the extent that applicable law expressly permits, despite this limitation;

* Make more copies of the Microsoft Technologies than specified in this EULA or allowed by applicable law, despite this limitation;

* Publish the Microsoft Technologies for others to copy;

* Rent, lease or lend the Microsoft Technologies;

* Transfer the Microsoft Technologies or this agreement to any third party other than as expressly permitted thereunder.

* Use the Microsoft Technologies for commercial software hosting services.
Export restrictions. The Microsoft Technologies are subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the Microsoft Technologies. These laws include restrictions on destinations, end users and end use. For additional information, see www.microsoft.com/exporting.

**HTML help**

The Software accompanied by this documentation contains redistributable parts of HTML help © Microsoft Corporation. All rights reserved.

Licensed under the terms of End User License Agreement for Microsoft software

**MD5 message digest algorithm reference implementation**

Copyright (C) 1991-2, RSA Data Security, Inc. Created 1991. All rights reserved.

This software is derived in part from the RSA Data Security, Inc. MD5 Message-Digest Algorithm

License is also granted to make and use derivative works provided that such works are identified as "derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm" in all material mentioning or referencing the derived work.

RSA Data Security, Inc. makes no representations concerning either the merchantability of this software or the suitability of this software for any particular purpose. It is provided "as is" without express or implied warranty of any kind.

https://www.ietf.org/rfc/rfc1321.txt

**Microsoft Visual C++ 2019 Runtime**

The Software contains redistributable parts of Microsoft Visual Studio (hereinafter - Microsoft Technologies).

© Microsoft Corporation. All rights reserved.

Microsoft Technologies are subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the software. These laws include restrictions on destinations, end users and end use. For additional information, see www.microsoft.com/exporting.

DISCLAIMER OF WARRANTY. MICROSOFT TECHNOLOGIES ARE LICENSED "AS-IS." YOU BEAR THE RISK OF USING THEM. MICROSOFT GIVES NO EXPRESS WARRANTIES, GUARANTEES OR CONDITIONS. YOU MAY HAVE ADDITIONAL CONSUMER RIGHTS OR STATUTORY GUARANTEES UNDER YOUR LOCAL LAWS WHICH THIS AGREEMENT CANNOT CHANGE. TO THE EXTENT PERMITTED UNDER YOUR LOCAL LAWS, MICROSOFT EXCLUDES THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.

Adobe-Core35_AFMs-314

This file and the 35 PostScript(R) AFM files it accompanies may be used, copied, and distributed for any purpose and without charge, with or without modification, provided that all copyright notices are retained; that the AFM files are not distributed without this file; that all modifications to this file or any of the AFM files are prominently noted in the modified file(s); and that this paragraph is not modified. Adobe Systems has no responsibility or obligation to support the use of the AFM files.

v8/fdlibm

Copyright (C) 1993-2004 by Sun Microsystems, Inc. All rights reserved.
Developed at SunSoft, a Sun Microsystems, Inc. business.
Permission to use, copy, modify, and distribute this software is freely granted, provided that this notice is preserved.

LZMA SDK

LZMA SDK is placed in the public domain.
Anyone is free to copy, modify, publish, use, compile, sell, or distribute the original LZMA SDK code, either in source code form or as a compiled binary, for any purpose, commercial or non-commercial, and by any means.

MICROSOFT XML CORE SERVICES (MSXML) 6.0

Whereas the ABBYY Software incorporates MICROSOFT XML CORE SERVICES (MSXML) 6.0 or its components (hereinafter referred to as the "Microsoft Technologies"), You agree to be bound by the following Microsoft Software License Terms:

The Microsoft Technologies are licensed, not sold. The Microsoft Software License Terms and this License agreement only give to You some rights to use the Microsoft Technologies. Microsoft reserves all other rights. Unless applicable law gives to You more rights despite this limitation, You may use the Microsoft Technologies only as expressly permitted in the Microsoft Software License Terms (may be found at https://www.microsoft.com/en-us/download/confirmation.aspx?id=3988) and in the EULA for ABBYY Software. In doing so, You must comply with any technical limitations in the Microsoft Technologies that only allow You to use it in certain ways. For more information, see www.microsoft.com/licensing/userights <http://www.microsoft.com/licensing/userights>.

You may not

• alter any copyright, trademark or patent notice in the Microsoft Technologies;
• use Microsoft’s trademarks in Software names or in a way that suggests Software comes from or is endorsed by Microsoft;
• distribute the Microsoft Technologies to run on a platform other than the Windows platform;
• include the Microsoft Technologies in malicious, deceptive or unlawful programs;

• disclose the results of any benchmark tests of the Microsoft Technologies to any third party without Microsoft's prior written approval;

• work around any technical limitations in the Microsoft Technologies;

• reverse engineer, decompile or disassemble the Microsoft Technologies, except and only to the extent that applicable law expressly permits, despite this limitation;

• make more copies of the Microsoft Technologies than specified in this License agreement or allowed by applicable law, despite this limitation;

• publish the Microsoft Technologies for others to copy;

• rent, lease or lend the Microsoft Technologies;

• use the Microsoft Technologies for commercial software hosting services.

Export restrictions. The Microsoft Technologies are subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the Microsoft Technologies. These laws include restrictions on destinations, end users and end use. For additional information, see www.microsoft.com/exporting.

**Microsoft Visual C++ 2015 OMP Library**

The Software accompanied by this documentation contains redistributable parts of Microsoft Visual C++ 2015 OMP Library.

© Microsoft Corporation. All rights reserved.

Microsoft Technologies are subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the software. These laws include restrictions on destinations, end users and end use. For additional information, see www.microsoft.com/exporting.

DISCLAIMER OF WARRANTY. MICROSOFT TECHNOLOGIES ARE LICENSED "AS-IS." YOU BEAR THE RISK OF USING THEM. MICROSOFT GIVES NO EXPRESS WARRANTIES, GUARANTEES OR CONDITIONS. YOU MAY HAVE ADDITIONAL CONSUMER RIGHTS OR STATUTORY GUARANTEES UNDER YOUR LOCAL LAWS WHICH THIS AGREEMENT CANNOT CHANGE. TO THE EXTENT PERMITTED UNDER YOUR LOCAL LAWS, MICROSOFT EXCLUDES THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.

**TWAIN Header**

The TWAIN Toolkit is distributed as is. The developer and distributors of the TWAIN Toolkit expressly disclaim all implied, express or statutory warranties including, without limitation, the implied warranties of merchantability, noninfringement of third party rights and fitness for a particular purpose. Neither the developers nor the distributors will be liable for damages, whether direct, indirect, special, incidental, or consequential, as a result of the reproduction, modification, distribution or other use of the TWAIN Toolkit.
**twain-header**

The TWAIN Toolkit is distributed as is. The developer and distributors of the TWAIN Toolkit expressly disclaim all implied, express or statutory warranties including, without limitation, the implied warranties of merchantability, noninfringement of third party rights and fitness for a particular purpose. Neither the developers nor the distributors will be liable for damages, whether direct, indirect, special, incidental, or consequential, as a result of the reproduction, modification, distribution or other use of the TWAIN Toolkit.

**Microsoft Visual C++ Redistributable**

© Microsoft Corporation. All rights reserved.

Microsoft Technologies are subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the software. These laws include restrictions on destinations, end users and end use. For additional information, see [www.microsoft.com/exporting](http://www.microsoft.com/exporting).

DISCLAIMER OF WARRANTY. MICROSOFT TECHNOLOGIES ARE LICENSED “AS-IS.” YOU BEAR THE RISK OF USING THEM. MICROSOFT GIVES NO EXPRESS WARRANTIES, GUARANTEES OR CONDITIONS. YOU MAY HAVE ADDITIONAL CONSUMER RIGHTS OR STATUTORY GUARANTEES UNDER YOUR LOCAL LAWS WHICH THIS AGREEMENT CANNOT CHANGE. TO THE EXTENT PERMITTED UNDER YOUR LOCAL LAWS, MICROSOFT EXCLUDES THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.

**HDPhotoDPK**

The Software contains redistributable parts of Microsoft Technologies.

© Microsoft Corporation. All rights reserved.

Microsoft Technologies are subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to the software. These laws include restrictions on destinations, end users and end use. For additional information, see [www.microsoft.com/exporting](http://www.microsoft.com/exporting).

DISCLAIMER OF WARRANTY. MICROSOFT TECHNOLOGIES ARE LICENSED “AS-IS.” YOU BEAR THE RISK OF USING THEM. MICROSOFT GIVES NO EXPRESS WARRANTIES, GUARANTEES OR CONDITIONS. YOU MAY HAVE ADDITIONAL CONSUMER RIGHTS OR STATUTORY GUARANTEES UNDER YOUR LOCAL LAWS WHICH THIS AGREEMENT CANNOT CHANGE. TO THE EXTENT PERMITTED UNDER YOUR LOCAL LAWS, MICROSOFT EXCLUDES THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.

**Python-2.7.18**

Copyright (c) 2000 BeOpen.com. All rights reserved.
Copyright (c) 1995-2001 Corporation for National Research Initiatives. All rights reserved.
Copyright (c) 1991-1995 Stichting Mathematisch Centrum. All rights reserved.
Licensed under the Python license https://docs.python.org/3/license.html

MD4 message digest algorithm reference implementation
RSA Data Security, Inc. MD4 Message-Digest Algorithm

/* Copyright (C) 1990-2, RSA Data Security, Inc. All rights reserved.

   License to copy and use this software is granted provided that it is identified as the "RSA Data
   Security, Inc. MD4 Message-Digest Algorithm" in all material mentioning or referencing this software
   or this function.

   License is also granted to make and use derivative works provided that such works are identified as
   "derived from the RSA Data Security, Inc. MD4 Message-Digest Algorithm" in all material mentioning
   or referencing the derived work.

   RSA Data Security, Inc. makes no representations concerning either the merchantability of this
   software or the suitability of this software for any particular purpose. It is provided "as is" without
   express or implied warranty of any kind.

   These notices must be retained in any copies of any part of this documentation and/or software.

CUDA Runtime for Windows
© 2007-2019 NVIDIA Corporation. All rights reserved.
Licensed under the terms of the License Agreement for NVIDIA Software Development Kits available
at https://docs.nvidia.com/cuda/eula/index.html#nvidia-driver-license

CUDA Runtime v11.2
CUDA Runtime for Windows
© 2007-2020 NVIDIA Corporation. All rights reserved.
License Agreement for NVIDIA Software Development Kits is available at
https://docs.nvidia.com/cuda/eula/index.html#nvidia-driver-license
CUDA Runtime v11.8
© 2007-2023, NVIDIA Corporation & Affiliates. All rights reserved.
License Agreement for NVIDIA Software Development Kits is available at https://docs.nvidia.com/cuda/eula/index.html#nvidia-driver-license

We don't use any dependencies of CUDA Runtime distributed under General Public License

**Rhash**

Copyright (c) 2009, Aleksey Kravchenko <rhash.admin@gmail.com>

Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is hereby granted.

THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

**FreeType (for Pdfium) 2.12.1**

Portions of the ABBYY Software accompanied by this documentation are copyright © 2006-2022 The FreeType Project (www.freetype.org). All rights reserved.

FreeType software may be found at https://github.com/freetype/freetype

**FreeType**

Portions of this software are copyright © <2009> The FreeType Project (www.freetype.org). All rights reserved.

The FreeType Project LICENSE

2006-Jan-27

Copyright 1996-2002, 2006 by

David Turner, Robert Wilhelm, and Werner Lemberg

Introduction

==========
The FreeType Project is distributed in several archive packages; some of them may contain, in addition to the FreeType font engine, various tools and contributions which rely on, or relate to, the FreeType Project.

This license applies to all files found in such packages, and which do not fall under their own explicit license. The license affects thus the FreeType font engine, the test programs, documentation and makefiles, at the very least.

This license was inspired by the BSD, Artistic, and IJG (Independent JPEG Group) licenses, which all encourage inclusion and use of free software in commercial and freeware products alike. As a consequence, its main points are that:

- We don't promise that this software works. However, we will be interested in any kind of bug reports. (`as is' distribution)

- You can use this software for whatever you want, in parts or full form, without having to pay us. (`royalty-free' usage)

- You may not pretend that you wrote this software. If you use it, or only parts of it, in a program, you must acknowledge somewhere in your documentation that you have used the FreeType code. (`credits')

We specifically permit and encourage the inclusion of this software, with or without modifications, in commercial products.

We disclaim all warranties covering the FreeType Project and assume no liability related to the FreeType Project.

Finally, many people asked us for a preferred form for a credit/disclaimer to use in compliance with this license. We thus encourage you to use the following text:

"""

Portions of this software are copyright © <year> The FreeType Project (www.freetype.org). All rights reserved.

"""

Please replace <year> with the value from the FreeType version you actually use.
Legal Terms

0. Definitions

Throughout this license, the terms 'package', 'FreeType Project', and 'FreeType archive' refer to the set of files originally distributed by the authors (David Turner, Robert Wilhelm, and Werner Lemberg) as the 'FreeType Project', be they named as alpha, beta or final release.

'You' refers to the licensee, or person using the project, where 'using' is a generic term including compiling the project's source code as well as linking it to form a 'program' or 'executable'. This program is referred to as 'a program using the FreeType engine'.

This license applies to all files distributed in the original FreeType Project, including all source code, binaries and documentation, unless otherwise stated in the file in its original, unmodified form as distributed in the original archive.

If you are unsure whether or not a particular file is covered by this license, you must contact us to verify this.

The FreeType Project is copyright (C) 1996-2000 by David Turner, Robert Wilhelm, and Werner Lemberg. All rights reserved except as specified below.

1. No Warranty

THE FREETYPE PROJECT IS PROVIDED 'AS IS' WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT WILL ANY OF THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY DAMAGES CAUSED BY THE USE OR THE INABILITY TO USE, OF THE FREETYPE PROJECT.

2. Redistribution

This license grants a worldwide, royalty-free, perpetual and irrevocable right and license to use, execute, perform, compile, display, copy, create derivative works of, distribute and sublicense the FreeType Project (in both source and object code forms) and derivative works thereof for any
purpose; and to authorize others to exercise some or all of the rights granted herein, subject to the following conditions:

- Redistribution of source code must retain this license file ('FTL.TXT') unaltered; any additions, deletions or changes to the original files must be clearly indicated in accompanying documentation. The copyright notices of the unaltered, original files must be preserved in all copies of source files.

- Redistribution in binary form must provide a disclaimer that states that the software is based in part of the work of the FreeType Team, in the distribution documentation. We also encourage you to put an URL to the FreeType web page in your documentation, though this isn't mandatory.

These conditions apply to any software derived from or based on the FreeType Project, not just the unmodified files. If you use our work, you must acknowledge us. However, no fee need be paid to us.

3. Advertising
--------------

Neither the FreeType authors and contributors nor you shall use the name of the other for commercial, advertising, or promotional purposes without specific prior written permission.

We suggest, but do not require, that you use one or more of the following phrases to refer to this software in your documentation or advertising materials: `FreeType Project', `FreeType Engine', `FreeType library', or `FreeType Distribution'.

As you have not signed this license, you are not required to accept it. However, as the FreeType Project is copyrighted material, only this license, or another one contracted with the authors, grants you the right to use, distribute, and modify it. Therefore, by using, distributing, or modifying the FreeType Project, you indicate that you understand and accept all the terms of this license.

4. Contacts
------------

There are two mailing lists related to FreeType:

- freetype@nongnu.org
Discusses general use and applications of FreeType, as well as future and wanted additions to the library and distribution. If you are looking for support, start in this list if you haven’t found anything to help you in the documentation.

- freetype-devel@nongnu.org

Discusses bugs, as well as engine internals, design issues, specific licenses, porting, etc.

Our home page can be found at https://www.freetype.org

**LibHeif**

The library `libheif` is distributed under the terms of the GNU Lesser General Public License, version 3.

LibHeif is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

**GNU LESSER GENERAL PUBLIC LICENSE**

Version 3, 29 June 2007

Copyright © 2007 Free Software Foundation, Inc.

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

This version of the GNU Lesser General Public License incorporates the terms and conditions of version 3 of the GNU General Public License, supplemented by the additional permissions listed below.

0. Additional Definitions.

As used herein, “this License” refers to version 3 of the GNU Lesser General Public License, and the “GNU GPL” refers to version 3 of the GNU General Public License.

“The Library” refers to a covered work governed by this License, other than an Application or a Combined Work as defined below.
An “Application” is any work that makes use of an interface provided by the Library, but which is not otherwise based on the Library. Defining a subclass of a class defined by the Library is deemed a mode of using an interface provided by the Library.

A “Combined Work” is a work produced by combining or linking an Application with the Library. The particular version of the Library with which the Combined Work was made is also called the “Linked Version”.

The “Minimal Corresponding Source” for a Combined Work means the Corresponding Source for the Combined Work, excluding any source code for portions of the Combined Work that, considered in isolation, are based on the Application, and not on the Linked Version.

The “Corresponding Application Code” for a Combined Work means the object code and/or source code for the Application, including any data and utility programs needed for reproducing the Combined Work from the Application, but excluding the System Libraries of the Combined Work.

1. Exception to Section 3 of the GNU GPL.
You may convey a covered work under sections 3 and 4 of this License without being bound by section 3 of the GNU GPL.

2. Conveying Modified Versions.
If you modify a copy of the Library, and, in your modifications, a facility refers to a function or data to be supplied by an Application that uses the facility (other than as an argument passed when the facility is invoked), then you may convey a copy of the modified version:

a) under this License, provided that you make a good faith effort to ensure that, in the event an Application does not supply the function or data, the facility still operates, and performs whatever part of its purpose remains meaningful, or

b) under the GNU GPL, with none of the additional permissions of this License applicable to that copy.

The object code form of an Application may incorporate material from a header file that is part of the Library. You may convey such object code under terms of your choice, provided that, if the incorporated material is not limited to numerical parameters, data structure layouts and accessors, or small macros, inline functions and templates (ten or fewer lines in length), you do both of the following:

a) Give prominent notice with each copy of the object code that the Library is used in it and that the Library and its use are covered by this License.
b) Accompany the object code with a copy of the GNU GPL and this license document.


You may convey a Combined Work under terms of your choice that, taken together, effectively do not restrict modification of the portions of the Library contained in the Combined Work and reverse engineering for debugging such modifications, if you also do each of the following:

a) Give prominent notice with each copy of the Combined Work that the Library is used in it and that the Library and its use are covered by this License.

b) Accompany the Combined Work with a copy of the GNU GPL and this license document.

c) For a Combined Work that displays copyright notices during execution, include the copyright notice for the Library among these notices, as well as a reference directing the user to the copies of the GNU GPL and this license document.

d) Do one of the following:

0) Convey the Minimal Corresponding Source under the terms of this License, and the Corresponding Application Code in a form suitable for, and under terms that permit, the user to recombine or relink the Application with a modified version of the Linked Version to produce a modified Combined Work, in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source.

1) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (a) uses at run time a copy of the Library already present on the user's computer system, and (b) will operate properly with a modified version of the Library that is interface-compatible with the Linked Version.

e) Provide Installation Information, but only if you would otherwise be required to provide such information under section 6 of the GNU GPL, and only to the extent that such information is necessary to install and execute a modified version of the Combined Work produced by recombining or relinking the Application with a modified version of the Linked Version. (If you use option 4d0, the Installation Information must accompany the Minimal Corresponding Source and Corresponding Application Code. If you use option 4d1, you must provide the Installation Information in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source.)


You may place library facilities that are a work based on the Library side by side in a single library together with other library facilities that are not Applications and are not covered by this License, and convey such a combined library under terms of your choice, if you do both of the following:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities, conveyed under the terms of this License.

b) Give prominent notice with the combined library that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.

6. Revised Versions of the GNU Lesser General Public License.
The Free Software Foundation may publish revised and/or new versions of the GNU Lesser General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library as you received it specifies that a certain numbered version of the GNU Lesser General Public License “or any later version” applies to it, you have the option of following the terms and conditions either of that published version or of any later version published by the Free Software Foundation. If the Library as you received it does not specify a version number of the GNU Lesser General Public License, you may choose any version of the GNU Lesser General Public License ever published by the Free Software Foundation.

If the Library as you received it specifies that a proxy can decide whether future versions of the GNU Lesser General Public License shall apply, that proxy’s public statement of acceptance of any version is permanent authorization for you to choose that version for the Library.

**libde265**

GNU LESSER GENERAL PUBLIC LICENSE

Version 3, 29 June 2007

Copyright © 2007 Free Software Foundation, Inc.

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

This version of the GNU Lesser General Public License incorporates the terms and conditions of version 3 of the GNU General Public License, supplemented by the additional permissions listed below.

0. Additional Definitions.

As used herein, “this License” refers to version 3 of the GNU Lesser General Public License, and the “GNU GPL” refers to version 3 of the GNU General Public License.

“The Library” refers to a covered work governed by this License, other than an Application or a Combined Work as defined below.

An “Application” is any work that makes use of an interface provided by the Library, but which is not otherwise based on the Library. Defining a subclass of a class defined by the Library is deemed a mode of using an interface provided by the Library.
A “Combined Work” is a work produced by combining or linking an Application with the Library. The particular version of the Library with which the Combined Work was made is also called the “Linked Version”.

The “Minimal Corresponding Source” for a Combined Work means the Corresponding Source for the Combined Work, excluding any source code for portions of the Combined Work that, considered in isolation, are based on the Application, and not on the Linked Version.

The “Corresponding Application Code” for a Combined Work means the object code and/or source code for the Application, including any data and utility programs needed for reproducing the Combined Work from the Application, but excluding the System Libraries of the Combined Work.

1. Exception to Section 3 of the GNU GPL.

You may convey a covered work under sections 3 and 4 of this License without being bound by section 3 of the GNU GPL.

2. Conveying Modified Versions.

If you modify a copy of the Library, and, in your modifications, a facility refers to a function or data to be supplied by an Application that uses the facility (other than as an argument passed when the facility is invoked), then you may convey a copy of the modified version:

a) under this License, provided that you make a good faith effort to ensure that, in the event an Application does not supply the function or data, the facility still operates, and performs whatever part of its purpose remains meaningful, or

b) under the GNU GPL, with none of the additional permissions of this License applicable to that copy.


The object code form of an Application may incorporate material from a header file that is part of the Library. You may convey such object code under terms of your choice, provided that, if the incorporated material is not limited to numerical parameters, data structure layouts and accessors, or small macros, inline functions and templates (ten or fewer lines in length), you do both of the following:

a) Give prominent notice with each copy of the object code that the Library is used in it and that the Library and its use are covered by this License.

b) Accompany the object code with a copy of the GNU GPL and this license document.

You may convey a Combined Work under terms of your choice that, taken together, effectively do not restrict modification of the portions of the Library contained in the Combined Work and reverse engineering for debugging such modifications, if you also do each of the following:

a) Give prominent notice with each copy of the Combined Work that the Library is used in it and that the Library and its use are covered by this License.

b) Accompany the Combined Work with a copy of the GNU GPL and this license document.

c) For a Combined Work that displays copyright notices during execution, include the copyright notice for the Library among these notices, as well as a reference directing the user to the copies of the GNU GPL and this license document.

d) Do one of the following:

0) Convey the Minimal Corresponding Source under the terms of this License, and the Corresponding Application Code in a form suitable for, and under terms that permit, the user to recombine or relink the Application with a modified version of the Linked Version to produce a modified Combined Work, in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source.

1) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (a) uses at run time a copy of the Library already present on the user's computer system, and (b) will operate properly with a modified version of the Library that is interface-compatible with the Linked Version.

e) Provide Installation Information, but only if you would otherwise be required to provide such information under section 6 of the GNU GPL, and only to the extent that such information is necessary to install and execute a modified version of the Combined Work produced by recombining or relinking the Application with a modified version of the Linked Version. (If you use option 4d0, the Installation Information must accompany the Minimal Corresponding Source and Corresponding Application Code. If you use option 4d1, you must provide the Installation Information in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source.)


You may place library facilities that are a work based on the Library side by side in a single library together with other library facilities that are not Applications and are not covered by this License, and convey such a combined library under terms of your choice, if you do both of the following:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities, conveyed under the terms of this License.

b) Give prominent notice with the combined library that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.

6. Revised Versions of the GNU Lesser General Public License.

The Free Software Foundation may publish revised and/or new versions of the GNU Lesser General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.
Each version is given a distinguishing version number. If the Library as you received it specifies that a certain numbered version of the GNU Lesser General Public License “or any later version” applies to it, you have the option of following the terms and conditions either of that published version or of any later version published by the Free Software Foundation. If the Library as you received it does not specify a version number of the GNU Lesser General Public License, you may choose any version of the GNU Lesser General Public License ever published by the Free Software Foundation.

If the Library as you received it specifies that a proxy can decide whether future versions of the GNU Lesser General Public License shall apply, that proxy's public statement of acceptance of any version is permanent authorization for you to choose that version for the Library

LibJPEG 9d

This software is copyright (C) 1991-2020, Thomas G. Lane, Guido Vollbeding.
this software is based in part on the work of the Independent JPEG Group

Independent JPEG Group License
LEGAL ISSUES
In plain English:
1. We don't promise that this software works. (But if you find any bugs, please let us know!)
2. You can use this software for whatever you want. You don't have to pay us.
3. You may not pretend that you wrote this software. If you use it in a program, you must acknowledge somewhere in your documentation that you've used the IJG code.

In legalese:
The authors make NO WARRANTY or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided "AS IS", and you, its user, assume the entire risk as to its quality and accuracy.

This software is copyright (C) 1991-1998, Thomas G. Lane. All Rights Reserved except as specified below.

Permission is hereby granted to use, copy, modify, and distribute this software (or portions thereof) for any purpose, without fee, subject to these conditions:
(1) If any part of the source code for this software is distributed, then this README file must be included, with this copyright and no-warranty notice unaltered; and any additions, deletions, or changes to the original files must be clearly indicated in accompanying documentation.
(2) If only executable code is distributed, then the accompanying documentation must state that "this software is based in part on the work of the Independent JPEG Group".
Permission for use of this software is granted only if the user accepts full responsibility for any undesirable consequences; the authors accept NO LIABILITY for damages of any kind.

These conditions apply to any software derived from or based on the IJG code, not just to the unmodified library. If you use our work, you ought to acknowledge us.

Permission is NOT granted for the use of any IJG author's name or company name in advertising or publicity relating to this software or products derived from it. This software may be referred to only as "the Independent JPEG Group's software".

We specifically permit and encourage the use of this software as the basis of commercial products, provided that all warranty or liability claims are assumed by the product vendor.

ansi2knr.c is included in this distribution by permission of L. Peter Deutsch, sole proprietor of its copyright holder, Aladdin Enterprises of Menlo Park, CA. ansi2knr.c is NOT covered by the above copyright and conditions, but instead by the usual distribution terms of the Free Software Foundation; principally, that you must include source code if you redistribute it. (See the file ansi2knr.c for full details.) However, since ansi2knr.c is not needed as part of any program generated from the IJG code, this does not limit you more than the foregoing paragraphs do.

The Unix configuration script "configure" was produced with GNU Autoconf. It is copyright by the Free Software Foundation but is freely distributable. The same holds for its supporting scripts (config.guess, config.sub, ltconfig, ltmain.sh). Another support script, install-sh, is copyright by M.I.T. but is also freely distributable.

It appears that the arithmetic coding option of the JPEG spec is covered by patents owned by IBM, AT&T, and Mitsubishi. Hence arithmetic coding cannot legally be used without obtaining one or more licenses. For this reason, support for arithmetic coding has been removed from the free JPEG software. (Since arithmetic coding provides only a marginal gain over the unpatented Huffman mode, it is unlikely that very many implementations will support it.) So far as we are aware, there are no patent restrictions on the remaining code.

The IJG distribution formerly included code to read and write GIF files. To avoid entanglement with the Unisys LZW patent, GIF reading support has been removed altogether, and the GIF writer has been simplified to produce "uncompressed GIFs". This technique does not use the LZW algorithm; the resulting GIF files are larger than usual, but are readable by all standard GIF decoders.

We are required to state that

"The Graphics Interchange Format(c) is the Copyright property of CompuServe Incorporated. GIF(sm) is a Service Mark property of CompuServe Incorporated."

libwebp

Copyright (c) 2010, Google Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of Google nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

_jpeg.v8d_

This software is copyright (C) 1991-2012, Thomas G. Lane, Guido Vollbeding. All Rights Reserved except as specified below.

ansi2knr.c is included in this distribution by permission of L. Peter Deutsch, sole proprietor of its copyright holder, Aladdin Enterprises of Menlo Park

LEGAL ISSUES

=============

In plain English:

1. We don't promise that this software works. (But if you find any bugs, please let us know!)
2. You can use this software for whatever you want. You don't have to pay us.
3. You may not pretend that you wrote this software. If you use it in a program, you must acknowledge somewhere in your documentation that you've used the IJG code.

In legalese:
The authors make NO WARRANTY or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided "AS IS", and you, its user, assume the entire risk as to its quality and accuracy.

This software is copyright (C) 1991-2012, Thomas G. Lane, Guido Vollbeding. All Rights Reserved except as specified below.

Permission is hereby granted to use, copy, modify, and distribute this software (or portions thereof) for any purpose, without fee, subject to these conditions:

(1) If any part of the source code for this software is distributed, then this README file must be included, with this copyright and no-warranty notice unaltered; and any additions, deletions, or changes to the original files must be clearly indicated in accompanying documentation.

(2) If only executable code is distributed, then the accompanying documentation must state that "this software is based in part on the work of the Independent JPEG Group".

(3) Permission for use of this software is granted only if the user accepts full responsibility for any undesirable consequences; the authors accept NO LIABILITY for damages of any kind.

These conditions apply to any software derived from or based on the IJG code, not just to the unmodified library. If you use our work, you ought to acknowledge us.

Permission is NOT granted for the use of any IJG author's name or company name in advertising or publicity relating to this software or products derived from it. This software may be referred to only as "the Independent JPEG Group's software".

We specifically permit and encourage the use of this software as the basis of commercial products, provided that all warranty or liability claims are assumed by the product vendor.

ansi2knr.c is included in this distribution by permission of L. Peter Deutsch, sole proprietor of its copyright holder, Aladdin Enterprises of Menlo Park, CA. ansi2knr.c is NOT covered by the above copyright and conditions, but instead by the usual distribution terms of the Free Software Foundation; principally, that you must include source code if you redistribute it. (See the file ansi2knr.c for full details.) However, since ansi2knr.c is not needed as part of any program generated from the IJG code, this does not limit you more than the foregoing paragraphs do.
The Unix configuration script "configure" was produced with GNU Autoconf. It is copyright by the Free Software Foundation but is freely distributable. The same holds for its supporting scripts (config.guess, config.sub, ltmain.sh). Another support script, install-sh, is copyright by X Consortium but is also freely distributable.

The IJG distribution formerly included code to read and write GIF files. To avoid entanglement with the Unisys LZW patent, GIF reading support has been removed altogether, and the GIF writer has been simplified to produce "uncompressed GIFs". This technique does not use the LZW algorithm; the resulting GIF files are larger than usual, but are readable by all standard GIF decoders.

We are required to state that “The Graphics Interchange Format(c) is the Copyright property of CompuServe Incorporated. GIF(sm) is a Service Mark property of CompuServe Incorporated.”

**Jasper**

JasPer License Version 2.0 [https://www.ece.uvic.ca/~frodo/jasper/LICENSE](https://www.ece.uvic.ca/~frodo/jasper/LICENSE)

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia

All rights reserved.
Permission is hereby granted, free of charge, to any person (the "User") obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

1. The above copyright notices and this permission notice (which includes the disclaimer below) shall be included in all copies or substantial portions of the Software.

2. The name of a copyright holder shall not be used to endorse or promote products derived from the Software without specific prior written permission.
THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF THE SOFTWARE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER. THE SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. NO ASSURANCES ARE PROVIDED BY THE COPYRIGHT HOLDERS THAT THE SOFTWARE DOES NOT INFRINGE THE PATENT OR OTHER INTELLECTUAL PROPERTY RIGHTS OF ANY OTHER ENTITY. EACH COPYRIGHT HOLDER DISCLAIMS ANY LIABILITY TO THE USER FOR CLAIMS BROUGHT BY ANY OTHER ENTITY BASED ON INFRINGEMENT OF INTELLECTUAL PROPERTY RIGHTS OR OTHERWISE. AS A CONDITION TO EXERCISING THE RIGHTS GRANTED HEREUNDER, EACH USER HEREBY ASSUMES SOLE RESPONSIBILITY TO SECURE ANY OTHER INTELLECTUAL PROPERTY RIGHTS NEEDED, IF ANY. THE SOFTWARE IS NOT FAULT-TOLERANT AND IS NOT INTENDED FOR USE IN MISSION-CRITICAL SYSTEMS, SUCH AS THOSE USED IN THE OPERATION OF NUCLEAR FACILITIES, AIRCRAFT NAVIGATION OR COMMUNICATION SYSTEMS, AIR TRAFFIC CONTROL SYSTEMS, DIRECT LIFE SUPPORT MACHINES, OR WEAPONS SYSTEMS, IN WHICH THE FAILURE OF THE SOFTWARE OR SYSTEM COULD LEAD DIRECTLY TO DEATH, PERSONAL INJURY, OR SEVERE PHYSICAL OR ENVIRONMENTAL DAMAGE ("HIGH RISK ACTIVITIES"). THE COPYRIGHT HOLDERS SPECIFICALLY DISCLAIM ANY EXPRESS OR IMPLIED WARRANTY OF FITNESS FOR HIGH RISK ACTIVITIES.

xmlsec1-1.2.14

Copyright (C) 2002-2003 Aleksey Sanin. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE ALEKSEY SANIN BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNEC-
TION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Aleksey Sanin shall not be used in advertising or
otherwise to promote the sale, use or other dealings in this Software without prior written
authorization from him.

Mozilla Public License Version 1.1

1. Definitions.

1.0.1. "Commercial Use" means distribution or otherwise making the Covered Code available to a third
party.

1.1. "Contributor" means each entity that creates or contributes to the creation of Modifications.

1.2. "Contributor Version" means the combination of the Original Code, prior Modifications used by a
Contributor, and the Modifications made by that particular Contributor.

1.3. "Covered Code" means the Original Code or Modifications or the combination of the Original
Code and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism generally accepted in the software
development community for the electronic transfer of data.

1.5. "Executable" means Covered Code in any form other than Source Code.

1.6. "Initial Developer" means the individual or entity identified as the Initial Developer in the Source
Code notice required by Exhibit A.

1.7. "Larger Work" means a work which combines Covered Code or portions thereof with code not
governed by the terms of this License.

1.8. "License" means this document.

1.8.1. "Licensable" means having the right to grant, to the maximum extent possible, whether at the
time of the initial grant or subsequently acquired, any and all of the rights conveyed herein.

1.9. "Modifications" means any addition to or deletion from the substance or structure of either the
Original Code or any previous Modifications. When Covered Code is released as a series of files, a
Modification is:

Any addition to or deletion from the contents of a file containing Original Code or previous
Modifications.

Any new file that contains any part of the Original Code or previous Modifications.

1.10. "Original Code" means Source Code of computer software code which is described in the Source
Code notice required by Exhibit A as Original Code, and which, at the time of its release under this
License is not already Covered Code governed by this License.
1.10.1. "Patent Claims" means any patent claim(s), now owned or hereafter acquired, including without limitation, method, process, and apparatus claims, in any patent Licensable by grantor.

1.11. "Source Code" means the preferred form of the Covered Code for making modifications to it, including all modules it contains, plus any associated interface definition files, scripts used to control compilation and installation of an Executable, or source code differential comparisons against either the Original Code or another well known, available Covered Code of the Contributor's choice. The Source Code can be in a compressed or archival form, provided the appropriate decompression or de-archiving software is widely available for no charge.

1.12. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms of, this License or a future version of this License issued under Section 6.1. For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with You. For purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2. Source Code License.

2.1. The Initial Developer Grant.

The Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license, subject to third party intellectual property claims:

under intellectual property rights (other than patent or trademark) Licensable by Initial Developer to use, reproduce, modify, display, perform, sublicense and distribute the Original Code (or portions thereof) with or without Modifications, and/or as part of a Larger Work; and

under Patents Claims infringed by the making, using or selling of Original Code, to make, have made, use, practice, sell, and offer for sale, and/or otherwise dispose of the Original Code (or portions thereof).

the licenses granted in this Section 2.1 (a) and (b) are effective on the date Initial Developer first distributes Original Code under the terms of this License.

Notwithstanding Section 2.1 (b) above, no patent license is granted: 1) for code that You delete from the Original Code; 2) separate from the Original Code; or 3) for infringements caused by: i) the modification of the Original Code or ii) the combination of the Original Code with other software or devices.

2.2. Contributor Grant.

Subject to third party intellectual property claims, each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license
under intellectual property rights (other than patent or trademark) Licensable by Contributor, to use, reproduce, modify, display, perform, sublicense and distribute the Modifications created by such Contributor (or portions thereof) either on an unmodified basis, with other Modifications, as Covered Code and/or as part of a Larger Work; and

under Patent Claims infringed by the making, using, or selling of Modifications made by that Contributor either alone and/or in combination with its Contributor Version (or portions of such combination), to make, use, sell, offer for sale, have made, and/or otherwise dispose of: 1) Modifications made by that Contributor (or portions thereof); and 2) the combination of Modifications made by that Contributor with its Contributor Version (or portions of such combination).

the licenses granted in Sections 2.2 (a) and 2.2 (b) are effective on the date Contributor first makes Commercial Use of the Covered Code.

Notwithstanding Section 2.2 (b) above, no patent license is granted: 1) for any code that Contributor has deleted from the Contributor Version; 2) separate from the Contributor Version; 3) for infringements caused by: i) third party modifications of Contributor Version or ii) the combination of Modifications made by that Contributor with other software (except as part of the Contributor Version) or other devices; or 4) under Patent Claims infringed by Covered Code in the absence of Modifications made by that Contributor.

3. Distribution Obligations.

3.1. Application of License.

The Modifications which You create or to which You contribute are governed by the terms of this License, including without limitation Section 2.2. The Source Code version of Covered Code may be distributed only under the terms of this License or a future version of this License released under Section 6.1, and You must include a copy of this License with every copy of the Source Code You distribute. You may not offer or impose any terms on any Source Code version that alters or restricts the applicable version of this License or the recipients' rights hereunder. However, You may include an additional document offering the additional rights described in Section 3.5.

3.2. Availability of Source Code.

Any Modification which You create or to which You contribute must be made available in Source Code form under the terms of this License either on the same media as an Executable version or via an accepted Electronic Distribution Mechanism to anyone to whom you made an Executable version available; and if made available via Electronic Distribution Mechanism, must remain available for at least twelve (12) months after the date it initially became available, or at least six (6) months after a subsequent version of that particular Modification has been made available to such recipients. You are responsible for ensuring that the Source Code version remains available even if the Electronic Distribution Mechanism is maintained by a third party.
3.3. Description of Modifications.

You must cause all Covered Code to which You contribute to contain a file documenting the changes You made to create that Covered Code and the date of any change. You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Code provided by the Initial Developer and including the name of the Initial Developer in (a) the Source Code, and (b) in any notice in an Executable version or related documentation in which You describe the origin or ownership of the Covered Code.

3.4. Intellectual Property Matters

(a) Third Party Claims

If Contributor has knowledge that a license under a third party's intellectual property rights is required to exercise the rights granted by such Contributor under Sections 2.1 or 2.2, Contributor must include a text file with the Source Code distribution titled "LEGAL" which describes the claim and the party making the claim in sufficient detail that a recipient will know whom to contact. If Contributor obtains such knowledge after the Modification is made available as described in Section 3.2, Contributor shall promptly modify the LEGAL file in all copies Contributor makes available thereafter and shall take other steps (such as notifying appropriate mailing lists or newsgroups) reasonably calculated to inform those who received the Covered Code that new knowledge has been obtained.

(b) Contributor APIs

If Contributor's Modifications include an application programming interface and Contributor has knowledge of patent licenses which are reasonably necessary to implement that API, Contributor must also include this information in the LEGAL file.

(c) Representations.

Contributor represents that, except as disclosed pursuant to Section 3.4 (a) above, Contributor believes that Contributor's Modifications are Contributor's original creation(s) and/or Contributor has sufficient rights to grant the rights conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in Exhibit A in each file of the Source Code. If it is not possible to put such notice in a particular Source Code file due to its structure, then You must include such notice in a location (such as a relevant directory) where a user would be likely to look for such a notice. If You
created one or more Modification(s) You may add your name as a Contributor to the notice described in Exhibit A. You must also duplicate this License in any documentation for the Source Code where You describe recipients' rights or ownership rights relating to Covered Code. You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Covered Code. However, You may do so only on Your own behalf, and not on behalf of the Initial Developer or any Contributor. You must make it absolutely clear than any such warranty, support, indemnity or liability obligation is offered by You alone, and You hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer or such Contributor as a result of warranty, support, indemnity or liability terms You offer.

3.6. Distribution of Executable Versions.

You may distribute Covered Code in Executable form only if the requirements of Sections 3.1, 3.2, 3.3, 3.4 and 3.5 have been met for that Covered Code, and if You include a notice stating that the Source Code version of the Covered Code is available under the terms of this License, including a description of how and where You have fulfilled the obligations of Section 3.2. The notice must be conspicuously included in any notice in an Executable version, related documentation or collateral in which You describe recipients' rights relating to the Covered Code. You may distribute the Executable version of Covered Code or ownership rights under a license of Your choice, which may contain terms different from this License, provided that You are in compliance with the terms of this License and that the license for the Executable version does not attempt to limit or alter the recipient's rights in the Source Code version from the rights set forth in this License. If You distribute the Executable version under a different license You must make it absolutely clear that any terms which differ from this License are offered by You alone, not by the Initial Developer or any Contributor. You hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer or such Contributor as a result of any such terms You offer.

3.7. Larger Works.

You may create a Larger Work by combining Covered Code with other code not governed by the terms of this License and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this License are fulfilled for the Covered Code.

4. Inability to Comply Due to Statute or Regulation.

If it is impossible for You to comply with any of the terms of this License with respect to some or all of the Covered Code due to statute, judicial order, or regulation then You must: (a) comply with the terms of this License to the maximum extent possible; and (b) describe the limitations and the code they affect. Such description must be included in the LEGAL file described in Section 3.4 and must be included with all distributions of the Source Code. Except to the extent prohibited by statute or
regulation, such description must be sufficiently detailed for a recipient of ordinary skill to be able to understand it.

5. Application of this License.

This License applies to code to which the Initial Developer has attached the notice in Exhibit A and to related Covered Code.

6. Versions of the License.

6.1. New Versions

Netscape Communications Corporation ("Netscape") may publish revised and/or new versions of the License from time to time. Each version will be given a distinguishing version number.

6.2. Effect of New Versions

Once Covered Code has been published under a particular version of the License, You may always continue to use it under the terms of that version. You may also choose to use such Covered Code under the terms of any subsequent version of the License published by Netscape. No one other than Netscape has the right to modify the terms applicable to Covered Code created under this License.

6.3. Derivative Works

If You create or use a modified version of this License (which you may only do in order to apply it to code which is not already Covered Code governed by this License), You must (a) rename Your license so that the phrases "Mozilla", "MOZILLA", "MOZPL", "Netscape", "MPL", "NPL" or any confusingly similar phrase do not appear in your license (except to note that your license differs from this License) and (b) otherwise make it clear that Your version of the license contains terms which differ from the Mozilla Public License and Netscape Public License. (Filling in the name of the Initial Developer, Original Code or Contributor in the notice described in Exhibit A shall not of themselves be deemed to be modifications of this License.)

7. DISCLAIMER OF WARRANTY

COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE COVERED CODE IS FREE OF DEFECTS, MERCHANTABILITY, FIT FOR A PARTICULAR PURPOSE OR
NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE IS WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

8. Termination

8.1. This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses to the Covered Code which are properly granted shall survive any termination of this License. Provisions which, by their nature, must remain in effect beyond the termination of this License shall survive.

8.2. If You initiate litigation by asserting a patent infringement claim (excluding declaratory judgment actions) against Initial Developer or a Contributor (the Initial Developer or Contributor against whom You file such action is referred to as "Participant") alleging that:

such Participant's Contributor Version directly or indirectly infringes any patent, then any and all rights granted by such Participant to You under Sections 2.1 and/or 2.2 of this License shall, upon 60 days notice from Participant terminate prospectively, unless if within 60 days after receipt of notice You either: (i) agree in writing to pay Participant a mutually agreeable reasonable royalty for Your past and future use of Modifications made by such Participant, or (ii) withdraw Your litigation claim with respect to the Contributor Version against such Participant. If within 60 days of notice, a reasonable royalty and payment arrangement are not mutually agreed upon in writing by the parties or the litigation claim is not withdrawn, the rights granted by Participant to You under Sections 2.1 and/or 2.2 automatically terminate at the expiration of the 60 day notice period specified above.

any software, hardware, or device, other than such Participant's Contributor Version, directly or indirectly infringes any patent, then any rights granted to You by such Participant under Sections 2.1(b) and 2.2(b) are revoked effective as of the date You first made, used, sold, distributed, or had made, Modifications made by that Participant.

8.3. If You assert a patent infringement claim against Participant alleging that such Participant's Contributor Version directly or indirectly infringes any patent where such claim is resolved (such as by license or settlement) prior to the initiation of patent infringement litigation, then the reasonable value of the licenses granted by such Participant under Sections 2.1 or 2.2 shall be taken into account in determining the amount or value of any payment or license.

8.4. In the event of termination under Sections 8.1 or 8.2 above, all end user license agreements (excluding distributors and resellers) which have been validly granted by You or any distributor hereunder prior to termination shall survive termination.
9. LIMITATION OF LIABILITY

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU.

10. U.S. government end users


11. Miscellaneous

This License represents the complete agreement concerning subject matter hereof. If any provision of this License is held to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable. This License shall be governed by California law provisions (except to the extent applicable law, if any, provides otherwise), excluding its conflict-of-law provisions. With respect to disputes in which at least one party is a citizen of, or an entity chartered or registered to do business in the United States of America, any litigation relating to this License shall be subject to the jurisdiction of the Federal Courts of the Northern District of California, with venue lying in Santa Clara County, California, with the losing party responsible for costs, including without limitation, court costs and reasonable attorneys' fees and expenses. The application of the United Nations Convention on Contracts for the International Sale of Goods is expressly excluded. Any law or regulation which provides that the language of a contract shall be construed against the drafter shall not apply to this License.

12. Responsibility for claims
As between Initial Developer and the Contributors, each party is responsible for claims and damages arising, directly or indirectly, out of its utilization of rights under this License and You agree to work with Initial Developer and Contributors to distribute such responsibility on an equitable basis. Nothing herein is intended or shall be deemed to constitute any admission of liability.

13. Multiple-licensed code

Initial Developer may designate portions of the Covered Code as "Multiple-Licensed". "Multiple-Licensed" means that the Initial Developer permits you to utilize portions of the Covered Code under Your choice of the MPL or the alternative licenses, if any, specified by the Initial Developer in the file described in Exhibit A.

**XMLSec Library**

For XMLSec Library:
- partly MIT license; partly MPL 1.1 license

xmlsec, xmlsec-openssl, xmlsec-gnutls libraries

------------------------------------------------------------------------------------------------------------------

Copyright (C) 2002-2003 Aleksey Sanin. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE ALEKSEY SANIN BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CON-
NECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Aleksey Sanin shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

xmlsec-nss library

------------------------------------------------------------------------

Copyright (C) 2002-2003 Aleksey Sanin. All Rights Reserved.
Copyright (c) 2003 America Online, Inc. All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

Portions of the Software were created using source code and/or APIs governed by the Mozilla Public License (MPL). The MPL is available at http://www.mozilla.org/MPL/MPL-1.1.html. The MPL permits such portions to be distributed with code not governed by MPL, as long as the requirements of MPL are fulfilled for such portions.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE ALEKSEY SANIN BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Aleksey Sanin shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.
Mozilla Public License Version 1.1

1. Definitions.

1.0.1. "Commercial Use" means distribution or otherwise making the Covered Code available to a third party.

1.1. "Contributor" means each entity that creates or contributes to the creation of Modifications.

1.2. "Contributor Version" means the combination of the Original Code, prior Modifications used by a Contributor, and the Modifications made by that particular Contributor.

1.3. "Covered Code" means the Original Code or Modifications or the combination of the Original Code and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism generally accepted in the software development community for the electronic transfer of data.

1.5. "Executable" means Covered Code in any form other than Source Code.

1.6. "Initial Developer" means the individual or entity identified as the Initial Developer in the Source Code notice required by Exhibit A.

1.7. "Larger Work" means a work which combines Covered Code or portions thereof with code not governed by the terms of this License.

1.8. "License" means this document.

1.8.1. "Licensable" means having the right to grant, to the maximum extent possible, whether at the time of the initial grant or subsequently acquired, any and all of the rights conveyed herein.

1.9. "Modifications" means any addition to or deletion from the substance or structure of either the Original Code or any previous Modifications. When Covered Code is released as a series of files, a Modification is:

Any addition to or deletion from the contents of a file containing Original Code or previous Modifications.

Any new file that contains any part of the Original Code or previous Modifications.

1.10. "Original Code" means Source Code of computer software code which is described in the Source Code notice required by Exhibit A as Original Code, and which, at the time of its release under this License is not already Covered Code governed by this License.

1.10.1. "Patent Claims" means any patent claim(s), now owned or hereafter acquired, including without limitation, method, process, and apparatus claims, in any patent Licensable by grantor.

1.11. "Source Code" means the preferred form of the Covered Code for making modifications to it, including all modules it contains, plus any associated interface definition files, scripts used to control compilation and installation of an Executable, or source code differential comparisons against either the Original Code or another well known, available Covered Code of the Contributor's choice. The
Source Code can be in a compressed or archival form, provided the appropriate decompression or de-archiving software is widely available for no charge.

1.12. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms of, this License or a future version of this License issued under Section 6.1. For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with You. For purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2. Source Code License.

2.1. The Initial Developer Grant.

The Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license, subject to third party intellectual property claims:

under intellectual property rights (other than patent or trademark) Licensable by Initial Developer to use, reproduce, modify, display, perform, sublicense and distribute the Original Code (or portions thereof) with or without Modifications, and/or as part of a Larger Work; and

under Patents Claims infringed by the making, using or selling of Original Code, to make, have made, use, practice, sell, and offer for sale, and/or otherwise dispose of the Original Code (or portions thereof).

the licenses granted in this Section 2.1 (a) and (b) are effective on the date Initial Developer first distributes Original Code under the terms of this License.

Notwithstanding Section 2.1 (b) above, no patent license is granted: 1) for code that You delete from the Original Code; 2) separate from the Original Code; or 3) for infringements caused by: i) the modification of the Original Code or ii) the combination of the Original Code with other software or devices.

2.2. Contributor Grant.

Subject to third party intellectual property claims, each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license

under intellectual property rights (other than patent or trademark) Licensable by Contributor, to use, reproduce, modify, display, perform, sublicense and distribute the Modifications created by such Contributor (or portions thereof) either on an unmodified basis, with other Modifications, as Covered Code and/or as part of a Larger Work; and

under Patent Claims infringed by the making, using, or selling of Modifications made by that Contributor either alone and/or in combination with its Contributor Version (or portions of such
combination), to make, use, sell, offer for sale, have made, and/or otherwise dispose of: 1) Modifications made by that Contributor (or portions thereof); and 2) the combination of Modifications made by that Contributor with its Contributor Version (or portions of such combination).

the licenses granted in Sections 2.2 (a) and 2.2 (b) are effective on the date Contributor first makes Commercial Use of the Covered Code.

Notwithstanding Section 2.2 (b) above, no patent license is granted: 1) for any code that Contributor has deleted from the Contributor Version; 2) separate from the Contributor Version; 3) for infringements caused by: i) third party modifications of Contributor Version or ii) the combination of Modifications made by that Contributor with other software (except as part of the Contributor Version) or other devices; or 4) under Patent Claims infringed by Covered Code in the absence of Modifications made by that Contributor.

3. Distribution Obligations.

3.1. Application of License.

The Modifications which You create or to which You contribute are governed by the terms of this License, including without limitation Section 2.2. The Source Code version of Covered Code may be distributed only under the terms of this License or a future version of this License released under Section 6.1, and You must include a copy of this License with every copy of the Source Code You distribute. You may not offer or impose any terms on any Source Code version that alters or restricts the applicable version of this License or the recipients' rights hereunder. However, You may include an additional document offering the additional rights described in Section 3.5.

3.2. Availability of Source Code.

Any Modification which You create or to which You contribute must be made available in Source Code form under the terms of this License either on the same media as an Executable version or via an accepted Electronic Distribution Mechanism to anyone to whom you made an Executable version available; and if made available via Electronic Distribution Mechanism, must remain available for at least twelve (12) months after the date it initially became available, or at least six (6) months after a subsequent version of that particular Modification has been made available to such recipients. You are responsible for ensuring that the Source Code version remains available even if the Electronic Distribution Mechanism is maintained by a third party.

3.3. Description of Modifications.

You must cause all Covered Code to which You contribute to contain a file documenting the changes You made to create that Covered Code and the date of any change. You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Code provided by the Initial Developer and including the name of the Initial Developer in (a) the Source Code, and (b) in any
notice in an Executable version or related documentation in which You describe the origin or ownership of the Covered Code.

3.4. Intellectual Property Matters

(a) Third Party Claims

If Contributor has knowledge that a license under a third party's intellectual property rights is required to exercise the rights granted by such Contributor under Sections 2.1 or 2.2, Contributor must include a text file with the Source Code distribution titled "LEGAL" which describes the claim and the party making the claim in sufficient detail that a recipient will know whom to contact. If Contributor obtains such knowledge after the Modification is made available as described in Section 3.2, Contributor shall promptly modify the LEGAL file in all copies Contributor makes available thereafter and shall take other steps (such as notifying appropriate mailing lists or newsgroups) reasonably calculated to inform those who received the Covered Code that new knowledge has been obtained.

(b) Contributor APIs

If Contributor's Modifications include an application programming interface and Contributor has knowledge of patent licenses which are reasonably necessary to implement that API, Contributor must also include this information in the LEGAL file.

(c) Representations.

Contributor represents that, except as disclosed pursuant to Section 3.4 (a) above, Contributor believes that Contributor's Modifications are Contributor's original creation(s) and/or Contributor has sufficient rights to grant the rights conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in Exhibit A in each file of the Source Code. If it is not possible to put such notice in a particular Source Code file due to its structure, then You must include such notice in a location (such as a relevant directory) where a user would be likely to look for such a notice. If You created one or more Modification(s) You may add your name as a Contributor to the notice described in Exhibit A. You must also duplicate this License in any documentation for the Source Code where You describe recipients' rights or ownership rights relating to Covered Code. You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Covered Code. However, You may do so only on Your own behalf, and not on behalf of the Initial Developer or any Contributor. You must make it absolutely clear than any such warranty, support,
indemnity or liability obligation is offered by You alone, and You hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer or such Contributor as a result of warranty, support, indemnity or liability terms You offer.

3.6. Distribution of Executable Versions.

You may distribute Covered Code in Executable form only if the requirements of Sections 3.1, 3.2, 3.3, 3.4 and 3.5 have been met for that Covered Code, and if You include a notice stating that the Source Code version of the Covered Code is available under the terms of this License, including a description of how and where You have fulfilled the obligations of Section 3.2. The notice must be conspicuously included in any notice in an Executable version, related documentation or collateral in which You describe recipients' rights relating to the Covered Code. You may distribute the Executable version of Covered Code or ownership rights under a license of Your choice, which may contain terms different from this License, provided that You are in compliance with the terms of this License and that the license for the Executable version does not attempt to limit or alter the recipient's rights in the Source Code version from the rights set forth in this License. If You distribute the Executable version under a different license You must make it absolutely clear that any terms which differ from this License are offered by You alone, not by the Initial Developer or any Contributor. You hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer or such Contributor as a result of any such terms You offer.

3.7. Larger Works.

You may create a Larger Work by combining Covered Code with other code not governed by the terms of this License and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this License are fulfilled for the Covered Code.

4. Inability to Comply Due to Statute or Regulation.

If it is impossible for You to comply with any of the terms of this License with respect to some or all of the Covered Code due to statute, judicial order, or regulation then You must: (a) comply with the terms of this License to the maximum extent possible; and (b) describe the limitations and the code they affect. Such description must be included in the LEGAL file described in Section 3.4 and must be included with all distributions of the Source Code. Except to the extent prohibited by statute or regulation, such description must be sufficiently detailed for a recipient of ordinary skill to be able to understand it.

5. Application of this License.
This License applies to code to which the Initial Developer has attached the notice in Exhibit A and to related Covered Code.

6. Versions of the License.

6.1. New Versions

Netscape Communications Corporation ("Netscape") may publish revised and/or new versions of the License from time to time. Each version will be given a distinguishing version number.

6.2. Effect of New Versions

Once Covered Code has been published under a particular version of the License, You may always continue to use it under the terms of that version. You may also choose to use such Covered Code under the terms of any subsequent version of the License published by Netscape. No one other than Netscape has the right to modify the terms applicable to Covered Code created under this License.

6.3. Derivative Works

If You create or use a modified version of this License (which you may only do in order to apply it to code which is not already Covered Code governed by this License), You must (a) rename Your license so that the phrases "Mozilla", "MOZILLAPL", "MOZPL", "Netscape", "MPL", "NPL" or any confusingly similar phrase do not appear in your license (except to note that your license differs from this License) and (b) otherwise make it clear that Your version of the license contains terms which differ from the Mozilla Public License and Netscape Public License. (Filling in the name of the Initial Developer, Original Code or Contributor in the notice described in Exhibit A shall not of themselves be deemed to be modifications of this License.)

7. DISCLAIMER OF WARRANTY

COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE COVERED CODE IS FREE OF DEFECTS, MERCHANTABILITY, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE IS WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.
8. Termination

8.1. This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses to the Covered Code which are properly granted shall survive any termination of this License. Provisions which, by their nature, must remain in effect beyond the termination of this License shall survive.

8.2. If You initiate litigation by asserting a patent infringement claim (excluding declaratory judgment actions) against Initial Developer or a Contributor (the Initial Developer or Contributor against whom You file such action is referred to as "Participant") alleging that:

such Participant's Contributor Version directly or indirectly infringes any patent, then any and all rights granted by such Participant to You under Sections 2.1 and/or 2.2 of this License shall, upon 60 days notice from Participant terminate prospectively, unless if within 60 days after receipt of notice You either: (i) agree in writing to pay Participant a mutually agreeable reasonable royalty for Your past and future use of Modifications made by such Participant, or (ii) withdraw Your litigation claim with respect to the Contributor Version against such Participant. If within 60 days of notice, a reasonable royalty and payment arrangement are not mutually agreed upon in writing by the parties or the litigation claim is not withdrawn, the rights granted by Participant to You under Sections 2.1 and/or 2.2 automatically terminate at the expiration of the 60 day notice period specified above.

any software, hardware, or device, other than such Participant's Contributor Version, directly or indirectly infringes any patent, then any rights granted to You by such Participant under Sections 2.1(b) and 2.2(b) are revoked effective as of the date You first made, used, sold, distributed, or had made, Modifications made by that Participant.

8.3. If You assert a patent infringement claim against Participant alleging that such Participant's Contributor Version directly or indirectly infringes any patent where such claim is resolved (such as by license or settlement) prior to the initiation of patent infringement litigation, then the reasonable value of the licenses granted by such Participant under Sections 2.1 or 2.2 shall be taken into account in determining the amount or value of any payment or license.

8.4. In the event of termination under Sections 8.1 or 8.2 above, all end user license agreements (excluding distributors and resellers) which have been validly granted by You or any distributor hereunder prior to termination shall survive termination.

9. LIMITATION OF LIABILITY

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL DEVELOPER, ANY OTHER
CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY RESULTING FROM SUCH PARTY’S NEGLIGENCE TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU.

10. U.S. government end users


11. Miscellaneous

This License represents the complete agreement concerning subject matter hereof. If any provision of this License is held to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable. This License shall be governed by California law provisions (except to the extent applicable law, if any, provides otherwise), excluding its conflict-of-law provisions. With respect to disputes in which at least one party is a citizen of, or an entity chartered or registered to do business in the United States of America, any litigation relating to this License shall be subject to the jurisdiction of the Federal Courts of the Northern District of California, with venue lying in Santa Clara County, California, with the losing party responsible for costs, including without limitation, court costs and reasonable attorneys' fees and expenses. The application of the United Nations Convention on Contracts for the International Sale of Goods is expressly excluded. Any law or regulation which provides that the language of a contract shall be construed against the drafter shall not apply to this License.

12. Responsibility for claims

As between Initial Developer and the Contributors, each party is responsible for claims and damages arising, directly or indirectly, out of its utilization of rights under this License and You agree to work with Initial Developer and Contributors to distribute such responsibility on an equitable basis. Nothing herein is intended or shall be deemed to constitute any admission of liability.
13. Multiple-licensed code

Initial Developer may designate portions of the Covered Code as "Multiple-Licensed". "Multiple-Licensed" means that the Initial Developer permits you to utilize portions of the Covered Code under Your choice of the MPL or the alternative licenses, if any, specified by the Initial Developer in the file described in Exhibit A.

**libxml2-2.9.10**

Copyright (C) 1998-2012 Daniel Veillard. All Rights Reserved.

Except where otherwise noted in the source code (e.g. the files hash.c,list.c and the trio files, which are covered by a similar licence but with different Copyright notices) all the files are:

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

**PCRE**

Copyright(c) 2009-2016 Zoltan Herczeg

All rights reserved.

THE "BSD" LICENCE

-----------------
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the University of Cambridge nor the names of any contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE

**bigint (for Pdfium)**

Big Integer Library (for Pdfium)

Original code by Matt McCutchen.

I, Matt McCutchen, the sole author of the original Big Integer Library, waive my copyright to it, placing it in the public domain. The library comes with absolutely no warranty.

Copyright 2014 PDFium Authors. All rights reserved.

Use of this source code is governed by a BSD-style license.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.